Trädvy Permalänk
Medlem
Plats
Mitt i skogen
Registrerad
Jun 2004

Kör någon Kernel 2.6.14?

Hejsan,
Har planer på att försök för första gång uppdatera kerneln till v2.6.14.
Men innan skulle jag vilja höra om det är någon annan som testat den som kan ge mig tips eller liknade på vad man (inte)ska ta med.
Och sedan är den stabil och så? Utgår från den är det.

//Zadazi - Citera mig om du vill att jag ska komma ihåg att svara.

"Allting går med våld. Om inte, använd MER Våld. Går det inte med mer våld så går det sönder."

Trädvy Permalänk
Medlem
Plats
Slottsbron
Registrerad
Jan 2002

jag kör den. jag orkade inte patcha å krångla för att få stöd för mitt nätverkskort (integrerat på Asrock 939DualSata-2), och för mej har den funkat bra de dagar jag använt den iaf

peter@server ~ $ uptime
22:26:14 up 30 days, 21:28, 4 users, load average: 21.77, 42.33, 26.94

Trädvy Permalänk
Medlem
Plats
Mitt i skogen
Registrerad
Jun 2004

Okej, låter bra.
Startade just "intsalltionen" av den. ^^
Så nu är det bara att hålla tummarna.

//Zadazi - Citera mig om du vill att jag ska komma ihåg att svara.

"Allting går med våld. Om inte, använd MER Våld. Går det inte med mer våld så går det sönder."

Trädvy Permalänk
Medlem
Plats
Falun
Registrerad
Okt 2001

Kan bara tillägga att du kommer troligtvis få kompilera om din kärna ett antal gånger om du är "nybörjare". Jag tror jag kompilerade om 10 gånger innan jag fick en fullt fungerade kärna, som stödde allt som behövdes. En körbar kärna fick jag efter 5 gånger kanske. Det finns mycket smått man kan glömma. Man skulle kunna ta med så mycket som möjligt för att slippa kompilera om, men det är inte att rekommendera. Bättre å kompilera in stöd efter stöd. Så att du bara får in de grejer som verkligen behövs.
Ta reda på vad ALL din hårdvara heter och leta upp dem i det program du använder för att välja saker till din kernel.

Lycka till!
PS. kör också 2.6.14

Har bytt namn från: nulleman ~ Blogg: http://skorpion.se
MacBook Pro: 15.4' ~ 1.83GHz ~ 1512MB RAM ~ 80GB HDD
Medlem i signaturen blodtörstiga Appleanvändare

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jul 2001

Jag kör 2.6.14.3 eller .4 på min server, fungerar perfa. Bra mycket snabbare än vanilla-kerneln som var med i sarge iaf

lspci är ett bra kommado att ha i en annan virterm när du ska confa, bara ett tips.

(\ /)
(O.o)
(> <) This is Bunny. Copy Bunny into your signature to help him on his way to world domination

Trädvy Permalänk
Medlem
Plats
Mitt i skogen
Registrerad
Jun 2004

okej.
Låter trevlig misslyckades på första försöket men fy den som ger sig. ^^
Nu till försök number två.

//Zadazi - Citera mig om du vill att jag ska komma ihåg att svara.

"Allting går med våld. Om inte, använd MER Våld. Går det inte med mer våld så går det sönder."

Trädvy Permalänk
Medlem
Registrerad
Jun 2004

Alternativt så kan du tanka en färdig config och ändra lite i den :).

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Dec 2001

Vad kör du för dist? Blir så mycket lättare att guida dig rätt då, t ex för Debian så tar man den gamla configen och bakar ett eget paket utifrån den, så slipper man göra om allt 10 gånger;-)

Trädvy Permalänk
Medlem
Plats
Mitt i skogen
Registrerad
Jun 2004
Citat:

Ursprungligen inskrivet av peppelorum
Vad kör du för dist? Blir så mycket lättare att guida dig rätt då, t ex för Debian så tar man den gamla configen och bakar ett eget paket utifrån den, så slipper man göra om allt 10 gånger;-)

Kör debian. ^^
Det felet jag får att den inte kan mountera root pattrition. Vet inte riktigt om det är kärnan eller om det är lilo som spökar. =(

//Zadazi - Citera mig om du vill att jag ska komma ihåg att svara.

"Allting går med våld. Om inte, använd MER Våld. Går det inte med mer våld så går det sönder."

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Okt 2001

Du har ntagligen missat stödet för ditt filsystem

Macbook Air 13" (2012)

Trädvy Permalänk
Medlem
Plats
Mitt i skogen
Registrerad
Jun 2004
Citat:

Ursprungligen inskrivet av wisdom
Du har ntagligen missat stödet för ditt filsystem

Jo samma sak som jag tänke på men den ger mig deta eror medelandet endå. (Har stöd för mitt system nu ; )
"Kernel Panic - no a syncing: VF: Unable to mount root fs on unkown - block (3, 1)"

Tror personligen att det är någon med lilo att göra för jag såg just att den ska mounta hda1(root) två gånger. ska testa att trixa lite.

//Zadazi - Citera mig om du vill att jag ska komma ihåg att svara.

"Allting går med våld. Om inte, använd MER Våld. Går det inte med mer våld så går det sönder."

Trädvy Permalänk
Medlem
Registrerad
Jun 2004

EDIT: missade helt att du använde lilo :).

Gammalt inlägg:
Du använder grub right?

Simpel snabb guide:

Flytta dig: cd /boot/grub
Editera (svengelska): nano menu.lst
Hitta delen

title Debian GNU/Linux, kernel 2.6.14 root (hd0,0) kernel /boot/vmlinuz-2.6.14 root=/dev/hdc1 ro <-----DEN HÄR RADEN initrd /boot/initrd.img-2.6.14 savedefault boot

där "=/" är så ska det vara ett "= /" utan mellanslaget i mitten.
Byt ut hdc1 mot din rootpartition.
Weee.

Trädvy Permalänk
Medlem
Plats
Mitt i skogen
Registrerad
Jun 2004

Romar: Tackar. ser vätigt ut ska testa det snart.
EDIT: min rad ser redan ut så.
root = /dev/hda1

//Zadazi - Citera mig om du vill att jag ska komma ihåg att svara.

"Allting går med våld. Om inte, använd MER Våld. Går det inte med mer våld så går det sönder."

Trädvy Permalänk
Medlem
Registrerad
Sep 2004
Citat:

Ursprungligen inskrivet av Romar
EDIT: missade helt att du använde lilo :).

Gammalt inlägg:
Du använder grub right?

Simpel snabb guide:

Flytta dig: cd /boot/grub
Editera (svengelska): nano menu.lst
Hitta delen

title Debian GNU/Linux, kernel 2.6.14 root (hd0,0) kernel /boot/vmlinuz-2.6.14 root=/dev/hdc1 ro <-----DEN HÄR RADEN initrd /boot/initrd.img-2.6.14 savedefault boot

där "=/" är så ska det vara ett "= /" utan mellanslaget i mitten.
Byt ut hdc1 mot din rootpartition.
Weee.

Du vet att man kan välja "Inga Smileys i detta inlägg" va?

Laptop: Zepto Znote 3215W | Intel C2D T7250 2.0ghz | 2GB ram | Intel X3100 GPU | 120 GB 5400rpm hdd | Intel 4965 AGN | 9-cell batteri
Kamera: Nikon D80 + batterigrepp | Nikkor AF-S DX 18-55mm 3.5-5.6G VR | Nikkor AF-S 70-300/4.5-5.6 G VR IF-ED | Nikkor AF 50mm 1.8D | Nikon SB-600 blixt

Trädvy Permalänk
Medlem
Registrerad
Jun 2004
Citat:

Ursprungligen inskrivet av Synt4x_3rr0r
Du vet att man kan välja "Inga Smileys i detta inlägg" va?

Jo det gör att göra så också, men... det är fel

Trädvy Permalänk
Medlem
Plats
Mitt i skogen
Registrerad
Jun 2004
Citat:

Ursprungligen inskrivet av Romar
Jo det gör att gåra så också, men... det är fel

hehehe.. ^^

Hmm.. kan inte fatta varför det inte funka. =(
Det jag lagt till i lilo.conf är:
image=/usr/src/linux-2.6.14/arch/i386/boot/bzImage
label=New-Linux
read-only
root=/dev/hda1

//Zadazi - Citera mig om du vill att jag ska komma ihåg att svara.

"Allting går med våld. Om inte, använd MER Våld. Går det inte med mer våld så går det sönder."

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Dec 2001

Okej, nu gör vid det här The Debian Way, så slipper vi allt strul;-)

Dra in lite paket förpaketbakning (apt-get install gcc kernel-package kernel-source-2.4.18 libc6-dev tk8.3 libncurses5-dev fakeroot)
Dra hem sourcen för kärnan till /usr/src och packa upp.
Byt namn på mappen till 'linux'.
Kopiera config-filen den kärnan du kör (cp /boot/config-X /usr/src/linux) Byt ut X mot den kärnversion du kör (uname -a ger dig mer).
Ställ dig i sourcemappen (cd /usr/src/linux)
Uppdatera configen (make oldconfig) och svara på frågorna.
Baka ett paket för kärnan (make-kpkg kernel_image), kör du med något skumt scsi-kort så kan du köra (make-kpkg --bzimage kernel_image)
Installera kärnan (dpkg -i ../kernel-image-X.deb)
Voila, lilo eller grub ska donas till automagiskt och du slipper mecka själv.

http://newbiedoc.sourceforge.net/system/kernel-pkg.html är en ganska bra länk om du vill läsa mer.

Trädvy Permalänk
Medlem
Registrerad
Jun 2004

http://www.falkotimme.com/howtos/debian_kernel2.6_compile/ind... har en bra guide, och sen är han ganska trevlig också :).

Trädvy Permalänk
Medlem
Plats
Mitt i skogen
Registrerad
Jun 2004

Romar och peppelorum, får tacka för länkarna för det funkar nu.
Vet faktisk inte vad som var fel. =/ Men det funkar. xD

//Zadazi - Citera mig om du vill att jag ska komma ihåg att svara.

"Allting går med våld. Om inte, använd MER Våld. Går det inte med mer våld så går det sönder."

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2005
Citat:

Ursprungligen inskrivet av .: Ph0ß1u§ :.
Jag kör 2.6.14.3 eller .4 på min server, fungerar perfa.

Intressant med tanke på att bara 2.6.14.1 har blivit släppt

Citat:

Ursprungligen inskrivet av Zadazi
"Kernel Panic - no a syncing: VF: Unable to mount root fs on unkown - block (3, 1)"

För mig låter det mer som att du saknar stöd för hårdvaran, fick något liknande när jag glömde kompilera in stöd för SATA tidigare, men bra att det fungerar nu iaf.

EDIT: använder 2.6.13.2 eftersom jag inte kan få igång ATI-drivarna med 2.6.14

Stationär: Intel-baserad, Arch + KDE
Bärbar: Dell XPS 13, Arch + KDE

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Jul 2001

Jag brukar alltid städa bort massa saker som jag inte har... Gammalt CD-ROM stöd, ISDN osv..