Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jul 2001

Visa lokala .html i OSX

Sitter och knåpar ihop en liten hemsida på min iBook, men har lite problem att visa .html-filerna när de ligger lokalt på datorn. Vad gör jag för fel?
Det är bara HTML-koden som visas.. Sidan ritas alltså inte upp.. Vad tusan beror det på?
Samma sak i både Firefox och Safari..

WS: Core i7 2600k | 32 GB DDR3 | Geforce GTX 750 TI 2GB | 256 + 180 GB SSD | Win10 x64 Professional + Antergos Linux (Arch-derivat)
Bärbar: Macbook Pro Retina 13" | Intel Core I5 2,4Ghz | 16GB RAM | 256GB Flash
Server: 3x HP Proliant microserver Gen8 | 16 GB DDR3 ECC ram | Sammanlagt 26TB HDD | Esxi
NAS: Synology DS414 | 12 TB HD

Trädvy Permalänk
Medlem
Plats
Lärdomssätet nr 1
Registrerad
Jan 2002

Antar att du inte har startat den inbyggda webbservern (Apache). Såhär gör du:
1. Starta "Systeminställningar"
2. Klicka på "Fildelning"
3. Kryssa för "Personlig webbdelning"
4. Flytta Html-dokumenten/et till "[Din hemkatalog]/Webbsidor
5. Nu borde du komma åt html-filerna genom adressen http://127.0.0.1/~[ditt användarnamn]/htmlfilen.html

Lycka till!

Tjo Göingar!

Trädvy Permalänk
Hedersmedlem
Plats
Uppsala
Registrerad
Jul 2001

Man ska iofs kunna kolla på HTML-filer utan en webbserver... Annat är det givetvis med serverside-språk.

Asus G751JY-T7037H / i7 4860HQ / GTX 980M 4 GB / 16 GB RAM / Samsung XP941 512 GB M.2 PCIe x4 / Win 10, Arch Linux / Dell U2414H
LG G6 (H870)

Trädvy Permalänk
Medlem
Registrerad
Jan 2004

Skulle tro att det fattas kod i "headers" på filerna...
Annars kan du kika på sidorna med textredigeraren eller vad som helst nästan…

Me fail english, thats unpossible!

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av Linux Lover
Antar att du inte har startat den inbyggda webbservern (Apache). Såhär gör du:
1. Starta "Systeminställningar"
2. Klicka på "Fildelning"
3. Kryssa för "Personlig webbdelning"
4. Flytta Html-dokumenten/et till "[Din hemkatalog]/Webbsidor
5. Nu borde du komma åt html-filerna genom adressen http://127.0.0.1/~[ditt användarnamn]/htmlfilen.html

Lycka till!

Alltså jag vill bara förhandsgranska sidorna i webläsaren. Känns inte som jag ska behöva dra igång en webserver för det.. Har redan en sådan i nätverket, så det är lugnt, men det känns jäkligt omständigt att tanka upp sidan till servern varje gång jag vill göra en förändring och kolla hur det blir .. Man måste ju kunna öppna en fil lokalt och få sidan uppritad i firefox och safari? Varför visar den bara html-koden i webläsaren? Jag fattar inte det.. Filen har ju filändelsen .html..

OBS! Det är endast HTML.. Inget annat.

WS: Core i7 2600k | 32 GB DDR3 | Geforce GTX 750 TI 2GB | 256 + 180 GB SSD | Win10 x64 Professional + Antergos Linux (Arch-derivat)
Bärbar: Macbook Pro Retina 13" | Intel Core I5 2,4Ghz | 16GB RAM | 256GB Flash
Server: 3x HP Proliant microserver Gen8 | 16 GB DDR3 ECC ram | Sammanlagt 26TB HDD | Esxi
NAS: Synology DS414 | 12 TB HD

Trädvy Permalänk
Medlem
Plats
Lärdomssätet nr 1
Registrerad
Jan 2002
Citat:

Ursprungligen inskrivet av -=fredrik=-
Alltså jag vill bara förhandsgranska sidorna i webläsaren. Känns inte som jag ska behöva dra igång en webserver för det.. Har redan en sådan i nätverket, så det är lugnt, men det känns jäkligt omständigt att tanka upp sidan till servern varje gång jag vill göra en förändring och kolla hur det blir .. Man måste ju kunna öppna en fil lokalt och få sidan uppritad i firefox och safari? Varför visar den bara html-koden i webläsaren? Jag fattar inte det.. Filen har ju filändelsen .html..

OBS! Det är endast HTML.. Inget annat.

Då förstår jag vad du menar. Testade nyss att öppna en testfil i Firefox och det fungerar perfekt. Har du kontrollerat att det inte är några felaktigheter i din kod, t ex skräptecken före "<html>"?

Tjo Göingar!

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av Linux Lover
Då förstår jag vad du menar. Testade nyss att öppna en testfil i Firefox och det fungerar perfekt. Har du kontrollerat att det inte är några felaktigheter i din kod, t ex skräptecken före "<html>"?

<HTML> <HEAD> <TITLE>WiddeNet</TITLE> </HEAD> <BODY TOPMARGIN="0" LEFTMARGIN="0" MARGINWIDTH="0" BGCOLOR="GRAY" TEXT="white"> <TABLE BORDER="1" CELLPADDING="0" CELLSPACING="0" WIDTH="100%" HEIGHT="100%"> <TR> <TD WIDTH="100%" HEIGHT="100%"> <table border="1" cellpadding="0" cellspacing="0" width="542" height="407"> <tr> <td valign="top" width="542" height="407"> <img src="dead.jpg"></td></tr></table> </TD></TR></TABLE> </BODY></HTML>

Där är koden.. Väldigt enkel sida, och jag hittar inga fel i koden...

WS: Core i7 2600k | 32 GB DDR3 | Geforce GTX 750 TI 2GB | 256 + 180 GB SSD | Win10 x64 Professional + Antergos Linux (Arch-derivat)
Bärbar: Macbook Pro Retina 13" | Intel Core I5 2,4Ghz | 16GB RAM | 256GB Flash
Server: 3x HP Proliant microserver Gen8 | 16 GB DDR3 ECC ram | Sammanlagt 26TB HDD | Esxi
NAS: Synology DS414 | 12 TB HD

Trädvy Permalänk
Medlem
Registrerad
Jan 2004

För mig öppnar den som en grå bakgrund med en ram med missad bild…

Me fail english, thats unpossible!

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av tva
För mig öppnar den som en grå bakgrund med en ram med missad bild…

Och du kör OSX? Varför öppnas den inte så för mig då? Jävligt skumt =(

WS: Core i7 2600k | 32 GB DDR3 | Geforce GTX 750 TI 2GB | 256 + 180 GB SSD | Win10 x64 Professional + Antergos Linux (Arch-derivat)
Bärbar: Macbook Pro Retina 13" | Intel Core I5 2,4Ghz | 16GB RAM | 256GB Flash
Server: 3x HP Proliant microserver Gen8 | 16 GB DDR3 ECC ram | Sammanlagt 26TB HDD | Esxi
NAS: Synology DS414 | 12 TB HD

Trädvy Permalänk
Medlem
Registrerad
Jan 2004

Kör Os X
Kopierar det ovan till texthanteraren - konverterar till ren text - sparar med filändelse .html

Vad skriver du koden i för program?
Det är inte programmet som lägger till mer kontrolltecken som giddrar till allt?

Me fail english, thats unpossible!

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av tva
Kör Os X
Kopierar det ovan till texthanteraren - konverterar till ren text - sparar med filändelse .html

Vad skriver du koden i för program?
Det är inte programmet som lägger till mer kontrolltecken som giddrar till allt?

Se där
Där låg problemet.
Tänk att jag missade en så simpel sak.. Checkade källkoden i firefox och den såg inte fin ut

WS: Core i7 2600k | 32 GB DDR3 | Geforce GTX 750 TI 2GB | 256 + 180 GB SSD | Win10 x64 Professional + Antergos Linux (Arch-derivat)
Bärbar: Macbook Pro Retina 13" | Intel Core I5 2,4Ghz | 16GB RAM | 256GB Flash
Server: 3x HP Proliant microserver Gen8 | 16 GB DDR3 ECC ram | Sammanlagt 26TB HDD | Esxi
NAS: Synology DS414 | 12 TB HD