Windows eller nVidias IDE-drivrutiner

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Dec 2004

Windows eller nVidias IDE-drivrutiner

Vilken av dem ska man välja? Båda kanske har för och nackdelar.

Sitter i sitsen att jag snart ska formatera om hårddisken, och jag vill gärna veta redan innan vilket man borde/inte borde välja.

Edit: Har två st SATAII-diskar (snart tre), alla av samma märke. Inga PATA-diskar.

Min dator äger mig. True story.

Trädvy Permalänk
Medlem
Plats
Infernum
Registrerad
Jul 2001

Inte Nvidias iaf.. använd M$ drivrutiner.

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Dec 2004

Någon motivering till varför?

Jag har lite problem med mina hårddiskar nu, de gillar definitivt inte multitasking, och att packa upp rarfiler tar EXTREMT lång tid, så något är seriöst fel.

Min dator äger mig. True story.

Trädvy Permalänk
Medlem
Plats
Skelleftehamn
Registrerad
Dec 2002

nVidias funkar utmärkt för mig

Trädvy Permalänk
Medlem
Plats
Infernum
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av Ackelind
Någon motivering till varför?

Jag har lite problem med mina hårddiskar nu, de gillar definitivt inte multitasking, och att packa upp rarfiler tar EXTREMT lång tid, så något är seriöst fel.

Prova att växla mellan dom & se om det blir någon skillnad.

Har provat dom & får hängningar i UT99 när jag kör med Nvidias...

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Dec 2004

Jag börjar fundera på vilken det är jag har nu egentligen. Hur kan man se skillnaden?

Jag kanske HAR just nVidias drivrutiner och det är därför allt strular så förbannat.

Min dator äger mig. True story.

Trädvy Permalänk
Medlem
Plats
Valbo
Registrerad
Aug 2002

Jag använder nVidias IDE drivisar.. fungerar bra för mig.

föresten hur kan man strunta i att installera nVidias IDE drivisar och bara installera Sata drivarna?

Desktop: | Core i5-4690K | Zotac GTX 970 | 16Gb RAM | 256Gb Samsung 830 SSD
NAS: HP Microserver Gen8 | 12GB DDR2 Ram | 3x1.5Tb ZFS | FreeNAS

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Sep 2005

byta drivare - m$ vs nvida

Hej.

Något liknande detta gör du för att kolla och ev byta drivare.

Gå in i Device Manager (via Administrative Tools - Computer Management), gå till 'IDE ATA/ATAPI Controllers'. Leta upp 'Standard Dual Channel PCI IDE Controller'. Högerklicka och kolla 'Properties' och 'Driver' på alla rader så ser du om det är Microsoft eller NVidia. Om det är NVidia, välj 'Upgrade Driver', och klicka dig fram tills dess du får välja drivrutin från en lista. Där väljer du sedan 'Standard Dual Channel PCI IDE Controller.

Du bör klara dej med denna info - annars får du återkomma så kanske någon annan kan ge dej mer detaljerad info..

Edit: Nvidias drivare funkar inte så bra på min Samsung SP Sata disk - M$ drivare funkar där emot riktigt bra.

MVH
skrock

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Dec 2004

Skrock, jag hittar lite allt möjligt

2* NVIDIA nForce4 Serial ATA Controller
Primär IDE-kanal
Sekundär IDE-kanal
Standard PCI IDE-styrenhet

Verkar ju som har har nVidias kontroller installerade då, men under Standard PCI IDE-styrenhet så står det microsoft som leverantör.

Jag har inga IDE-diskar, bara två (snart tre) SATA-II diskar (samsung spinpoint allihopa), samt en IDE DVDRW.

Min dator äger mig. True story.

Trädvy Permalänk
Avstängd
Plats
Köping
Registrerad
Okt 2005

Du har nvidias sata drivare
MS pata drivare

AMD Phenom II 965 c3//XFX Ati 5850 BE//Intel X25-M 80gb ssd//WD 750gb Black//Asus bräda M4A79XTD EVO//g15 v2//g500
Samsung t240 Fullhd gaming monitor//incoming sammy 2270
Lappy Asus UL30VT-QX030V

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Nov 2005

körde in minna drivrutiner å då blev allt helt cp... formaterade om hdd men det var ändå kvar! gick inte att starta datorn, det kom bara fram en cp nvidia sak men jag resetade cmos och sen så funkade det.. fan va jag hatade nvidia just då:P men annars är dom bra:)

E2180 @ 2.45ghz , 2x2048mb DDR2 800mhz, 8800gts 540/1920

Trädvy Permalänk
Medlem
Registrerad
Aug 2005

Man behöver inte installera Nvidias drivrutiner, ingen prestandaskillnad och det fungarar ofta mer problemfritt med dem som installeras automatiskt av windows (xp sp2) såvida man inte planerar att köra hårddiskarna i RAID.

...och det där med att rarfiler tar lång tid att packa upp låter annars som det klassiska "hårddisk i PIO-läge" problemet

En ssd som baseras på en kontroller från sandforce komprimerar data för ökad prestanda/livslängd. AS-SSD använder data som inte går att komprimera och ger då sämsta möjliga resultat, ATTO använder data som är lätt att komprimera och ger bästa möjliga resultat. Eftersom program/os/spel ofta går att komprimera någorlunda bra så hamnar den verkliga prestandan någonstans mellan dessa resultat vid normal användning.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2001

För mig tog det upp till 3 min för windows att boota med MS drivrutiner. 25+ sekunder med nVidias.

MSI X99A SLI KRAIT Edition| Intel i7 6850K @ 4,4 GHz| EK based custom watercooling| Samsung 950 PRO 512GB M.2 NVMe| HyperX Predator DDR4 2800MHz 16GB 14-14-14-36| 2*Sapphire TRI-X R9 290X @ 1120 MHz GPU 1450 Memory| ASUS 27" mg279q @ 60-144 Hz OC:ed Freesync range| Creative SoundBlaster Recon3D PCIe| Cooler Master Vanguard 1000W| Fractal Design Define S| Windows 10 Pro

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Dec 2004
Citat:

Ursprungligen inskrivet av Frispel
Man behöver inte installera Nvidias drivrutiner, ingen prestandaskillnad och det fungarar ofta mer problemfritt med dem som installeras automatiskt av windows (xp sp2) såvida man inte planerar att köra hårddiskarna i RAID.

...och det där med att rarfiler tar lång tid att packa upp låter annars som det klassiska "hårddisk i PIO-läge" problemet

Problemet är att de inte är i PIO-läge.

Dessutom är ALLA guider skrivna för PATA-diskar, medan mina är SATA. Har SATA ens PIO-läge?

Står bara "Let bios select transfer mode" när jag kollar på egenskaperna.

Kan det vara att NCQ är aktiverat? Det kanske är därför jag har helt VÄRDELÖS multitasking?

Min dator äger mig. True story.

Trädvy Permalänk
Medlem
Plats
Finland
Registrerad
Apr 2005

Har alltid använt Nvidias storage driver som den heter numera i nForce 6.70 som oxå tillsätter en SATA styrenhet och de har alltid givit mig bättre resultat i disk prestanda test och samt har jag aldrig upplevt några problem med dem.

Med dessa omtalade drivrutiner går det inte annat än att testa dem själv, för vissa fungerar de, för andra inte.

Intel® Core i5-4670K @ 4.4GHz | ASRock Z87 Extreme 6 | G.Skill Sniper 2x8GB @ DDR3-1866 CL9 | Samsung 840 Pro 128GB SSD | Gigabyte GTX 970 G1 (överklockat) | Corsair HX 750W | ViewSonic VX2268wm 22" 120Hz LCD | Phanteks PH-TC14PE | M-Audio Q40 hörlurar | Logitech MX-518 | Everglide Titan MonsterMat | Windows 7 x64 Professional

Trädvy Permalänk
Medlem
Plats
Söderhamn
Registrerad
Okt 2004

Har alltid kört in Nvidias egna aldrig haft nåt problem med dom så inte ens bekymrat mig om det mer än så.

i5-2500k@4.5, Asus P8Z68-V, Asus GTX970, Antec Kühler 620, Corsair Vengence 8GB, Corsair HX650, Samsung 840 EVO 250Gb, Intel 520 120Gb, 1+2 Tb HDD, Dell U2515H

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jan 2006

Nvidias

Nvidias egna är att rekommendera, men dock kan en del få problem med dem... Jag trodde länge att det va de som gjorde att mitt windows tog sån tid på sig att boota, men efter jag stängde av NCQ(Native Command Queing) så verkar de funka bättre...

/Jonas

Asrock P67 Extreme 4 | Intel i7 2600K@4ghz | 8GB Crucial Ballistix DDR3 1600mhz | Gigabyte GTX660Ti 2gb | SB X-Fi | HDD Total 2TB | Coolermaster Realpower 520w | Coolermaster Stacker | All Components are watercooled ||

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Dec 2004

Jag tror vi är lösningen på spåren.

Vet någon om NCQ är aktiverat med Windows IDE-drivrutiner? Jag har tydligen nVidias drivrutiner, och NCQ är aktiverat per default. Just nu har jag avaktiverat NCQ och jag tycker mig känna att systemet flyter på bra mycket bättre faktiskt.

Btw, ska inte WinRAR vara CPU-krävande?

För mig så drar det ca 5% CPU-kraft medan jag packar upp för fullt. Det kanske beror på packningsgraden, antar att enbart "store" är använt för vissa filer. CnQ körde fortfarande på 5x multipel tidigare när jag testade.

Edit: 2min50sek tog det att extrahera en 680mb fil på samma hårddisk som jag hade 11mb/s nedströms trafik på.

Edit2: Testade en 700mb fil på en obelastad samt en lätt belastad (500kb/s uppströms trafik) hårddisk. Tog 37sek i båda fallen.

Med NCQ på hade det tagit betydligt längre tid.

Min dator äger mig. True story.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jan 2006

Winrar brukar slöa ner rätt rejält ja..

Winrar är rätt krävande ja...

Tar ett exempel på hur mitt system packar upp på tid..

Ett rar arkiv på totalt 4.4gb tar cirka 4 minuter om jag packar upp det till samma disk som jag läser det ifrån, och det tar 1 minut o 30 sekunder om jag packar det till en disk som inte jobbar med nåt annat...

Har du installerat drivrutinen för din cpu från amds sida med tanke på att du kör CNQ ?

Min data spec är som följer iaf...

Asus A8N-SLi Deluxe
AMD64 3500+ (Venice) @ 2375mhz(3-4-4-8)
Corasiar PC4000PT 2*1024mb @ 237,5mhz
2 st Seagate Sata och 1 Seagate PATA

Har inte CNQ aktiverat...

Jag vet inte om NCQ är aktiverat med windows rutinerna, aldrig tänkt på det då jag aldrig haft problem med dem... Men jag märkte skillnad med nvidia rutinerna när jag stängde av NCQ iaf...

/Jonas

Asrock P67 Extreme 4 | Intel i7 2600K@4ghz | 8GB Crucial Ballistix DDR3 1600mhz | Gigabyte GTX660Ti 2gb | SB X-Fi | HDD Total 2TB | Coolermaster Realpower 520w | Coolermaster Stacker | All Components are watercooled ||

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Dec 2004

Det beror på hur man räknar att det är krävande. Arkiv som är sparade med winrar kan antingen bara vara "store" eller så kan det vara någon form av kompression inblandad. Har du kompression så är minnesbandbredd och processorn något som har stor betydelse, är det bara "store" så blir det disk i/o som gäller.

Jag har inte CnQ aktiverat nu. Har avinstallerat AMDs CPU-drivrutin dessutom.

Ska testa packa upp 4.4gb data som är enbart är packat med "store" så vi kan jämföra. Tidigare tog det runt 15-20 minuter för mig!

Mitt system går i 2.25GHz, minnena går med 333Mhz divider i 204Mhz, 2.5-3-3-8 1T. Diskarna är de som står i sign.

Edit: Sådär. 4.4gb data i en fil packad med "store" tog ca 4:15 att packa upp till samma disk.

Är det någon fler som känner för att göra samma sak så vi kan jämföra tider? Leta reda på något på 4.4gb som är packat med "store" och extrahera det till samma disk (obelastad disk). En dvdiso brukar vara i den storleken.

Min dator äger mig. True story.