Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jan 2004

Förvirrande minnesmängder

Hej.

Jag kör med 4x1GB Corsair minnen i ett ASUS Commando men en sak som förvirrar mig är mängden som nämns på olika ställen. Jag vet att 32bit inte har stöd för mer än ca 3GB men vissa värden förvirrar mig.

Vista säger 3007 MB Ramminne.
CPU-z säger (I memory-tabben) 4096 MB. (Kan ju inte vara så, eller rent hårdvara stämmer det ju men jag kan ju inte få ut allt).

Det som förvirrar mig dock är att BIOS i starten osv säger att det är 3007 MB installerat. Samma gäller för memtest. Borde inte bios och memtest säga att jag har 4gb installerat? och sen kommer begränsningen i Vista 32bit sen att den bara känner 3gb.

Tacksam om någon kan trassla upp det här. :s

EDIT: En annan sak jag undrar är varför Memory-tabben i CPUz säger att jag har CL5 timings när jag har CL4-minnen.

Kör på Corsair XMS2 Xtreme DDR2 XMS2-6400 800MHz (4-4-4-12) (TWIN2X2048-6400C4)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2003

Har ingen egenerfarenhet av Asus Commando men kan ju vara så att man specifikt måste ställa in att det ska mappa MMIO-grejer på högre adresser för att allt minne ska synas. Att CPU-Z säger 4 GB beror som du misstänkte på att den läser vilken hårdvara du har installerat, inte hur mycket ditt OS kan adressera. När det gäller timings som visas i CPU-Z så brukar de stämma. Har du sett till att sätta rätt timings manuellt? Bara för att minnena har en viss specifikation är det inte säkert att det är just de timings som programmerats in i SPD. Har sett sådant förut.

Antec P280 | Corsair RM750x | ASUS P8Z68-V Pro/GEN3 | i7 2700K | Corsair Vengeance LP 4x8GB 1600MHz | MSI GTX 1070 Gaming X | Samsung 840 Pro 256GB | Crucial M4 64GB | X-Fi Xtreme Music | QNIX QX2710

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jan 2004

Hittade nått som hette Memory Remap nånting... Den var disabled. satte igång den nu och nu visar memtest och bios 4gb! Tack så mkt

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2003
Citat:

Ursprungligen inskrivet av Lootcher
Hittade nått som hette Memory Remap nånting... Den var disabled. satte igång den nu och nu visar memtest och bios 4gb! Tack så mkt

Precis den jag pratade om. Den mappar om adresserna som reserveras till I/O för enheter till adresser som ligger långt över de 4 GB. Finns ju 2^64 adresser att leka med.

Antec P280 | Corsair RM750x | ASUS P8Z68-V Pro/GEN3 | i7 2700K | Corsair Vengeance LP 4x8GB 1600MHz | MSI GTX 1070 Gaming X | Samsung 840 Pro 256GB | Crucial M4 64GB | X-Fi Xtreme Music | QNIX QX2710

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jan 2004

En annan konstig sak nu.. Bios Memtest och CPUz visar 4gb RAM. Jag kör dock 32bit så jag får inte ut allt. Men windows VIsta Business 32bit visar 2gb ram installerat... Den borde ju visa typ 3,2~~~ungefär.. Varför gör dne inte det? :S

Nu installerade jag SP1 och nu visar systeminformationsaken 4GB. Men aktivitetshanteraren visar 2gb totalt fysiskt minne.. Vista hittar inte dom extra gigabyten som borde finnas med..

EDIT: I avancerade systeminfo säger vista "Fysiskt Minne installerat" 4GB... MEn Fysiskt minne tillgängligt 2gb... Så tom vista vet ju hur mkt minne det handlar om... Ska pröva installera 64bit och se om problemet löser sig.

Trädvy Permalänk
Hjälpsam
Plats
Karlskoga
Registrerad
Jan 2007

Kan bero på att du har på memory remapping.
Memory remaping flyttar upp en del minne, så de ligger ovanför 4GB.
Om det flyttar upp 2GB, får du bara tillgång till 4-2=2, med ett 32 bitars OS.
Bäst är att bara slå på det om du har ett 64 bitars OS.

AMD FX-8350 | KINGSTON 32GB ECC arbetsminne | Asus Sabertooth 990FX R2 | Radeon R9 290 | Seagate 2TB 3,5 " SSHD | Cooler Master V700 | Noctua NH-U12P SE2 | Dell U2410 | Corsair 600T Graphite vit | Windows 10 64bit |
Ett standardknep om hårdvaran krånglar, är att gå in i BIOS och ladda defaultinställningarna, på så sätt konfigureras BIOS mot din hårdvara.

Trädvy Permalänk
Medlem
Plats
Uddevalla
Registrerad
Jan 2004

Okej, editade precis och såg din kommentar nu. Tack för hjälpen, håller som sagt på att installera 64bit nu och hoppas det löser allting.. Tack än en gång för hjälpen!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2003
Citat:

Ursprungligen inskrivet av Lootcher
Okej, editade precis och såg din kommentar nu. Tack för hjälpen, håller som sagt på att installera 64bit nu och hoppas det löser allting.. Tack än en gång för hjälpen!

Ja, det kommer det att göra. Att Vista 32bit efter SP1 visade 4 GB ram var för att de ändrat så att den istället skulle visa mängd installerat minne. Extremt dumt val enligt mig, men troligen för att Dell och andra "märkes-datorer" såldes med 4 GB ram och 32bit OS.

Tycker personligen att Vista 64bit är bättre än 32bit. Stabilt som en klippa och allmänt trevligt.

Antec P280 | Corsair RM750x | ASUS P8Z68-V Pro/GEN3 | i7 2700K | Corsair Vengeance LP 4x8GB 1600MHz | MSI GTX 1070 Gaming X | Samsung 840 Pro 256GB | Crucial M4 64GB | X-Fi Xtreme Music | QNIX QX2710