Excel - Räkna ut summan från liknande textfält

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Mar 2008

Excel - Räkna ut summan från liknande textfält

Hej!

Jag har ett stort excel blad med flera celler/tabeller som innehåller en viss textfras, till höger om denna text finns en summa, det jag skulle vilja göra är att om texten innehåller en viss mening, ta beloppett och lägg in den i formeln som räknar ut summan.

Är detta möjligt?

Mvh

| Asus ROG Crosshair VII Hero | AMD Ryzen 2700X | Noctua NH-D15 SE-AM4 | G.Skill TridentZ 16GB DDR4 @ 3200Mhz | Palit GeForce RTX 2080 Ti 11GB GamingPro OC | Samsung 860 EVO 500GB + Samsung 860 EVO 1TB | Corsair AX850 | Fractal Define R6 TG Blackout | Acer XG270HU |

Monitor Audio Silver 200 + Yamaha WXC-50 + Rotel RB-1552 MkII
Klipsch R-115SW
Sennheiser HD650

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2009

gör en if formel som kollar om värdet i a1 stämmer med din textfras, om den stämmer så tar du värdet i b1 och lägger till den i formeln som räknar ut vad du nu behöver

Min dator: Silent Base 600 | 1700X @ 3.9Ghz | MSI Gaming X 1080TI | RM750X | 512Gb M2 | 16Gb 3200mhz Ram | S34E790C @ 3440x1440
Tjejens dator: Define r4 | i5 3570k @ 4.2ghz | GTX Titan | 750w Supernova | 240gb SSD | 32gb ram
Citera/Tagga för svar!

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Mar 2008
Skrivet av Christley:

gör en if formel som kollar om värdet i a1 stämmer med din textfras, om den stämmer så tar du värdet i b1 och lägger till den i formeln som räknar ut vad du nu behöver

Alright, återkommer senare då

| Asus ROG Crosshair VII Hero | AMD Ryzen 2700X | Noctua NH-D15 SE-AM4 | G.Skill TridentZ 16GB DDR4 @ 3200Mhz | Palit GeForce RTX 2080 Ti 11GB GamingPro OC | Samsung 860 EVO 500GB + Samsung 860 EVO 1TB | Corsair AX850 | Fractal Define R6 TG Blackout | Acer XG270HU |

Monitor Audio Silver 200 + Yamaha WXC-50 + Rotel RB-1552 MkII
Klipsch R-115SW
Sennheiser HD650

Trädvy Permalänk
Medlem
Plats
Framför datorn
Registrerad
Mar 2003

Det går att göra ganska enkelt

B5:B100 Ändra det till de celler/rader som innehåller texten
"Småköp" Ändra det till den text du vill matcha
D5:d100 Ändra det till de celler/rad som innehåller beloppet

=SUMMA.OM(B5:B100;"Småköp";D5:D100)

R.I.P Robert 2004-01-29 (klasskompis) Läs: Artikel Nr 1. | Artikel Nr 2. | Artikel Nr 3.