Ändra SATA-inställningar

Permalänk
Medlem

Ändra SATA-inställningar

Kör Win7 Pro x64 på en Dell Latitude E5540.
Har på denna försökt installera Windows XP Mode men fått kontinuerliga BSOD, vilket enligt ccm.net-forum har att göra med inställningar av SATA (skall vara IDE för att fungera, enl. ccm, och det är många som intygar att det löst deras problem med just blåskärm under installation av Win XP Mode).

Min E5540 var förinställd på RAID On visade det sig.
Något alternativ för IDE, annat än att "disable" SATA, finns inte i BIOS.

Fråga 1: Blir resultatet av att ha SATA som "disabled" samma som att köra IDE?

Fråga 2: Kan man ändra i SATA-inställningarna (från RAID till Disabled) utan att det påverkar systemet när man sedan gör en omstart (har läst trådar där ändringar gjort att systemet vägrar att komma igång och man har fått installera OS helt från början - och det vill man ju INTE).?

Permalänk
Rekordmedlem
Skrivet av ICIT:

Kör Win7 Pro x64 på en Dell Latitude E5540.
Har på denna försökt installera Windows XP Mode men fått kontinuerliga BSOD, vilket enligt ccm.net-forum har att göra med inställningar av SATA (skall vara IDE för att fungera, enl. ccm, och det är många som intygar att det löst deras problem med just blåskärm under installation av Win XP Mode).

Min E5540 var förinställd på RAID On visade det sig.
Något alternativ för IDE, annat än att "disable" SATA, finns inte i BIOS.
http://forumbilder.se/GA6R2/sata-config-web.jpg?width=650

http://forumbilder.se/GA6R2/sata-config-detalj.JPG?width=650

Fråga 1: Blir resultatet av att ha SATA som "disabled" samma som att köra IDE?

Fråga 2: Kan man ändra i SATA-inställningarna (från RAID till Disabled) utan att det påverkar systemet när man sedan gör en omstart (har läst trådar där ändringar gjort att systemet vägrar att komma igång och man har fått installera OS helt från början - och det vill man ju INTE).?

Det låter långsökt att det skulle påverka alls men det var ett tag sedan jag körde xpmode, jag har för mig att jag körde på raid just då och hursomhelst så installeras ju xpmode i den win 7 som går så installationen av xpmode borde inte påverkas alls men däremot kanske nått program som ska köras i xpmode.
Du kan hursomhelst inte hålla på att växla mellan raid och nått annat som ahci eller ideläge på satakontrollern eftersom raidläget kopplar ihop flera fysiska diskar så att de visas som en mot operativsystemet.
Du kan kanske gå runt det genom att köra en virtuell xpmaksin i vmware eller nån annan hypervisor ?

Permalänk
Medlem

Bara baka in intel RST (ahci) drivers i installationen så kan du lägga in XP (varför man nu vill det) utan problem.

Permalänk
Medlem
Skrivet av _niko_:

Bara baka in intel RST (ahci) drivers i installationen så kan du lägga in XP (varför man nu vill det) utan problem.

RST var obekant för mig. Hittade två drivrutiner för RST: Intel® Rapid Storage Technology (Intel® RST) Version: 15.8.1.1007 och RST and AHCI Driver and GUI Version: 11.6.0.1030. Men jag blir osäker på två saker:

  1. Är någon av dessa rätt driver för min dator

  2. Vad menar du med "baka in intel RST (ahci) drivers i installationen"

Vad beträffar punkt 1:
Enligt vad jag kan se uppfyller mitt system endast ett av kraven angivna för dessa (för det senare finns de mer specifikt i specifikationen för drivrutinen i fråga)

  • d.v.s. OS: Jag kör Win7 x64;

  • men jag uppfyller inte vad som anges för RAID/AHCI-Controllers eller System (CPU)
    (jag kör en 4th Generation Intel® Core™ i3 Processor (Haswell; i3-4010U); och RAID-controller är: Intel(R) ICH8M-E/ICH9M-E SATA RAID Controller)

Jag tycker det verkar konstigt att ett så pass ordinärt system som mitt inte skulle uppfylla villkoren, men det är vad som står i specarna.

Punkt 2:

  1. Menar du att det på något sätt skulle bakas in i WinXP-installationen - hur då i så fall?

  2. Eller är det i helt enkelt en uppdatering/tillägg till det för datorn ursprungliga systemet?

När det gäller din undran om att lägga in XP: "varför man nu vill det", så förstår jag mycket väl vad du tänker, och skulle själv inte kommit på tanken - om det inte varit för att jag har två stycken mycket enkla (8- resp. 16-bitars) program som jag inte kan tänka mig att vara utan men som tyvärr inte går att köra i Win7-miljö. Därav Windows XP-Mode.

EDIT:
Det finns en tidigare version (14.8.14.1063) av Intel® Rapid Storage Technology (utan Optane Memory). Tyvärr framgår det inte vilka krav på hårdvara som gäller där (inte av Release Notes heller)... Men det kanske finns någon här som vet?

Permalänk
Medlem
Skrivet av mrqaffe:

Du kan kanske gå runt det genom att köra en virtuell xpmaksin i vmware eller nån annan hypervisor ?

Jag provade med Oracles "Virtual Box", men mitt system gick som sirap med den konstellationen (provade lite olika konfigurationer med allokerat minne men utan större framgång - mitt system på E5540:an har endast 4GB RAM).
Jag har en annan, bättre utrustad, dator som jag tänkte testa Virtual Box på (i7 och 16 GB RAM) i hopp om att det skall fungera bättre.

Permalänk
Medlem
Skrivet av ICIT:

Kör Win7 Pro x64 på en Dell Latitude E5540.

Min E5540 var förinställd på RAID On visade det sig.
Något alternativ för IDE, annat än att "disable" SATA, finns inte i BIOS.
http://forumbilder.se/GA6R2/sata-config-web.jpg?width=650

http://forumbilder.se/GA6R2/sata-config-detalj.JPG?width=650

Fråga 1: Blir resultatet av att ha SATA som "disabled" samma som att köra IDE?

Nej. Det stänger av det.
Det ska finnas en SATA leagacy/native läge i vissa Dell BIOS som kan gör detta. Native är då SATA och leagacy är IDE.
Finns inte denna, kan du inte välja det.

Bästa jag kan tänka mig då är att försöka hitta en drivare som fungerar med AHCI, eller kör RAID + drivare (som även fanns på XP tiden).

Skrivet av ICIT:

Fråga 2: Kan man ändra i SATA-inställningarna (från RAID till Disabled) utan att det påverkar systemet när man sedan gör en omstart (har läst trådar där ändringar gjort att systemet vägrar att komma igång och man har fått installera OS helt från början - och det vill man ju INTE).?

Hmm
Det är lite komplicerat och riskabelt, men ska gå:
https://forums.hexus.net/motherboards/112584-how-enable-ahci-...

Tänk på att du måste ha 32-bit drivare, och de måste just vara för XP.
Föreslår också att du tar en backup först, om något går fel.

Permalänk
Medlem

@ICIT: Använd t.ex http://www.nliteos.com/ för att enkelt stoppa in drivers i XP installationen.

https://downloadcenter.intel.com/download/17882/Intel-Matrix-...

Permalänk
Medlem
Skrivet av ICIT:

Jag tycker det verkar konstigt att ett så pass ordinärt system som mitt inte skulle uppfylla villkoren, men det är vad som står i specarna.

Så är det med märkesdatorer, tillverkaren kan välja fritt vad de vill supporta och inte i BIOS/UEFI.
Klassiskt fall är ju laptops där du inte kan ställa in support för VT-x trots att CPUn som följer med har det.
Bygger du ihop en egen burk så kan du i större mån göra vad du vill, men det är ju i regel inte aktuellt för laptop, såvida du inte hittar ett "hackat" BIOS som ger dig fler inställningar, men det kan ju vara vanskligt att installera, kanske inte 100% fungerande.

Jag tolkar det hela som 1. kontroller inte på alls. 2. kontroller i AHCI-mode 3. kontroller i RAID-mode, så ingen legacy mode finns.
Att baka in AHCI-drivers (alt. RAID) i Windows XP -installationen är nog det enda vettiga. Som folk har förelsagit, ta backup på det du har, gör en custom XP-distribution, installera.

Permalänk
Medlem
Skrivet av Paddanx:

Nej. Det stänger av det.
Det ska finnas en SATA leagacy/native läge i vissa Dell BIOS som kan gör detta. Native är då SATA och leagacy är IDE.
Finns inte denna, kan du inte välja det.

Tack, igen, Paddanx
Den enda möjligheten att växla till "Legacy" är i valet mellan UEFI och legcy, men det är ju något helt annat och utförs ju under Boot Sequence

Så, det är bara att konstatera att mitt system inte kan växla till IDE.

Skrivet av Paddanx:

Bästa jag kan tänka mig då är att försöka hitta en drivare som fungerar med AHCI, eller kör RAID + drivare (som även fanns på XP tiden).

..../Tänk på att du måste ha 32-bit drivare, och de måste just vara för XP.
Föreslår också att du tar en backup först, om något går fel.
.../

Ok. Jag har nu, efter att ha läst ditt och de två efterföljande inläggen, insett att det är för XP som drivrutinen är tänkt. Och, p.g.a. frekvent BSOD under själva installationen (alldels i början) av XP-Mode, blir jag alltså tvungen att använda speciell programvara.

@niko: tack för länk till NTLite, ett för mig helt okänt program lika mycket i sig som själva konceptet, att det ens fanns något sådant, vilket säger en del om min kunskapsnivå - som iofs tack vare SweClockers i allmänhet, och för ämnet i den här tråden i synnerhet, nu har bättrat sig ännu ett litet snäpp.

Samtidigt inser jag naturligtvis att det kommer bli en hel del att sätta sig i.
Och jag måste också hitta en RST-driver som passar både för XP och min E5540. Någon sådan har jag inte hittat än.

Dessutom fungerar det, som det är just nu med min 5540:a, inte att göra en systemavbild (med Windows eget verktyg). Det har att göra med att Systempartitionen (som skapas i samband med installationen av OS:et, Windows 7 i det här fallet) görs för liten för att det skall bli ett tillräckligt stort ledigt utrymme där för att Windows säkerhetskopieringsverktyg (systemavbildning) skall fungera. Det skall finnas sätt att komma förbi det här genom att på olika vis (det finns flera versioner), förändra storleken på Systempartitionen, men även det är rätt krångligt och kanske inte helt riskfritt.

Skrivet av Paddanx:

Hmm
Det är lite komplicerat och riskabelt, men ska gå:
https://forums.hexus.net/motherboards/112584-how-enable-ahci-...

Ja det här handlade ju om att, för SATA, växla från RAID till Disabled.
Men som jag förstod dig i början av ditt inlägg så stänger ju Disabled av SATA och jag får alltså inte IDE som var tanken - om jag nu förstått dig rätt, och då är ju hela idén med förändringen till Disabled inte meningsfull - så vitt jag begriper.

Det var dock, med utgångspunkt från att jag skulle kunna växla till IDE, som jag ställde frågan och jag har faktiskt snubblat över länken du hänvisar till, bland en del andra för just Win 7, då jag funderade över om det skulle gå att ändra för en dator (med Win10) där jag ville gå från RAID till AHCI.

Sammantaget gör detta att projektet (att installera Win XP Mode på min E5540, som var bakgrunden till den här tråden - och jag inser att det blivit väldigt långt från ursprungsämnet och egentligen skulle postas på en mer adekvat plats, men det började rulla på...) kommer bli rätt tidkrävande - och förmodligen involvera en del riskmoment som jag för stunden är osäker på om jag vill gå in på just nu.
I praktiken betyder det att jag måste flytta ner det här projektet på prioritetslistan, men kommer att återkomma längre fram -så vitt jag inte helt överger Win7, även på 5540:an, för att ev. köra Win10 eller tar upp projektet att börja testa Linux (Ubuntu), något jag länge haft planer för. Vad som då kommer att ske med Win XP Mode blir ju en annan fråga, och kanske inte alls aktuell för den datorn.

Permalänk
Medlem
Skrivet av _niko_:

Tack för svar!
Förstår dock inte riktigt hänvisningen till Intel Matrix Storage Manager - hur den är tänkt att hjälpa mig och hur jag skall använda den - men jag misstänker att det har något med RST-drivers att göra eftersom man hänvisar till detta längst med på sidan (jag är medveten om att frågan kan uppfattas som väldigt nybörjarmässig, men det är den nivån jag befinner mig på och hoppas på överseende med det).

Permalänk
Medlem
Skrivet av ICIT:

Tack, igen, Paddanx
Den enda möjligheten att växla till "Legacy" är i valet mellan UEFI och legcy, men det är ju något helt annat och utförs ju under Boot Sequence
http://forumbilder.se/GA6UD/boot-config-detalj.jpg?width=650
Så, det är bara att konstatera att mitt system inte kan växla till IDE.

Verkar så då ja.

Skrivet av ICIT:

Samtidigt inser jag naturligtvis att det kommer bli en hel del att sätta sig i.
Och jag måste också hitta en RST-driver som passar både för XP och min E5540. Någon sådan har jag inte hittat än.

Ser det nu... Intel verkar ha städat sin hemsida.
Men jag förstår ditt problem. Tror Ivy bridge var gränsnivån för var XP stöd fanns än på de flesta plattformar. Ev kan du försöka med Vista 32-bit drivare, men det är inte säkert de är stabila heller.

Skrivet av ICIT:

Dessutom fungerar det, som det är just nu med min 5540:a, inte att göra en systemavbild (med Windows eget verktyg). Det har att göra med att Systempartitionen (som skapas i samband med installationen av OS:et, Windows 7 i det här fallet) görs för liten för att det skall bli ett tillräckligt stort ledigt utrymme där för att Windows säkerhetskopieringsverktyg (systemavbildning) skall fungera. Det skall finnas sätt att komma förbi det här genom att på olika vis (det finns flera versioner), förändra storleken på Systempartitionen, men även det är rätt krångligt och kanske inte helt riskfritt.

Finns andra program som kan göra detta, så bråka inte med Win 7s begränsning om du inte behöver.

Skrivet av ICIT:

Ja det här handlade ju om att, för SATA, växla från RAID till Disabled.
Men som jag förstod dig i början av ditt inlägg så stänger ju Disabled av SATA och jag får alltså inte IDE som var tanken - om jag nu förstått dig rätt, och då är ju hela idén med förändringen till Disabled inte meningsfull - så vitt jag begriper.

Hela poängen var menat att det finns sätt att skifta drivare. Principen är typ samma oavsett vilken du skiftar mellan.

Det var dock, med utgångspunkt från att jag skulle kunna växla till IDE, som jag ställde frågan och jag har faktiskt snubblat över länken du hänvisar till, bland en del andra för just Win 7, då jag funderade över om det skulle gå att ändra för en dator (med Win10) där jag ville gå från RAID till AHCI.
[/quote]

Win 8/10 är busenkel.

Starta om i felsäkert läge.
När den startar om..., byt till det läge du vill ha i BIOS, sen låt den boota felsäkert.
Sen när du är inne i felsäkert läge så starta om igen till vanligt läge.

Ev kan man behöva lägga in drivare till RAID för att den ska bli glad om man går från IDE -> RAID tex, men då du går till AHCI, har den alla drivare själv.

Skrivet av ICIT:

Sammantaget gör detta att projektet (att installera Win XP Mode på min E5540, som var bakgrunden till den här tråden - och jag inser att det blivit väldigt långt från ursprungsämnet och egentligen skulle postas på en mer adekvat plats, men det började rulla på...) kommer bli rätt tidkrävande - och förmodligen involvera en del riskmoment som jag för stunden är osäker på om jag vill gå in på just nu.
I praktiken betyder det att jag måste flytta ner det här projektet på prioritetslistan, men kommer att återkomma längre fram -så vitt jag inte helt överger Win7, även på 5540:an, för att ev. köra Win10 eller tar upp projektet att börja testa Linux (Ubuntu), något jag länge haft planer för. Vad som då kommer att ske med Win XP Mode blir ju en annan fråga, och kanske inte alls aktuell för den datorn.

Win XP får du nog titta på en äldre maskin för. Sandybridge eller kanske Ivy bridge. Då fanns chipset drivare än.

Permalänk
Medlem
Skrivet av Paddanx:

Ser det nu... Intel verkar ha städat sin hemsida.
Men jag förstår ditt problem. Tror Ivy bridge var gränsnivån för var XP stöd fanns än på de flesta plattformar. Ev kan du försöka med Vista 32-bit drivare, men det är inte säkert de är stabila heller.
/....
Win XP får du nog titta på en äldre maskin för. Sandybridge eller kanske Ivy bridge. Då fanns chipset drivare än.
.../

Det har sakta men säkert gått upp för mig att det nog ligger till på det sättet. Fick det defenitivt bekräftat när jag sökte drivare på Intel, inte hittade några och tog upp kontakten med deras support där jag blev tydligt avrådd från att försöka baka in RST-drivare i min XP-image på 5540:an.

Skrivet av Paddanx:

Finns andra program som kan göra detta, så bråka inte med Win 7s begränsning om du inte behöver.
/...

Jodå, jag har tittat på ett par enklare (gratisversioner). Testat en (EaseUs Todo Backup, tror det var v. 8 någon ting) som inte fungerade tillräckligt bra (fungerade inte att spegla endast C-partitionen - fick veta att de jobbade på saken och skulle fixa problemet till kommande uppdateringar. Om det blivit så vet jag inte. Jag har faktiskt inte hittat någon lösning för burkarna med W7 ännu - bortsett från den dagliga backupen av övriga partitioner (också väldigt basic Microsoft - SyncToy - som tillsvidarelösning) och att jag någon gång emellanåt klonat hela disken på resp. maskin - men det är ju verkligen inte någon vettig rutin. Planerar (sedan länge) en mer "riktigt" backuprutin för filer (fortfarande gratisprogram), FreeFileSync tror jag skulle kunna vara vettigt.
När det gäller spegling av programpartitionen hoppas jag det kommer att flyta på bättre med W10. Annars får du gärna tipsa om ett bra gratis backupprogram som kan ta enbart C-partitionen och gärna med inkrementell och/eller sekventiell kopiering.

Skrivet av Paddanx:

Hela poängen var menat att det finns sätt att skifta drivare. Principen är typ samma oavsett vilken du skiftar mellan.
.../
Win 8/10 är busenkel.

Starta om i felsäkert läge.
När den startar om..., byt till det läge du vill ha i BIOS, sen låt den boota felsäkert.
Sen när du är inne i felsäkert läge så starta om igen till vanligt läge.

Ev kan man behöva lägga in drivare till RAID för att den ska bli glad om man går från IDE -> RAID tex, men då du går till AHCI, har den alla drivare själv.

Stort tack för länk och info.
Löjligt enkelt för W8 & W10 får man säga
Förmodligen blir det dock sällan jag kommer att behöva gå till väga på så sätt. Samtliga maskiner som är aktuella för W10 kommer att installeras från början, som UEFI och AHCI. Skulle möjligen bli aktuellt med RAID för någon av dem längre fram och då är det ju skönt att redan från början veta att proceduren är så enkel.