Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016

Ljudet flyttar sig

Har två HDMI ut från grafikkortet varav en är DVI-HDMI adapter. Startar jag om datorn kan de ha bytt med varandra så den jag satt som standardenhet för ljud (DVI-HDMI) byter med den andra och det blir tyst. Får då gå in i inställningarna igen. Finns det någon lösning?

Var lika även innan jag ominstallerade Windows så det problemet löstes inte.

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2017

Testa inaktivera den du inte vill ha?

Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016

@MarcusHuddinge: Tar bild från en och ljudet från den andra.

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2004
Skrivet av yrfhar:

@MarcusHuddinge: Tar bild från en och ljudet från den andra.

Det han menar är att du ska högerklicka på de enheterna som du inte använder för ljud och välja "inaktivera" eller "disable" (beroende på språket).
Då finns det bara en enhet kvar som används som högtalare Det påverkar inte bilden.

“Problems that remain persistently insoluble should always be suspected as questions asked in the wrong way.” ― Alan W. Watts

Trädvy Permalänk
Medlem
Registrerad
Dec 2015

Windows är sämst i världen på att hantera ljudenheter, har själv några st med receiver, headset, htc vive, tv etc och windows fukkar alltid upp saker och skiter fullständigt i vad användaren tycker.

Att tanka hem "Audio output switcher" gör livet lite enklare, speciellt om man använder hot-keys.
Men finns det nån lösning för att få windows att respektera inställningarna man gör så är jag också intresserad

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2017
Skrivet av warh0g:

Det han menar är att du ska högerklicka på de enheterna som du inte använder för ljud och välja "inaktivera" eller "disable" (beroende på språket).
Då finns det bara en enhet kvar som används som högtalare Det påverkar inte bilden.

this ^
Borde ju funka

Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016
Skrivet av warh0g:

Det han menar är att du ska högerklicka på de enheterna som du inte använder för ljud och välja "inaktivera" eller "disable" (beroende på språket).
Då finns det bara en enhet kvar som används som högtalare Det påverkar inte bilden.

Ska prova detta och prova. Det jag misstänker är att om Windows får för sig att swisha till den ej aktiva enheten så står jag på ruta ett igen. Men ska prova.

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.

Trädvy Permalänk
Medlem
Plats
Södertälje
Registrerad
Aug 2007

Switcha till ej aktiv har jag inte fått men den slår på nvidia hdmi sedan en tid på windows 10 har jag fått men inte att den byter till den. Men jag kör inte ljud över hdmi som standard.

CPU: i7 3770k@4,50Ghz MB Z77X-D3H RAM: 16GB@2133mhz (10-12-11-27 2T)
GPU: 980Ti@1404,8 HDD: 4st MLC 1st TLC and 2st HDD for random: FD-PSU-TS2B-800W. Sound: SB-Z -> toslink (DTS)-> old JVC. MB Via to Z-2300 for VOIP. http://valid.x86.fr/nf1u3d https://www.techpowerup.com/gpuz/gxryb

Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016
Skrivet av MarcusHuddinge:

Testa inaktivera den du inte vill ha?

Skrivet av warh0g:

Det han menar är att du ska högerklicka på de enheterna som du inte använder för ljud och välja "inaktivera" eller "disable" (beroende på språket).
Då finns det bara en enhet kvar som används som högtalare Det påverkar inte bilden.

Skrivet av yrfhar:

Ska prova detta och prova. Det jag misstänker är att om Windows får för sig att swisha till den ej aktiva enheten så står jag på ruta ett igen. Men ska prova.

Tyvärr hjälper inte detta. Windows verkar göra det som operativsystemet tror är bäst för mig. Byter hej vilt om jag stänger av datorn och sedan sätter på.

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.

Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016

Sitter nu med Windows 10 Insider Preview 17134.1 (rs4_release) och gott folk, det bli värre. Innan kunde det byta under en omstart men nu byter det hej vilt. KODI fungerar bara med ljud ut till TV-högtalarna.

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.

Trädvy Permalänk
Medlem
Plats
Helsingborg
Registrerad
Jan 2015

Inaktivera ljudenheten i enhetshanteraren, snarare än i ljudenheter, så finns det absolut inget sätt för windows att falla tillbaka på den.

Anledningen till att den skiftar, trots att du ställt in en specifik på default, är troligtvis för att DVI-anslutningen kollas först och är vid det tillfället den enda möjliga ljudenheten inkopplad, därför faller windows tillbaka på den. Vild spekulation, men känns som den logiska förklaringen.

Du lär ha två stycken NVidia High Definition-enheter, utan möjlighet att klura ut vilken som är vilken, så du får köra uteslutningsmetoden och inaktivera en av dem och sen kolla vilken som försvinner från listan i ljudenheter.

Vet att det inte är någon direkt superpraktiskt lösning, men det är den enda lösningen jag känner till.

Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016
Skrivet av elBenko:

Inaktivera ljudenheten i enhetshanteraren, snarare än i ljudenheter, så finns det absolut inget sätt för windows att falla tillbaka på den.
.......
Vet att det inte är någon direkt superpraktiskt lösning, men det är den enda lösningen jag känner till.

Då får jag ingen bild. Ska prova med dessa inställningar:

Vilket gjorde att vid omstart får jag inget ljud alls fr+ån DVI och inte heller när jag återaktiverade ljudet från HDMI.

Synd att min Soundbar från Samsung, HW-K960, inte klarar 4K HDR 60 Hz, annars vore detta problem ur världen. Samsung prissänker från 16 000 kr till 8 000 kr istället för att buggfixa.

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.

Trädvy Permalänk
Medlem
Plats
Västra Götaland
Registrerad
Mar 2016

Tröttnade till slut på att få ut ATMOS från PC och in med ljudkortet igen (DD-Live och DTS Connect) så kör nu med optisk ljudkabel som innan. Köpte mig en Xbox One X så nu inget krångel med att få till 4K HDR ATMOS på Netflix och samma får Shield köra från KODI/Plex.

Frågan är nu bara vad jag ska göra med min Chrome Cast Ultra? En helt onödig pryl men vill ändå inte sälja.
Min setup
PC klarar HDR från You Tube med Chrome
Shield klarar 4K HDR ATMOS från KODI
Xbox One klarar 4K HDR ATMOS från Netflix
Chromecast rätt värdelös förutom att klara YT med HDR
TV appen klarar HBO 5.1 men den tjänsten har jag sagt upp då UI är rätt värdelöst att hitta i.

Ryzen 1800X - Palit Nvidia GTX 1080 - Samsung (2016) 4K UHD TV som skärm och Samsung HW-K960 till ljudet.