Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2017

Problem med Realtek ALC898

Köpte nyligen ett https://www.msi.com/Motherboard/B350I-PRO-AC som fungerar förträffligt förutom att ljudenheten i rubriken inte existerar som enhet i Win10 enhetshanteraren. Har installerat officiella drivrutiner för MSI Win10 64-bit och aldrig fått något felmeddelande, men enheten existera efteråt inte i Win10 enhetshanteraren och går därför inte att använda för line-out. Vad tror ni? Är den defekt eller är det ett bristande handhavande från min sida? Nu är det lite skit samma eftersom jag kör via inbyggda ljudkrets i AMD RX580 , men det gnager ändå i bakhuvudet. Uppskattar tips som inte har med ominstallation av OS att göra :).

Trädvy Permalänk
Medlem
Registrerad
Aug 2005

Testa att ladda ner drivrutinerna från Realteks hemsida istället, fast i min erfarehenhet brukar dessa enheter fungera med generiska drivrutiner från Windows också.

Trädvy Permalänk
Medlem
Registrerad
Mar 2018

@Wcx: Pröva dessa istället http://www.realtek.com/downloads/ Kanske fungerar bättre.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2017

Ok ska testa det.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2017

Ser i efterhand att tråden nog ligger i fel kategori. MOD får gärna flytta den. Har testat med föreslagna drivrutiner med samma resultat. Enheten dyker upp i program som Aida64, men jag kan inte nå den via Win10. Nåja...som sagt det är inget som påverkar dagliga användningen. Ska testa med någon Linux distro när jag ids. Tack och bock för förslagen.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2007

Antagligen har Windows installerat sina egna generiska drivrutiner och då står det typ "Ljudenhet". Testa att avinstallera och installera drivrutinerna från MSIs hemsida.

Spel: Ryzen 7 1800x, MSI 1080 ti, 16GB DDR4 Flare X
Har haft dessa GPUer: Tseng ET6000, Matrox M3D, 3DFX Voodoo 1-3, nVidia Riva 128, TNT, TNT2, Geforce 256 SDR+DDR, Geforce 2mx, 3, GT 8600m, GTX460 SLI, GTX580, GTX670 SLI, 1080 ti AMD Radeon 9200, 4850 CF, 6950@70, 6870 CF, 7850 CF, R9 390, Vega 64
Lista beg. priser GPUer ESD for dummies

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Sep 2002

Kontrollera att ljudkortet är aktiverat i BIOS

AMD Ryzen 2700X (Phanteks PH-TC14PE ) * Corsair LPX 16GB @3000MHz (Hynix) * ASUS Prime X370-PRO * MSI GTX 1080 Gaming @2050/11000MHz * Crucial BX100 500GB * Fractal Design Define S * Corsair RM750x

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2017

@Herr Kantarell: Ljudenheten är osynlig i enhetshanteraren. Finns inte som valbar ljudenhet i ljudinställningar. Dyker dock upp i andra program som Aida64. Kan kretsen ändå vara defekt?

@veckans: Provat att avaktivera och aktivera i bios ett flertal gånger med noll resultat.

När jag installerar Realtek programvara för ljudkortet så går allt smärtfritt utan felmeddelande, men när jag efteråt kollar i "Program" och "Program (x86)" så finns ingen katalog som härleder till ljudkortsinstallation. Finns inte heller någon startad process i aktivitetshanteraren efter reboot.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2007
Skrivet av Wcx:

@Herr Kantarell: Ljudenheten är osynlig i enhetshanteraren. Finns inte som valbar ljudenhet i ljudinställningar. Dyker dock upp i andra program som Aida64. Kan kretsen ändå vara defekt?

@veckans: Provat att avaktivera och aktivera i bios ett flertal gånger med noll resultat.

När jag installerar Realtek programvara för ljudkortet så går allt smärtfritt utan felmeddelande, men när jag efteråt kollar i "Program" och "Program (x86)" så finns ingen katalog som härleder till ljudkortsinstallation. Finns inte heller någon startad process i aktivitetshanteraren efter reboot.

Tror att moderna kretsar gör sig "Icke valbara" om du inte kopplar in hörlurar eller dyl.
Likaså att HDMI ljudenheten försvinner om man inte kopplar en skärm via HDMI.

Spel: Ryzen 7 1800x, MSI 1080 ti, 16GB DDR4 Flare X
Har haft dessa GPUer: Tseng ET6000, Matrox M3D, 3DFX Voodoo 1-3, nVidia Riva 128, TNT, TNT2, Geforce 256 SDR+DDR, Geforce 2mx, 3, GT 8600m, GTX460 SLI, GTX580, GTX670 SLI, 1080 ti AMD Radeon 9200, 4850 CF, 6950@70, 6870 CF, 7850 CF, R9 390, Vega 64
Lista beg. priser GPUer ESD for dummies

Trädvy Permalänk
Medlem
Registrerad
Aug 2005

Högerklicka på ljudikonen nere i system tray och välj "Playback devices". Högerklicka i listan och bocka för "Show Disabled Devices" och "Show Disconnected Devices" och se om de inte dyker upp då. Som Kantarell säger kanske enheterna är avaktiverade/dolda för att de inte används.

Trädvy Permalänk
Hedersmedlem
Plats
Omnipresent
Registrerad
Okt 2004
Skrivet av Wcx:

@Herr Kantarell: Ljudenheten är osynlig i enhetshanteraren. Finns inte som valbar ljudenhet i ljudinställningar. Dyker dock upp i andra program som Aida64. Kan kretsen ändå vara defekt?

@veckans: Provat att avaktivera och aktivera i bios ett flertal gånger med noll resultat.

När jag installerar Realtek programvara för ljudkortet så går allt smärtfritt utan felmeddelande, men när jag efteråt kollar i "Program" och "Program (x86)" så finns ingen katalog som härleder till ljudkortsinstallation. Finns inte heller någon startad process i aktivitetshanteraren efter reboot.

Är ljudet på i UEFI:n och inte hittas i enhetshanteraren så är det troligen något fel på kretsen antagligen.....
Hör med dem du köpte kortet av om utbyte.

Gud är Död! - Nietzsche
Nietzsche är Död! - Gud

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2017

Har testat förslagen, resettat bios och testat med ubuntu. Ingen framgång. Skulle kunna testa flasha bios till äldre utgåva men tappar då stöd för min Ryzen 2600, så det är ingen god idé :). Ids inte reklamera. Andrahandsvärdet lär sjunka men det är ingen dyrgrip ändå. Tack ska ni ha för goda tips!

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2017

Lyckligt slut :). Inbyggda nätverkskortet har strulat allt mer med tiden och försvann också som enhet igår. Genomförde en lite grundligare koll och såg att EK-kylflänsen monterad på M.2 SSD låg an mot chassits bottenplåt. Tydligen orsakade det kortslutning för när jag la ett tunnt plastark emellan som isolering så hoppade både ljudkort och nätverkskort igång.