Ryzen 2700x visar endast 2 kärnor och 4 trådar som aktiva.

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Feb 2009

Ryzen 2700x visar endast 2 kärnor och 4 trådar som aktiva.

Hej!
Från första början körde jag processorn helt i defaultinställningar och då visade Ryzen Master att den tuffade på i upp till 4350Mhz (ibland peakede den ända upp på 4,4 Ghz) på alla kärnor med en core volt (enligt Ryzen Master) på mellan 1,45-1,55 v.
So far so good, åtminstone då jag fattat det så att de höga volten inte är någon fara då jag har kylning som klarar av att hålla temps under kontroll (max jag nått under spel är omkring 70 grader) medan idle hoppar lite mellan ca 35-55 beroende på vad jag grejar med och hur pass mycket processorn boostar sig själv.

Så till problemet:

När jag spelar började datorn starta om sig själv i tid och otid - varför jag efter lite googlande testade att stänga av SMT i Ryzen Master.
(Som Default i Ryzen Master tickade alla kärnor på som ovan, alltså upp mot 4,4 Ghz som max på samtliga kärnor.)

Helt plötsligt, utan att jag gjort mycket annat än att byta till Game Mode i Mastern (för att kunna avaktivera SMT) så blev det istället så att det under Current står att 2 kärnor går i 4350 mhz och resten står i 600 mhz.
Under Game Mode står 4 kärnor på 4,0 Ghz.

Aktivitetshanteraren, HWInfo och övriga mjukvaru"kontroller" visar alltså att 2 fysiska kärnor är aktiva - till skillnad från förut - trots att jag som sagt försökt aktivera Game Mode - och då skulle ju 4 kärnor vara aktiverade...

I UEFI-inställningarna står bland annat:

SVM: Disabled

SMT: Auto

Core level... : Auto

Skall något av detta ändras för att jag skall komma tillbaka till Default-läget eller hur tusan skall jag göra?

Jag skulle föredra att alla kärnor tuffar på som förut på max och att jag bara kan stänga av SMT i Ryzen Master om något spel "kräver" detta för att fungera. I övrigt håller jag mig gärna borta från att krångla med massa inställningar som jag inte förstår mig på.

Vad/Hur göra för att gå tillbaka till Default?

Tacksam om någon kan förklara detta för mig på ett enkelt sätt.

Mvh, Fredrik

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2011
Skrivet av thunderwolf:

Hej!
Från första början körde jag processorn helt i defaultinställningar och då visade Ryzen Master att den tuffade på i upp till 4350Mhz (ibland peakede den ända upp på 4,4 Ghz) på alla kärnor med en core volt (enligt Ryzen Master) på mellan 1,45-1,55 v.
So far so good, åtminstone då jag fattat det så att de höga volten inte är någon fara då jag har kylning som klarar av att hålla temps under kontroll (max jag nått under spel är omkring 70 grader) medan idle hoppar lite mellan ca 35-55 beroende på vad jag grejar med och hur pass mycket processorn boostar sig själv.

Så till problemet:

När jag spelar började datorn starta om sig själv i tid och otid - varför jag efter lite googlande testade att stänga av SMT i Ryzen Master.
(Som Default i Ryzen Master tickade alla kärnor på som ovan, alltså upp mot 4,4 Ghz som max på samtliga kärnor.)

Helt plötsligt, utan att jag gjort mycket annat än att byta till Game Mode i Mastern (för att kunna avaktivera SMT) så blev det istället så att det under Current står att 2 kärnor går i 4350 mhz och resten står i 600 mhz.
Under Game Mode står 4 kärnor på 4,0 Ghz.

Aktivitetshanteraren, HWInfo och övriga mjukvaru"kontroller" visar alltså att 2 fysiska kärnor är aktiva - till skillnad från förut - trots att jag som sagt försökt aktivera Game Mode - och då skulle ju 4 kärnor vara aktiverade...

I UEFI-inställningarna står bland annat:

SVM: Disabled

SMT: Auto

Core level... : Auto

Skall något av detta ändras för att jag skall komma tillbaka till Default-läget eller hur tusan skall jag göra?

Jag skulle föredra att alla kärnor tuffar på som förut på max och att jag bara kan stänga av SMT i Ryzen Master om något spel "kräver" detta för att fungera. I övrigt håller jag mig gärna borta från att krångla med massa inställningar som jag inte förstår mig på.

Vad/Hur göra för att gå tillbaka till Default?

Tacksam om någon kan förklara detta för mig på ett enkelt sätt.

Mvh, Fredrik

Om du inte överklockat eller så så låter det helt sinnes att datorn bara startar om sig... Det är något som är galet. "game mode" i Ryzen master stänger ju av kärnor så det känns som förväntat beteende.

Som första steg i felsökning så skulle jag välja "load optimized defaults" i UEFI/BIOS för att säkerställa att det inte är någon inställning där som bråkar.

Första inlägget i en tråd är sällan relevant när tid har förflutit. Vänligen svara på mitt senaste inlägg i tråden, inte det första, annars blir det kass. http://ozzed.net Min egenkomponerade 8-bit musik. Gillar du musiken från gamla klassiska NES eller Gameboy och liknande är det värt ett besök. :) Jag finns också på Spotify, Bandcamp, Jamendo, Youtube, och du kan även följa mig på Twitter och Facebook.

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Feb 2009

@Ozzed:

Nä, det enda som jag gjort var att ställa upp minnena på 3200 mhz och det funkar utan problem. När väl SMT var borta så funkade spelet utan problem så även om det inte är någon bra lösning så var det "nödvändigt" för att kunna spela. Konstigt nog.

Nu lyckades jag, genom idogt googlande, så hitta en inställning i msconfig där man helt sonika avmarkerar en ruta som anger antal aktiva processorer - det löste problemet och nu visas korrekt antal fysiska och virtuella kärnor i tex aktivitetshanteraren och i Ryzen Master ser "Current" ut som det gjorde tidigare.

Tyvärr går det ju inte att göra några manuella ändringar under just Current så SMT finns ju där synnerligen aktivt.

Om man gör en egen profil med SMT avaktiverat men alla kärnor på 3700 - kommer beteendet i övrigt att likna det som jag har i Current nu? Alltså att volten justeras automatiskt i harmoni med kylning osv och mhz på kärnorna tuffar på av sig själva i högsta möjliga hastighet - även det i harmoni med kylningens förmåga?

Jag tänker att man då kan göra en egen Game-profil som funkar som i stycket ovan med SMT avaktiverat och en vanlig vardagsprofil som kör som Current gör i nuläget med SMT på. Går det eller måste jag hålla på och ställa in tex volten automatiskt isåfall?

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2011
Skrivet av thunderwolf:

@Ozzed:

Nä, det enda som jag gjort var att ställa upp minnena på 3200 mhz och det funkar utan problem. När väl SMT var borta så funkade spelet utan problem så även om det inte är någon bra lösning så var det "nödvändigt" för att kunna spela. Konstigt nog.

Nu lyckades jag, genom idogt googlande, så hitta en inställning i msconfig där man helt sonika avmarkerar en ruta som anger antal aktiva processorer - det löste problemet och nu visas korrekt antal fysiska och virtuella kärnor i tex aktivitetshanteraren och i Ryzen Master ser "Current" ut som det gjorde tidigare.

Tyvärr går det ju inte att göra några manuella ändringar under just Current så SMT finns ju där synnerligen aktivt.

Om man gör en egen profil med SMT avaktiverat men alla kärnor på 3700 - kommer beteendet i övrigt att likna det som jag har i Current nu? Alltså att volten justeras automatiskt i harmoni med kylning osv och mhz på kärnorna tuffar på av sig själva i högsta möjliga hastighet - även det i harmoni med kylningens förmåga?

Jag tänker att man då kan göra en egen Game-profil som funkar som i stycket ovan med SMT avaktiverat och en vanlig vardagsprofil som kör som Current gör i nuläget med SMT på. Går det eller måste jag hålla på och ställa in tex volten automatiskt isåfall?

Ja, såvida du inte ställt in manuell Vcore i BIOS så ska kärnorna tuffa på så som du beskriver. Det är ju också lätt att verifiera med t. ex HWINFO64 eller rent av aktivitetshanteraren. Ser du där att cpu-frekvensen inte är statisk utan går upp och ner så är det som det ska.

Däremot så kan dina problem bero på att XMP inte alltid garanterat funkar, som ett test så skulle du kunna ställa ner hastigheten från 2300 till 3133 och se om krascherna upphör.

Första inlägget i en tråd är sällan relevant när tid har förflutit. Vänligen svara på mitt senaste inlägg i tråden, inte det första, annars blir det kass. http://ozzed.net Min egenkomponerade 8-bit musik. Gillar du musiken från gamla klassiska NES eller Gameboy och liknande är det värt ett besök. :) Jag finns också på Spotify, Bandcamp, Jamendo, Youtube, och du kan även följa mig på Twitter och Facebook.

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Feb 2009

@Ozzed:

Yes, precis så gör det - så då är den biten som den skall iallafall.
Just volten blir lite förvirrande ibland bara när vissa hävdar att processorn börjar degraderas näst intill direkt med såpass hög v core medan andra säger att det är såhär det skall se ut med Zen+ och att den höga volten är fullt normal och att systemet självt klockar ner sig om nivåerna skulle gå upp till skadliga nivåer. Som novis blir man "lite" småförvirrad.

Låter som ett bra förslag att testa att ställa ner minneshastigheten ett snäpp. Alltid bra att kunna utesluta möjliga orsaker till krångel. (:

Finns det något program där jag kan testa minnet förresten? Stabilitetstest alltså. Tänker att det kan vara ett bra första steg för att se så det inte är så att det är den biten som havererar.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2007
Skrivet av thunderwolf:

@Ozzed:

Yes, precis så gör det - så då är den biten som den skall iallafall.
Just volten blir lite förvirrande ibland bara när vissa hävdar att processorn börjar degraderas näst intill direkt med såpass hög v core medan andra säger att det är såhär det skall se ut med Zen+ och att den höga volten är fullt normal och att systemet självt klockar ner sig om nivåerna skulle gå upp till skadliga nivåer. Som novis blir man "lite" småförvirrad.

Låter som ett bra förslag att testa att ställa ner minneshastigheten ett snäpp. Alltid bra att kunna utesluta möjliga orsaker till krångel. (:

Finns det något program där jag kan testa minnet förresten? Stabilitetstest alltså. Tänker att det kan vara ett bra första steg för att se så det inte är så att det är den biten som havererar.

Skriv memory i windows sökruta och starta windows egna minnestestprogram.

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2011
Skrivet av thunderwolf:

@Ozzed:

Yes, precis så gör det - så då är den biten som den skall iallafall.
Just volten blir lite förvirrande ibland bara när vissa hävdar att processorn börjar degraderas näst intill direkt med såpass hög v core medan andra säger att det är såhär det skall se ut med Zen+ och att den höga volten är fullt normal och att systemet självt klockar ner sig om nivåerna skulle gå upp till skadliga nivåer. Som novis blir man "lite" småförvirrad.

Låter som ett bra förslag att testa att ställa ner minneshastigheten ett snäpp. Alltid bra att kunna utesluta möjliga orsaker till krångel. (:

Finns det något program där jag kan testa minnet förresten? Stabilitetstest alltså. Tänker att det kan vara ett bra första steg för att se så det inte är så att det är den biten som havererar.

OCCT http://www.ocbase.com/index.php/download det är ett av de hårdare stabilitetstesten och belastar såväl minne som cpu duktigt hårt. Ställ in det på att köra ~30 minuter. Klarar datorn inte testet så är det instabilitet någonstans, och då det bara är minnet som är "klockat" så blir det ett logiskt steg att ställa ner till 3133, testa igen, bliir det fel 3066, 3000, 2933 osv tills det är stabilt.

Spänningen är inget att oroa sig för Tittar du i HWINFO64 så är det "CPU Core Voltage (SVI2 TFN)" som är den äkta spänningen, och den kan gå upp till 1.512v utan att det är någon fara, det handlar oftast om milisekunder vilket inte är skadligt för cpu. Det som kan degradera är om man manuellt ställer Vcore högre äv 1.425V, då den i det läget matar på med den spänningen konstant och över tid så kan då transistorerna slitas ut och processorn degraderas. Men låter man det vara på AUTO och inte klockar så kommer det inte hända, då SenseMI som det heter ser till att det blir en säker spänning vid en given frekvens, så det är helt lugnt.

Första inlägget i en tråd är sällan relevant när tid har förflutit. Vänligen svara på mitt senaste inlägg i tråden, inte det första, annars blir det kass. http://ozzed.net Min egenkomponerade 8-bit musik. Gillar du musiken från gamla klassiska NES eller Gameboy och liknande är det värt ett besök. :) Jag finns också på Spotify, Bandcamp, Jamendo, Youtube, och du kan även följa mig på Twitter och Facebook.

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Feb 2009

@Ozzed:

Skall testa detta på direkten tack för hjälpen!

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2011
Skrivet av thunderwolf:

@Ozzed:

Skall testa detta på direkten tack för hjälpen!

Hur har det gått? Fick du ordning på det?

Första inlägget i en tråd är sällan relevant när tid har förflutit. Vänligen svara på mitt senaste inlägg i tråden, inte det första, annars blir det kass. http://ozzed.net Min egenkomponerade 8-bit musik. Gillar du musiken från gamla klassiska NES eller Gameboy och liknande är det värt ett besök. :) Jag finns också på Spotify, Bandcamp, Jamendo, Youtube, och du kan även följa mig på Twitter och Facebook.

Trädvy Permalänk
Medlem
Plats
Vänersborg
Registrerad
Feb 2009

@Ozzed:
Sorry för otroligt sent svar..
Stresstestet gick utan problem, körde i 60 minuter och allt var OK där alltså.

Lyckades till slut googla mig fram till att Win10 (som jag förstod det) ibland alldeles på egen hand gör någon fuländring och justerar antal aktiva kärnor.
Löstes genom att följa tipset man fick på sidan ifråga om att öppna msconfig, gå in under en "avancerat"-flik och där avmarkera den ruta som blivit markerad och där "4 kärnor aktiva" stod som alternativ.
Efter att jag gjort detta och startat om datorn funkade allt klockrent igen, och såg även ut som förut i Ryzen Master.

Sä skam den som ger sig.

Nu håller jag för övrigt på att med små små pyttesteg prova att klocka min gamla 4790k som numera tjänstgör som htpc. Förvisso duger den ju utmärkt till det jag kommer att använda den till redan nu, typ netflix, vanligt surfande och mindre krävande spel, men det är alltid kul att lära sig nya saker.

Än en gång, tack för hjälpen!

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Feb 2011
Skrivet av thunderwolf:

@Ozzed:
Sorry för otroligt sent svar..
Stresstestet gick utan problem, körde i 60 minuter och allt var OK där alltså.

Lyckades till slut googla mig fram till att Win10 (som jag förstod det) ibland alldeles på egen hand gör någon fuländring och justerar antal aktiva kärnor.
Löstes genom att följa tipset man fick på sidan ifråga om att öppna msconfig, gå in under en "avancerat"-flik och där avmarkera den ruta som blivit markerad och där "4 kärnor aktiva" stod som alternativ.
Efter att jag gjort detta och startat om datorn funkade allt klockrent igen, och såg även ut som förut i Ryzen Master.

Sä skam den som ger sig.

Nu håller jag för övrigt på att med små små pyttesteg prova att klocka min gamla 4790k som numera tjänstgör som htpc. Förvisso duger den ju utmärkt till det jag kommer att använda den till redan nu, typ netflix, vanligt surfande och mindre krävande spel, men det är alltid kul att lära sig nya saker.

Än en gång, tack för hjälpen!

Härligt att det löste sig!

Första inlägget i en tråd är sällan relevant när tid har förflutit. Vänligen svara på mitt senaste inlägg i tråden, inte det första, annars blir det kass. http://ozzed.net Min egenkomponerade 8-bit musik. Gillar du musiken från gamla klassiska NES eller Gameboy och liknande är det värt ett besök. :) Jag finns också på Spotify, Bandcamp, Jamendo, Youtube, och du kan även följa mig på Twitter och Facebook.

Trädvy Permalänk
Medlem
Registrerad
Nov 2016
Skrivet av Ozzed:

Härligt att det löste sig!

Aa håller med löste sig