Problem med att installera HA på en RPi3 B+

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

Problem med att installera HA på en RPi3 B+

Hej,

Lyckades såklart stänga fliken på mitt nästan klara inlägg.. =(

Jag hade tänkt att komma igång med lite automation här hemma och fick tips här på forumet via en annan tråd att köra HA på en RPi. jag bestämde mig för det och beställde hem grejer för att få igång en RPi. Jag får in Raspian som jag ska och får igång allt med det. dock så lyckas jag inte få till installationen utav HA. Jag har provat med 2 olika guider, flera gånger per guide men fastnat varje gång.
Nedan är länkarna som jag använt:

https://snillevilla.se/sa-kommer-du-igang-med-home-assistant/
På denna så får jag upp att det är ngt fel på länken, har hållit på med den nedan så minns inte exakt vad den sa.. Sorry! Men antog att denna var gammal och att det kanske inte funkade längre..

https://www.home-assistant.io/hassio/installation/
Med denna så lyckas jag flasha över hassos på minnet och när jag sätter i det i RPi och kör igång den så är det en massa vit text som går förbi men till slut så stannar även denna. Får upp saker i stil med:

//
docker0: port 1(veth48f689c) entered blocking state
.... entered forwarding state
..... entered disabled state
...
..
IPv6: .... wlan0: link is not ready

//

vet inte om det säger något (inser att min information inte är supertydlig!). Men är det någon som kan säga om jag gör något fel? Jag flashar minnet på en macbook, men antar att det inte är det som är problemet?

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Plats
som gud är min närvaro överallt.
Registrerad
Nov 2005

@archie: inga problem

ladda ner denna: https://github.com/home-assistant/hassos/releases/download/2....

och denna: https://www.balena.io/etcher

flash översta länken till ditt minneskort med ovan länk mjukvara.
sätt i den i din rasberry och starta den, efter ca 20 minuter kan du logga in på ha genom att kolla i routern eller via detta verktyg: http://www.advanced-ip-scanner.com/se/ vilken ip din ha installation har.

Om du lär dig älska din smärta kommer du känna dig älskad var dag;-)

main dator: rampage v10, 6950x, Titan xp,64gig ram,intel 950,2x 10gig nic, asus 2k 165hz ips skärm, 900D custom vattenkylning.
main server: Supermicro, amd 6386se 16 trådar, 20TB i raid 6, 64gig ecc ram, 6x 10 gig nic. custom vattenkylning. 1/1gig nätverk via dedikerad fiberlina, router:usg pro4

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@aragon: Tack igen..

Har redan den filen nerladdad och har för mig att jag testat men gör det "mörkt" en gång.. alla andra gånger så har jag haft den kopplad till en skärm och då sett felmeddelanden. Kan iofs vara att jag sett fel och vart orolig, att den kanske behöver tid att installera..

Och med logga in menar du att via webläsare gå in på hassio.local:8123 alt. 192.168.xxx.xxx:8123?

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Plats
som gud är min närvaro överallt.
Registrerad
Nov 2005

@archie: hej, japp du kommer inte se mer än möjligen ha iconen med en skärm inkopplad i rasberry
du behöver gå till andressen som du skriv. det kan som sagt ta över 20 min innan den är färdig så ta det lugnt och se till att ha en rj45 kabel ansluten mellan raberry och routern.

vill du inte köra hass.io kan du testa hasbian, jag föredrar dock hass.io (men smaken är som baken)
båda är homeassistant bara lite olika sätta att installera och använda.

Om du lär dig älska din smärta kommer du känna dig älskad var dag;-)

main dator: rampage v10, 6950x, Titan xp,64gig ram,intel 950,2x 10gig nic, asus 2k 165hz ips skärm, 900D custom vattenkylning.
main server: Supermicro, amd 6386se 16 trådar, 20TB i raid 6, 64gig ecc ram, 6x 10 gig nic. custom vattenkylning. 1/1gig nätverk via dedikerad fiberlina, router:usg pro4

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@aragon: Den lever! funkar både via dator och via appen på mobilen, fattar nada än sålänge men nu när det väl finns där så ska jag börja läsa runt lite mer. Återkommer högst troligt med ett helt gäng med frågor, men ska försöka mig förstå det lite mer först.

För övrigt så hade jag min nätverkskabel kopplad direkt till min fiberbox innan, vet inte om det kan ha påverkat något. Men nu funkar det iaf!

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Plats
som gud är min närvaro överallt.
Registrerad
Nov 2005

@archie: gött, det är bara att fråga på.

Om du lär dig älska din smärta kommer du känna dig älskad var dag;-)

main dator: rampage v10, 6950x, Titan xp,64gig ram,intel 950,2x 10gig nic, asus 2k 165hz ips skärm, 900D custom vattenkylning.
main server: Supermicro, amd 6386se 16 trådar, 20TB i raid 6, 64gig ecc ram, 6x 10 gig nic. custom vattenkylning. 1/1gig nätverk via dedikerad fiberlina, router:usg pro4

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Nov 2006
Skrivet av archie:

@aragon: Den lever! funkar både via dator och via appen på mobilen, fattar nada än sålänge men nu när det väl finns där så ska jag börja läsa runt lite mer. Återkommer högst troligt med ett helt gäng med frågor, men ska försöka mig förstå det lite mer först.

För övrigt så hade jag min nätverkskabel kopplad direkt till min fiberbox innan, vet inte om det kan ha påverkat något. Men nu funkar det iaf!

Har precis själv börjat med HASSIO efter ett par år borta från home automation, där jag körde Domoticz som controller.

Måste säga att även om HASSIO möjligtvis är något mera arbete att få igång, så är det ändå inte svårt i slutändan, man måste bara hitta var man ska börja, när man väl har gjort det flyter det fantastiskt bra på.

Kan säga att min installation är mycket mindre nu i en lgh, än vad den var när jag körde Domoticz i en villa, men sensorer över allt.. Men jag gillar det, snabb är den med.

Själv strular det med min UPS med usb, får den inte upp, men det kommer väl(kanske)

Main: Acer X34A Fortress II i7 8700k ROG Strix Z370-F GTX 1080Ti Ducky Shine 6 SH HD650 O2 amp + DAC
Filserver: Lian Li PC-V354B X10SLH-F E3-1240Lv3 32GB ECC RAM IBM M1015
Media: Sony KD-65XF9005 Sony HT-ZF9 nVidia Shield TV 500GB
Yamaha HS-5

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@roosterx: Ja och jag som enbart hållit på med windows och office så är detta lite nytt.

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av archie:

@aragon: Den lever! funkar både via dator och via appen på mobilen, fattar nada än sålänge men nu när det väl finns där så ska jag börja läsa runt lite mer. Återkommer högst troligt med ett helt gäng med frågor, men ska försöka mig förstå det lite mer först.

För övrigt så hade jag min nätverkskabel kopplad direkt till min fiberbox innan, vet inte om det kan ha påverkat något. Men nu funkar det iaf!

Ja då hade du inte kopplat in den i ditt lan utan i värsta fall var den kopplad mot internet och i bästa fall var den inte inkopplad alls.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@aragon: Då fortsätter vi denna följetången.. Jag har inga sensorer och sånt än så jag håller på och sätter upp Hassio och försöker förstå.. (går sådär...)

Tänkte först ordna med remote access. Jag har följt denna guiden:
https://www.juanmtech.com/hassio-duckdns-add-on-set-up/

Gjort en del men fastnar vid steg 3 där jag ska konfigurera "Configuration.yaml"

jag kör via webläsare och går in i add-on:et men väl där hittar jag inte vad jag ska göra. Jag har försökt att skriva in de sakerna som jag ska i "config" rutan men kan inte spara om jag skriver något där. Vart hittar jag .yaml filen?

Saxat från juanmtech länken..
"Step 3: Edit the configuration.yaml file

Next, you need to add the new DuckDNS URL and also the SSL information in the configuration.yaml file. In Home Assistant, use the Configurator add-on to access the configuration.yaml file (You can also use Samba to edit the configuration.yaml file using any text editor). Under HTTP, set up the base_url to the new DuckDNS domain name. Then enter the following information for the SSL certificate and the SSL key. Lastly, click Save and restart Home Assistant to apply the changes."

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@aragon:
Uppdatering: Hittade min Configuration.yaml fil...

https://www.home-assistant.io/getting-started/configuration/
Följde ovan och la in detta sist i filen:
panel_iframe:
configurator:
title: Configurator
icon: mdi:wrench
url: http://hassio.local:3218

Funkade inte, provade att ändra "3218" till "8123" istället. Då får jag upp en kopia utav default bilden..

Tänkte att jag skulle ta och följa den guiden som jag hittade innan:
"Step 3: Edit the configuration.yaml file

Next, you need to add the new DuckDNS URL and also the SSL information in the configuration.yaml file. In Home Assistant, use the Configurator add-on to access the configuration.yaml file (You can also use Samba to edit the configuration.yaml file using any text editor). Under HTTP, set up the base_url to the new DuckDNS domain name. Then enter the following information for the SSL certificate and the SSL key. Lastly, click Save and restart Home Assistant to apply the changes."

Om det inte finns något HTTP i configuration.yaml är det bara att lägga till det då?

EDIT/tillägg: Testade att lägga till det och starta om Hassio, efter det så kan jag inte ansluta till den alls..
"Sidan fungerar inte hassio.local skickade ingen data.
ERR_EMPTY_RESPONSE"

Är det bara att flasha om kortet och börja om?

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Plats
som gud är min närvaro överallt.
Registrerad
Nov 2005
Skrivet av archie:

@aragon:
Uppdatering: Hittade min Configuration.yaml fil...

https://www.home-assistant.io/getting-started/configuration/
Följde ovan och la in detta sist i filen:
panel_iframe:
configurator:
title: Configurator
icon: mdi:wrench
url: http://hassio.local:3218

Funkade inte, provade att ändra "3218" till "8123" istället. Då får jag upp en kopia utav default bilden..

Tänkte att jag skulle ta och följa den guiden som jag hittade innan:
"Step 3: Edit the configuration.yaml file

Next, you need to add the new DuckDNS URL and also the SSL information in the configuration.yaml file. In Home Assistant, use the Configurator add-on to access the configuration.yaml file (You can also use Samba to edit the configuration.yaml file using any text editor). Under HTTP, set up the base_url to the new DuckDNS domain name. Then enter the following information for the SSL certificate and the SSL key. Lastly, click Save and restart Home Assistant to apply the changes."

Om det inte finns något HTTP i configuration.yaml är det bara att lägga till det då?

EDIT/tillägg: Testade att lägga till det och starta om Hassio, efter det så kan jag inte ansluta till den alls..
"Sidan fungerar inte hassio.local skickade ingen data.
ERR_EMPTY_RESPONSE"

Är det bara att flasha om kortet och börja om?

hej igen, ett par grund saker så du slipper installera om varje gång du gör något galet
1: installera samba modulen så du når din config fil även om inte homeassistant startar intefaces
2: installera ssh så du kan starta om home assistant även från din dator
3: var gång du du gör en minsta ändring i config filen, då går du till inställningar och trycker på kontrollera min config, starta aldrig om utan att göra detta! lyser det rött så är det något som är fel i config filen, lyser det blått är det ok att starta om.

4: i homeassistant så är mellanslag ett tecken, dvs glömmer du göra ett mellan slag eller gör ett för mycket kommer det bli fel.
normalt sätt när man lägger in enheter så är det två mellanslag efter att man lagt till vilken tjänst det gäller, för varje rad i configen ökar det med 2 mellan slag,

5: det finns en mycket bra wiki med exempel för varje komponent på homessistant hemsida.
https://www.home-assistant.io/components/ sök på det du vill göra tex duckdns: https://www.home-assistant.io/addons/duckdns/

kolla om du kan nå din installation med https i stället för http

jag blev lite sugen på att gör om min installation i natt så just nu kan jag inte skicka över en exakt blid till dig, förmodligen kan jag skicka över en blid till dig på pm senare i kväll hur du konfigurerar duckdns.

Om du lär dig älska din smärta kommer du känna dig älskad var dag;-)

main dator: rampage v10, 6950x, Titan xp,64gig ram,intel 950,2x 10gig nic, asus 2k 165hz ips skärm, 900D custom vattenkylning.
main server: Supermicro, amd 6386se 16 trådar, 20TB i raid 6, 64gig ecc ram, 6x 10 gig nic. custom vattenkylning. 1/1gig nätverk via dedikerad fiberlina, router:usg pro4

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2007
Skrivet av archie:

@aragon: Då fortsätter vi denna följetången.. Jag har inga sensorer och sånt än så jag håller på och sätter upp Hassio och försöker förstå.. (går sådär...)

Tänkte först ordna med remote access. Jag har följt denna guiden:
https://www.juanmtech.com/hassio-duckdns-add-on-set-up/

Gjort en del men fastnar vid steg 3 där jag ska konfigurera "Configuration.yaml"

jag kör via webläsare och går in i add-on:et men väl där hittar jag inte vad jag ska göra. Jag har försökt att skriva in de sakerna som jag ska i "config" rutan men kan inte spara om jag skriver något där. Vart hittar jag .yaml filen?

Saxat från juanmtech länken..
"Step 3: Edit the configuration.yaml file

Next, you need to add the new DuckDNS URL and also the SSL information in the configuration.yaml file. In Home Assistant, use the Configurator add-on to access the configuration.yaml file (You can also use Samba to edit the configuration.yaml file using any text editor). Under HTTP, set up the base_url to the new DuckDNS domain name. Then enter the following information for the SSL certificate and the SSL key. Lastly, click Save and restart Home Assistant to apply the changes."

Se upp med tredjepartsguider för Hassio/Home Assistant. De har skett så mycket ändringar senaste året att många guider man hittar inte längre stämmer. Jag fastnade flera gånger i höstas för att jag följde delvis felaktiga guider. Men det löste sig varje gång genom att jag även kollade lite mer i den officiella dokumentationen.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@teejee: Låter extremt vettigt!

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Registrerad
Mar 2018

@archie: du kör väl med hass.io? Varför inte använda dig av den här då? https://www.home-assistant.io/addons/duckdns/ Sköter ju allt åt dig, det enda du behöver göra själv är att fixa ett konto på duckdns.org

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@aragon: Jag börjar om från början. Jag kom inte åt den alls, jag fick inte heller upp någon bild på tvn när jag kopplade in HDMI. Grejen är att jag körde den check config efter alla ändringar, det var bara det att efter att jag la in det kring "http" och startade om så kom den inte upp igen och jag fick ingen access till den. Aja nu har jag flashat om iaf.

Jag tar om några saker från början som jag inte fattar och som jag inte får till.
Jag vill få igång den så att jag kan lägga till sensorer och alla de sakerna när jag väl fått hem det, det känner jag att jag "nog" har kläm på. Men innan jag gör det så vill jag:

1. Installera Hassio.
check!

2. lägga till "configurator" (vet inte varför men guiden säger att man ska göra det.) :p1
"panel_iframe:
configurator:
title: Configurator
icon: mdi:wrench
url: http://hassio.local:3218"
Här får jag upp ikonen men när jag trycker på den så får jag upp "Hassio.local avvisade anslutningen"

3. Kunna ansluta remote till HA på ett säkert sätt, utan att hela världen får access till den. Jag antar att Duckdns är lösningen på det? Jag har nog fått ordning på det, men räcker det att köra duckdns?

4. Går det säkerhetskopiera det man gör? det skulle jag isf kunna göra, antar att jag kommer att förstöra mer en än gång och kan ju vara smidigt att inte behöva göra om allt hela tiden. (just nu är det ju rätt ok då jag i stort sett kör helt standard..

5. Alltså det här med Samba och SSH fattar jag nada utav.. Sorry! Jag har installerat add-onsen och startat men fattar inte vad jag ska göra med dem eller hur jag ska komma åt dem. (sitter som sagt 90% utav min tid på en MacBook Air här hemma, om det spelar någon roll.)

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@ToddTheOdd: Jag har gjort det, men räcker det att göra det? skapa konto, installera add on och lägga in raderna. klart?

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Plats
som gud är min närvaro överallt.
Registrerad
Nov 2005
Skrivet av archie:

@aragon: Jag börjar om från början. Jag kom inte åt den alls, jag fick inte heller upp någon bild på tvn när jag kopplade in HDMI. Grejen är att jag körde den check config efter alla ändringar, det var bara det att efter att jag la in det kring "http" och startade om så kom den inte upp igen och jag fick ingen access till den. Aja nu har jag flashat om iaf.

Jag tar om några saker från början som jag inte fattar och som jag inte får till.
Jag vill få igång den så att jag kan lägga till sensorer och alla de sakerna när jag väl fått hem det, det känner jag att jag "nog" har kläm på. Men innan jag gör det så vill jag:

1. Installera Hassio.
check!

2. lägga till "configurator" (vet inte varför men guiden säger att man ska göra det.) :p1
"panel_iframe:
configurator:
title: Configurator
icon: mdi:wrench
url: http://hassio.local:3218"
Här får jag upp ikonen men när jag trycker på den så får jag upp "Hassio.local avvisade anslutningen"

3. Kunna ansluta remote till HA på ett säkert sätt, utan att hela världen får access till den. Jag antar att Duckdns är lösningen på det? Jag har nog fått ordning på det, men räcker det att köra duckdns?

4. Går det säkerhetskopiera det man gör? det skulle jag isf kunna göra, antar att jag kommer att förstöra mer en än gång och kan ju vara smidigt att inte behöva göra om allt hela tiden. (just nu är det ju rätt ok då jag i stort sett kör helt standard..

5. Alltså det här med Samba och SSH fattar jag nada utav.. Sorry! Jag har installerat add-onsen och startat men fattar inte vad jag ska göra med dem eller hur jag ska komma åt dem. (sitter som sagt 90% utav min tid på en MacBook Air här hemma, om det spelar någon roll.)

Ok, vi börjar med duckdns video guide: https://www.youtube.com/watch?v=VUTPAoB27iQ
du har skapat ett konto och domän så du får ett access token som du lägga in i duckdns config?
normalt sätt gör man följande.
1: skapar kontot så man får en domän och accesstoken
2: instellerar duckdns
3: finfigurer duckdns genomatt ändra false till true samt lägger in ditt nyligen skapade token såhär, tabort null och ersätt med "ditt skapade token mellan apostrophe" (Du ska ha detta tecknet på varje sida ")
4: går till raden domän och lägger in: "dindomän.duckdns.org" Spara

5: går till hassio och klicka på Configurator och klicka på open web ui, gå till configure filen och leta efter #http (finns i början) ta bort # och gör så http hamnar längst till vänster.
hoppa ner 1 rad och gör 2 mellanslag.
skriv: base_url: https://DITTDOMÄN.duckdns.org:8123
hoppa ner 1 rad, gör två mellan slag från vänster och skriv: ssl_certificate: /ssl/fullchain.pem
hoppa ner en rad, två mellanslag från vänster och skriv:ssl_key: /ssl/privkey.pem

spara och gå nu tillbaka till duck dns och starta det, vänta en stund och kolla om server konvig är ok, är den inte det vänta en stund till
har du konfat allt rätt ska det inte bli några felmeddelanden men det kan bli det i början tills allt är färdigt, det är viktigt att du inte startar om innan du får ok av installationen.

när du väl får ok från server, starta om: OBS nu måste du alltid använda https (ej http)

du ska inte lägga till konfigurator i configfilen, du installerar plugginet via hassio och startar det.
(titta inte på gamla guider, enda guiderna du ska tilla på är dom officiella då dom uppdateras när sakerna ändras)

Säkerhetskopior gör du under hassio, klicka på fliken snapshot och skapa en backupp, det kan ta en stund så ta det lungt, när den är skapad klickar du på den och laddar ner den.

samba är ett lan protokoll så du kan komma åt foldern med configfilen från din dator om inte homeassistant startar.
samma sak med ssl, ladda ner putty , så kan du använda det för att styra homeassistant när det strular.

obs att både samba och ssl behöver lite konfiguration, detta gör du i själva pluginet, tex samba lägger du in ett namn mellan "" ("kalle" ) samma sak med lösen ord: "" ("ditt lösen")

på ssl är det bara lösen du skriver mellan "" användarnamnet är root

Om du lär dig älska din smärta kommer du känna dig älskad var dag;-)

main dator: rampage v10, 6950x, Titan xp,64gig ram,intel 950,2x 10gig nic, asus 2k 165hz ips skärm, 900D custom vattenkylning.
main server: Supermicro, amd 6386se 16 trådar, 20TB i raid 6, 64gig ecc ram, 6x 10 gig nic. custom vattenkylning. 1/1gig nätverk via dedikerad fiberlina, router:usg pro4

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@aragon: Nej jag har velat lite kring det med Configurator, men eftersom att det stod på https://www.home-assistant.io/getting-started/configuration/ så tänkte jag att det är ngt som jag behöver. Men men. Nu är den borta.

Jag följde denna guiden (https://www.home-assistant.io/components/duckdns/) igår och kunde ansluta remote. Tog bort och testade enligt din guide nu här på morgonen men får det inte att funka.

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
http:
base_url: https://xxxxxxxxx.duckdns.org:8123
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

Får upp följare felmeddelande när jag kontrollerar config.

"Konfigurationen är inte giltig
Invalid config for [http]: not a file for dictionary value @ data['http']['ssl_certificate']. Got '/ssl/fullchain.pem'
not a file for dictionary value @ data['http']['ssl_key']. Got '/ssl/privkey.pem'. (See /config/configuration.yaml, line 23). Please check the docs at https://home-assistant.io/components/http/"

Jag har inga problem att gå tillbaka men vill ju ha det som är rätt såklart, och att det fortfarande är säkert.

Hmm ja SSL och Samba får nog bli ett steg 2..

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Plats
som gud är min närvaro överallt.
Registrerad
Nov 2005
Skrivet av archie:

@aragon: Nej jag har velat lite kring det med Configurator, men eftersom att det stod på https://www.home-assistant.io/getting-started/configuration/ så tänkte jag att det är ngt som jag behöver. Men men. Nu är den borta.

Jag följde denna guiden (https://www.home-assistant.io/components/duckdns/) igår och kunde ansluta remote. Tog bort och testade enligt din guide nu här på morgonen men får det inte att funka.

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
http:
base_url: https://xxxxxxxxx.duckdns.org:8123
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

Får upp följare felmeddelande när jag kontrollerar config.

"Konfigurationen är inte giltig
Invalid config for [http]: not a file for dictionary value @ data['http']['ssl_certificate']. Got '/ssl/fullchain.pem'
not a file for dictionary value @ data['http']['ssl_key']. Got '/ssl/privkey.pem'. (See /config/configuration.yaml, line 23). Please check the docs at https://home-assistant.io/components/http/"

Jag har inga problem att gå tillbaka men vill ju ha det som är rätt såklart, och att det fortfarande är säkert.

Hmm ja SSL och Samba får nog bli ett steg 2..

testa att startom duckdns, vänta 30min och kolla om den är.ok nu, den du länkar till är inte säker då den inte använder ssl

jag kan skicka över en bild på exakt hur min duckdns ser ut via pm om du vill.

Om du lär dig älska din smärta kommer du känna dig älskad var dag;-)

main dator: rampage v10, 6950x, Titan xp,64gig ram,intel 950,2x 10gig nic, asus 2k 165hz ips skärm, 900D custom vattenkylning.
main server: Supermicro, amd 6386se 16 trådar, 20TB i raid 6, 64gig ecc ram, 6x 10 gig nic. custom vattenkylning. 1/1gig nätverk via dedikerad fiberlina, router:usg pro4

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@aragon: Den använder förmodligen inte ssl. skicka gärna över. Får kolla mer på det imorgon.

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Registrerad
Mar 2018

Du kan pröva med

http:
..base_url: https://xxxxxxxxxxx.duckdns.org
..server_port: 8123
..ssl_certificate: /ssl/fullchain.pem
..ssl_key: /ssl/privkey.pem

fungerade bättre för mig. Var en del krångel med att ha porten på samma rad. Kommer inte ihåg vilket felmeddelande det gav dock. Punkterna i början ska inte vara punkter utan mellanslag.

Och du har väl fixat "Forwarding 8123 external TCP to 8123 on hassio" i din router?

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Jun 2002

@aragon: Då fortsätter vi problem följetongen.. Fortsätter tagga dig med.

Jag har ju som sagt fått ordning på min rpi för ngn vecka sedan och väntar in att sensorerna ska komma i lager för att kunna lägga en order. Igår kv kom det en uppdatering när jag loggade in via web, tänkte att jag testar och ser vad som händer. Den uppdaterade och nu kommer jag inte åt min rpi. Får upp följande meddelande när jag försöker ansluta "ERR_EMPTY_RESPONSE". Gissar att jag behöver komma in i min config fil, jag lyckades inte få upp min ssh innan jag gjorde min uppdatering. Är det bara att flasha om och börja om eller finns det ngt annat tips?

Jag har försökt att ansluta via både hassio.local.. samt ip nummer men inget.

-AMD Ryzen 1600 -Vengence 16GB -Palit 1060 6gb

Trädvy Permalänk
Medlem
Registrerad
Mar 2018

@archie: Ett litet förslag att nästa gång så kan du ju testa att läsa chanelog innan du kör in en ny update. Då hade du sett att du borde absolut inte gjort det du precis ha gjort. Så i ditt fall så är nog det lättaste att börja om från början. Pass även på att lägga in https://www.home-assistant.io/addons/check_config/ och kör den innan du bara springer på och trycker på update nästa gång.

Trädvy Permalänk
Medlem
Plats
som gud är min närvaro överallt.
Registrerad
Nov 2005
Skrivet av archie:

@aragon: Då fortsätter vi problem följetongen.. Fortsätter tagga dig med.

Jag har ju som sagt fått ordning på min rpi för ngn vecka sedan och väntar in att sensorerna ska komma i lager för att kunna lägga en order. Igår kv kom det en uppdatering när jag loggade in via web, tänkte att jag testar och ser vad som händer. Den uppdaterade och nu kommer jag inte åt min rpi. Får upp följande meddelande när jag försöker ansluta "ERR_EMPTY_RESPONSE". Gissar att jag behöver komma in i min config fil, jag lyckades inte få upp min ssh innan jag gjorde min uppdatering. Är det bara att flasha om och börja om eller finns det ngt annat tips?

Jag har försökt att ansluta via både hassio.local.. samt ip nummer men inget.

som ovan skriver är det nog smidigast att köra om den. jag förutsätter att du gjort en backup? då går det på några minuter att få tillbaka allt. Jag har inte kolla vad sista uppdateringen gjorde med rasberry men du kan testa att dra ur strömmen och se om den bootar efter det. kolla även så den inte bytt ip efter uppdateringen om du inte satt ett fast ip på den. för min del blev det strul med video i senaste uppdateringen. trodde jag äntligen skulle få igång livestream i cards 😫 förhoppningsvis kommer det en fix inom någon dag.

Skickades från m.sweclockers.com

Om du lär dig älska din smärta kommer du känna dig älskad var dag;-)

main dator: rampage v10, 6950x, Titan xp,64gig ram,intel 950,2x 10gig nic, asus 2k 165hz ips skärm, 900D custom vattenkylning.
main server: Supermicro, amd 6386se 16 trådar, 20TB i raid 6, 64gig ecc ram, 6x 10 gig nic. custom vattenkylning. 1/1gig nätverk via dedikerad fiberlina, router:usg pro4