Hjälp att installera Gnome settings igen..

Trädvy Permalänk
Medlem
Registrerad
Nov 2015

Hjälp att installera Gnome settings igen..

Jag kör pop os och när jag skulle uppdatera lite program så gick det inte uppdatera Gnome settings så jag testade att av installera programmet för att sedan installera det igen. Men när jag ska installera det kommer det bara fram ett felmeddelande ( There Was An Error Installing GNOME Settings. The following packages have unmet dependencies:
gnome-control-center: Depends: libpop-upgrade-gtk but it is not going to be installed ).

När jag testa att installera libpop-upgrade-gtk vi terminalen så kommer detta upp
$ sudo apt install libpop-upgrade-gtk
[sudo] password for j:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpop-upgrade-gtk : Depends: pop-upgrade (= 0.1.0~1573581345~19.10~253a2c1) but 0.1.0~1571503136~19.04~601dec7 is to be installed
E: Unable to correct problems, you have held broken packages.

Vad ska jag göra för att kunna installera Gnome settings igen?

Trädvy Permalänk
Medlem
Registrerad
Nov 2015

Något jag tänkt på som kanske kan fixa det är att installera den förra versionen av Gnome settings som jag avinstallerade för att försöka installera den uppdaterade versionen. Men jag vet inte hur man installera en äldre version så om någon vet hur man gör det så hjälp mig gärna.

Trädvy Permalänk
Medlem
Registrerad
Jun 2006
Skrivet av jonetan:

Jag kör pop os och när jag skulle uppdatera lite program så gick det inte uppdatera Gnome settings så jag testade att av installera programmet för att sedan installera det igen. Men när jag ska installera det kommer det bara fram ett felmeddelande ( There Was An Error Installing GNOME Settings. The following packages have unmet dependencies:
gnome-control-center: Depends: libpop-upgrade-gtk but it is not going to be installed ).

När jag testa att installera libpop-upgrade-gtk vi terminalen så kommer detta upp
$ sudo apt install libpop-upgrade-gtk
[sudo] password for j:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpop-upgrade-gtk : Depends: pop-upgrade (= 0.1.0~1573581345~19.10~253a2c1) but 0.1.0~1571503136~19.04~601dec7 is to be installed
E: Unable to correct problems, you have held broken packages.

Vad ska jag göra för att kunna installera Gnome settings igen?

Ser ut som du har paket installerat från 2 olika versioner från Pop OS:
libpop-upgrade-gtk : Depends: pop-upgrade (= 0.1.0~1573581345~19.10~253a2c1) but 0.1.0~1571503136~19.04~601dec7 is to be installed

Vilken version har du nu? Har du kört "sudo apt update" emellan gångerna du försökte installera?

Nu använder jag inte Pop OS och vet inte exakt hur man uppgradera till nyaste versionen (som verkar vara 19.10). Men här står det hur man gör för att uppgradera. När du uppdatera till senaste (om du nu inte har senaste) kanske dina problem rättas till. Jag tar inget ansvar för vad som händer då jag inte använder Pop OS. Det är bara förslag från min sida.

Trädvy Permalänk
Medlem
Registrerad
Nov 2015
Skrivet av Eazy:

Ser ut som du har paket installerat från 2 olika versioner från Pop OS:
libpop-upgrade-gtk : Depends: pop-upgrade (= 0.1.0~1573581345~19.10~253a2c1) but 0.1.0~1571503136~19.04~601dec7 is to be installed

Vilken version har du nu? Har du kört "sudo apt update" emellan gångerna du försökte installera?

Nu använder jag inte Pop OS och vet inte exakt hur man uppgradera till nyaste versionen (som verkar vara 19.10). Men här står det hur man gör för att uppgradera. När du uppdatera till senaste (om du nu inte har senaste) kanske dina problem rättas till. Jag tar inget ansvar för vad som händer då jag inte använder Pop OS. Det är bara förslag från min sida.

Jag har redan 19.10.

När jag kör sudo apt update kommer detta upp
sudo apt update
[sudo] password for j:
Hit:1 http://ppa.launchpad.net/peterlevi/ppa/ubuntu eoan InRelease
Get:2 http://ppa.launchpad.net/system76/pop/ubuntu eoan InRelease [15,9 kB]
Hit:3 http://us.archive.ubuntu.com/ubuntu eoan InRelease
Hit:4 http://repository.spotify.com stable InRelease
Hit:5 http://apt.pop-os.org/proprietary eoan InRelease
Get:6 http://ppa.launchpad.net/system76/pop/ubuntu eoan/main Sources [29,2 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu eoan-security InRelease [97,5 kB]
Get:8 http://ppa.launchpad.net/system76/pop/ubuntu eoan/main i386 Packages [38,0 kB]
Get:9 http://ppa.launchpad.net/system76/pop/ubuntu eoan/main amd64 Packages [50,6 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu eoan-updates InRelease [97,5 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu eoan-backports InRelease [88,8 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu eoan-security/main Sources [24,3 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu eoan-security/universe Sources [5.376 B]
Get:14 http://us.archive.ubuntu.com/ubuntu eoan-security/main i386 Packages [52,2 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu eoan-security/main amd64 Packages [75,5 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu eoan-security/main Translation-en [28,7 kB]
Get:17 http://us.archive.ubuntu.com/ubuntu eoan-security/main amd64 DEP-11 Metadata [204 B]
Get:18 http://us.archive.ubuntu.com/ubuntu eoan-security/universe i386 Packages [33,0 kB]
Get:19 http://us.archive.ubuntu.com/ubuntu eoan-security/universe amd64 Packages [35,6 kB]
Get:20 http://us.archive.ubuntu.com/ubuntu eoan-security/universe Translation-en [18,9 kB]
Get:21 http://us.archive.ubuntu.com/ubuntu eoan-security/universe amd64 DEP-11 Metadata [1.416 B]
Get:22 http://us.archive.ubuntu.com/ubuntu eoan-security/universe amd64 c-n-f Metadata [1.972 B]
Get:23 http://us.archive.ubuntu.com/ubuntu eoan-updates/main Sources [33,5 kB]
Get:24 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe Sources [9.072 B]
Get:25 http://us.archive.ubuntu.com/ubuntu eoan-updates/main i386 Packages [80,8 kB]
Get:26 http://us.archive.ubuntu.com/ubuntu eoan-updates/main amd64 Packages [104 kB]
Get:27 http://us.archive.ubuntu.com/ubuntu eoan-updates/main Translation-en [38,9 kB]
Get:28 http://us.archive.ubuntu.com/ubuntu eoan-updates/main amd64 DEP-11 Metadata [25,6 kB]
Get:29 http://us.archive.ubuntu.com/ubuntu eoan-updates/main DEP-11 48x48 Icons [7.789 B]
Get:30 http://us.archive.ubuntu.com/ubuntu eoan-updates/main DEP-11 64x64 Icons [11,4 kB]
Get:31 http://us.archive.ubuntu.com/ubuntu eoan-updates/main DEP-11 128x128 Icons [25,5 kB]
Get:32 http://us.archive.ubuntu.com/ubuntu eoan-updates/main amd64 c-n-f Metadata [2.104 B]
Get:33 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe amd64 Packages [49,5 kB]
Get:34 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe i386 Packages [46,8 kB]
Get:35 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe Translation-en [25,5 kB]
Get:36 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe amd64 DEP-11 Metadata [24,2 kB]
Get:37 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe DEP-11 48x48 Icons [14,6 kB]
Get:38 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe DEP-11 64x64 Icons [22,9 kB]
Get:39 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe DEP-11 128x128 Icons [70,9 kB]
Get:40 http://us.archive.ubuntu.com/ubuntu eoan-updates/universe amd64 c-n-f Metadata [2.364 B]
Get:41 http://us.archive.ubuntu.com/ubuntu eoan-backports/universe amd64 DEP-11 Metadata [7.756 B]
Fetched 1.298 kB in 11s (123 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
30 packages can be upgraded. Run 'apt list --upgradable' to see them.

j@pop-os:~$ apt list --upgradable
Listing... Done
amd64-microcode/eoan-security,eoan-updates 3.20191021.1ubuntu0.19.10.1 amd64 [upgradable from: 3.20181128.1ubuntu2]
bind9-host/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
dkms/eoan-updates,eoan-updates 2.7.1-4ubuntu2.1 all [upgradable from: 2.7.1-4ubuntu2]
dnsutils/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
ffmpeg/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
intel-microcode/eoan-security,eoan-updates 3.20191115.1ubuntu0.19.10.1 amd64 [upgradable from: 3.20191112-0ubuntu0.19.10.2]
libavcodec58/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
libavdevice58/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
libavfilter7/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
libavformat58/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
libavresample4/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
libavutil56/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
libbind9-161/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
libdns-export1104/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
libdns1104/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
libirs161/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
libisc-export1100/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
libisc1100/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
libisccc161/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
libisccfg163/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
liblwres161/eoan-security 1:9.11.5.P4+dfsg-5.1ubuntu2.1 amd64 [upgradable from: 1:9.11.5.P4+dfsg-5.1ubuntu2]
libmysqlclient21/eoan-security,eoan-updates 8.0.18-0ubuntu0.19.10.1 amd64 [upgradable from: 8.0.17-0ubuntu2]
libpostproc55/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
libswresample3/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
libswscale5/eoan 7:4.1.4-1build2pop1~1573838760~19.10~c4dd25c amd64 [upgradable from: 7:4.1.4-1build2]
lua-lpeg/eoan-updates 1.0.0-2ubuntu0.19.10.1 amd64 [upgradable from: 1.0.0-2]
pop-upgrade/eoan 0.1.0~1573581345~19.10~253a2c1 amd64 [upgradable from: 0.1.0~1571503136~19.04~601dec7]
python3-distupgrade/eoan-updates,eoan-updates 1:19.10.15.3 all [upgradable from: 1:19.10.15.2]
repoman/eoan,eoan 1.0.2~1574200963~19.10~076fee6 all [upgradable from: 1.0.2~1571155793~19.10~c4051b4]
ubuntu-release-upgrader-core/eoan-updates,eoan-updates 1:19.10.15.3 all [upgradable from: 1:19.10.15.2]
jonatanandersson@pop-os:~$

Hur gör jag för att uppdatera dem?

Trädvy Permalänk
Medlem
Registrerad
Mar 2016

Programmet aptitude har en mer avancerad konfliktslösare än apt-get.
Testa med det.
Annars vet jag att det går att tvinga version i synaptic.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Nov 2015
Skrivet av FattarNiInte:

Programmet aptitude har en mer avancerad konfliktslösare än apt-get.
Testa med det.
Annars vet jag att det går att tvinga version i synaptic.

Skickades från m.sweclockers.com

Uppdaterade via aptitude och efter det gick det att installera GNOME settings igen.

Tusen tack för din hjälp!!

Trädvy Permalänk
Medlem
Registrerad
Nov 2015

@Eazy:
Har fått det att funka nu och ville bara tack för din hjälp!

Trädvy Permalänk
Medlem
Registrerad
Jun 2006
Skrivet av jonetan:

@Eazy:
Har fått det att funka nu och ville bara tack för din hjälp!

No problem.

Om du inte kört "apt update" innan du installerade det du installerade, hämtade den paket som inte stämde ihop med de övriga (jag gissar lite här).

"apt-update" uppdatera listan över de paket som finns att installera i repon och det ska man alltid göra innan man installera något paket. Har du en uppdateringshanterare som hela tiden kollar efter uppdaterade paket gör ju då programmet själv en apt-update med jämna mellanrum.