Blixtrande pixlar på mörkare bakgrund vid hög kontrast (DP, ej när HDMI)

Permalänk
Medlem

Blixtrande pixlar på mörkare bakgrund vid hög kontrast (DP, ej när HDMI)

Nyss fått igång mitt nybygge och installerat Windows.
Allt verkar funka toppen, utom att moderkortet har rätt usla möjligheter till fläktkurvor, och att datorn drar 20W när den är avstängd (10W även fast PSU helt avstängd!).
Men i övrigt verkar allt toppen!

Fast nu märkte jag att vid följande typer av bilder (verkar endast gälla utåt högra delen av skärmen) så blixtrar det av pixlar som kryper runt helt random längs med högra sidan av ljusa kanten. Någon pixel i taget, kanske 1/sekund i snitt.
Spelar ingen roll om det är ett ljust utforskarfönster eller som i detta fall notes, och det blir även samma om jag kör en screenshot och placerar screenshoten utåt högerkanten.

Körde aldrig DP på gamla datorn då jag ej fick igång det, men det är vad jag testade nu på nybygget.
Byter jag till HDMI istället så försvinner dessa blinkande pixlar.

Nu felsökte jag inte enormt mycket, utan ville i panik försäkra mig om att inte nya datorn är trasig (grafik/RAM/whatever).
Men är det någon som har nån hint om vad detta kan vara, utifrån min korta beskrivning?
Grafikkort, kabel, inställning på monitorn, fel på monitorn?

Permalänk
Medlem

Tyckte mig se lite blixtrande/krypande pixlar i mitten av skärmen i liknande situation även med HDMI (mitt i natten så kan varit ögonen bara).

Så nu flyttade jag över mitt gamla grafikkort (som jag ej hade tänkt återanvända) och kör det istället för IGP.
Och då VERKAR allt vara ok!
Osäker om mitt IGP är dåligt då på nåt sätt, att det inte pallar 1440p, eller kanske hade behövt uppdaterad driver eller så.
Får hålla tummarna att allt fortsätter funka nu med dedikerade 1650S istället!

EDIT: Synd bara att jag betalade 500 spänn extra för IGP...

Permalänk
Bildexpert 📺

Snö/pixelfel i bilden är ofta ett resultat av att något stör överföringen. Det uppstår en liten mängd bitfel. Kanske en dålig kabel. Det syns inte på skärmdumpar utan man behöver fånga dem med kamera.

Eftersom du får det med din iGPU och både HDMI och DP kan det vara något som stör den krets som alstrar signalen. Eller så är det något fel på ditt moderkort.

Permalänk
Medlem

Tack för svar

Fan också!
Nu ser jag att det blixtrar pixlar ibland på mörk bakgrund (intill stark kontrast) även från mitt 1650Super->DP!

Det är mycket mer sällan, och inte på samma ställen, som IGP->DP.
Typ samma nivå av fel som IGP->HDMI, kanske 2-3 pixelblink (som jag uppfattar) per minut!

Nu testar jag 1650S->HDMI och har ännu inte sett en enda vit blixtrande pixel!
Tyvärr kan jag ej testa DP på gamla datorn från grafikkortet för chassits bakdel gör att kabeln ej går att klicka ända i botten o jag får ingen signal....skulle behöva såga upp chassit!

Så jäkla märkligt! Alltid (?) intill starka kontraster.
Halvmycket blixtrande vita pixlar (varannan sek kanske) från IGP->DP.
Väldigt få blixtrande vita pixlar (1-2/min kanske) från IGP->HDMI.
Väldigt få blixtrande vita pixlar (1-2/min kanske) från 1650S->DP.
Än så länge inga problem från 1650S->HDMI.

Det verkar alltså som att dedikerade graffet är mycket bättre än IGP, och att HDMI är mycket bättre än DP.
Inte sett nåt på gammeldatorn - den kan inte köra DP för chassit hindrar kabeln, och jag kan ej testa HDMI->IGP för IGP på den klarar ej 1440p...

För att kolla att jag verkligen inte förlorat förståndet så var jag tvungen fånga en blixt på film, och här är en screenshot av det.
Om det blixtrat oftare så kunde jag testat screenshotta, men även IGP->DP var för sällan och kort för att det skulle va en enkel uppgift...

Permalänk
Medlem

Inser att det kan blixtra på som attan även från IGP->HDMI, om det är på precis rätt ställen på skärmen!
Ett högt vitt fönster mot min mörka bakgrund kan göra att det kryp-blixtrar längs hela kanten typ.
Screenshottar jag det hela och flyttar bilden 5cm åt vänster, så händer inget alls, o.s.v.

Vetefan, kanske skrotar hela bygget o flyttar tillbaks till gamla datorn och DVI istället...

Vad kan man utesluta helt, så jag vet vad jag kan spara om jag köper nytt igen?
Kan väl knappast vara RAM, eller PSU? Och såklart inte graffet heller.
Moderkort/CPU kanske räcker att byta, plus ett nytt Windows då om jag brände min nya OEM på dessa två dagar...

Permalänk
Medlem

@ASBR: Om du har möjlighet så känns det som att det är läge att testa någon annan skärm, alternativt med någon annan dator till skärmen. Jag har svårt att tänka mig någon annan förklaring än att det är fel på skärmen när du får samma fel via både olika grafikkort och olika bildgränssnitt (och olika kablar utgår jag ifrån, för det är väl ingen adapter inblandad någonstans?).

Om det skulle vara datorn som det är fel på så borde felet uppstå innan bilden skickas till grafikkortet, för det vore väldigt osannolikt att båda grafikkorten skulle störas på samma sätt. Det skulle i så fall indikera RAM, CPU eller moderkort, men då borde felet vara mer slumpartat tycker jag.

Permalänk
Medlem
Skrivet av perost:

@ASBR: Om du har möjlighet så känns det som att det är läge att testa någon annan skärm, alternativt med någon annan dator till skärmen. Jag har svårt att tänka mig någon annan förklaring än att det är fel på skärmen när du får samma fel via både olika grafikkort och olika bildgränssnitt (och olika kablar utgår jag ifrån, för det är väl ingen adapter inblandad någonstans?).

Om det skulle vara datorn som det är fel på så borde felet uppstå innan bilden skickas till grafikkortet, för det vore väldigt osannolikt att båda grafikkorten skulle störas på samma sätt. Det skulle i så fall indikera RAM, CPU eller moderkort, men då borde felet vara mer slumpartat tycker jag.

Aha, jo ligger något i det du säger.
Det är ju inte som när man får slumpvisa artefakter i spel (antar jag), utan dessa krypande/blixtrande pixlar följer kanterna ganska väl längs hög kontrast (ljust fönster över mörk bakgrund, fast bara vissa områden av skärmytan)!
Och såklart helt utan belastning - inne i spel etc har jag inte sett något när jag provspelat lite snabbt, så är ju ingen överhettning etc.

Men om monitorn är "trasig", varför blir det då MYCKET värre från IGP än från 1650S?
Och varför DP mycket värre än HDMI?
Och varför har jag inte sett något alls från gammeldatorn som kört DVI ett par månader?
Är ju själva fan att DP inte går använda på gamla datorn, chassit tar stopp som sagt, idiotiskt gammalt skitchassi!

Får börja med att plocka upp gamla 1080p-skärmen från källaren o testa nya datorn på den, även om det blir lägre upplösning.
Syns inget där så törs jag nog inte dra nån 100% slutsats, men syns felet där så vet jag 100% att det är nya datorn! (eller bägge kablarna...ehm...)

EDIT: Inga adapters, en HDMI och en DP, bägge nya som kom med skärmen för nån månad sen.

Permalänk
Medlem

Kanske lite kortis nånstans?
Eftersom datorn drar 20W även fast den är helt avstängd - och 11W även fast PSU-switch av!!!
Och då har jag ändå ett extra kvalitativt Seasonic-PSU!

EDIT: Och då har jag ändå stängt av alla mobo-leds i bios, stängt av USB-power när datorn av, och sett till att alla wake-on är av o.s.v.

Permalänk
Medlem

Video! (HDMI till IGP.)
IGP är som sagt mycket mycket mycket värre än dedikerade grafikkortet.
Flyttar jag ljusa fönstret 10cm till vänster så försvinner det typ helt, så är olika på olika områden av skärmen!

https://imgur.com/z22KmUP

De statiska stjärnorna är min bakgrund, så bry er inte om dem

EDIT: Flyttar jag fönstret långt till höger, så att vänsterkanten hamnar på samma ställe istället, så kan man ana blixtrarna även i fönstrets vita område - små svarta/gråa blixtar liksom, men mycket svårare att se.
Aja, ner i källaren o hämta upp gamla 1080p-skärmen, om det nu en kommer ge något...

Permalänk
Bildexpert 📺
Skrivet av ASBR:

Video! (HDMI till IGP.)
IGP är som sagt mycket mycket mycket värre än dedikerade grafikkortet.
Flyttar jag ljusa fönstret 10cm till vänster så försvinner det typ helt, så är olika på olika områden av skärmen!

https://imgur.com/z22KmUP

De statiska stjärnorna är min bakgrund, så bry er inte om dem

EDIT: Flyttar jag fönstret långt till höger, så att vänsterkanten hamnar på samma ställe istället, så kan man ana blixtrarna även i fönstrets vita område - små svarta/gråa blixtar liksom, men mycket svårare att se.
Aja, ner i källaren o hämta upp gamla 1080p-skärmen, om det nu en kommer ge något...

Klassisk "snö" från random bitfel i överföringen. Skulle nog överdriva om jag menade att jag sett det hundratals gånger. Men tillräckligt ofta för att ha slutat räknat många år sedan.

Förmodligen är det kablarna som inte håller. Gamla och slitna och orkar inte bandbredden. Att det är olika mängd med olika källor beror vanligtvis på att det olika kvalitet på signalkällorna.

För komplett uteslutning behöver du testa med:

  1. Andra kablar

  2. Andra källor

  3. Annan skärm

Kan också uppstå liknande fenomen fast då ofta mer uttalat från glapp vid själva PCB:n. Typisk situation är att kabeln dragit i eller hängt mot kontakten och PCB:n så att glappet uppstår i själva anslutningen – eller i själva kabelkontakten. Detta brukar man kunna stämma av genom att placera annan belastning mot kabeln, räta upp den med handen etc.

Permalänk
Medlem
Skrivet av Laxpudding:

Klassisk "snö" från random bitfel i överföringen. Skulle nog överdriva om jag menade att jag sett det hundratals gånger. Men tillräckligt ofta för att ha slutat räknat många år sedan.

Förmodligen är det kablarna som inte håller. Gamla och slitna och orkar inte bandbredden. Att det är olika mängd med olika källor beror vanligtvis på att det olika kvalitet på signalkällorna.

Stort tack igen!

Det låter ju trevligt att du tryggt kan identifiera problemet
Bägge kablarna är ju typ helt nya, de som kom med skärmen för nån månad sen.
Kan jag ändå typ utesluta nya datorn, alltså moderkort/CPU/minnen/PSU?

Citat:

För komplett uteslutning behöver du testa med:

  1. Andra kablar

  2. Andra källor

  3. Annan skärm

Prova med annan skärm? Jotack, jag kånkade just upp gamla 1080p-skärmen från källaren och den ger "no signal" med HDMI!
DP har den såklart inte. Så det blir inget test med annan skärm tyvärr!
Jag kan ju köpa en ny DP som första steg kanske - inkopplat i IGP blir det ju stoooora störningar så är lätt att identifiera.
I dedikerade grafikkortet är det väldigt svårt att upptäcka - kanske en blink i minuten eller två, så det är eländigt att felsöka!
Fler källor än mina två datorer (där den ena ej kan använda DP p.g.a. chassit) har jag tyvärr inte

Citat:

Kan också uppstå liknande fenomen fast då ofta mer uttalat från glapp vid själva PCB:n. Typisk situation är att kabeln dragit i eller hängt mot kontakten och PCB:n så att glappet uppstår i själva anslutningen – eller i själva kabelkontakten. Detta brukar man kunna stämma av genom att placera annan belastning mot kabeln, räta upp den med handen etc.

Jag har pillat och dragit en del i kablarna medan fenomenet visar sig och ser INGEN påverkan av det än så länge!
Kan det ändå vara kablarna/kontakten, och man kan typ utesluta nybygget (CPU/moderkort/minnen/PSU)???

Jag vetefan vad jag ska göra nu.
Det enda jag kommer på är att koppla in gamla datorn igen, och stirra mig blind på skärmen i en timme, och försöka se en endaste blinkande pixel en endaste gång, så vet jag att det är skärm/kablar/skärmkontakt och nya datorn är helt ok!
Annars har jag inte en susning vad jag ska göra - köpa ny monitor på chans, eller byta moderkort/CPU på chans, o fortsätta tills allt är utbytt o jag plötsligt har betalat två komplett nya system
Testar väl köpa kabel innan dock, men har inga stora förhoppningar att det ska hjälpa då bägge kablarna är så nya...

Permalänk
Bildexpert 📺

I min öron verkar det – tyvärr – som halvdan kvalitet på moderkortet eller kanske något med monteringen eller övrig utrustning som stör funktionen. Varpå du får mindre problem med ett dedikerat grafikkort.

Ett långskott är interferens med Wifi. Det är ett reelt problem med HDMI när man kommer upp i bandbredd, därav att Premium High Speed-certifierade kablar ska vara tillräckligt skärmade.

Permalänk
Medlem

Ok, så byta moderkort/CPU till att börja med kanske.

Kan det även vara RAM?

Kan det överhuvudtaget vara PSU/strömförsörjning?

Bra att veta om det finns NÅGOT som går att utesluta helt vid denna typ av problem - blir ju lite billigare då...

Allra billigast vore antagligen att hyra in Thomas Ytterberg, som jag tror bor i mina krokar då jag mött honom flera gånger, men det skulle nog kosta mer än några tusingar för nya komponenter, särskilt med Corona-riskpåslag

Men först ska jag stirra så ögonen blöder på gamla datorn med HDMI från ett annat dedikerat GPU som sitter i den nu...

Permalänk
Medlem

NEJ MEN VAD I...

Med ett ljust utforskarfönster i skärmens nyupptäckta weak-spot (som på filmklippet) så ser jag direkt de krypande/blixtrande pixlarna från GAMLA DATORN!!!
Så nybygget är helt safe!

Då är frågan om det är:

  • monitorn (som bara är nån månad gammal)

  • bägge kablarna som är skadade eller bara låg kvalitet (följde med billiga skärmen ju)

  • longshot, men kan det va lägenhetens strömförsörjning, att HDMI/DP är mycket mer känsliga än gammal DVI jag kört innan o minsta störningar ur väggen kan påverka

EDIT: Stänga av mitt eget Wifi gjorde ingen skillnad.

Permalänk
Bildexpert 📺

DVI kör man ofta med lägre bandbredd och är därför inte lika känsligt. Du kör vad 1440p? 144 Hz? Nära fyrdubbla bandbredden mot att köra 1080p/60.

Ja, det följer ofta med ganska dåliga kablar med skärmarna. Vilket är enkelt att ersätta: https://www.sweclockers.com/artikel/27577

Är det samma problem ändå, blir man förstås inte gladare, men kan bocka av i felsökningen

Permalänk
Medlem
Skrivet av Laxpudding:

DVI kör man ofta med lägre bandbredd och är därför inte lika känsligt. Du kör vad 1440p? 144 Hz? Nära fyrdubbla bandbredden mot att köra 1080p/60.

Ja, det följer ofta med ganska dåliga kablar med skärmarna. Vilket är enkelt att ersätta: https://www.sweclockers.com/artikel/27577

Är det samma problem ändå, blir man förstås inte gladare, men kan bocka av i felsökningen

60Hz 1440p är det som gäller här.

Funderar på promenad till Kjell och köpa deras halvdyra DP som är 1.4 och ska klara typ 8k, men ska kolla din guide först.

EDIT: 2 meter kabel så inget extremt där heller.

Permalänk
Medlem

Med tanke på extremt låga bandbredden jag förbrukar så borde vilken ny DP som helst duga.
Om jag då testat tre olika kablar, varav en splitter ny, och alla ger problemen, så måste det vara monitorn ju!
Då får jag fundera på om ny monitor är värt det eller om jag ska leva med ett par små stjärnblixtar i minuten tills vidare...

Om nu inte strömförsörjning i lägenheten kan påverka, eller andra yttre omständigheter?!

Permalänk
Bildexpert 📺

Kan också vara elproblem. Svårare att felsöka dock. Att man har något i systemet som är anslutet till kabel-TV är annars en klassiker till störkälla. Men jag har för mig att Comhem etc. numera skickar med bättre kablage där.

Permalänk
Medlem
Skrivet av Laxpudding:

Kan också vara elproblem. Svårare att felsöka dock. Att man har något i systemet som är anslutet till kabel-TV är annars en klassiker till störkälla. Men jag har för mig att Comhem etc. numera skickar med bättre kablage där.

Jag har ingen TV eller sånt alls
Min massiva 31.5" monitor är min "teve"

En liten rättelse: Jag tror inte DP ger värre störningar än HDMI, det är bara att det hamnar på andra områden av skärmen!
DP ger dessa kryp främst långt ut på högerkanten, där jag har mina "sticky notes" mot den mörka bakgrunden.
Med HDMI såg jag inga kryp där o tänkte det var bättre, men det är bara att problemet maxas mer centrerat på skrivbordet istället!

Permalänk
Rekordmedlem
Skrivet av ASBR:

Kanske lite kortis nånstans?
Eftersom datorn drar 20W även fast den är helt avstängd - och 11W även fast PSU-switch av!!!
Och då har jag ändå ett extra kvalitativt Seasonic-PSU!

EDIT: Och då har jag ändå stängt av alla mobo-leds i bios, stängt av USB-power när datorn av, och sett till att alla wake-on är av o.s.v.

Det är troligen nätfiltret som drar lite då det sitter kondensatorer i det och så kombinerar du det med en enkel mätare som varken gillar fasvridningen eller att mäta små effekter så blir det ofta en relativt dålig mätnoggranhet för jag tror inte at du har en verklig förbrukning som är så hög.

Permalänk
Medlem
Skrivet av mrqaffe:

Det är troligen nätfiltret som drar lite då det sitter kondensatorer i det och så kombinerar du det med en enkel mätare som varken gillar fasvridningen eller att mäta små effekter så blir det ofta en relativt dålig mätnoggranhet för jag tror inte at du har en verklig förbrukning som är så hög.

Nej förhoppningsvis inte, borde ju bli rätt varmt nånstans i lådan då...
Gjorde egen tråd om det här, inkl bild på min mätare
#18730093

Permalänk
Medlem
Skrivet av Laxpudding:

Kan också vara elproblem. Svårare att felsöka dock. Att man har något i systemet som är anslutet till kabel-TV är annars en klassiker till störkälla. Men jag har för mig att Comhem etc. numera skickar med bättre kablage där.

Ny DP-kabel, precis samma problem!
Så vi lär ju kunna utesluta kablar och datorer/grafikkort helt!
Kvar är alltså monitorn, och om det är signalfel så är det väl nåt som är lite dåligt i kontakterna typ, eller kretskort där, snarare än panel/pixlar i sig.

Men jag lever nog med detta tills vidare, sjukt nöjd med monitorn i övrigt - mest skönt nu att veta att nya datorn är ok!
Och det är den ju till 100% då felet gick att få fram precis lika illa från gamla datorn

Tack för all hjälp

Permalänk
Medlem

Så länge detta inte är något som kan skada min dator/grafikkort förstås!?!

Permalänk
Medlem

Kan ju bli ett större problem i framtiden i vilket fall när jag uppgraderar grafikkort.
Nytt kort kanske ger lite sämre signal än mitt 1650S, så skärmen beter sig lika illa som från nya datorns IGP eller gamla datorns GT1030.
Då blir jag tvingad till skärmbyte såklart.
Men när det bara är en pixel i minuten som flashar till så blir det ju mindre störande...