Kingston A400 - vägrar boota in i windows.

Permalänk
Medlem

Kingston A400 - vägrar boota in i windows.

Tjena!

Min vän har en gammal HDD som han kör windows på idag. Ett tag sedan uppgraderade han sina komponenter, däribland blev det ett inköp av en Kingston 480GB SSD.

Dock har jag problem att boota in i windows med denna SSD.

Till problemet:
Jag har, via en USB sticka som är formaterad via Rufus installerat windows på SSDn. I bios ser jag boot option: Kingston (följt av massa siffror och bokstäver), men den vägrar boota in i windows och bootar in direkt i bios.

Trasig SSD tänkte jag, jag tar med mig den hem och försöker kopplar den till min dator (har ett Asus X99-A moderkort & en 5930k cpu). Men SSDn hittas i windows och följande filer finns på den: https://i.imgur.com/F8rIaoR.png

Edit: Såhär ser det ut inne i bios https://i.imgur.com/dltRaNV.jpg

Jag har ingen aning vad jag kan göra. All hjälp mottages!

Orlaw

Tagit bort skrik på hjälp i rubrik /Andreaz1, mod
Permalänk
Medlem

Är det bild på SSDn i din datorn där 840 disken är din med din Windows på?

Du behöver inte använd Rufus för att skapa en USB sticka för installation av Windows.
Använd Media creation tool från MS, och ha bara 480GB disken i och radera alla partitioner på den och skapa ny och alla de andra partitionerna Windows behöver så ska det funka.

Permalänk
Medlem
Skrivet av elixyr:

Är det bild på SSDn i din datorn där 840 disken är din med din Windows på?

Du behöver inte använd Rufus för att skapa en USB sticka för installation av Windows.
Använd Media creation tool från MS, och ha bara 480GB disken i och radera alla partitioner på den och skapa ny och alla de andra partitionerna Windows behöver så ska det funka.

Precis, 840 är min med windows jag använder nu för research och dylikt.

Jag använde mig sedan av creation tool och fixade USB stickan. Jag gjorde sedan precis vad du sa, samma resultat dock. Jag kopplade ut alla andra diskar och hade endast Kingston disken inne.

Permalänk
Medlem

En fundering, har det kanske med att SSDn är i MBR läge, och de andra är i Gpt? Vad betyder stjärnan ute till höger på disk 1 & 2?

https://i.imgur.com/qDGddNw.png
Disk 3 är Kingston disken

Permalänk
Medlem
Skrivet av Orlaw:

En fundering, har det kanske med att SSDn är i MBR läge, och de andra är i Gpt? Vad betyder stjärnan ute till höger på disk 1 & 2?

https://i.imgur.com/qDGddNw.png
Disk 3 är Kingston disken

Stjärnan är bara märke för att disken är gpt.

Låter ju märkligt brukar ju bara funka rakt av med nya diskar, har använt ett par A400 som boot diskar utan problem innan.

Du kanske får se över CSM inställningar på datorn där SSDn ska användas? Har du EFUI på båda maskinerna så ska det finnas en "Windows boot manager" på Kingston disken med.

Om du startar från USB välj att den ska starta USBt i EFUI om möjligt, borde gå från bios "boot override tabben"

Permalänk
Medlem

Eftersom du kommit så långt att du startat diskpart, så förutsätter jag att du har lite koll på denna.
DVS, kommandona "list disk". "select disk <nr>" och "clean".

Utan att ha koll på det, så gissar jag att bilden talar för att "Disk3" är A400-disken.
Den är då initierad som MBR (BIOS-läge (Legacy)), och Disk 1 & 2 som GPT (UEFI-läge).

Det finns två sätt.
Antingen så kör du den "diskpart clean", dvs, "select disk 3" om det är disk 3 som ä A400-disken och sedan kommandot "clean", sedan tar du ut disken, tar med den till din kompis kopplar in endast den disken och sedan installerar windows på den rakt upp-o-ner.
Alternativ två är att du konverterar disken till GPT-format, osäker på kommandot rakt av, google är din vän. Du kommer ändå bli tvungen att ta bort samtliga partitioner på disken då det skall skapas en EFI-partition också i uttrymmet.

Du kan även köra "diskpart clean" från windows installations-medium om du vill göra det utan att riskera att köra "diskpart clean" på fel disk. (Ha endast disken som windows skall installeras på inkopplad när du installerar windows för att unvika att boot-paritionen hamnar på fel disk.)

Här är en exempel-video.
https://www.youtube.com/watch?v=z4Z38pD1Gt0

Permalänk
Medlem

Jag kör just nu "clean all" på disk 3, vilket tydligen är en "djupare" form av clean. Disken är på 100% i enhetshanteraren (antar den rensas) och varit ett tag nu. Brukar det ta lång tid? @viita

Permalänk
Medlem

@Orlaw

Som jag förstått det så är "clean all" onödigt att köra på SSD:er och ja, "clean all" tar betydligt längre tid.

Permalänk
Medlem

Alright, läste på en guide att clean all är the way to go...oh well. Kan jag avbryta det på något vänster utan att oroa mig eller ska jag låta den köra slut?

Permalänk
Medlem

Har ingen aning om hur lång tid det kan tänkas ta på en 480GB? stor disk.
Borde inte ta så mycket längre tid.

Själv hade jag bara kört "select disk" och "clean".
Har gjort liknande på USB-minnen som använts som bland annat installationsmedium.
Där skiljer det sig dock lite.
Först "select disk" -> "clean" -> "create primary partition" -> "active" -> "exit", sedan har jag kunnat formatera usb-minnet i windows.

Första gången jag körde med endast "clean", då ville inte windows automatiskt skapa en ny partition åt mig utan indikerade endast att USB-minnet var aktivt hela tiden.

Permalänk
Rekordmedlem
Skrivet av Orlaw:

En fundering, har det kanske med att SSDn är i MBR läge, och de andra är i Gpt? Vad betyder stjärnan ute till höger på disk 1 & 2?

https://i.imgur.com/qDGddNw.png
Disk 3 är Kingston disken

Om det är en äldre dator är det tvärt om inte möjligt att boota från GPT partitioner utan bootenheten måste vara MBR för GPT stöds inte av äldre bios så enheterna fungerar inte innan win är bootat.

Men hade du andra enheter inkopplade när du installerade win så att det är nått strul med bootloadern ?

Permalänk
Medlem

Du kan alltid testa att slå av/på UEFI-läge i BIOS om möjligt, samt secure boot (om UEFI) och se om det gör någon skillnad. Du kan ju även testa att (i din egen dator) ta ut alla andra diskar och installera om Windows på den och se om den bootar då. I så fall kanske du kan testa att uppdatera BIOS på den dator där det strulade.

Permalänk
Medlem
Skrivet av mrqaffe:

Om det är en äldre dator är det tvärt om inte möjligt att boota från GPT partitioner utan bootenheten måste vara MBR för GPT stöds inte av äldre bios så enheterna fungerar inte innan win är bootat.

Men hade du andra enheter inkopplade när du installerade win så att det är nått strul med bootloadern ?

Du menar att jag har gammalt moderkort eller min vän har gammalt moderkort?

Permalänk
Rekordmedlem
Skrivet av Orlaw:

Du menar att jag har gammalt moderkort eller min vän har gammalt moderkort?

Du skrev gammal dator utan vidare specifikation, en del kallar moderna datorer gamla för att de skaffat det allra nyaste men är det en äldre dator så kan det vara problemet för datorer från win 7 tiden kan ofta inte boota från gpt partitioner.

Permalänk
Medlem
Skrivet av Viita:

Eftersom du kommit så långt att du startat diskpart, så förutsätter jag att du har lite koll på denna.
DVS, kommandona "list disk". "select disk <nr>" och "clean".

Utan att ha koll på det, så gissar jag att bilden talar för att "Disk3" är A400-disken.
Den är då initierad som MBR (BIOS-läge (Legacy)), och Disk 1 & 2 som GPT (UEFI-läge).

Det finns två sätt.
Antingen så kör du den "diskpart clean", dvs, "select disk 3" om det är disk 3 som ä A400-disken och sedan kommandot "clean", sedan tar du ut disken, tar med den till din kompis kopplar in endast den disken och sedan installerar windows på den rakt upp-o-ner.
Alternativ två är att du konverterar disken till GPT-format, osäker på kommandot rakt av, google är din vän. Du kommer ändå bli tvungen att ta bort samtliga partitioner på disken då det skall skapas en EFI-partition också i uttrymmet.

Du kan även köra "diskpart clean" från windows installations-medium om du vill göra det utan att riskera att köra "diskpart clean" på fel disk. (Ha endast disken som windows skall installeras på inkopplad när du installerar windows för att unvika att boot-paritionen hamnar på fel disk.)

Här är en exempel-video.
https://www.youtube.com/watch?v=z4Z38pD1Gt0

Tillslut blev den klar med att rensa, samma resultat. Bootar inte in i Windows, utan går direkt in i bios.
Jag ser disken i min "den här datorn", den sitter här med Windows filer på sig och dylikt...konstigt.

Skrivet av mrqaffe:

Om det är en äldre dator är det tvärt om inte möjligt att boota från GPT partitioner utan bootenheten måste vara MBR för GPT stöds inte av äldre bios så enheterna fungerar inte innan win är bootat.

Men hade du andra enheter inkopplade när du installerade win så att det är nått strul med bootloadern ?

Inga andra enheter inkopplade. Bara USB-stickan och SSDn, vid omstart tar jag ut USB och kör endast med SSDn.

Skrivet av Icetec:

Du kan alltid testa att slå av/på UEFI-läge i BIOS om möjligt, samt secure boot (om UEFI) och se om det gör någon skillnad. Du kan ju även testa att (i din egen dator) ta ut alla andra diskar och installera om Windows på den och se om den bootar då. I så fall kanske du kan testa att uppdatera BIOS på den dator där det strulade.

Det var exakt det jag gjorde. Vid varje installation togs alla andra diskar ut och, som nämnt ovan, fanns endast stickan och SSDn kopplad. Ska testa stänga av UEFI, har nog inte testat det ännu.

Kan det vara fel på disken? Varför hittar jag den i windows med alla filer, men den vägrar boota?

Permalänk
Medlem

Grejen är, när jag är inne i boot på windows som ni kan se på följande bild, så står det Windows Boot Manager bara på min Samsung EVO 120GB. När jag väljer vilken annan disk nere i listan, inklusive den längst ner på 120GB, så händer exakt samma sak: skärmen blir svart, och det bootar direkt in i BIOS.

Jag antar nu att målet är att få Windows Boot Manager att ploppa upp på Kingston disken också. Börjar kanske misstänka USB stickan. Eller, vad tror ni?
https://i.imgur.com/lVyswPS.jpg

Permalänk
Rekordmedlem
Skrivet av Orlaw:

Grejen är, när jag är inne i boot på windows som ni kan se på följande bild, så står det Windows Boot Manager bara på min Samsung EVO 120GB. När jag väljer vilken annan disk nere i listan, inklusive den längst ner på 120GB, så händer exakt samma sak: skärmen blir svart, och det bootar direkt in i BIOS.

Jag antar nu att målet är att få Windows Boot Manager att ploppa upp på Kingston disken också. Börjar kanske misstänka USB stickan. Eller, vad tror ni?
https://i.imgur.com/lVyswPS.jpg

Boot override brukar betyda "1 gång" men du vill ändra på "varje gång" och det är kanske boot option, ovanför ?

Permalänk
Medlem

Hade Windows varit installerad på Kingstondisken med UEFI hade du haft två Windows Boot Manager i listan.
Det finns inget i bios som pekar mot en efi-fil förutom till Samsung SSDn. Gjorde du stickan med Media creation tool den sista gången?
Kontrollera med Disk Part igen, har den MBR igen så har du gissningsvis inte installerat med media creation tool, för det är väl Windows 10 du installerar?

Permalänk
Medlem
Skrivet av Orlaw:

Tillslut blev den klar med att rensa, samma resultat. Bootar inte in i Windows, utan går direkt in i bios.
Jag ser disken i min "den här datorn", den sitter här med Windows filer på sig och dylikt...konstigt.

Inga andra enheter inkopplade. Bara USB-stickan och SSDn, vid omstart tar jag ut USB och kör endast med SSDn.

Det var exakt det jag gjorde. Vid varje installation togs alla andra diskar ut och, som nämnt ovan, fanns endast stickan och SSDn kopplad. Ska testa stänga av UEFI, har nog inte testat det ännu.

Kan det vara fel på disken? Varför hittar jag den i windows med alla filer, men den vägrar boota?

Om du skall installera Windows på A400-disken OCH du vill att en BOOT-loader skall läggas in på denna, börja med att koppla ur de andra diskarna så du BARA har A400-disken inkopplad.

Starta sedan Windows-installationen, om det finns en partition på A400-disken, tag bort denna, välj sedan att fortsätta installera Windows.

Då det endast finns en disk inkopplad och inga partitioner så kommer en partition för Windows och för boot-partitionen (EFI) skapas automatiskt sålänge du inte ställt in att UEFI skall använda Legacy mode.
(Legacy mode = BIOS = MBR, dvs, ej GPT)

Du kan oftast välja vilken disk som skall vara boot-disk, men det finns risk (även om den inte bör finnas), om du har flera diskar inkopplade att boot-partitionen ändå inte hamnar där du önskar.
Du ska kunna välja detta manuellt, men det är inte alltid allt fungerar logiskt.

EDIT:

OM du initierar A400-disken i Windows. Låter Windows (i en readan befintlig uppstartad installation) skapa en partition, så kommer partitionen vara så stor att den tar allt utrymme på disken, dvs, det finns inte längre utrymme på disken för Windows-installationen att skapa en Boot-partition (EFI).

Det var därför jag tidigare skrev.
Kör diskpart clean, spring sedan över till din kompis och installera Windows.

Nu är mitt råd.
Kör diskpart clean (endast clean, inte clean all). Stäng av datorn, skapa INTE någon partition på denna disk. Du kan initera den som GPT, men det är ej nödvändigt.
Koppla ur dina andra diskar.
Koppla Endast in A400-disken.
Kör Windows-installationen.
Då det inte finns något initerat på disken, och om du inte kör UEFI i Legacy mode (skall inte användas om det inte finns särskillda skäl dvs gammal hårdvara som kräver det), då skall Windows-installationen skapa alla nödvändiga partitioner.

Permalänk
Medlem
Skrivet av Viita:

Om du skall installera Windows på A400-disken OCH du vill att en BOOT-loader skall läggas in på denna, börja med att koppla ur de andra diskarna så du BARA har A400-disken inkopplad.

Starta sedan Windows-installationen, om det finns en partition på A400-disken, tag bort denna, välj sedan att fortsätta installera Windows.

Då det endast finns en disk inkopplad och inga partitioner så kommer en partition för Windows och för boot-partitionen (EFI) skapas automatiskt sålänge du inte ställt in att UEFI skall använda Legacy mode.
(Legacy mode = BIOS = MBR, dvs, ej GPT)

Du kan oftast välja vilken disk som skall vara boot-disk, men det finns risk (även om den inte bör finnas), om du har flera diskar inkopplade att boot-partitionen ändå inte hamnar där du önskar.
Du ska kunna välja detta manuellt, men det är inte alltid allt fungerar logiskt.

EDIT:

OM du initierar A400-disken i Windows. Låter Windows (i en readan befintlig uppstartad installation) skapa en partition, så kommer partitionen vara så stor att den tar allt utrymme på disken, dvs, det finns inte längre utrymme på disken för Windows-installationen att skapa en Boot-partition (EFI).

Det var därför jag tidigare skrev.
Kör diskpart clean, spring sedan över till din kompis och installera Windows.

Nu är mitt råd.
Kör diskpart clean (endast clean, inte clean all). Stäng av datorn, skapa INTE någon partition på denna disk. Du kan initera den som GPT, men det är ej nödvändigt.
Koppla ur dina andra diskar.
Koppla Endast in A400-disken.
Kör Windows-installationen.
Då det inte finns något initerat på disken, och om du inte kör UEFI i Legacy mode (skall inte användas om det inte finns särskillda skäl dvs gammal hårdvara som kräver det), då skall Windows-installationen skapa alla nödvändiga partitioner.

Tack för det utförliga svaret!
Kompisen är inte hemma idag, går det bra att jag kopplar ut alla andra diskar, har bara Kingston ikopplad och installerar Windows på den via stickan?

Följt stegen i diskpart och dylikt, enda som behövs nu är installationen

Permalänk
Medlem

https://i.imgur.com/PnjuY70.png

Jag hittar inte disken i Kingstons egna mjukvara - hmm?

Permalänk
Medlem
Skrivet av mrqaffe:

Boot override brukar betyda "1 gång" men du vill ändra på "varje gång" och det är kanske boot option, ovanför ?

Jag har bootoption:

#1 Kingston SSD
#2 Windows Boot Manager (Samsung EVO 120GB).

Det är mina två alternativ i Windows

Permalänk
Rekordmedlem
Skrivet av Orlaw:

Jag har bootoption:

#1 Kingston SSD
#2 Windows Boot Manager (Samsung EVO 120GB).

Det är mina två alternativ i Windows

I Windows ? Då är du på fel ställe för bootenhet bestämmer moderkortet så det ska ställas in i bios.
Du ska fysiskt koppla ur alla andra lagringsenheter och installera win på ssdn.
helst ska du använda Microsofts verktyg för att göra installations usbn så att du vet att det görs på rätt sätt och du får senaste versionen av win 10 men har du ett fungerande installationsmedia så behöver du inte göra om det

Permalänk
Medlem
Skrivet av Orlaw:

Tack för det utförliga svaret!
Kompisen är inte hemma idag, går det bra att jag kopplar ut alla andra diskar, har bara Kingston ikopplad och installerar Windows på den via stickan?

Följt stegen i diskpart och dylikt, enda som behövs nu är installationen

Ja, det är det enklaste, särskillt om du vill att det skall skapas både Boot-partition och Windows-partition på disken.
Då tar du bort risken att Windows skulle få för sig att lägga boot-partitionen någon annanstans ändå.

Om du sedan efter Windows-installationen kan Boota upp till Windows utan någon annan disk inkopplad så bör det bara vara att stoppa in disken i din kompis dator igen.

Kan hålla med om att det är lite märkligt att disken inte dyker upp i Kingstons mjukvara.

Permalänk
Medlem

Jag lämnade tillbaka disken, köpte en ny (Crucial) och det funkade på första försöket. Något måste ha varit fel med disken?!

Permalänk
Medlem
Skrivet av mrqaffe:

I Windows ? Då är du på fel ställe för bootenhet bestämmer moderkortet så det ska ställas in i bios.
Du ska fysiskt koppla ur alla andra lagringsenheter och installera win på ssdn.
helst ska du använda Microsofts verktyg för att göra installations usbn så att du vet att det görs på rätt sätt och du får senaste versionen av win 10 men har du ett fungerande installationsmedia så behöver du inte göra om det

Detta gjorde jag minst tio gånger 😅