Bluescreen problem - IRQL_NOT_LESS_OR_EQUAL ntoskrnl.exe

Permalänk
Medlem

Bluescreen problem - IRQL_NOT_LESS_OR_EQUAL ntoskrnl.exe

Hej,

Jag har börjat få frekventa bluescreens helt plötsligt.

Det har hänt när jag var AFK några gånger, men jag verkar kunna utlösa bluescreens genom att spela Red Dead Redemption 2 ett tag. Har dock inga andra lika krävande spel att testa med.
RDR2 verkar dock inte vara boven i det hela, då som sagt det hänt 1-2 gånger när jag inte ens använt datorn.

Felet jag får och kan se med BlueScreenView är "IRQL_NOT_LESS_OR_EQUAL ntoskrnl.exe 0x0000000a".

- Jag har provat sfc / scannow, inga problem hittades.
- Jag har provat Windows Memory Diagnostics, inga problem hittades.
- Jag har provat Windows egna Driver Verifier, inga problem hittades.

Mina specs är;
Intel i7 9700k
ASUS Z390-F gaming
ASUS Strix RTX 3080 OC
Corsair Vengeance LPX 4x8GB DDR4 3200MHz RAM
Corsair RM750x v2

Behöver fan hjälp med detta, lyckas ej lösa det på egen hand...

Om någon är kunnig kring dumpfiles har jag även laddat upp dessa på DropBox, länk finns här; https://www.dropbox.com/s/98pws1evxqhste8/DumpFiles.zip?dl=0

Tack på förhand allesammans,

Permalänk
Medlem

Jag hade liknande problem efter ha skruvat ihop en ny burk en gång. Ungefär samma felkoder, minns inte exakt. Visade sig att det var minnena som var defekta. Efter ett byte så funkade allt som det skulle igen. Jag har för mig att jag också körde memtest och liknande men inget avvikande där.

Permalänk
Moderator

Kolla så att alla drivrutiner är uppdaterade. Jag vet inte hur Windows egen variant funkar, jag brukar använda ett program som heter Driver Booster. Det är lätt att konfigurera så att det inte startar med Windows osv. om man vill ha kvar det.

Kör du minnena i XMP så prova att stänga av det och se om det blir bättre.
Koppla bort alla enheter som du kan klara dig utan och kolla om problemet försvinner.

Permalänk
Medlem
Skrivet av ghostfenix:

Visade sig att det var minnena som var defekta. Efter ett byte så funkade allt som det skulle igen. Jag har för mig att jag också körde memtest och liknande men inget avvikande där.

Tvekar starkt på att det skulle vara minnena, men det är klart, mycket möjligt ändå. Får kanske dra igång riktiga memtest86 istället för Windows variant, den är ju lagom mer pålitlig.

Skrivet av giplet:

Kolla så att alla drivrutiner är uppdaterade.

Kör du minnena i XMP så prova att stänga av det och se om det blir bättre.
Koppla bort alla enheter som du kan klara dig utan och kolla om problemet försvinner.

Får testa uppdatera alla drivers helt enkelt. Kan också testa att stänga av XMP.

Har dock inga speciella enheter kopplade till datorn... Tangentbord, mus, headset (3.5mm), nätverkskabel samt två skärmar via DisplayPort.

Permalänk
Medlem

1. Trasig drivrutin.
2. Ostabila minnen.
3. Döende disk.
4. Döende annan hårdvara.

Kan bero på i princip vad som helst.
hade det själ för många år sen var en disk som höll på att dö.
bara att ha den inkopplad orsakade felet spontant lite när som helst.

Permalänk
Medlem

Testat installera om Win10?

Permalänk
Medlem

Väldigt konstigt.
Hade alla senaste drivers installerade, men testade ändå att tanka ner alla senaste varianter från ASUS hemsida, avinstallera dom gamla och installera dom nya. Inte mixtrat med XMP eller annan överklockning ännu.

Nu har jag spelat RDR2 med exakt samma inställningar och program aktiverade som tidigare i över 30 minuter. Tidigare fick jag blåskärm bara efter några minuter. Så det kan eventuellt ha varit någon drivrutin som var knasig, alternativt så hade jag nyss bara tur. Spelade nämligen RDR2 tidigare i veckan i ca 2 timmar utan någon blåskärm.

Hinner dock inte felsöka mer ikväll, så vi får väl se om datorn fortsätter fungera felfritt eller om det kommer fler blåskärmar imorgon. Skulle det hända, så kör jag Memtest86 och återkommer i tråden allt eftersom.

Skrivet av Rouge of Darkness:

1. Trasig drivrutin.
2. Ostabila minnen.
3. Döende disk.
4. Döende annan hårdvara.

Kan bero på i princip vad som helst.
hade det själ för många år sen var en disk som höll på att dö.
bara att ha den inkopplad orsakade felet spontant lite när som helst.

Hmm, skulle iofs kunna vara min gamla snurrdisk. Sitter en säkert 10 år gammal 1TB Samsung HD103SJ som jag lagrar filmer o andra dokument på. Men det borde väl i sådanafall synas om jag kör t.ex CrystalDiskInfo?

Får som jag skrev ovan antagligen köra Memtest86 för att se om minnena är instabila.

Skrivet av Harddrive:

Testat installera om Win10?

Det är mer eller mindre en ny installation av Win10, har knappt några program installerade.

Hade en M.2 disk som jag köpte som refurb som blev korrupt och dog, så bytte den på garanti och fick ju då såklart installera Windows på nytt.

Permalänk

Kan kanske vara relaterat till Microsofts KB5001330-uppdatering om du sitter på W10 20H2. Om du har den uppdateringen installerad och fortsätter få random BSODs så testa avinstallera den.

Permalänk
Medlem
Skrivet av Rouge of Darkness:

4. Döende annan hårdvara.

Kan bero på i princip vad som helst.

Iofs, skulle det kunna vara så att det beror på att datorn får för lite ström från nätaggregatet, eller reagerar datorn annorlunda då? Tänker att om det är det så bör väl hela datorn stänga av sig ur en säkerhetssynpunkt snarare än att Windows ger blåskärm.

Försöker bara bolla lite idéer.

Jag trycker ju ett STRIX 3080 OC (400W vid full load) samt en i7 9700k överklockad till 4.9GHz, AiO med 4 fläktar i push-pull, 3 chassifläktar och 4 minnesmoduler allt på ett Corsair RM750x v2.

Har ingen wattmätare hemma men enligt kalkylerna så ska det ändå räcka med 750W till datorn, däremot så har mitt nätagg 2-3 år på nacken så det kan ju eventuellt vara så att den tappat lite effekt med åren.

Permalänk
Medlem
Skrivet av underd0g76:

Kan kanske vara relaterat till Microsofts KB5001330-uppdatering om du sitter på W10 20H2. Om du har den uppdateringen installerad och fortsätter få random BSODs så testa avinstallera den.

Det stämmer, har senaste uppdateringen. En snabb googlesökning visar att andra har problem med den med. Skulle kunna testa en rollback där med/vänta på nästa update, tack för infon!

Permalänk
Moderator
Skrivet av smurfeNn:

Iofs, skulle det kunna vara så att det beror på att datorn får för lite ström från nätaggregatet, eller reagerar datorn annorlunda då? Tänker att om det är det så bör väl hela datorn stänga av sig ur en säkerhetssynpunkt snarare än att Windows ger blåskärm.

Försöker bara bolla lite idéer.

Jag trycker ju ett STRIX 3080 OC (400W vid full load) samt en i7 9700k överklockad till 4.9GHz, AiO med 4 fläktar i push-pull, 3 chassifläktar och 4 minnesmoduler allt på ett Corsair RM750x v2.

Har ingen wattmätare hemma men enligt kalkylerna så ska det ändå räcka med 750W till datorn, däremot så har mitt nätagg 2-3 år på nacken så det kan ju eventuellt vara så att den tappat lite effekt med åren.

Har inte sett att du har en överklockning. Jag hade tagit bort den för att utesluta den ur ekvationen.

Så klart kan det vara ditt nätaggregat som strular. Du kan då få alla möjliga konstiga fel. Men om datorn blåskärmar när du inte använder datorn kan ju belastningen knappast vara så hög?

Permalänk
Medlem
Skrivet av giplet:

Har inte sett att du har en överklockning. Jag hade tagit bort den för att utesluta den ur ekvationen.

Så klart kan det vara ditt nätaggregat som strular. Du kan då få alla möjliga konstiga fel. Men om datorn blåskärmar när du inte använder datorn kan ju belastningen knappast vara så hög?

Bör testa ta bort överklockningen med, men har haft cpun överklockad i 1-2 år med bra temps utan strul innan.

Nej precis, men det har som sagt bara hänt nån gång eller två under loppet av 2 månader att samma BSOD hänt när jag varit AFK från datorn så det kan ju vara något strul där ändå

Permalänk
Medlem

Har nu testat att köra Memtest86 över natten. Inga konstigheter, passerade testet med XMP aktiverat..

https://www.dropbox.com/s/es136ks9trhk4xj/MemTest86-Report-20210424-004639.html?dl=0

Så nu är jag helt ovetande igen. Fick däremot en till bluescreen igår när jag spelade RDR2! Lyckades spela helt utan problem i 1,5h så jag tänkte verkligen att mitt problem var löst, sen stod jag i en butik på spelet och valde ut kläder (inte ens i närheten av hur krävande det är att rida runt på en häst o panga revolvern) och PANG! Blåskärm.

Denna gång fick jag en bluescreen som säger "SYSTEM_SERVICE_EXCEPTION nvlddmkm.sys" vilket pekar på Nvidia, men hur fan löser man det då? Klassisk DDU och ominstallering av drivers?

Permalänk
Medlem

Kass Nvidia drivrutin eller grafikkort.

börja med att testa olika drivrutins versioner.
ibland får inte nvidia in alla hästarna i hagen och kan släppa en ostabil drivrutin så testa lite olika drivrutiner.

funkar inte någon av drivrutinerna kan du börja misstänka defekt eller överhettande grafikkort.

notera att det behöver inte vara en komponent med inbyggd tempsensor t.ex minne eller vrm då inte alla kort har sensor på dessa som överhettar så testa att dra på gpu fläkten på fullt ös och spela så att du vet att det verkligen inte beror på överhettning.

Permalänk
Medlem
Skrivet av Rouge of Darkness:

Kass Nvidia drivrutin eller grafikkort.

börja med att testa olika drivrutins versioner.
ibland får inte nvidia in alla hästarna i hagen och kan släppa en ostabil drivrutin så testa lite olika drivrutiner.

funkar inte någon av drivrutinerna kan du börja misstänka defekt eller överhettande grafikkort.

notera att det behöver inte vara en komponent med inbyggd tempsensor t.ex minne eller vrm då inte alla kort har sensor på dessa som överhettar så testa att dra på gpu fläkten på fullt ös och spela så att du vet att det verkligen inte beror på överhettning.

Motsäger dig inte, men tveksamt att det skulle vara grafikkortet? Är ju ett ca 4 månader gammalt Strix 3080 OC modellen.

Men tack för tipset! Börjar med att köra DDU och göra en rollback till föregående driver, inser att GeForce Experience automatiskt uppdaterat min driver till senaste 466.11 drivern, så det kan mycket väl vara den som är boven i dramat.

Permalänk
Medlem
Skrivet av smurfeNn:

Motsäger dig inte, men tveksamt att det skulle vara grafikkortet? Är ju ett ca 4 månader gammalt Strix 3080 OC modellen.

Men tack för tipset! Börjar med att köra DDU och göra en rollback till föregående driver, inser att GeForce Experience automatiskt uppdaterat min driver till senaste 466.11 drivern, så det kan mycket väl vara den som är boven i dramat.

inte helt omöjligt att ett kort är trasigt direkt ur lådan pga fraktskada eller tillverkningsfel.

Permalänk
Medlem
Skrivet av smurfeNn:

Har nu testat att köra Memtest86 över natten. Inga konstigheter, passerade testet med XMP aktiverat..

https://www.dropbox.com/s/es136ks9trhk4xj/MemTest86-Report-20210424-004639.html?dl=0

Så nu är jag helt ovetande igen. Fick däremot en till bluescreen igår när jag spelade RDR2! Lyckades spela helt utan problem i 1,5h så jag tänkte verkligen att mitt problem var löst, sen stod jag i en butik på spelet och valde ut kläder (inte ens i närheten av hur krävande det är att rida runt på en häst o panga revolvern) och PANG! Blåskärm.

Denna gång fick jag en bluescreen som säger "SYSTEM_SERVICE_EXCEPTION nvlddmkm.sys" vilket pekar på Nvidia, men hur fan löser man det då? Klassisk DDU och ominstallering av drivers?

Hade samma problem med rdr2 innan, fick köra gpu på gameläge i Asus programvara. Man får aningen sänkt klocka då har inte haft en BSOD sen dess. Rdr2 är känsligt för överklockning på Nvidia kort

Permalänk
Medlem

Du har ingen Hirens BootCD 15.2 som bootar upp en liveCD med Windws 10 PE utan drivrutiner bortsett det nödvändigaste för att mus, nätverk m.m. ska funka. OBS! det tar en stund innan desktopen dyker upp. Kan vara bra att veta så du inte tror att datorn har hängt sig

Finns en drös med verktyg och testa datorn med.
Kraschar det då så måste det vara nåt fel på hårdvaran

Edit:
Finns andra liknade alternativ https://www.makeuseof.com/tag/bootable-windows-pe-based-recov...

Permalänk
Medlem

Har du testat att stänga av CPU C-States i bios?
Finns nytt bios beta till z390-F med Resizable BAR till ditt 3080 för lite extra fps. https://rog.asus.com/motherboards/rog-strix/rog-strix-z390-f-...

Permalänk
Medlem
Skrivet av Pe3:

Hade samma problem med rdr2 innan, fick köra gpu på gameläge i Asus programvara. Man får aningen sänkt klocka då har inte haft en BSOD sen dess. Rdr2 är känsligt för överklockning på Nvidia kort

Tveksamt att det är just RDR2, idag fick jag en BSOD ca 1 minut efter datorn bootade upp med enbart Chrome och NZXTs fläktstyrningsprogram igång.

Första för dagen var "UNEXPECTED_KERNEL_MODE_TRAP". Nästa BSOD idag var "CLOCK_WATCHDOG_TIMEOUT".

Lite googling pekar på minnesproblem eller CPU. Har som sagt haft överklockning på CPUn i 1-2 år utan några som helst problem, men jag har däremot installerat två till minnesmoduler i vintras så det pekar snarare däråt.

Så nu har jag testat att stänga av XMP och ser om det blir bättre. Fortsätter det så resettar jag nog BIOS helt för att utesluta några OC problem på CPUn.

Skrivet av AMD-FX:

Du har ingen Hirens BootCD 15.2 som bootar upp en liveCD med Windws 10 PE utan drivrutiner bortsett det nödvändigaste för att mus, nätverk m.m. ska funka. OBS! det tar en stund innan desktopen dyker upp. Kan vara bra att veta så du inte tror att datorn har hängt sig

Finns en drös med verktyg och testa datorn med.
Kraschar det då så måste det vara nåt fel på hårdvaran

Det får jag nog verkligen ta en titt på om jag inte löser det snart, tack för tipset!

Skrivet av Evbody:

Har du testat att stänga av CPU C-States i bios?
Finns nytt bios beta till z390-F med Resizable BAR till ditt 3080 för lite extra fps. https://rog.asus.com/motherboards/rog-strix/rog-strix-z390-f-...

Yes, har funderat på om en BIOS update skulle lösa problemet, men har läst att folk har problem med instabilitet på nya Beta-versionen och det känns inte helt smart att skaffa i min sits Så får avvakta med Resizable BAR.

Så fort den färdiga versionen kommer ut blir det en update!

Permalänk
Medlem

Resettade igår alla BIOS settings och har idag inte fått en enda BSOD. Kan ju va ett undantag men tror inte det.

Väldigt lustigt måste jag säga, har som sagt haft CPUn överklockad i snart 2 år utan problem eller höga temps så förstår verkligen inte varför blåskärmar framkommer nu. XMP har jag självklart också haft igång minst lika länge.

Ska aktivera XMP igen, köra lite stabilitetstester och se, är det inte minnena som knasar får jag väl försöka överklocka på nytt och hitta en stabilare lösning. Tack alla för er hjälp!