Kan ej boota in till Windows 10 - Konstant BSOD Hypervisor_Error vid boot.

Permalänk

Kan ej boota in till Windows 10 - Konstant BSOD Hypervisor_Error vid boot.

Hej Sweclockers!

I come in great need,

För ett par dagar sedan fick min Windows 10 en BSOD med felmeddelandet: Hypervisor_Error.

Efter att datorn startat om så kommer jag vid boot till när Windows-loggan visas och får direkt en ny BSOD med Hypervisor_Error.

Vad jag provat:

  • Gått in i BIOS och stängt av SVM, men då kommer jag till Windows-loggan och sen startar datorn om sig bara...

  • Kört mem86-test, fick 0 errors efter 4 rundor ~6h

  • Försökt gå in i Safe-Mode. Den kommer till "Automatic Repair" bara för att starta om sig...

  • Skapat en Win10 installations USB och försökt installera om Windows 10, men då kommer jag inte ens in till installationsfönstret...

Kör wsl2 och Docker desktop i Windows, undrar ifall det är det som har sabbat windows, givet hypervisor_erroret?

Var går man härifrån är då frågan... Ska jag kanske testa uppdatera BIOS på moderkortet och hoppas att det löser problemet?

Var för snabb på skapa-inlägg knappen!
Permalänk
Arvid Nordqvist-mannen

Docker Desktop kräver VM, här Hyper-V. Så det är troligen problemet alt. inställningar. Pröva avinstallera och ta bort Hyper-V, se om det funkar.

Permalänk
Skrivet av tcntad:

Docker Desktop kräver VM, här Hyper-V. Så det är troligen problemet alt. inställningar. Pröva avinstallera och ta bort Hyper-V, se om det funkar.

Kommer inte in till Windows, så det blir lite svårt att avinstallera program då
Jag sitter fast i boot...

Permalänk
Medlem

Du skrev att du testat stänga av SVM, och den bootar om, då är det nog ganska illa, testa köra en live linux på USB see om det funkar, och på den vägen felsöka.

Permalänk
Skrivet av puttey:

Du skrev att du testat stänga av SVM, och den bootar om, då är det nog ganska illa, testa köra en live linux på USB see om det funkar, och på den vägen felsöka.

Yes, provade det och jag kommer in!

Kan se alla diskar, vilket är bra. Tänkte försöka föra över lite filer från C till en annan disk som backup.

Frågan är om man kan stänga av Hyper-V och avinstallera program via Linux USBn?

Permalänk
Arvid Nordqvist-mannen
Skrivet av Webpiraten:

Yes, provade det och jag kommer in!

Kan se alla diskar, vilket är bra. Tänkte försöka föra över lite filer från C till en annan disk som backup.

Frågan är om man kan stänga av Hyper-V och avinstallera program via Linux USBn?

Läste nog lite för fort där
Kan du boota en windowsinstallation hyffsat så du får upp CMD kan du säkert använda DISM /remove-feature eller liknande. Osäker på om Linux kan det.

Permalänk
Skrivet av tcntad:

Läste nog lite för fort där
Kan du boota en windowsinstallation hyffsat så du får upp CMD kan du säkert använda DISM /remove-feature eller liknande. Osäker på om Linux kan det.

Hehe sånt händer

Det är kruxet, jag försökte boota med en Windows USB, men den vill inte ens starta!

Permalänk
Arvid Nordqvist-mannen
Skrivet av Webpiraten:

Hehe sånt händer

Det är kruxet, jag försökte boota med en Windows USB, men den vill inte ens starta!

Har du annan dator att tillse att installationsmediet funkar?

Permalänk
Medlem

Du har inte råkat stänga av hårdvaru-virtualisering i BIOS?

Permalänk
Skrivet av tcntad:

Har du annan dator att tillse att installationsmediet funkar?

Har som tur jobbdatorn hemma, så får ta och testa det

Permalänk
Skrivet av dlq84:

Du har inte råkat stänga av hårdvaru-virtualisering i BIOS?

Nä, den är aktiverad

Permalänk

Statusuppdatering

Efter mycket testande så lyckades jag ta mig in till Windows igen.
Jag hade testat bootat från en USB-sticka med Ubuntu, för att se b.l.a. om alla diskar var fungerande vilket de var.
Startade då om datorn och som ett mirakel så lyckades jag starta Windows!

Det första man såg var ett felmeddelande:
"Docker.Core.Backend.BackendQuitException: Hardware assisted virtualization and data execution protection must be enabled in BIOS". Så det verkar ha varit ett Docker/WSL2 relaterat problem!
Passade på då att avinstallera Docker Desktop, WSL2 och avaktivera allting som har med Hypervisor/Hyper-V att göra.

Startade om datorn och då kunde den helt plötslig inte boota in till Windows igen...

Helvete!

Jahap tänkte jag, vad är det som är fel nu då?!
Passade då på att uppdatera BIOS till senaste versionen i ett hopp att det skulle lösa problemet. Startade om, men samma fel uppstod, Windows startar inte.

Provade då att avaktivera och sen aktivera SVM i BIOS för att se ifall det var nått strul med det. När jag aktiverade SVM igen så ville Windows starta.

Det här har verkligen varit en berg-och-dalbana av känslor, allt från extas till melankoli

Så nu sitter jag och gör en Recovery Drive och sen blir det att installera om Windows.
Får se ifall det löser allting!

Permalänk

Statusuppdatering #2

Så efter att ha installerat om Windows på Fredagen så verkade allting fungera. Däremot så kom det tillbaka på Måndag morgon...

Skickade då in datorn på felsökning på ett lokalt datorföretag. Visade sig att CPU:n (3900x) hade dött...

Ringde Inet och fick veta att det var 3 års garanti, så det blir bara att skicka in den då

Ovanligt att CPU:n dör så där, köpte den 2020-03 så den är relativt ny. Efter att ha sökt lite på nätet så verkar folk haft problem med just ryzen.

Så det var inte Windows problem trots allt!