Nya erbjudanden i Webhallen Gamers Unite

Logitech StreamCam ger störningar på vissa USB portar?

Permalänk
Medlem

Logitech StreamCam ger störningar på vissa USB portar?

Hej,

Har köpt en Logitech StreamCam som kommer med en fast USB-C kabel. För att dels förlänga kabeln samt kunna koppla in den i äldre datorn utan USB-C vid behov så köpte jag en USB-C till USB-A adapter och en USB skarvkabel(USB 3.0).

https://www.netonnet.se/art/dator-surfplatta/datortillbehor/kablar/adapter/andersson-usb-a-to-usb-c-adapter-3a-60w-black/1017111.13721/?siteType=2

Nedis Förlängningskabel USB A-hane - USB A-hona 2m

Det visade sig dock snabbt att denna adapter trappade ner USB standarden till 2.0 vilket medförde att det blev 30 istället för 60 FPS. Det fanns dock inga andra störningar, allt såg bra ut.

Jag bytte adaptern till en sådan här istället :

Satechi USB-A till USB-C Adapter

Med denna adapter blir resultatet lite blandet enligt följande :

Moderkort : ROG STRIX B550-F GAMING

1. 2x USB 2.0, på dessa 2 portar blir det stabil bild men endast 30 FPS
2. 1x USB 3.2 Gen 2(sitter bredvid USB-C uttaget) , Detta är den enda portan som fungerar felfritt och som ger 60 FPS
6. 4x USB 3.2 Gen 1 Type A Här blir det rejält med störningar men den kör 60 FPS
7. 1x USB 3.2 Gen 2 Type C, denna fungerar utmärkt precis som #2

I fronta av datorn sitter det 4 portar, samtliga blir det stabil bild med men 30 FPS (USB 2.0)

Jag fick uppfattninge att USB 3.0 ska räcka för att få 1080p och 60 fps med denna kamera så varför blir det störningar på Gen 1? Har det med systemet eller adaptern att göra?

Permalänk
Medlem

Skulle tro att det är en kombination av lite allt möjligt. Två meter är ganska långt att förlänga USB med och ställer en del krav på kabeln. Hade själv en hel del trubbel med det när jag skulle förlänga till Oculus-sensorer, blir rätt snabbt spänningsfall och dålig signalintegritet. Sen har du en USB-C->A-adapter på det som inte alltid är helt smärtfritt som du märkt, plus de mer eller mindre ökända USB-problemet på AM4.

Skulle börja med att testa en annan förlängningskabel, så kort som möjligt. Har bra erfarenhet av Amazon Basics och Ugreen. Det är dock inte alls säkert att det kommer hjälpa och har du otur behövs en aktiv kabel.

Permalänk
Medlem

Det verka fungera på USB3.2 gen 2 - kör på dessa!.

Skulle tro att en del i problematiken också ligger hur USB3.2 gen 1 hubben är kopplad in längre in i datorn, dvs. om det går direkt på en PCIe mot CPU eller via PCIe-expandrar. - USB3.3 gen 2 är byggd för 10 GBit/s och har förmodligen mer raka vägar mot CPU än tex USB3.2 gen 1. med 5 GBit/s som förmodligen går igenom en PCIe-expander på moderkortet och förstnämnda har helt enkelt mer kapacitet i reserv för att hantera 'trafikstockningarna'