Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Nov 2004

Upplösning i Ubuntu, hjälp..

Jag vill använda upplösningen 1280x1024 men max är 1024x768, min /etc/X11/xorg.conf ser ut på detta sätt (ny installation).

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV43 [GeForce 6600 GT]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV43 [GeForce 6600 GT]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection

Jag har en LG L1980Q Skärm och ett Nvidia Geforce 6600 grafikkort.

Länk till skärmen på Komplett..
http://www.komplett.se/k/ki.asp?sku...p;view=detailed

Där står det 75 Hz x 83 kHz, men gäller detta även för DVI som jag kör? Hittar inget om det. DVI är väl max 60 Hz? Iaf på min skärm.

Kan någon försöka hjälpa mig, det skulle verkligen uppskattas för jag ger snart upp..

Antec Sonata Plus 550, Intel Core 2 Duo 8400, Zalman CNPS9700 NT, Evga 750i SLi FTW, 2X GeForce 8800GT SLI, 2X Arctic Cooling Accelero S1, 4X Corsair TWIN2X8500C5D 4096MB, Western Digital 500GB Caviar Black, Vista x64.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Nov 2004

Testat att ändra

SubSection "Display" Depth 24 Modes "1024x768" "800x600" "640x480" EndSubSection

till:

SubSection "Display" Depth 24 Modes "1280x1024" "1024x768" "800x600" "640x480" EndSubSection

?

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Nov 2004

Funkar inte =/

Antec Sonata Plus 550, Intel Core 2 Duo 8400, Zalman CNPS9700 NT, Evga 750i SLi FTW, 2X GeForce 8800GT SLI, 2X Arctic Cooling Accelero S1, 4X Corsair TWIN2X8500C5D 4096MB, Western Digital 500GB Caviar Black, Vista x64.

Trädvy Permalänk
Medlem
Registrerad
Apr 2004

Testat "sudo dkpg-reconfigure xserver-xorg"?

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av Tuniz
Funkar inte =/

Glöm inte att starta om X och gdm. Vet du inte hur man gör det så kan du köra en "Microsoft:are" och starta om hela datorn.

Trädvy Permalänk
Medlem
Plats
Tibro[ ] Strömstad [X]
Registrerad
Mar 2004

starta om X : alt-ctrl-backsteg

@gegoxaren på identi.ca
min personliga Blag ^_^
#python #cSharp #php #sqlite #freetard #loonix

Trädvy Permalänk
Medlem
Plats
Söderhamn
Registrerad
Okt 2004

Jag höll på att bli vansinnig på detta problem personligen, men i slutändan så visade det sig att allting funkade bra så länge jag inte använde ATi's egna drivare då dessa saknade stöd för 1280x960@75hz som är den perfekta upplösningen på min kassa skärm, även om man ställde in det perfekt så blev det en annan upplösning, bytte drivare och det funkade kalas igen.

Lite OFT kanske ville bara ge min lilla historia till detta problem, sedan har jag märkt att Ubuntu inte verkar hantera skärmars upplösningar och liknande lika bra som Suse med sin enkelhelt åtminstone inte "out-of-the-box" eller hur man ska säga.

i7-3960X, Asus Sabertooth X79, Asus GTX970, Bequiet Silent Loop 120, Corsair Vengence 32GB, Corsair HX650, Samsung 840 EVO 250Gb, Intel 520 120Gb, 1+2 Tb HDD, Dell U2515H

Trädvy Permalänk
Medlem
Registrerad
Apr 2004
Citat:

Ursprungligen inskrivet av PMJ
Lite OFT kanske ville bara ge min lilla historia till detta problem, sedan har jag märkt att Ubuntu inte verkar hantera skärmars upplösningar och liknande lika bra som Suse med sin enkelhelt åtminstone inte "out-of-the-box" eller hur man ska säga.

Jag har samma erfarenhet på min bärbara med 1280x800, fick bara ut 1024x768 i Ubuntu. SUSE identifierade dock skärmen redan i installern och satte upplösningen till 1280x800 utan att jag behövde göra någonting.

Trädvy Permalänk
Medlem
Plats
Nora
Registrerad
Aug 2004

sudo xorgconfig i en terminal :), den är alltid lika trevlig

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Nov 2004

Någon vänlig själ som kan fylla i min xorg.conf på ett korrekt sätt? För jag får det verkligen inte att funka =/ Har försökt ett antal gånger nu men X vägrar bara att starta när jag försöker ändra något.

Antec Sonata Plus 550, Intel Core 2 Duo 8400, Zalman CNPS9700 NT, Evga 750i SLi FTW, 2X GeForce 8800GT SLI, 2X Arctic Cooling Accelero S1, 4X Corsair TWIN2X8500C5D 4096MB, Western Digital 500GB Caviar Black, Vista x64.

Trädvy Permalänk
Medlem
Registrerad
Nov 2001
Citat:

Ursprungligen inskrivet av Tuniz
Någon vänlig själ som kan fylla i min xorg.conf på ett korrekt sätt? För jag får det verkligen inte att funka =/ Har försökt ett antal gånger nu men X vägrar bara att starta när jag försöker ändra något.

Jag har samma problem i Ubuntu. Har ett Geforce 6800 kort!

En gång för alla nu hur gör man för att få större upplösning i Ubuntu? Jag vill ha 1280x1024 60hz

Beskriv hur man gör.

AMD64 4000+, Geforce 6800, 1024 Ram, HP 19" TFT 16ms, 660 Gb HDD

Trädvy Permalänk
Medlem
Plats
Uppland
Registrerad
Jul 2003

Har du ett ATI kort kan kanske detta vara något för dig:
http://wiki.cchtml.com/index.php/Ubuntu_Dapper_Installation_G...

Mvh Dax

Server: HPE Gen8 / UNRaid 6.x.x
Brandvägg: Unifi USG Pro 4
Wifi: Unifi AP x 3

Trädvy Permalänk
Medlem
Registrerad
Nov 2001

Jag har ett Nvidia 6800.
Men var ändrar man upplösningen till större än 1024x768? Blir galen på att ha det så här. Jag vill köra 1280x1024.

AMD64 4000+, Geforce 6800, 1024 Ram, HP 19" TFT 16ms, 660 Gb HDD

Trädvy Permalänk
Medlem
Plats
Uppland
Registrerad
Jul 2003

Installera då Nvidias drivers i Ubuntu. finns guider på ubuntus forum för det

Server: HPE Gen8 / UNRaid 6.x.x
Brandvägg: Unifi USG Pro 4
Wifi: Unifi AP x 3

Trädvy Permalänk
Medlem
Registrerad
Nov 2001
Citat:

Ursprungligen inskrivet av Dax
Installera då Nvidias drivers i Ubuntu. finns guider på ubuntus forum för det

Tror du det hjälper? Vilka ska man välja då?
Vilket Ubuntu forum hittar dessa guider? Dom jag har läst på verkar dom flesta ha problem.

AMD64 4000+, Geforce 6800, 1024 Ram, HP 19" TFT 16ms, 660 Gb HDD