Långsam läs- och skrivhastighet på RAID1-array

Trädvy Permalänk
Medlem
Plats
Värnamo
Registrerad
Maj 2010

Långsam läs- och skrivhastighet på RAID1-array

Köpte två nya lagringsdiskar och då tänkte jag jämföra dem med mina andra. Detta blev resultatet. Jag tycker det verkar väldigt långsamt i jämförelse med de nya. Tror ni något kan vara fel?

2 x Western Digital Caviar Green WD20EADS 32MB 2TB (5400 RPM)

2 x Western Digital RE4-GP WD2002FYPS 64MB 2TB (5400 RPM)

"I wan't to believe"

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2003

Nyare WD GP EADS ska man INTE ha i RAID, hur kan du ha missat det?

Trädvy Permalänk
Medlem
Plats
Värnamo
Registrerad
Maj 2010
Skrivet av jookeer:

Nyare WD GP EADS ska man INTE ha i RAID, hur kan du ha missat det?

Jo jag har hört det men är inte det p.g.a. att de ha spärrat möjligheten att justera TLER? Mina gick att justera TLER på. Eller finns det nånon annan anledning?

"I wan't to believe"

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2003

De senaste, om jag minns rätt, man kunde ändra TLER på va 1 TB för 1-2 år sedan, då fanns inte 2 TB, rätta mig om jag har fel!

Trädvy Permalänk
Hedersmedlem
Plats
QuakeNet
Registrerad
Jul 2001

Har för mig att man kan ändra på alla 2 TB-diskar som producerats före Oktober 2010, om jag inte minns helt galet.

Angående problemet - prestandan ser väldigt kass ut. Vad har du för dator i övrigt, vilken typ av RAID använder du och vilket kontrollerkort? Testat med andra prestandatestprogram, typ HDTach eller HDTune?

SWECLOCKERS.COM :: If Quake was done today :: Serverrum
WS: Asus P9X79 :: Core i7 3820 :: 32 GB RAM :: Samsung 830 256 GB :: 2x Intel 910 400 GB PCIE :: PNY Geforce GTX 970 XLR8 :: Gigabyte Odin GT 800W :: 2x Samsung Syncmaster S27A950D
NAS: SuperMicro X10-SLM-F :: Core i3 4130T :: 24 GB Kingston ECC :: Ri-Vier RVS2-06A 12Bay 2U :: IBM M1015 (IT) :: Mellanox Connect2X SFP+ :: Intel XL710-QDA1 QSFP+ ::

Trädvy Permalänk
Medlem
Plats
Värnamo
Registrerad
Maj 2010

Operativsystem: Windows 7 Ultimate x64
Moderkort: Gigabyte P55M-UD2
Processor: Core i3 530
Nätaggregat: Corsair AX 850
Minne: 8 GB 1600 Mhz

Kör hårdvaru-RAID1 på integrerat Intel P55 Express Chipset, med Intel Rapid Storage Technology.

Min trial har gått ut på HD tune men jag ska testa HDTach och lägga upp resultat. Jag märker ju dock prestandaskillnad vid filöverföring i Windows så det lutar väl inte åt att Crystal Disk mäter fel?

Jag har testat att köra Western Digitals "Data Lifeguard Diagnostic" i DOS, men jag får följande meddelande:
NO DRIVE FOUND
ERROR/STATUS CODE 0120

I detta skede hade jag alla 4 diskar + systemdisken inkopplade.

Detta är surt

Vad tror ni?

"I wan't to believe"

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Jul 2001

Gäller RAID problemet med enklare diskar även mjukvarubaserad raid eller är det endast när man kör hårdvarubaserat?

Numer nästan helt drogfri!

Trädvy Permalänk
Medlem
Plats
Värnamo
Registrerad
Maj 2010
Skrivet av Khamel:

Gäller RAID problemet med enklare diskar även mjukvarubaserad raid eller är det endast när man kör hårdvarubaserat?

Vad menar du med enklare diskar?

Har inte testat något annat än. Skulle vilja stänga av RAIDen och testa diskarna individuellt men måste jag då rensa all data först?

"I wan't to believe"

Trädvy Permalänk
Medlem
Plats
Skellefteå
Registrerad
Jul 2001
Skrivet av Allemannen:

Vad menar du med enklare diskar?

Har inte testat något annat än. Skulle vilja stänga av RAIDen och testa diskarna individuellt men måste jag då rensa all data först?

Billigare diskar utan stöd för RAID från tillverkaren menade jag

Numer nästan helt drogfri!

Trädvy Permalänk
Moderator
Plats
Sverige
Registrerad
Dec 2005

Var köpte du Green och fick EADS? Eller beställde du specifikt EADS? EARS är det som gäller vid köp av lösa diskar och har gjort så länge. EARS är mycket snabbare. EADS har inte tillverkats på snart 1 år vad jag vet.

Är inte diskarna från slaktade externa varianter, är det mycket konstigt.

Synpunkter på min moderering? Hör av dig via PM eller mail.

W7, Intel 5820K, Asus X99-S, Crucial DDR4 2133MHz 32GB, Sapphire 290X Tri-X, Intel 730 SSD, WD Black+Green+HGST, Silverstone FT02, Corsair AX1200, Corsair K90, Logitech MX518, Eizo 2736w, Eaton 5115 UPS. Huawei P10 Plus
* Stolt paragrafryttare *

Trädvy Permalänk
Medlem
Plats
Värnamo
Registrerad
Maj 2010
Skrivet av MultiMan:

Var köpte du Green och fick EADS? Eller beställde du specifikt EADS? EARS är det som gäller vid köp av lösa diskar och har gjort så länge. EARS är mycket snabbare. EADS har inte tillverkats på snart 1 år vad jag vet.

Är inte diskarna från slaktade externa varianter, är det mycket konstigt.

Jag köpte specifikt EADS från Webhallen för nästan 1 år sedan. Köpte dem för att jag hade läst mig till att man kunde justera TLER på dem, och det funkade.

Men detta är konstigt:
Jag kopierade att data från gamla 2xEADS-arrayen till den nya 2xFYPS-arrayen för att stänga av RAID. Efter all data var kopierad körde jag en ny benchmark.

Detta är alltså 2 x Western Digital RE4-GP WD2002FYPS 64MB 2TB (5400 RPM), de som i tidigare test (se början av tråd) hade betydligt högre prestanda. Jag fattar inte, kan datan vara korrupt på något sätt och slöa ner?

Upptäckte en sak, jag har write-back cache enabled på båda arraysen. Är det fel?

Några tips på vidare felsökning?

Tack!

"I wan't to believe"

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2003

Haru aktiverat cachen i RST?

Trädvy Permalänk
Medlem
Plats
Värnamo
Registrerad
Maj 2010
Skrivet av jookeer:

Haru aktiverat cachen i RST?

Japp, i mjukvaruprogrammet

"I wan't to believe"

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2003
Skrivet av Allemannen:

Japp, i mjukvaruprogrammet

RST heter det - inget annat

Trädvy Permalänk
Moderator
Plats
Sverige
Registrerad
Dec 2005

RE4 är ju en enterprisedisk med helt annan optimerad firmware speciellt för att fungera bra med många trådar (QD32 som exempel i testet) och kommer alltid vara bättre än vanliga green i sådana tester, ibland dramatiskt. Att du har nästan oförändrade 4K och 4k QD32, men försämring av större sekventiella överföringar tyder på problem någon annanstans än diskarna tror jag. Kablar, drivrutiner eller kontroller. Dåliga kablar (med omsändning som följd) lär påverka mer desto större block som ska överföras. En hel hög med 4K-block ryms ju i cachen utan vidare.

Spånar endast såhär på morgonen, men någon tanke kanske stämmer ändå.

Synpunkter på min moderering? Hör av dig via PM eller mail.

W7, Intel 5820K, Asus X99-S, Crucial DDR4 2133MHz 32GB, Sapphire 290X Tri-X, Intel 730 SSD, WD Black+Green+HGST, Silverstone FT02, Corsair AX1200, Corsair K90, Logitech MX518, Eizo 2736w, Eaton 5115 UPS. Huawei P10 Plus
* Stolt paragrafryttare *

Trädvy Permalänk
Medlem
Plats
Värnamo
Registrerad
Maj 2010

Ok, jag accepterar att Enterprise-diskarna kommer vara bättre än mina gamla. Men varför sjönk sekventiell läsning från 104,2 till 27,41? Jag har ju inte bytt kablar, drivrutin eller kontrolelr mellan testen.

Jag tycker din spåning låter mycket produktiv

"I wan't to believe"

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2003

Vad säger SMART-testet då?