Köpte SSD-disk dock stödjer inte mitt moderkort AHCI, lösning?

Trädvy Permalänk
Medlem
Plats
Lenhovda
Registrerad
Aug 2004

Köpte SSD-disk dock stödjer inte mitt moderkort AHCI, lösning?

Hejsan!
Sitter och brainstormar en lösning för min dator och jag provar väl här med för att se om någon vet en duglig lösning på mitt problem.
Min dator, som har några år på nacken, fick en OCZ Vertex 2 60GB HDD och tydligen är det att rekommendera att köra disken i AHCI läge för att få tillgång till TRIM samt bättre prestanda.
Problemet är att moderkortet, som är ett AM2+ (Asus M2N-SLI Deluxe) med nVidia 570 chip inte har AHCI på sina 6 sataportar. så då undrar jag vad jag ska göra som inte kräver att jag köper nya delar osv.

Hjälp och tipps uppskattas!

Just nu sitter det en AMD Phenom X4 9500 Quad samt 4GB DDR2 minnen på den och tänkte slänga in W7 x64 på SSD-disken men måste få bukt med AHCI problemet.

MVH

-=[ Asus M2N-SLI Deluxe ] - [ AMD x2 4200+ 65w ] - [ 4x1GB Kingston DDR2-667 ] - [ AMCC 3ware Escalade 8506-8 PCI-X ] - [ ~8 TiB HD ] - [ ATI Radeon HD 2600XT ]=-

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2010

Kör i IDE-läge och dra trim manuellt några gånger i månaden?

“Always be wary of any helpful item that weighs less than its operating manual.”
― Terry Pratchett, Jingo

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2008

Förmodligen kommer jag få internet-stryk av andra medlemmar för att jag säger detta, men kör själv med en 320 Intel SSD 120 GB och jag glömde ordna AHCI innan installationen, dock är datorn rapp som attan ändå, vad jag har sett är det ändå prestandasiffrorna som drar mest nytta av AHCI än vad din användarupplevelse gör. Med andra ord, skit i AHCI, installera Windoze och njut av att det går med blixtens fart att öppna program och ladda spel.

Kan tillägga att jag körde både med och utan AHCI med min förra SSD, Crucial M225 64 GB och jag märkte ingen skillnad, men det gjorde mina benchmarkprogram.

Trädvy Permalänk
Medlem
Registrerad
Dec 2008

Kolla om du kan köra raid-läge. Brukar vara ahci då.

Trädvy Permalänk
Medlem
Plats
Lenhovda
Registrerad
Aug 2004

Tack för alla svar!
Har provat med raidläge men det hjälper inte, tydligen stödjer inte nvidias chipset (dom gammla iaf) AHCI.
Dock kom jag över denna information :

Citat:

Just to put in here for nForce users, nForce boards do not support AHCI (with the exception of nForce boards that include onboard graphic cards), and also don't send the TRIM command for SSDs. It can do NCQ through its controller though. The JMicron SATA ports do support AHCI, but you'd get worse performance running a HDD through these, than on the normal SATA ports.

You can uninstall the Nvidia controller though in Device Manager and install Microsoft's IDE Controller, which can send TRIM commands for SSDs.

Head to Device Manager (Open Start menu, type Device Manager), and click "IDE ATA/ATAPI Controllers", and you will see 3 Nvidia Serial ATA Controllers. Right click one of them and click "Properties" and go to the "Driver" tab. Click "Update Driver". Click "Browse my Computer", and then "Let me pick". You will see the option to choose "Standard Dual Channel PCI IDE Controller". Click this and click "Next" and let it install.

Do the same for the other two Nvidia Controllers in Device Manager and restart your system. After the controllers have installed, you will be asked to reboot again.

SSDs will now have a slight performance boost with the TRIM command, and also regular HDDs also have a slight increase as well.

http://www.sevenforums.com/tutorials/61869-ahci-enable-window...

Får väl köra på IDE läge och fixa enligt den guiden, låter det bra?

MVH

-=[ Asus M2N-SLI Deluxe ] - [ AMD x2 4200+ 65w ] - [ 4x1GB Kingston DDR2-667 ] - [ AMCC 3ware Escalade 8506-8 PCI-X ] - [ ~8 TiB HD ] - [ ATI Radeon HD 2600XT ]=-

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2010

Jupp jupp - skillnaden mellan AHCI och IDE-lägena har jag iallafall inte märkt. Installerade Win7 på min SSD så fort jag fått den utan att läsa på - det blev ju IDE-läge då. Satt med det några månader innan jag iddes installera om och int faen har jag märkt nån större skillnad.

“Always be wary of any helpful item that weighs less than its operating manual.”
― Terry Pratchett, Jingo

Trädvy Permalänk
Medlem
Plats
Lenhovda
Registrerad
Aug 2004
Skrivet av Juggernawt:

Kör i IDE-läge och dra trim manuellt några gånger i månaden?

Har du lust att berätta hur man drar trim manuellt för mig?

-=[ Asus M2N-SLI Deluxe ] - [ AMD x2 4200+ 65w ] - [ 4x1GB Kingston DDR2-667 ] - [ AMCC 3ware Escalade 8506-8 PCI-X ] - [ ~8 TiB HD ] - [ ATI Radeon HD 2600XT ]=-

Trädvy Permalänk
Medlem
Plats
Lenhovda
Registrerad
Aug 2004

Någon som vet om HDD SMART Monitoring ska vara Enabled eller Distabled i BIOS, jag vet ju vad det gör med datorn, men tänkte mer på om det "krockar" med SSD'n på något sätt? Är inte så "uppdaterad" inom SSD världen

-=[ Asus M2N-SLI Deluxe ] - [ AMD x2 4200+ 65w ] - [ 4x1GB Kingston DDR2-667 ] - [ AMCC 3ware Escalade 8506-8 PCI-X ] - [ ~8 TiB HD ] - [ ATI Radeon HD 2600XT ]=-

Trädvy Permalänk
Medlem
Registrerad
Aug 2005
Skrivet av radimax:

Hejsan!
Sitter och brainstormar en lösning för min dator och jag provar väl här med för att se om någon vet en duglig lösning på mitt problem.
Min dator, som har några år på nacken, fick en OCZ Vertex 2 60GB HDD och tydligen är det att rekommendera att köra disken i AHCI läge för att få tillgång till TRIM samt bättre prestanda.
Problemet är att moderkortet, som är ett AM2+ (Asus M2N-SLI Deluxe) med nVidia 570 chip inte har AHCI på sina 6 sataportar. så då undrar jag vad jag ska göra som inte kräver att jag köper nya delar osv.

Hjälp och tipps uppskattas!

Just nu sitter det en AMD Phenom X4 9500 Quad samt 4GB DDR2 minnen på den och tänkte slänga in W7 x64 på SSD-disken men måste få bukt med AHCI problemet.

MVH

En vertex 2 kommer att klara sig bra även utan trim, sandforce-diskar har bra intern garbage collection. Sitter själv med en agility 2 60gb med windows xp och har inte märkt av någon degradering av prestandan (varken upplevd eller mätbar) trots ca 850gb skrivna till disken.

Skrivet av radimax:

Någon som vet om HDD SMART Monitoring ska vara Enabled eller Distabled i BIOS, jag vet ju vad det gör med datorn, men tänkte mer på om det "krockar" med SSD'n på något sätt? Är inte så "uppdaterad" inom SSD världen

Pröva med det på, får du felmeddelande vid starten så är det bara att stänga av.

En ssd som baseras på en kontroller från sandforce komprimerar data för ökad prestanda/livslängd. AS-SSD använder data som inte går att komprimera och ger då sämsta möjliga resultat, ATTO använder data som är lätt att komprimera och ger bästa möjliga resultat. Eftersom program/os/spel ofta går att komprimera någorlunda bra så hamnar den verkliga prestandan någonstans mellan dessa resultat vid normal användning.