XBMC hittar inte vissa film-filer

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Okt 2008

XBMC hittar inte vissa film-filer

Tja

Har ett hyffsat irriterande problem. Det är så att xbmc inte hittar en del filmer fast dom kommer från samma mapp som andra filmer som hittas gör. Måste man döpa filerna till nåt speciellt eller? Tycker jag har döpt alla efter samma system.

Kan hitta film-filerna om jag väljer files i video-fliken men dom kommer inte upp i movieläget med snygg presentation, sammanfattning, fanart etc.

Nån som vet vad problemet är??

/Johan

Chassi: Antec 1200 MoBo: Asus P6T Deluxe CPU: i7 920 @3,6 GHz GPU: Gigabyte gtx 580 OC @855 MHz
RAM: Corsair Vengeance 12 GB PSU: Corsair 750 W SSD: Plextor M3 Pro 120 GB Ljudkort: Creative Fatality Game

Trädvy Permalänk
Medlem
Plats
Trelleborgen
Registrerad
Jul 2001

Inte så att du satt XBMC till att stacka filer med liknande namn?

http://wiki.xbmc.org/index.php?title=File_Stacking

//Gelantious
I heard life sucks, that''s why I''m glad I don''t have one.

Trädvy Permalänk
Medlem
Plats
\\Localhost
Registrerad
Mar 2006

har också märkt att den inte hittar vissa titlar automatiskt och lägger till i fim listan

jag löste det genom att om den inte dyker upp att ersätta alla mellanrum med punkter "..."

t.ex
min.film.720p.2010

istället för

min film 720p 2010

och sen starta om en gång så att biblioteket updateras

Asus Z97-A, I7 4790K @4.8GHz 1.29V, 24Gb ram, 2x GIGABYTE GTX 970 WindForce 3X OC @ 1511Mhz/7246Mhz.

Trädvy Permalänk
Medlem
Plats
Gagnef
Registrerad
Jul 2011
Skrivet av Oetzi:

Tja

Har ett hyffsat irriterande problem. Det är så att xbmc inte hittar en del filmer fast dom kommer från samma mapp som andra filmer som hittas gör. Måste man döpa filerna till nåt speciellt eller? Tycker jag har döpt alla efter samma system.

Kan hitta film-filerna om jag väljer files i video-fliken men dom kommer inte upp i movieläget med snygg presentation, sammanfattning, fanart etc.

Nån som vet vad problemet är??

/Johan

Min gissning är att XBMC inte "automatiskt" kan identifiera filmfilerna. D.v.s av nån anledning så kan de inte läsa ut namnat på filmerna korrekt. Du har 2 alternativ. Endera går du in och manuellt ändrar (tryck "I" när du har filmen markerad har jag för mig) eller så döper du om dem till ett sånt format att XBMC klarar av att namnge dem.

Personligen gillar jag inte "movie" läget eftersom den inte är särksilt bra på att identifiera avsnitt i serier korrekt men om du bara har filmer borde det vara aningens lättare.

Jag har istället gjort så att varje mapp heter exakt som filmen/serien. Då klarar XBMC nästan jämt att göra en identifiering. Jag struntar sen i att göra en korrekt sökning på själva filmfilen utan den visar jag som en lista. Presentationen blir snygg med framsidor på filmer/serier men man väljer själva filen i "file" mode.

Hoppas jag lyckats förklara litegranna iaf

I7930@3.90 | RX480 | Intel 320 - 160 GB | 12 GB RAM | X58A-UDR3 (rev 1.0) | 650 WATT POWER

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Okt 2008

Tack för svar, får testa lite. Troligtvis återkommer jag pga. att jag har provat bytt namn på en film till lite olika men problemet kvarstår.

Har bl.a. bara döpt den till 28.weeks.later.CD01 och CD02. Dom ligger i mappen med liknande namn men den hittas ändå inte.

Är kanske trött eller bara trög men vad menas med att stacka filerna, fatta inte riktigt det som stod i länken

Mvh
/Johan

Chassi: Antec 1200 MoBo: Asus P6T Deluxe CPU: i7 920 @3,6 GHz GPU: Gigabyte gtx 580 OC @855 MHz
RAM: Corsair Vengeance 12 GB PSU: Corsair 750 W SSD: Plextor M3 Pro 120 GB Ljudkort: Creative Fatality Game

Trädvy Permalänk
Medlem
Plats
Gagnef
Registrerad
Jul 2011
Skrivet av Oetzi:

Tack för svar, får testa lite. Troligtvis återkommer jag pga. att jag har provat bytt namn på en film till lite olika men problemet kvarstår.

Har bl.a. bara döpt den till 28.weeks.later.CD01 och CD02. Dom ligger i mappen med liknande namn men den hittas ändå inte.

Är kanske trött eller bara trög men vad menas med att stacka filerna, fatta inte riktigt det som stod i länken

Mvh
/Johan

Personligen hade jag döpt mappen till "28 weeks later" och räknat med att det funkat.

*går iväg till HTPCn och skapar en map och kör en scrappern*
.
.
.
Jajamän. En mapp med det namnet och en fil med samma namn hittar den perfekt. Men jag kan nästan garantera att med 2 CD's så är det inte korrekt namngivning. Filnamnet får inte vara nåt annat än själva filmnamnet.

I7930@3.90 | RX480 | Intel 320 - 160 GB | 12 GB RAM | X58A-UDR3 (rev 1.0) | 650 WATT POWER

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Okt 2008
Skrivet av FX9:

Personligen hade jag döpt mappen till "28 weeks later" och räknat med att det funkat.

*går iväg till HTPCn och skapar en map och kör en scrappern*
.
.
.
Jajamän. En mapp med det namnet och en fil med samma namn hittar den perfekt. Men jag kan nästan garantera att med 2 CD's så är det inte korrekt namngivning. Filnamnet får inte vara nåt annat än själva filmnamnet.

Menar du att man måste fixa om alla filmer som är 2 filer till 1? Jag har fått en del filmer att funka när jag använt skrivsättet med punkter mellan + CD01 och
CD02 (bl.a. 28 weeks later funkar då)

Har för mig The dark knight skrivet på samma sätt strular t.ex. men har inte hunnit kolla så mycket mer, hatar tenta-tider...

/Johan

Chassi: Antec 1200 MoBo: Asus P6T Deluxe CPU: i7 920 @3,6 GHz GPU: Gigabyte gtx 580 OC @855 MHz
RAM: Corsair Vengeance 12 GB PSU: Corsair 750 W SSD: Plextor M3 Pro 120 GB Ljudkort: Creative Fatality Game

Trädvy Permalänk
Medlem
Plats
Gagnef
Registrerad
Jul 2011
Skrivet av Oetzi:

Menar du att man måste fixa om alla filmer som är 2 filer till 1? Jag har fått en del filmer att funka när jag använt skrivsättet med punkter mellan + CD01 och
CD02 (bl.a. 28 weeks later funkar då)

Har för mig The dark knight skrivet på samma sätt strular t.ex. men har inte hunnit kolla så mycket mer, hatar tenta-tider...

/Johan

Om du vill att filmerna ska fungera i "biblioteksläge", så ja. Vad jag förstått så går det inte att få filmerna korrekt inlästa i biblioteksläge om de inte har väldigt strikt namngivning. Det är en anledning till att jag inte använder det läget. Istället har jag en katalog per film och då hittar den katalogerna bra, så får man gå in i varje katalog och välja den fil man ska spela upp. Det går att få framsida om filmen men inte fullt samma funktionalitet som med bibliotek.

EDIT: om du vill dubbelkolla vad som funkar i en scrapper så gå in på imdb och kolla hur namnet på filmen stavas där. Kan ibland vara små variationer från fall till fall (detta är nästan ett måste på anime via anidb.net, med alla konstiga japanska stavningar)

I7930@3.90 | RX480 | Intel 320 - 160 GB | 12 GB RAM | X58A-UDR3 (rev 1.0) | 650 WATT POWER

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Okt 2008
Skrivet av FX9:

Om du vill att filmerna ska fungera i "biblioteksläge", så ja. Vad jag förstått så går det inte att få filmerna korrekt inlästa i biblioteksläge om de inte har väldigt strikt namngivning. Det är en anledning till att jag inte använder det läget. Istället har jag en katalog per film och då hittar den katalogerna bra, så får man gå in i varje katalog och välja den fil man ska spela upp. Det går att få framsida om filmen men inte fullt samma funktionalitet som med bibliotek.

EDIT: om du vill dubbelkolla vad som funkar i en scrapper så gå in på imdb och kolla hur namnet på filmen stavas där. Kan ibland vara små variationer från fall till fall (detta är nästan ett måste på anime via anidb.net, med alla konstiga japanska stavningar)

Ok tack Ska se om jag kanske får till det genom att döpa filmerna till enbart namnet utan punkter imellan och sen ha cd01/cd02 efter. Verkar funka på många filmer nu när jag provat så blir väl att sätta sig och döpa om alla

/Johan

Chassi: Antec 1200 MoBo: Asus P6T Deluxe CPU: i7 920 @3,6 GHz GPU: Gigabyte gtx 580 OC @855 MHz
RAM: Corsair Vengeance 12 GB PSU: Corsair 750 W SSD: Plextor M3 Pro 120 GB Ljudkort: Creative Fatality Game