porten redan använd.

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

porten redan använd.

har använt min minecraft server via hamachi länge nu, men ville testa om jag kunde göra så att andra kunda connecta via min externa ip.

på min router har jag satt portforward på 25565, min server är satt på min externa ip. jag menar, vad mer behövs?

den säger det här: failed to bind port! perhaps a server is already running on that port?

hur kollar jag ens detta?

tacksam för svar (:

(dick har vi någon skit router innan våran bra router, ip tv och skit, så ska testa att bara köra via den bra routern senare)

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Sep 2009

Netstat?

+ vilka routerar har du egentligen?

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2008

Ja, om du har ställt in routern rätt så lär problemet orsakas av den "dåliga" routern.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Dec 2011

Du ska portforwarda på din interna ip som du joinar på och slla andra joinar på din externa.

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

http://www.inet.se/produkt/5401809/netgear-wireless-n-wndr450...

det är den bra routern.

den dåliga vet jag inte vad den heter, och det värsta e att du inte ens kan ställa in saker på den via webläsaren.
kommer som sagt testa utan den dåliga och hoppas på det bästa.

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

så har testat nu, fick samma problem.

testade med båda minecraft.exe servern och min bukkit.

men går det att kolla om porten avnänds på något sätt?

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Registrerad
Dec 2011

Du har inte redan en server igång då?

Dator: OCZ Agility 3 60GB || Intel i7 3770k 4gHz || ASRock Z77 Extreme4 || 12GB Vengeance Ram
6 TB Hdd || Gigabyte 780 windforce || Corsair Carbide 500R|| Fatal1ty 500W PSU 80+ ||
Kamera: Sony Alpha A33

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Sep 2009
Skrivet av wiloh:

så har testat nu, fick samma problem.

testade med båda minecraft.exe servern och min bukkit.

men går det att kolla om porten avnänds på något sätt?

Skriv netstat -ano i cmd och leta upp din port och posta sedan vad som står där. Om du har linux eller liknande(mac?) så borde du kunna lägga till "grep 25565" så här: netstat -an | grep 80.
så slipper du leta en massa.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Aug 2011

I inställningarna i routern skrev forwardade du väl till 192.168.X.X?

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

nej jag har inte en annan server igång.

och kunde inte hitta 25565 via netstat -an ;/

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

@snacker: japp, jag kan välja min egen dator i en lista till och med ``wiloh-dator 192.168.1.2``

så det har jag inte tagit fel på.

problemet verkar ju vara att något annat använder porten. värt att kolla igenom processer efter en server kanske. dock har jag fått samma fel meddelande förut.

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2010

Jag hade samma problem för ett tag sedan och om jag minns rätt så löste jag det genom att lämna ip adressen i properties filen blank och portforwarda. Det va ett tag sedan så jag kan komma ihåg fel.

CPU: Ryzen 5 16000 Moderkort: ASUS PRIME B350-PLUS Grafikkort: Gigabyte GeForce GTX 1060 Ram: 16GB PSU: Corsair HX750W Chassi: Fractal Design Define C

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

hahaha tackar helmius, det verkar ha löst skiten XD

lite kul att jag gjorde fel genom att skriva in rätt^^

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

om någon har tid kan dom testa komma in.

81.170.246.173:25565

skrev fel ;P

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Sep 2009

I fall du vill veta, fungerar inte att joina. Kan dock få svar om jag pingar din adress utan port nummer. Så det känns som att du fortfarande inte fått portarna rätt ännu. Kan du göra print screen på din konfiguration?

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

81.170.246.173:25565 råkade skriva fel första gången så kontroll testa ni också XD

vill du ha en screenshot över min server.properties fil eller vad?

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Sep 2009

Nej, tänkte mer på där du har ställt in dina port inställningar för routern.

Trädvy Permalänk
Medlem
Plats
Sandviken
Registrerad
Aug 2010

I server properties ska du INTE ändra ip. Där ska ip't vara blankt. Alltså:

server-ip=

Sen när du öppnar portar så ska dom peka på din interna IP, dvs. Din 192.168.x.x adress!

Sen ansluter dina kompisar via din externa ip + port. Exempel:

83.253.425.142:25565

Det fetmarkerade är porten.

"Music expresses that which cannot be said and on which it is impossible to be silent." - Victor Hugo
- Beyerdynamic DT770, Pro-Ject Head Box II, Asus Xonar DX -

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

lol nämn en sida som imageshack.org fast utan att man måste bli medlem -.-

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Sep 2009

Fan, det såg ju änna ut som det skulle göra hehe. Men i fältet Service type: TCP/UDP. Finns det något alternativ som tex bara "auto"? Samt du kan ju testa att ställa in portarna så här: 25560-25570. Så att den öppnar i ett intervall typ. En sådan här lösning ska ju aldrig behövas men alltför ofta tycker jag routernas konfigurations sidor är knäppa som tusan^^

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

nä, fanns bara TCP/UDP och TCP, UDP så vet fan inte.

satte dock start och ending mellan 60-70 så det ska ju fungera nu.

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Plats
östersund
Registrerad
Sep 2010

har nog hittat svaaret. den hade inte uppdaterat min IP hade en annan typ. testa gå in på denna:

81.170.205.74

EDIT: måste man altså skaffa sig statiskt IP adress?

chassi: cooler master stryker.RAM: 16GB.CPU: i7 2600knätagg: corsair AX750W.GPU: R) 390X. HDD:4TB + 120GB SSD

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av wiloh:

har använt min minecraft server via hamachi länge nu, men ville testa om jag kunde göra så att andra kunda connecta via min externa ip.

på min router har jag satt portforward på 25565, min server är satt på min externa ip. jag menar, vad mer behövs?

den säger det här: failed to bind port! perhaps a server is already running on that port?

hur kollar jag ens detta?

tacksam för svar (:

(dick har vi någon skit router innan våran bra router, ip tv och skit, så ska testa att bara köra via den bra routern senare)

så där får jag också när jag testar att ta bort hamachi.. och jag har testat att avaktivera hela hamachi på nätverks inställningar och sen starta om datorn men det funkar inte då heller ..

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

Har haft samma problem, bara att min router ligger bakom en annan.

Har inget intresse för nätverk så jag har aldrig lärt mig om det, får väll ta ett ryck i helgen.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av Cubebenq:

Har haft samma problem, bara att min router ligger bakom en annan.

Har inget intresse för nätverk så jag har aldrig lärt mig om det, får väll ta ett ryck i helgen.

aa men har du först en router och sen en till i kopplad i den?
isåfall äre väll bara att öppna portar i båda ? eller är det inte så enkelt;)
//noordan

Trädvy Permalänk
Medlem
Registrerad
Jun 2011

Vet faktiskt inte, försökte fixa problemet med DMZ men det fungerade inte.

Får väll pröva som du sa

Trädvy Permalänk
Medlem
Registrerad
Nov 2011
Skrivet av Cubebenq:

Vet faktiskt inte, försökte fixa problemet med DMZ men det fungerade inte.

Får väll pröva som du sa

okej , ja det är bara att prova sig fram

vad är DMZ?

Trädvy Permalänk
Medlem
Registrerad
Jun 2011
Skrivet av noordan:

okej , ja det är bara att prova sig fram

vad är DMZ?

Ja visst är där!

Ska jag vara ärlig vet jag heller inte vad DMZ är, det verkar dock inte vara så rekommenderat att ha på enligt routern.

Trädvy Permalänk
Medlem
Plats
Sandviken
Registrerad
Aug 2010
Skrivet av Cubebenq:

Ja visst är där!

Ska jag vara ärlig vet jag heller inte vad DMZ är, det verkar dock inte vara så rekommenderat att ha på enligt routern.

DMZ innebär ungefär att alla portar öppnas till den IP man skriver in, detta är ett lite enklare sätt att öppna portar då man bara behöver skriva in sin IP så får man alla portar helt öppna. Brukar göra så ibland när jag hostar minecraft till mina kompisar, dock innebär detta sämre säkerhet!

"Music expresses that which cannot be said and on which it is impossible to be silent." - Victor Hugo
- Beyerdynamic DT770, Pro-Ject Head Box II, Asus Xonar DX -