Total War: Shogun 2 Krashar vid loading screen. [HJÄLP MIG!]

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011

Total War: Shogun 2 Krashar vid loading screen. [HJÄLP MIG!]

Tjena!
Spelet bara krashar på loading screen. Det kommer upp en windows ruta där det står "Total War Shogun 2 har slutat att fungera" alltså ingen varning, ingen info, ingenting den bara kraschar. Jag har testat allt. Jag har testat att Verifiera Integritets Cachen. Funkade inte, testat att sänka ljudkvaliten. Testat att ta bort konfig filen. Testat att byta språk. Testat att installera om alla Redists (DirectX osv) testat att starta Steam i administratörs privilegier. Testat allt det funkar inte snälla hjälp mig!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011

Kan det ha med de senaste drivrutiner från Nvidia att göra?

Trädvy Permalänk
Medlem
Plats
regnvm Helsingia regio
Registrerad
Dec 2009
Skrivet av LinusNeuman:

Kan det ha med de senaste drivrutiner från Nvidia att göra?

Mycket möjligt. Mitt shogun 2 krashade efter 15 mins lirande med atis 12.1 drivrutin så nog kan dåliga drivrutiner ge de problem du upplever.

Laptop: ASUS-G751JY

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Zeuxlarsson:

Mycket möjligt. Mitt shogun 2 krashade efter 15 mins lirande med atis 12.1 drivrutin så nog kan dåliga drivrutiner ge de problem du upplever.

Ska testa att backa upp till nån gammal drivrutin, finns så många att välja mellan :/
EDIT: Funkar fortfarande inte.
Håller just nu på med en ren om installation. Rensade datorn från allting som hade med Total War att göra!
Dock så är ju inte Steam direkt min största anledning till att jag har 100Mb... Förfan den laddar ner i 500Kb
EDIT: Installerat om och 4 timmars väntan var åt trollskogen. Funkar fortfarande inte. Jag har rensat absolut allting från datorn som har med Total War och göra och det funkar inte nu heller, det måste ha med nån drivrutin o göra. Jag ska installera nån äldre grafikkortsdrivrutin o se sen.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011

Nej, det funkar fortfarande inte.

  • Har testat att installera om.

  • Har testat att starta steam och shogun2 med admin privilegier.

  • Har testat att installera om ALLA drivrutiner på datorn.

  • Har testat att installera äldre Nvidia Drivrutiner ändå tillbaks till 270.61.

  • Har testat att göra nån sorts registry cleaner som fixar till alla register som kan gå helt åt trollskogen ifall spelet kraschar nångång utan att stänga av spelet som man ska.

  • Har testat att ta bort konfig filen.

  • Har testat att starta spelet i DirectX 9 mode.

  • Har testat att ta bort några mappar som ligger i Steam/userdata som tydligen skulle hjälpa.

Alltså, det har funkat innan, av nån bisarr anledning så har det slutat att funka.

Trädvy Permalänk
Medlem
Plats
regnvm Helsingia regio
Registrerad
Dec 2009

Det enda som kvarstår är hårdvarufel men detta är också tveksamt om du inte upplever liknande problem i andra spel.

Laptop: ASUS-G751JY

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2009

Har du använt mod? Ta bort alla referenser i filer till gamla moddar (även de som ligger under C:\användare\användare\appdata\roaming\the creative assembly och alla under mappar).

Sedan testa med att använda Steambeta (alltså själva steam-klienten, inte spelet, det går att välja i steam under arkiv/inställningar/delta i beta välj steam beta update) det hjälpte mig (och några till) i Napoleon när det strula för någon månad sen.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Josuroli:

Har du använt mod? Ta bort alla referenser i filer till gamla moddar (även de som ligger under C:\användare\användare\appdata\roaming\the creative assembly och alla under mappar).

Sedan testa med att använda Steambeta (alltså själva steam-klienten, inte spelet, det går att välja i steam under arkiv/inställningar/delta i beta välj steam beta update) det hjälpte mig (och några till) i Napoleon när det strula för någon månad sen.

Aha, nej jag har inte kört med mods, och har testat att rensa den mappen, ska göra den där steam beta grejen Man får inte hoppas för mycket, men man kan ju alltid hålla tummarna. Fattar inte att det helt random slutar funka :S
EDIT: Funkar inte. Skriver till Steam Supporten.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Zeuxlarsson:

Det enda som kvarstår är hårdvarufel men detta är också tveksamt om du inte upplever liknande problem i andra spel.

Ne, detta är det enda spelet, och det är helt random att det slutat funka, har ju testat att köra med gamla drivisar, många säger också att de uppdaterat bios så har det funkat, men jag har redan senaste. Ska skriva till steam support ifall det som han den där andra skrev inte funkar.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
regnvm Helsingia regio
Registrerad
Dec 2009

Vad jag förstår så är ditt kort ett titanum, dessa är kända för att ha problem. Jag tror på hårdvarufel.

Laptop: ASUS-G751JY

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Zeuxlarsson:

Vad jag förstår så är ditt kort ett titanum, dessa är kända för att ha problem. Jag tror på hårdvarufel.

Ajajaj! Hoppas jag inte, men samtidigt så skulle det förklara en hel del.
Jag skaffade mitt kort nån vecka efter att det fanns o köpa, så det kanske är så att dom tillverkade med nån trasig del på den tiden o det funkar nu osv, vem vet, men jag har alltså haft det i nästan ett år, inte överklockat. Och det är ju Military Class och vad dom (dom=Msi) nu skryter över som säger att det ska klara flera år extra. Detta är som sagt det enda spel som min dator inte vill samarbeta med om man ska uttrycka sig så. Jag upplever inga som helst problem med nåt annat, någonsin. Förutom en sak faktiskt, när jag först byggde ihop min nya dator, så skulle jag kolla om det va så bra som alla sa att det va. Det var det inte alls, jag blev så jävla arg, jag hade för första gången i mitt liv byggt en dator, och köpt ett kort som fått jätte bra kritik, men sen så kan man inte spela Mafia 2 på low på en 1024x720 skärm. Dock efteråt visade det sig att det hade med mina drivrutiner och göra, så det var väl bara ett missförstånd. Dock så kan det säkert vara så att mitt kort inte stödjer Shogun 2 så bra som jag skulle vilja, men då skulle det ju inte funka förut? Jag har spelat Shogun 2 i ett år nästan, och nu så helt random skulle man spela så funkar det inte. Jag har sett folk på Total War forumet som fortfarande inte kan spela spelet, och dom har inte gjort nånting, dom har tilloch med ominstallerat Windows utan att det funkar.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Mar 2009

Hittade detta om du inte prövat: http://shoguntotalwar.yuku.com/topic/69653/Finding-the-script... (fast med Shogun 2 foldern)

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Josuroli:

Hittade detta om du inte prövat: http://shoguntotalwar.yuku.com/topic/69653/Finding-the-script... (fast med Shogun 2 foldern)

Skall jag ta bort hela mappen? För jag har tagit bort konfig filen innan, tänkte om mappen funkar.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011

Skrev såhär till Supporten (SEGA hänvisade mig till support.se@panvision.com)
Hej!
Jag har spelat Total War: Shogun 2 sedan det släpptes. Men igår när jag skulle starta spelet så kom jag bara till loading screen där det är en gul bakgrund i mitten av skärmen sen så står det Shogun 2 copyright med mera.
När jag ska starta spelet så står det om jag vill spela i DirectX11 eller 9, testat båda, funkar inte något av dom. Detta är väldigt konstigt då det funkat varje dag sedan release men just igår och idag så har det slutat funka.
Har testat att installera om.
Har testat att starta steam och shogun2 med admin privilegier.
Har testat att installera om ALLA drivrutiner på datorn.
Har testat att installera äldre Nvidia Drivrutiner ändå tillbaks till 270.61 som kom för nåt år sen.
Har testat att göra nån sorts registry cleaner som fixar till alla register som kan gå helt åt trollskogen ifall spelet kraschar nångång utan att stänga av spelet som man ska.
Har testat att ta bort konfig filen.
Har testat att starta spelet i DirectX 9 mode.
Har testat att ta bort några mappar som ligger i Steam/userdata som tydligen skulle hjälpa.
Har testat att starta i lägsta ljudkvalitet som går, och om installerat dom drivrutinerna och ALLA drivrutiner.
Har testat att starta Steam i "Steam Beta" som man kan välja i Steam settings -> Beta participating.
Har testat att rensa datorn som ens nämner Total War och gjort en total ominstallation. (även de som ligger under C:\användare\användare\appdata\roaming\the creative assembly och alla under mappar).
Jag har aldrig kört med några mods. Jag har bara ett DLC och det är "Blood Pack"
Jag har senaste BIOS på mitt moderkort från MSI (870A-G54)
Har av avktiverat Nvidia 3D vision.
Har av aktiverat 120Hz på datorn.
Har kollat så att Steam och Shogun2 inte blockeras av brandväggen
Har testat att avinstallera mitt virusprogram och kollat om det funka.
Alltså, det har funkat innan, av nån bisarr anledning så har det slutat att funka.
Min dator är inte överklockad nånstans. Så det borde funka. Jag har kompisar som ominstallerat Windows och det har fortfarande inte funkat för dom, det betyder att det är ett hårdvaru fel för dom, men då hade väl spelet aldrig funkat? Vi har ju spelat förut sen release och helt plötsligt så slutade det funka.
Min dator:
GPU: N560GTX-TI-TwinFrozrII-OC-1Gb
CPU: Phenom II X4 965 BE 125W
PSU: Corsair CX600W
RAM: Corsair Vengeance 1600Mhz 4Gbx2 DDR3
Moderkort: 870A-G54
Chassi: Xigmatek Asgard
OS: Win7 64
Internet Anslutning: 100Mb/s
Skärm: 23"AsusVG236 3D
Accesoarer:
Nvidia 3D Vision
Mionix Naos 3200 (Mus)
Jag vill inte ha tillbaka några pengar, jag vill bara kunna spela mitt spel. Snälla, gör ert bästa med att försöka fixa detta problem, om ni till och med behöver fråga de som gjort spelet så gör det, jag vill spela!

Trädvy Permalänk
Medlem
Plats
regnvm Helsingia regio
Registrerad
Dec 2009

Som sagt tidigare. 560-titanium-korten är kända för att ha problem och ofta inte fungera alls. Du har ett felande grafikkort.

Laptop: ASUS-G751JY

Trädvy Permalänk
Medlem
Plats
Halland
Registrerad
Sep 2007

How to Resolve Freeze and Crash on Menu – Loading Screen
Comment by Christopher. Hi guys, i have got a mail from steam explaining exactly what to do. Just follow these steps and you fix the freeze issue in the first loading screen. (Samers problem)

Please exit Steam and go to the folder called C:\Program Files\Steam\ (this is the default location for a Steam installation – if you set a different installation directory, you will need to browse to it). Delete all of the files in this folder except: The \Steamapps\ folder and Steam.exe (this file is listed as an application and features the black and white Steam logo) Restart your computer. Then, launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut. With Steam running, re-test the original issue.

Intel i5 3570k @ 4.5 GHz || Asrock Z77 Performance || Dark Rock Pro 2 || 1080ti || Dark Power Pro 10 || Acer Predator Z35P

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Ninotramp:

How to Resolve Freeze and Crash on Menu – Loading Screen
Comment by Christopher. Hi guys, i have got a mail from steam explaining exactly what to do. Just follow these steps and you fix the freeze issue in the first loading screen. (Samers problem)

Please exit Steam and go to the folder called C:\Program Files\Steam\ (this is the default location for a Steam installation – if you set a different installation directory, you will need to browse to it). Delete all of the files in this folder except: The \Steamapps\ folder and Steam.exe (this file is listed as an application and features the black and white Steam logo) Restart your computer. Then, launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut. With Steam running, re-test the original issue.

Will test!
EDIT: Didn't work./Funkade inte.
Det kanske är ett felande kort isåfall, men varför funkar det i alla andra spel? Vad ska jag göra nu? Ska jag vänta på att supporten svarar, se o testa det dom föreslår, och ifall det inte funkar, ska jag säga att det kanske är ett felande kort? Ska jag gå in på nån sorts hemsida och säga till Msi att mitt kort är ett måndags exemplar? Jag är ganska säker på att jag kan fråga efter ett nytt exemplar fårn Komplett?
Men som sista försök innan att göra nåt åt mitt måndagsexemplar om det nu är det. Ska jag uppdatera bios i kortet? Alla säger att dom gjort det så har det funkat. Hur gör jag det?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Zeuxlarsson:

Som sagt tidigare. 560-titanium-korten är kända för att ha problem och ofta inte fungera alls. Du har ett felande grafikkort.

EDIT: Det kanske är ett felande kort isåfall, men varför funkar det i alla andra spel? Vad ska jag göra nu? Ska jag vänta på att supporten svarar, se o testa det dom föreslår, och ifall det inte funkar, ska jag säga att det kanske är ett felande kort? Ska jag gå in på nån sorts hemsida och säga till Msi att mitt kort är ett måndags exemplar? Jag är ganska säker på att jag kan fråga efter ett nytt exemplar fårn Komplett?
Men som sista försök innan att göra nåt åt mitt måndagsexemplar om det nu är det. Ska jag uppdatera bios i kortet? Alla säger att dom gjort det så har det funkat. Hur gör jag det?

Trädvy Permalänk
Medlem
Plats
Halland
Registrerad
Sep 2007

Formatera Windows. Om du är desperat.

Intel i5 3570k @ 4.5 GHz || Asrock Z77 Performance || Dark Rock Pro 2 || 1080ti || Dark Power Pro 10 || Acer Predator Z35P

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Ninotramp:

Formatera Windows. Om du är desperat.

NEEEEEVVVEEEERR!!!!!
Det skulle oavsett att jag kan spela spelet igen, så skulle det inte vara värt det. Och om det inte funkade efteråt så skulle jag fan skjuta mig! Det kanske är så att det är ett måndags exemplar :/

Trädvy Permalänk
Medlem
Registrerad
Jun 2003

Vad är det för hastighet på GPU/Minne på grafikkortet? Enligt Nvidia är det 822/1645 default på GTX 560 Ti. Om kortet är lite fabriksöverklockat så använd MSI utilityn och ställ ner och testa.

Jag kör Shogun 2 med ett Asus vanilj-GTX 580@default och WHQL 295.73 (har inte uppgraderat till senaste än).

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Buio:

Vad är det för hastighet på GPU/Minne på grafikkortet? Enligt Nvidia är det 822/1645 default på GTX 560 Ti. Om kortet är lite fabriksöverklockat så använd MSI utilityn och ställ ner och testa.

Jag kör Shogun 2 med ett Asus vanilj-GTX 580@default och WHQL 295.73 (har inte uppgraderat till senaste än).

Min är fabriksklockad till 880Hz, kan köra ner o testa

Trädvy Permalänk
Medlem
Registrerad
Jun 2003

Om du vill prova så "rent" som möjligt, dvs utan 3:dje-parts bakgrundsprogram och tjänster kan man använda msconfig för att testa det. Dvs få ner antalet bakgrundsprocesser/tjänster till minimum (som du kan se i taskmanager). Det är lite krångligt, men värt ifall man vill utesluta utomstående mjukvara. Risken är dock att det är något annat problem, men ifall man inte kommer vidare är det något att testa i alla fall.

Kör snabbkommando Win+R, skriv "msconfig", klicka i "Diagnostic startup" och boota sen om. När du bootar om kommer msconfig ploppa upp så du vet att du kör i diagnostikläge, och det är enkelt att sen backa till "Normal startup". När du är i det här läget är antivirus och i princip alla bakgrundsprogram avstängda. Prova kör Steam och Shogun 2. Innan du kör kan du också stänga av Steam Overlay genom att högerklicka på Shogun 2 och välja "Properties" och sen kryssa av "Enable Steam community in-game" För att återgå, starta msconfig igen och välj "Normal startup" och boota om, ställ även tillbaks Steam overlay på samma ställe.

Om det fortfarande inte fungerar så har du i alla fall i princip uteslutit allting utom spelet/drivers/windows. Fungerar spelet så är det alltså något som körs i bakgrunden som stör. Då kommer det krångliga att hitta vad det är för något.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Buio:

Om du vill prova så "rent" som möjligt, dvs utan 3:dje-parts bakgrundsprogram och tjänster kan man använda msconfig för att testa det. Dvs få ner antalet bakgrundsprocesser/tjänster till minimum (som du kan se i taskmanager). Det är lite krångligt, men värt ifall man vill utesluta utomstående mjukvara. Risken är dock att det är något annat problem, men ifall man inte kommer vidare är det något att testa i alla fall.

Kör snabbkommando Win+R, skriv "msconfig", klicka i "Diagnostic startup" och boota sen om. När du bootar om kommer msconfig ploppa upp så du vet att du kör i diagnostikläge, och det är enkelt att sen backa till "Normal startup". När du är i det här läget är antivirus och i princip alla bakgrundsprogram avstängda. Prova kör Steam och Shogun 2. Innan du kör kan du också stänga av Steam Overlay genom att högerklicka på Shogun 2 och välja "Properties" och sen kryssa av "Enable Steam community in-game" För att återgå, starta msconfig igen och välj "Normal startup" och boota om, ställ även tillbaks Steam overlay på samma ställe.

Om det fortfarande inte fungerar så har du i alla fall i princip uteslutit allting utom spelet/drivers/windows. Fungerar spelet så är det alltså något som körs i bakgrunden som stör. Då kommer det krångliga att hitta vad det är för något.

Funkar inte

Trädvy Permalänk
Medlem
Registrerad
Jun 2003
Skrivet av LinusNeuman:

Funkar inte

Trist, men inte oväntat.

Du använder Realteks ljudkortsdriver från denna antar jag? Den är i alla fall ny såg jag.
http://www.msi.com/product/mb/870A-G54.html#/?div=Driver&os=W...

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Buio:

Trist, men inte oväntat.

Du använder Realteks ljudkortsdriver från denna antar jag? Den är i alla fall ny såg jag.
http://www.msi.com/product/mb/870A-G54.html#/?div=Driver&os=W...

Ska testa imorron efterskolan!
Håller tummarna!
Fanns det någon changelog? Kul o se vad dom gjort.

(Har svårt att sova, har legat i sängen sedan 22.00 kan bara inte somna Ska starta en tråd om tips att somna kanske..)
EDIT: Funkar inte Läste på ett forum som hade samma problem som hade uppdaterat drivisarna och sen gjort en verify file integrity. Och sen funkat men det funkar inte för mig Inget funkar för mig Fick svar från supporten de sa att de inte hade nån aning om vad som var problemet och vidarebefordrade mig till den brittiska avdelningen.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Feb 2012

Har du fått det att fungera? Jag och en kompis har kört en multiplayer campaign på 80turns just nu och har funkat hur bra som helst tills igår, då av någon anledning kan jag inte ladda strider :S Jag kommer in i spelet och kan loada savet mm men direkt när vi ska köra en strid så slutar spelet ladda och får som du att, Shogun 2 svara ej. Fruktansvärt jobbigt. Hände mig på Empire total war med, fast då va det savet som blev korrupt, blir inget mer total war efter detta

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011

Nu har jag fått svar från SEGA UK.
Dear Customer,

Thank you for contacting SEGA Support.

We are sorry to read that you are encountering this issue with Total War: Shogun 2.

In order to troubleshoot the issue, please follow these steps and try running the game after each one:

1) Use the secondary installer for Visual C++ and rename the ClientRegistry.blob file:
- Navigate to the following folder: C:\Program files\Steam\steamapps\common\total war shogun 2\redist
- Inside the "redist" folder, double click on the "vcredist_x86" executable
- When installation is finished, and after making sure that Steam is not running (if it is open, use the top menu: "Steam" -> "Exit"), navigate to its installation path: C:\Program files\Steam
- Right-click the file named "ClientRegistry.blob" and select "Rename". Change the name of this file to "ClientRegistryOld.blob"

2) Uninstall C++ 2005 and reinstall it, as it might have become corrupt:

- Click on Start -> Control Panel
Windows Vista / 7: Select “Programs and features” (or “Uninstall a program”)
Windows XP: Select “Add or remove programs”

- Click on Microsoft Visual C++ 2005 Redistributable and select “Uninstall”. Do this for all instances of Visual C++ 2005
- Once Visual C++ 2005 has been completely uninstalled, access the following path: C:\Program files\Steam\steamapps\common\total war shogun 2\redist
- Inside the "redist" folder, double click on the "vcredist_x86" executable to reinstall Visual C++ 2005

3) Check the Steam client Properties:
- Ensure that the Steam installation folder and its contents are not set to “Read-only”
- Check that the “Steam.exe” application file is not being run in “Compatibility mode” and that you are running it as an Administrator. To check this, right-click on the file and select “Properties”, then the “Compatibility” tab

4) Look for Steam client updates:
- Open Steam
- Click on the top left menu: "Steam" and select "Check for Steam Client Updates..."
- Steam will restart automatically if an update needs to be applied

5) Verify the integrity of the game’s cache:
- From the Steam Games Library, right-click on Total War: Shogun 2 and select "Properties" from the menu
- Select the Local files tab and click the "Verify integrity of game cache..." button
- Steam will verify the game cache files - this process may take several minutes
- If Steam finds that some files need to be reacquired, repeat the verification process once more

6) Disable your Antivirus and any other security software:
You should be able to temporarily deactivate your Antivirus by right-clicking on its icon in the notification area, next to the system clock. If you cannot deactivate the Antivirus using this method, please refer to the instructions from your software provider.

Jag har testat detta och det funkar INTE och det gäller FALL OF THE SAMURAI OCKSÅ, JAG HAR BETALAT FÖR TVÅÅÅ SPEL JAG INTE KAN ANVÄNDA.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011

En sak dom tipsade om var att ha Steam mappen fri så att den inte var skrivskyddad, testade det men när den väl var klar så dök den upp som skrivskyddad igen. Varöfr gör den så och hur fixar jag det?

Trädvy Permalänk
Medlem
Registrerad
Jun 2003
Skrivet av LinusNeuman:

En sak dom tipsade om var att ha Steam mappen fri så att den inte var skrivskyddad, testade det men när den väl var klar så dök den upp som skrivskyddad igen. Varöfr gör den så och hur fixar jag det?

Om man installerar Steam och Spel i Windows Program-mapp så skyddar systemet filerna där. Det går att ändra manuellt, men är lite krångligt. Ett annat alternativ är att starta spelet i admin-läge (då får det fulla rättigheter i mappen). Du kan göra det genom att högerklicka på ikonen i Start-menyn/Alla Program och välja kör som Admin. Hittar du inte det så kan du alltid starta spelet från hårddisken med utforskaren och högerklicka på programfilen och välja samma sak.