Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006

Inget ljud via HDMI

Hej,

Jag har lite problem med att få ljud från datorn ut ur tvn. Grafikkortet är ett ATI RADEON HD 4250 och är kopplat direkt till tvn. Jag har läst ett antal trådar men utan att lyckats lösa problemet så nu hoppas jag att jag kan få bättre hjälp.
Tvn är en LG SL9000.

Så här ser det ut på skärmen:

Vill ni ha mer info om datorn så säg till

Med Vänlig Hälsning

Jonas

[Svantepung]

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Aug 2006

Om jag förstår dig rätt så har du kopplat en HDMI-HDMI kabel utan adapter från en HDMI kontakt som sitter på moderkortet till HDMI kontakten på TVn, och du har inget annat grafikkort i datorn, har jag förstått det hela rätt?

janee

Trädvy Permalänk
Medlem
Plats
Bergshamra (Stockholm)
Registrerad
Jan 2011

Den där ljudkontrollen uppe till vänster, högerklicka på Realtek HDMI output och välj typ standard eller nåt sånt

Om du använder DVI-HDMI utan ljud så kommer det nog inte att funka, det finns nämligen olika typer av DVI

CPU: Intel Core i7 4770K MOBO: ASUS Z87-A RAM: 4x8 GB Corsair Vengeance 1866 MHz GPU: MSI 280X Gaming 3GB PSU: EVGA SuperNOVA NEX1500 Classfied Chassi: Corsair Obsidian 550D Webhallen Edition Kylare: Corsair Hydro H100i DVD/BD: ASUS Blu-Ray Combo 14x SSD: Corsair Neutron GTX 480GB HDD:

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2008

Använder du dvi-hdmi adapter måste du använda AMDs egen adapter: http://www.inet.se/produkt/5408583/ati-dvi-till-hdmi-adapter

Det funkar nämligen inte med vilken adapter som helst.

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006
Skrivet av janee:

Om jag förstår dig rätt så har du kopplat en HDMI-HDMI kabel utan adapter från en HDMI kontakt som sitter på moderkortet till HDMI kontakten på TVn, och du har inget annat grafikkort i datorn, har jag förstått det hela rätt?

Det stämmer bra. Den är direkt inkopplad till en kontakt som sitter på moderkortet och inget annat grafikkort finns.

[Svantepung]

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006
Skrivet av ChineseBoy:

Den där ljudkontrollen uppe till vänster, högerklicka på Realtek HDMI output och välj typ standard eller nåt sånt

Om du använder DVI-HDMI utan ljud så kommer det nog inte att funka, det finns nämligen olika typer av DVI

Skrivet av Superlight:

Använder du dvi-hdmi adapter måste du använda AMDs egen adapter: http://www.inet.se/produkt/5408583/ati-dvi-till-hdmi-adapter

Det funkar nämligen inte med vilken adapter som helst.

Jag använder ingen DVI-adapter och det går inte att välja standard där :/

[Svantepung]

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Dec 2008

Det du vill försöka göra är att ställa in HDMI som ljudkälla... Vet inte varför det står "ej inkopplad" på HDMI uppe i vänster hörn, kan du aktivera den i menyen eller? Testa även att ställa in HDMI som enda ljudkälla/standard i menyn i mitten av skärmen.

CPU: Core i5 750 @ 3.5 Ghz med Cooler Master H212+ / MB: MSI P55 GD65 / RAM: 4x2 GB Corsair XMS3 @ 1600 Mhz / GPU: MSI GTX760 Hawk 2GB / HDD: Intel 520 (OS) + Intel 320 + 2x Samsung F3 + WD Black / PSU: Corsair HX650 / Ljudkort: Creative X-fi XtremeGamer / Chassi: Fractal Design Define R2. Dags att uppgradera snart...

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2008

Vad använder du för moderkort? Du behöver kanske drivrutiner för HDMI-ljudet.

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Aug 2006

Jag kan inte se att du har Catalyst CC eler Vision Center så om du saknar detta så finns drivrutiner att hämta från denna sida, jag har fyllt i dom 3 första stegen korrekt för en HD4250 grafikkrets men du måste även välja rätt operativsystem

Länk till sidan för nedladdning av drivrutiner http://support.amd.com/us/gpudownload/Pages/index.aspx

janee

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006
Skrivet av Vlademil:

Det du vill försöka göra är att ställa in HDMI som ljudkälla... Vet inte varför det står "ej inkopplad" på HDMI uppe i vänster hörn, kan du aktivera den i menyen eller? Testa även att ställa in HDMI som enda ljudkälla/standard i menyn i mitten av skärmen.

Testade nu att inaktivera några av ljudkällorna, men då gick det inte alls. Det blev en röd markering på ljudikonen nere till höger. Kan det vara så att jag måste köpa ett separat grafikkort? Alltså att det inte går med det som är i nu?

[Svantepung]

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006
Skrivet av Superlight:

Vad använder du för moderkort? Du behöver kanske drivrutiner för HDMI-ljudet.

Skrivet av janee:

Jag kan inte se att du har Catalyst CC eler Vision Center så om du saknar detta så finns drivrutiner att hämta från denna sida, jag har fyllt i dom 3 första stegen korrekt för en HD4250 grafikkrets men du måste även välja rätt operativsystem
http://img694.imageshack.us/img694/2931/catalystcchd4200serie...

Länk till sidan för nedladdning av drivruter http://support.amd.com/us/gpudownload/Pages/index.aspx

Superlight, moderkortet ska jag kolla upp snarast.

janee, tror du att det går att ordna med dom programmen?

Tackar vänligast för allas hjälpsamhet och alla snabba svar!

[Svantepung]

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Aug 2006
Skrivet av svantepung:

Testade nu att inaktivera några av ljudkällorna, men då gick det inte alls. Det blev en röd markering på ljudikonen nere till höger. Kan det vara så att jag måste köpa ett separat grafikkort? Alltså att det inte går med det som är i nu?

Det är endast den översta HDMI Output som skall vara aktiverad när du vill ha ut ljudet till TVn via HDMI kabeln.

Edit: jag har alltid använt Catalyst CC eller Vision Center när jag har kopplat en HDMI kabel till TVn och då har både bild och ljud fungerat bra om man först kopplar in HDMI kabeln och sedan markerat AMD HDMI Output i uppspleningsenheter och satt den som Standard och klickat på OK.

janee

Trädvy Permalänk
Moderator
Registrerad
Aug 2007
Skrivet av ChineseBoy:

Den där ljudkontrollen uppe till vänster, högerklicka på Realtek HDMI output och välj typ standard eller nåt sånt

Om du använder DVI-HDMI utan ljud så kommer det nog inte att funka, det finns nämligen olika typer av DVI

Du har svaret här. Det måste vara en grön bock för HDMI output. Tyvärr kan du inte få ut ljudet på flera ställen utan att pilla med tredjepartsprogram så vill du använda HDMI ibland och några andra högtalare ibland får du göra om inställningen.

Använd gilla för att markera nyttiga inlägg!

Trädvy Permalänk
Medlem
Plats
Skåne Helsingborg
Registrerad
Sep 2009

Är där inte två DVI utgångar på grafikkortet? Jag vet att oftast är det bara den ena som skickar ut ljud. Är det ren hdmi så är det nåt du har gjort med fel med ljudinställningarna.

I Fractal Design Define R4 Arctic White I EVGA GeForce GTX 680 2GB I i7 2600K I 16gb 1333mhz I Be-Quiet Pure Power L8 630W I 1 TB hårddisk I SanDisk SSD Extreme 120GB I Logitech MX Master I SteelSeries 4HD Mousepad I Samsung S27A950D I Logitech Z623 I

Trädvy Permalänk
Medlem
Plats
Skåne Helsingborg
Registrerad
Sep 2009
Skrivet av giplet:

Du har svaret här. Det måste vara en grön bock för HDMI output. Tyvärr kan du inte få ut ljudet på flera ställen utan att pilla med tredjepartsprogram så vill du använda HDMI ibland och några andra högtalare ibland får du göra om inställningen.

Du har inte svaret på din fråga här kära trådskapare. Du kan inte sätta standard då din dator säger tydligt att den känner ej av någon ljudkälla från hdmi. Det står ej inkopplat. Det ska stå "klart" om det är redo att aktiveras...

I Fractal Design Define R4 Arctic White I EVGA GeForce GTX 680 2GB I i7 2600K I 16gb 1333mhz I Be-Quiet Pure Power L8 630W I 1 TB hårddisk I SanDisk SSD Extreme 120GB I Logitech MX Master I SteelSeries 4HD Mousepad I Samsung S27A950D I Logitech Z623 I

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006
Skrivet av tednasadator:

Är där inte två DVI utgångar på grafikkortet? Jag vet att oftast är det bara den ena som skickar ut ljud. Är det ren hdmi så är det nåt du har gjort med fel med ljudinställningarna.

Det finns en DVI, en VGA och en HDMI-utgång från grafikkortet. Det märkliga är att det går inte att spela upp ljud från den vanliga ljudutgången heller, men det tror jag beror på tvn och eftersom att LG support inte ville hjälpa mig med annat än HDMI så vill jag få detta att fungera. Jag har inte ändrat i några inställningar mer än inaktiverat dom och sedan aktiverat dom på nytt.

[Svantepung]

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006

Kan även tillägga att det blir ljud via HDMI när jag spelar xbox, men det är inget klart ljud, utan det skorrar lite.

[Svantepung]

Trädvy Permalänk
Medlem
Registrerad
Mar 2009
Skrivet av svantepung:

Kan även tillägga att det blir ljud via HDMI när jag spelar xbox, men det är inget klart ljud, utan det skorrar lite.

Okej. Kan ha missat detta, så jag frågar. Har du installerat senaste drivrutinerna till grafikkortet? Har du testat med en annan HDMIkabel?
Som det ser ut på din printscreen, så registrerar den ju helt klart HDMI som en ljudkälla, dock visar den som frånkopplad. Får mig att tänka på kabeln. Återkom gärna!

Delid 3770k@5.9GHz, Mpower, 32GB Corsair Dominator@2600MHz/CL10
XFire 390x@1335/1750, Carbide 540 AIR
E34 S36B38Turbo 897WHP

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006
Skrivet av Demonoidz:

Okej. Kan ha missat detta, så jag frågar. Har du installerat senaste drivrutinerna till grafikkortet? Har du testat med en annan HDMIkabel?
Som det ser ut på din printscreen, så registrerar den ju helt klart HDMI som en ljudkälla, dock visar den som frånkopplad. Får mig att tänka på kabeln. Återkom gärna!

Nej, det har du inte missat men jag har uppdaterat drivrutinerna. Däremot har jag endast testat två kablar, som kanske kan vara av sämre kvalitet!? Men med tanke på att jag ändå får ljud genom xboxet så borde det ju bli liknande ljud i datorn tycker jag, även att det är skorrande.

[Svantepung]

Trädvy Permalänk
Medlem
Registrerad
Mar 2009
Skrivet av svantepung:

Nej, det har du inte missat men jag har uppdaterat drivrutinerna. Däremot har jag endast testat två kablar, som kanske kan vara av sämre kvalitet!? Men med tanke på att jag ändå får ljud genom xboxet så borde det ju bli liknande ljud i datorn tycker jag, även att det är skorrande.

Hm. Du har ingen mjukvara installerat som kan tänkas stoppa HDMIljudet?

Delid 3770k@5.9GHz, Mpower, 32GB Corsair Dominator@2600MHz/CL10
XFire 390x@1335/1750, Carbide 540 AIR
E34 S36B38Turbo 897WHP

Trädvy Permalänk
Medlem
Plats
Ligger i norr
Registrerad
Nov 2007

Har du laddat hem korrekta HDMI-ljud-drivare enligt Janees instruktion?

Fo3

Bara en enda ros på ett evigt klänge
så är livet
trist varar länge
men underbart är kort -
alldeles för kort

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Dec 2006
Skrivet av Demonoidz:

Hm. Du har ingen mjukvara installerat som kan tänkas stoppa HDMIljudet?

Nej, inte vad jag vet. Vad skulle det kunna vara för mjukvara?

Skrivet av FatherOfThree:

Har du laddat hem korrekta HDMI-ljud-drivare enligt Janees instruktion?

Fo3

Ja, det har jag gjort. Men det hjälpte dessvärre inte :/

[Svantepung]

Trädvy Permalänk
Medlem
Plats
Stockholms län
Registrerad
Maj 2005
Skrivet av giplet:

Du har svaret här. Det måste vara en grön bock för HDMI output. Tyvärr kan du inte få ut ljudet på flera ställen utan att pilla med tredjepartsprogram så vill du använda HDMI ibland och några andra högtalare ibland får du göra om inställningen.

Jag använder både HDMI och mitt ljudkort samtidigt. Media Player Classic skickar ljud till TV över HDMI samtidigt som allt annat ljud spelas via ljudkortet som vanligt. Spotifyjäveln spelar allt ljud på samtliga ljudutgångar. Jag har ett HD4850 och inga tredjepartsprogram så det borde gå? Handlar det om drivrutiner eller har riktiga grafikkort en ljudkrets i sig?

Det där med att man måste välja en ljudutgång som standard försvann i Win 7.

Desktop ||| i5 3570K | 16Gb | 240Gb | 1,5Tb | GTX 970 4Gb |||
iPhone 4S ||| 2x1.0 GHz A5 | 0,5Gb | 32Gb | PowerVR SGX543MP2 |||

Citera när du svarar!

Trädvy Permalänk
Medlem
Plats
Stockholms län
Registrerad
Maj 2005
Skrivet av svantepung:

Nej, inte vad jag vet. Vad skulle det kunna vara för mjukvara?

Ja, det har jag gjort. Men det hjälpte dessvärre inte :/

Du, byt HDMI port.

Desktop ||| i5 3570K | 16Gb | 240Gb | 1,5Tb | GTX 970 4Gb |||
iPhone 4S ||| 2x1.0 GHz A5 | 0,5Gb | 32Gb | PowerVR SGX543MP2 |||

Citera när du svarar!

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Hejsan.
Jag har det kopplat likadant (kabel direkt mellan dator och TV) men har Högtalare och HDMI Out som standard.
"Realtek Digital Output" har jag inaktiverad. Den använder man väl bara om man kopplar datorn till sin hemmabioanläggning?

Så jag förslår att du helt enkelt provar att inaktivera Digital Output.
och låter Högtalare och NVIDIA HDMI Out vara aktiverade.
SAMT sätter den sistnämnda som standardenhet också (högerklicka) Annars funkar inte ljudet för mig.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2011
Trädvy Permalänk
Medlem
Registrerad
Maj 2012

HAR SVARET SOM HJÄLPER DIG

Okej, detta är något många har problem med, dock finns det en enkel lösning som hjälper 99,9%.
Följ dessa steg min vän:
1. Högerklick på volymkontroller nere till höger, välj uppspelningsenheter.
2. Högerklick på hdmi ljudkontrollen som det står "ej inkopplad etc".
3. Välj egenskaper. Därefter väljer du egenskaper IGEN och därefter nere till vänster "ändra inställningar".
4. Sedan väljer du "drivrutin" och därefter väljer du "återställ tidigare drivrutin". När du gjort detta kommer du få en mängd nya ljudkontroller via hdmi. Du väljer den som står som aktiverad och högerklickar på den, för att sedan välja den som standardenhet. Klart, ljud via hdmi.

On english:
if you locate the driver in "Properties", right click the speaker down by the clock on your desktop toolbar. Select "Playback Devices". There you should have the "Digital audio (HDMI)" icon.
Click it and select "Properties" at the next window. Again, select "Properties". Now you get to yet another window.
At the bottom left corner there's a button that says, "Change Settings". Click it and if UAC needs permission, then allow it. OK, another window, klick the "Driver" tab, here you should click the "Rollback Driver" button.
And when it is done, voila: HDMI sound again!