Hjälp med SD-kort i Cyanogenmod 9

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Feb 2009

Hjälp med SD-kort i Cyanogenmod 9

Jag köpte mig nyligen en surfplattan, en Ainol Novo 7 Aurora. Helt vanlig kinaplatta med IPS-skärm, en A10 CPU och 1 GB i RAM.
Den kör nu Cyanogenmod 9 20120804 efter intensivt testande en väldigt massa ROM:s så fungerade denna klart bäst.

Problemet jag har nu är bara att jag inte kan få SD-kortet att fungera som önskat. (Samsung micro-sd 32 GB Klass 10)
Den hittar minneskortet under inställningar->lagring, och det fungerar bra i CWM 6.0.1.0.
Men om jag t.ex ska starta kameran så står det "SD-crad not mounted". Jag kan heller inte föra över appar ifrån interna minnet (3 GB) till minneskortet. Då får man meddelandet att det inte finns tillräckligt med plats på kortet.

Om man istället försöker komma åt filerna via Filemanager coh liknande programvaror så går det att får fram. Mina filer ligger då under "/extsd" istället, och försöker man gå in på "/sdcard" så står det att det inte är monterat.
Jag tolkar detta om att om man kan få plattan att räkna att "/extsd" egentligen är "/sdcard" så skulle det fungerar som önskat, men det är bara en gissning.

Jag är inte speciellt erfaren när det gäller root, Cyanogenmod och har googlat runt väldigt mycket.
All hjälp är därför mycket uppskattad!

i7 3820, Antec kühler h2o 620, MSI x79ma-gd45, R9 290, 16 GB DDR3 1600 Mhz Corsair LP, 120 Gb Samsung 830, 1 Tb Spinpoint F3, 750 Gb Seagate Momentus XT, Fractal Design Define Mini
LG 29EA93 2560x1080, Mionix Zibal 60, Razer Deathadder Respawn, Mionix Nash 20

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2010

/sdcard på den plattan är som standard internminnet. Har en likadan, mitt interna kort har en storlek på ca 5.3GB. Resten av internminnet används av systemet.

I /etc/vold.fstab kan du se hur det monteras. Har själv inte provat att ändra så /sdcard blir det externa kortet och /extsd det interna, men det kan fungera. Ta backup först bara.

Det låter också som att det interna minnet blivit korrupt på något sätt. Kolla på hur man flashar med LiveSuit, där finns ett alternativ som också partitionerar internminnet. Då borde allting funka bättre.

Du får gärna citera eller nämna mig (@ToJa92) om du svarar på något jag skrivit.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Dec 2008

Gjorde du en full wipe när du uppdaterade till cm9? Det kan ske skumma fel om man inte gör wipes när man byter rom. (cm6-->cm9 är ett ganska stort steg) Testa också att göra en formatering på all lagringsmedia. (för mig emmc och sdcard på min galaxy s 2)
jag var tvungen att formatera och partitionera all min lagringsmedia i clockworkmod recovery på min galaxy s2 för att sdkorten skulle fungera som de skulle.

formatera och partitionera om lagringsmedian borde lösa problemet.

Detta var dock för mig.

Hoppas det löser sig
Mvh.

CPU: Intel i5 4670k | MoBo: MSI Z87 Gaming AC | GPU: Gigabyte GTX 970
Ram: 2x4GB Corsair 1600MHz | Nätagg: Corsair CX650 :(
System: Samsung 840 120 GB | Övrigt: Samsung 850 256 GB

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Feb 2009
Skrivet av ToJa92:

/sdcard på den plattan är som standard internminnet. Har en likadan, mitt interna kort har en storlek på ca 5.3GB. Resten av internminnet används av systemet.

I /etc/vold.fstab kan du se hur det monteras. Har själv inte provat att ändra så /sdcard blir det externa kortet och /extsd det interna, men det kan fungera. Ta backup först bara.

Det låter också som att det interna minnet blivit korrupt på något sätt. Kolla på hur man flashar med LiveSuit, där finns ett alternativ som också partitionerar internminnet. Då borde allting funka bättre.

Tack, jag ska testa det snart! Testade med livesuit men fick det inte fungera bra. Körde med CWM istället.

Skrivet av olleb:

Gjorde du en full wipe när du uppdaterade till cm9? Det kan ske skumma fel om man inte gör wipes när man byter rom. (cm6-->cm9 är ett ganska stort steg) Testa också att göra en formatering på all lagringsmedia. (för mig emmc och sdcard på min galaxy s 2)
jag var tvungen att formatera och partitionera all min lagringsmedia i clockworkmod recovery på min galaxy s2 för att sdkorten skulle fungera som de skulle.

formatera och partitionera om lagringsmedian borde lösa problemet.

Detta var dock för mig.

Hoppas det löser sig
Mvh.

Jag körde full wipes, och du läste nog fel. Jag gick inte ifrån CM 6 -> CM 9.
Jag körde med CM 9 ifrån början men använde CWM 6.0.1.0 (ClockworkMod)
Jag har inte testat att formatera och portionera både interna och externa i CWM.
Jag får göra det!

i7 3820, Antec kühler h2o 620, MSI x79ma-gd45, R9 290, 16 GB DDR3 1600 Mhz Corsair LP, 120 Gb Samsung 830, 1 Tb Spinpoint F3, 750 Gb Seagate Momentus XT, Fractal Design Define Mini
LG 29EA93 2560x1080, Mionix Zibal 60, Razer Deathadder Respawn, Mionix Nash 20

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Feb 2009

Jag har nu formaterat och partionerat både internt och externt i CWM. Med samma resultat.

i7 3820, Antec kühler h2o 620, MSI x79ma-gd45, R9 290, 16 GB DDR3 1600 Mhz Corsair LP, 120 Gb Samsung 830, 1 Tb Spinpoint F3, 750 Gb Seagate Momentus XT, Fractal Design Define Mini
LG 29EA93 2560x1080, Mionix Zibal 60, Razer Deathadder Respawn, Mionix Nash 20

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2010
Skrivet av dahlberg1992:

Tack, jag ska testa det snart! Testade med livesuit men fick det inte fungera bra. Körde med CWM istället.

Vad var det som inte fungerade då?
Följer du den här guiden så bör internminnet dyka upp som det ska: http://gadgetfreakz.co.uk/downloads/gfz-novo7/Ainol_Novo_7_Fi...
Efter att LiveSuit formaterat och flashat romen, starta upp den i alla fall en gång. Sen kan du installera CWM och vilken rom du nu vill ha.

Du får gärna citera eller nämna mig (@ToJa92) om du svarar på något jag skrivit.

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Feb 2009
Skrivet av ToJa92:

Vad var det som inte fungerade då?
Följer du den här guiden så bör internminnet dyka upp som det ska: http://gadgetfreakz.co.uk/downloads/gfz-novo7/Ainol_Novo_7_Fi...
Efter att LiveSuit formaterat och flashat romen, starta upp den i alla fall en gång. Sen kan du installera CWM och vilken rom du nu vill ha.

Nu när jag körde med Livesuit och stock rom så blev resultatet annorlunda.
Nu är det interna minnet på 0.91 GB (2.9 GB innan) och SD-kortet i menyn är 5.5 GB(innan 29 GB).
Varför blir det så litet?

EDIT: Nu när jag kollade lite mer så fanns det ett till SD-kort undet på 5.5 GB som var på 27 GB.

i7 3820, Antec kühler h2o 620, MSI x79ma-gd45, R9 290, 16 GB DDR3 1600 Mhz Corsair LP, 120 Gb Samsung 830, 1 Tb Spinpoint F3, 750 Gb Seagate Momentus XT, Fractal Design Define Mini
LG 29EA93 2560x1080, Mionix Zibal 60, Razer Deathadder Respawn, Mionix Nash 20

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Dec 2008
Skrivet av dahlberg1992:

Jag körde full wipes, och du läste nog fel. Jag gick inte ifrån CM 6 -> CM 9.
Jag körde med CM 9 ifrån början men använde CWM 6.0.1.0 (ClockworkMod)
Jag har inte testat att formatera och portionera både interna och externa i CWM.
Jag får göra det!

yep, det kan man lugnt säga! ber om ursäkt.
Mvh.

CPU: Intel i5 4670k | MoBo: MSI Z87 Gaming AC | GPU: Gigabyte GTX 970
Ram: 2x4GB Corsair 1600MHz | Nätagg: Corsair CX650 :(
System: Samsung 840 120 GB | Övrigt: Samsung 850 256 GB

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2010
Skrivet av dahlberg1992:

Nu när jag körde med Livesuit och stock rom så blev resultatet annorlunda.
Nu är det interna minnet på 0.91 GB (2.9 GB innan) och SD-kortet i menyn är 5.5 GB(innan 29 GB).
Varför blir det så litet?

EDIT: Nu när jag kollade lite mer så fanns det ett till SD-kort undet på 5.5 GB som var på 27 GB.

Ja, då har det blivit rätt. Välj inte att formatera i CWM i fortsättningen så borde allt fungera som det ska nu
Att det 5.5GB är för att ~1GB är tilldelat systempartitionen(och då också appar som är installerade på internminnet). Sen försvinner lite pga filsystemet och att det räknas lite olika som vanligt(USB-minnen, hårddiskar osv. är ju inte heller exakt den storlek som anges).

Observera dock att allt nu hamnar på det interna SD-kortet, alltså inte det externa. Som sagt kan det vara möjligt att ändra /etc/vold.fstab för att få det som du vill ha det.

Du får gärna citera eller nämna mig (@ToJa92) om du svarar på något jag skrivit.

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Feb 2009
Skrivet av ToJa92:

Ja, då har det blivit rätt. Välj inte att formatera i CWM i fortsättningen så borde allt fungera som det ska nu
Att det 5.5GB är för att ~1GB är tilldelat systempartitionen(och då också appar som är installerade på internminnet). Sen försvinner lite pga filsystemet och att det räknas lite olika som vanligt(USB-minnen, hårddiskar osv. är ju inte heller exakt den storlek som anges).

Observera dock att allt nu hamnar på det interna SD-kortet, alltså inte det externa. Som sagt kan det vara möjligt att ändra /etc/vold.fstab för att få det som du vill ha det.

Japp, ska lägga in CWM och se om jag får igång CM9 som jag vill också. Ska undvika att formatera där!

Jag behöver inte byta plats på minnena om det fungerar som jag önskar nu. Innan kunde den inte ens hitta PDF:er på mitt externa. Det är det viktigaste, om det bara fungerar nu så blir jag väldigt nöjd.
Tack för hjälpen!

i7 3820, Antec kühler h2o 620, MSI x79ma-gd45, R9 290, 16 GB DDR3 1600 Mhz Corsair LP, 120 Gb Samsung 830, 1 Tb Spinpoint F3, 750 Gb Seagate Momentus XT, Fractal Design Define Mini
LG 29EA93 2560x1080, Mionix Zibal 60, Razer Deathadder Respawn, Mionix Nash 20