Black Ops 2 - Fler spelare på samma nätverk fungerar inte

Trädvy Permalänk
Medlem
Plats
Sala
Registrerad
Dec 2007

Black Ops 2 - Fler spelare på samma nätverk fungerar inte

Hej!

Vi är två personer i samma nätverk som vill spela samtidigt men som det ser ut nu så kan bara en av oss ha spelet igång för att man ens ska kunna ansluta till spelservrarna. Den som startar spelet efter den första fastnar på "Connecting to online services".

Vi har haft exakt samma problem med andra spel men då har det hjälpt att lägga till t.ex. "-port xxxx" eller "clientport xxxx" i spelets launch options. Tyvärr hittar jag inget fungerande kommando för Black Ops 2.

Vi har en pfSense-router om det skulle spela någon roll.

Jag chattade med Activisions livesupport igår men jag blev inte så mycket klokare. Först säger de att jag måste skaffa en ip-adress per spelare vilket i och för sig skulle lösa problemet men det måste finnas en enklare lösning. Sedan påstod de att vår 100/100 fiberlina är för långsam och att felet ligger hos vår ISP.

Nu vänder jag mig till er. Någon som har haft samma problem och hittat en lösning?

//Mattias

Trädvy Permalänk
Medlem
Registrerad
Apr 2012

Antar att du kör en switch som inte kan ge nya ip adresser. Med dom får man problem med i många spel..

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Sala
Registrerad
Dec 2007

Har löst problemet men ett nytt har uppstått.

I pfSense-routern ändrade jag i Firewall -> NAT -> Outbound från "Manual Outbound NAT rule generation (AON Advanced Outbound NAT)" till "Automatic outbound NAT rule generation (IPsec passthrough included)".

Nu kan vi ansluta samtidigt men nu har vi båda NAT: Strict istället. Det fungerar bra om vi spelar med någon som är NAT: Open men lite irriterande när man är själv eftersom man inte hittar lika många matcher.

Trädvy Permalänk
Medlem
Plats
Trollhättan
Registrerad
Sep 2008
Skrivet av thuvan:

Nu kan vi ansluta samtidigt men nu har vi båda NAT: Strict istället. Det fungerar bra om vi spelar med någon som är NAT: Open men lite irriterande när man är själv eftersom man inte hittar lika många matcher.

Jag fixade det problemet genom att fixa statisk ip-address och därefter öppna port 3074 för tcp/udp.

i7 3770K 4,8GHz|Z77A-GD65|16GB 2133MHz|Palit GTX 1080|NH-D14|Air 540|AX850
Xonar DGX|HyperX Cloud|XL2411Z

Trädvy Permalänk
Medlem
Plats
Sala
Registrerad
Dec 2007
Skrivet av Gwaniiz:

Jag fixade det problemet genom att fixa statisk ip-address och därefter öppna port 3074 för tcp/udp.

Det har jag redan gjort. Jag var NAT: Open innan jag ändrade till automatic i Outbound NAT. Behövde även ändra till Static Port i en av de rules som redan ligger där för att få NAT: Open från början. Dock används ju inte dessa nu när jag kör automatic och därmed blir båda datorerna NAT: Strict.

Det jag skulle behöva göra är att skapa rules i Outbound NAT för våra två datorer i routern så jag slipper köra Automatic. Jag vet bara inte hur jag ska sätta upp detta.

Förhoppningsvis förstår någon vad jag pratar om.

Denna tråd kanske passar bättre i nätverksdelen av forumet?