Crysis 2, hur tvinga av Vsync?

Trädvy Permalänk
Medlem
Registrerad
Aug 2012

Crysis 2, hur tvinga av Vsync?

Hej!
Jag satt och spelade Crysis 2 (1080p, high/very high) och fick stabila 30 fps.
Helt okej tänkte jag, eftersom mitt grafikkort är ganska klent 750m.

Vad blir min fps om jag sänker upplösningen och hela köret?, tänkte jag.
Sagt och gjort sänkte jag till 1336x786 (eller vad det nu blir för upplösning..), och allt på lägsta.

Fortfarande stabila 30 fps, varken mer eller mindre.

Så min första tanke var "min CPU kanske flaskar?" (Har i7 4702qm, 4 kärnor, 8 trådar 2.2ghz (som kan gå upp lite i turbo då såklart). Nu kollar jag alltså CPU användning och ingen av kärnorna går upp i 100%. Processorn jobbar totalt i mellan 20-40 procent när jag spelar.
Det är alltså inte den som flaskar.
Jag börjar nu tänka att det måste vara vsync som är på, trots att jag har stängt av det i både spelet och nvidias kontrollpanel.

För att dubbelkolla min teori sänker jag upplösningen lite till och vipps är jag uppe i stabila 60 fps, varken mer eller mindre.

Så frågorna då:

1. Verkar det för er andra att det är vsync som spökar för mig?
2. Om datorn kan trycka ut 30 fps i 1080p (high/very high) måste den väl palla en hel del mer (kanske 50 fps?) i 1336x768?
3. Hur kan jag tvinga av vsync?

Jag är extremt tacksam för alla eventuella svar

Äkta Windows och äkta kopia av Crysis 2, allt uppdaterat och drivrutiner uppdaterade.

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Feb 2010

Helt klart ett V-Sync problem! Hur du ska lösa det däremot vet jag inte.

i7 3930K - Noctua NH-D14 - Palit 1070 Jetstream 8GB - Asus Sabertooth x79 - Corsair Vengeance DDR3 LP 4x4GB - Crucial MX100 256GB - AOC q2770Pqu 1440p - Corsair RM650x - Fractal Design R5 - Logitech G403 - Filco Majestouch-2 - Denon AVR-2113 - Dali Zensor 1

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Maj 2011

Man brukar kunna ändra Vsync från 1 till 0 i spelets .ini fil.

Fractal Design Define R4 | Intel core i7 2600K | Corsair H80 | ASUS Radeon HD7970 Direct CU II TOP | Asus P8Z77-V | Corsair Vengeance 8GB | HDD 1TB | Samsung EVO 840 120GB | Fractal Design Newton R2 1000W

Trädvy Permalänk
Medlem
Registrerad
Aug 2012

Ett till problem med Crysis 2

Skrivet av Justin91:

Helt klart ett V-Sync problem! Hur du ska lösa det däremot vet jag inte.

Jag tror jag tillslut löste det! Men nu har jag ännu ett problem..
När jag har spelat Crysis 2 ett tag så får jag massiva framerate drops.
Jag kommer helt plötsligt ned i ca 1-2 fps utan någon uppenbar anledning och efter kanske 15-20 sekunder spelar jag i den vanliga fps:en.

Jag har kollat cpu-temp och det verkar inte vara problemet
Jag har kollat gpu-temp och det verkar inte heller vara problemet (vissa gpu stress test får upp min gpu i betydligt högre temperatur.
Men vad jag har märkt blir minnet helt fullt, och jag antar att det kan vara därför?

Jag har 2GB grafikminne och enligt GPU-Z är min minnesanvändning när jag spelar ca 2030MB (Max är ju som sagt 2048).

Underligt tycker jag, Crysis 2 kan väl ändå inte använda så mycket grafikminne?
Jag spelar ju trots allt bara i 1080p med låga inställningar..

Vad tror du jag kan göra åt problemet?

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Feb 2010
Skrivet av PatrickP:

Jag tror jag tillslut löste det! Men nu har jag ännu ett problem..
När jag har spelat Crysis 2 ett tag så får jag massiva framerate drops.
Jag kommer helt plötsligt ned i ca 1-2 fps utan någon uppenbar anledning och efter kanske 15-20 sekunder spelar jag i den vanliga fps:en.

Jag har kollat cpu-temp och det verkar inte vara problemet
Jag har kollat gpu-temp och det verkar inte heller vara problemet (vissa gpu stress test får upp min gpu i betydligt högre temperatur.
Men vad jag har märkt blir minnet helt fullt, och jag antar att det kan vara därför?

Jag har 2GB grafikminne och enligt GPU-Z är min minnesanvändning när jag spelar ca 2030MB (Max är ju som sagt 2048).

Underligt tycker jag, Crysis 2 kan väl ändå inte använda så mycket grafikminne?
Jag spelar ju trots allt bara i 1080p med låga inställningar..

Vad tror du jag kan göra åt problemet?

Hur mycket ramminne har du? Om det är mindre än 8GB kanske problemet ligger där annars är det väl kassa drivrutiner och då får du helt enkelt rulla tillbaka till stabila drivrutiner som t.ex. 314.22. Om problemet fortfarande inte är löst har jag ingen aning tyvärr.

i7 3930K - Noctua NH-D14 - Palit 1070 Jetstream 8GB - Asus Sabertooth x79 - Corsair Vengeance DDR3 LP 4x4GB - Crucial MX100 256GB - AOC q2770Pqu 1440p - Corsair RM650x - Fractal Design R5 - Logitech G403 - Filco Majestouch-2 - Denon AVR-2113 - Dali Zensor 1

Trädvy Permalänk
Medlem
Registrerad
Aug 2012
Skrivet av Justin91:

Hur mycket ramminne har du? Om det är mindre än 8GB kanske problemet ligger där annars är det väl kassa drivrutiner och då får du helt enkelt rulla tillbaka till stabila drivrutiner som t.ex. 314.22. Om problemet fortfarande inte är löst har jag ingen aning tyvärr.

8GB RAM, det är inte ens i närheten av att fyllas
Eftersom det jag har samma problem i mer än detta spel, borde jag göra en enskild tråd om det då?

Trädvy Permalänk
Medlem
Registrerad
Jan 2010

Börja som sagt med att gå tillbaka i drivrutiner. Vet inte vad senaste stabila är för mobila kretsar men testa en eller ett par tillbaka

EDIT: Har du installerat några "moddar" med t.ex. high-res texturer(om det nu finns till Crysis 2?)

Själv kör jag bara spelet "som vanligt" med höga inställningar ingame och det tar ~1730MB grafikminne.

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Feb 2010
Skrivet av PatrickP:

8GB RAM, det är inte ens i närheten av att fyllas
Eftersom det jag har samma problem i mer än detta spel, borde jag göra en enskild tråd om det då?

Ja det borde du dock är jag osäker på om moddarna gillar det.. om moddarna inte gillar det kommer dom sammanfoga trådarna vilket blir väldigt rörigt.

i7 3930K - Noctua NH-D14 - Palit 1070 Jetstream 8GB - Asus Sabertooth x79 - Corsair Vengeance DDR3 LP 4x4GB - Crucial MX100 256GB - AOC q2770Pqu 1440p - Corsair RM650x - Fractal Design R5 - Logitech G403 - Filco Majestouch-2 - Denon AVR-2113 - Dali Zensor 1

Trädvy Permalänk
Medlem
Registrerad
Aug 2012
Skrivet av krrjon:

Börja som sagt med att gå tillbaka i drivrutiner. Vet inte vad senaste stabila är för mobila kretsar men testa en eller ett par tillbaka

EDIT: Har du installerat några "moddar" med t.ex. high-res texturer(om det nu finns till Crysis 2?)

Själv kör jag bara spelet "som vanligt" med höga inställningar ingame och det tar ~1730MB grafikminne.

Skrivet av Justin91:

Ja det borde du dock är jag osäker på om moddarna gillar det.. om moddarna inte gillar det kommer dom sammanfoga trådarna vilket blir väldigt rörigt.

Jag tror jag har hittat problemet
Det verkar inte vara GPU:n det är fel på, utan processorn.
Det är nämligen så att processorn klockar ner sig till 0,11 GHz (ja, noll komma elva..) enligt aktivitetshanteraren.
Processorn i fråga är en i7 4702MQ (basfrekvens på 2,2GHz, men kan gå upp till 2,9GHz med 4 kärnor, 3,1GHz med 2 kärnor, 3,2GHz med en kärna).

Någon som har någon aning om varför detta händer?
Processorn är inte överdrivet varm när detta händer. Runt 75-80 grader, men jag kan få upp den i över 90 grader om jag stresstestar den och grafikchippet samtidigt)

EDIT: Självklart är strömsladden inkopplad när jag spelar.

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Feb 2010
Skrivet av PatrickP:

Jag tror jag har hittat problemet
Det verkar inte vara GPU:n det är fel på, utan processorn.
Det är nämligen så att processorn klockar ner sig till 0,11 GHz (ja, noll komma elva..) enligt aktivitetshanteraren.
Processorn i fråga är en i7 4702MQ (basfrekvens på 2,2GHz, men kan gå upp till 2,9GHz med 4 kärnor, 3,1GHz med 2 kärnor, 3,2GHz med en kärna).

Någon som har någon aning om varför detta händer?
Processorn är inte överdrivet varm när detta händer. Runt 75-80 grader, men jag kan få upp den i över 90 grader om jag stresstestar den och grafikchippet samtidigt)

EDIT: Självklart är strömsladden inkopplad när jag spelar.

Säker på att den inte klockar ner sig även i stresstestet? Om den gör det är det helt klart temperaturproblem, 90 grader är väldigt högt för en processor faktiskt.. Montera om kylaren eller skaffa en ny kylare ifall om du kör med standardkylaren.

i7 3930K - Noctua NH-D14 - Palit 1070 Jetstream 8GB - Asus Sabertooth x79 - Corsair Vengeance DDR3 LP 4x4GB - Crucial MX100 256GB - AOC q2770Pqu 1440p - Corsair RM650x - Fractal Design R5 - Logitech G403 - Filco Majestouch-2 - Denon AVR-2113 - Dali Zensor 1

Trädvy Permalänk
Medlem
Registrerad
Aug 2012
Skrivet av Justin91:

Säker på att den inte klockar ner sig även i stresstestet? Om den gör det är det helt klart temperaturproblem, 90 grader är väldigt högt för en processor faktiskt.. Montera om kylaren eller skaffa en ny kylare ifall om du kör med standardkylaren.

Den klockar inte ner sig i stresstestet (intel burn test), den jobbar på 100% hela tiden men kör ändå i en bra frekvens

Kan inte riktigt montera om kylaren (eller skaffa en ny) med tanke på att det är en laptop. Den processorn klarar upp till 100 grader enligt intel.

Trädvy Permalänk
Medlem
Plats
Lidköping
Registrerad
Feb 2010
Skrivet av PatrickP:

Den klockar inte ner sig i stresstestet (intel burn test), den jobbar på 100% hela tiden men kör ändå i en bra frekvens

Kan inte riktigt montera om kylaren (eller skaffa en ny) med tanke på att det är en laptop. Den processorn klarar upp till 100 grader enligt intel.

Ok då är det säkert inga problem med temperaturen.
Kolla alla dina energisparinställningar, eftersom att det är en laptop försöker den säkert spara ström genom att sänka klockfrekvensen ordentligt. Sätt den på maximal prestanda på precis allt som kan ha att göra med processorn.

i7 3930K - Noctua NH-D14 - Palit 1070 Jetstream 8GB - Asus Sabertooth x79 - Corsair Vengeance DDR3 LP 4x4GB - Crucial MX100 256GB - AOC q2770Pqu 1440p - Corsair RM650x - Fractal Design R5 - Logitech G403 - Filco Majestouch-2 - Denon AVR-2113 - Dali Zensor 1