Importera filer från en gammal IDE 3,5" HDD

Trädvy Permalänk
Medlem
Registrerad
Jan 2014

Importera filer från en gammal IDE 3,5" HDD

Tjena Sweclockers!

Har en mycket gammal IDE hårddisk jag använde på min första dator (windows 98) länge sedan och vill komma åt filerna som jag har på den. Disken var funktionell då komponenten avmonterades. Sedan arkiverades disken i en låda (ostört, fram tills nu).

Jag har fått låna en IDE/Sata -> USB 2 adapter av Deltaco (sata-61) utav en arbetskamrat.
Hårddisken är en Maxtor 90840D5. Diskens Jumpers är inställda på Master enligt klistermärket.
Mitt operativsystem är Windows 7 Ultimate. Specifikationer om övriga datorkomponenter fås på begäran.

När jag först kopplade in den externa strömkällan till disken surrade den igång utan konstiga ljud (vilket enligt min uppfattning är ett bra tecken). 15 sekunder därefter kopplade jag in USB-sladden. Det kom upp ett meddelande om att drivrutiner installerades framgångsrikt (USB mass storage device under Universal Serial Bus controllers i enhetshanteraren och USB Device under Disk Drives)

Det dök dock inte upp någon enhet i Dator. Således kunde jag inte komma åt mina filer. Jag har prövat två programvaror för att försöka hitta filer: Find and Mount och EaseUS utan framgång. Programvarorna påstod att enheten var på 0 kB. Jag kollade Diskhanteraren. Disk 3 hittas, det står dock "Unknown" och "Not Initialized" som kommentar. Kollar jag på egenskaper av "USB Device" i enhetshanteraren och klickar på "Volumes"-fliken får jag också fram "Disk 3, Type: Unknown, Status: Not Initialized, Partition style: Not Applicable, Capacity: 0 MB.

Så, vad nu? Varje gång jag kopplar in och startar disken kommer ett USB-"inkopplingsljud" fram, men ingen enhet att undersöka.

Detta är, som ni möjligtvis märker, mitt första inlägg så jag ursäktar mig för eventuella missar
Tack!

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Jan 2002

Skumt att den inte hittar diskens storlek, det borde den göra tack vare usb kontrollern...
Har du inte tillgång till nån annan "gammel" dator som har en IDE baserad CD/DVD osv?
Många kör ju fortfarande med maskiner som faktiskt har en IDE port på moderkortet.

Att disken skulle gått och blivit kass med åren, har jag svårt att tro.
Iaf skall den visas som det den faktiskt är.

Prova även att köra Hirens Boot CD / Ultimate Boot CD och köra acess till disken via DOS eller Unbuntu och prova där.
Ha disken inkopplad via USB redan vid start av datorn - det brukar inte vara ett problem i fall som dessa.

Citera eller Svara för respons! •
Pixel Artist - Öppen för förslag på beställningsjobb! PM'a mig. • Mer på Instagram
YouTube - Gör lite såsaker här ibland, unboxing, drönar/go-pro saker och dyl. •

Trädvy Permalänk
Medlem
Registrerad
Jan 2014

Tack för svar, och ursäkta för mitt fördröjda svar!

Jag har tyvärr ingen dator med ett moderkort som har en IDE port.

Jag kan lägga till att jag har prövat adaptern på två datorer, med samma resultat. Borde problemet därför inte ligga i antingen Disken eller Adaptern?

Jag ska se över ditt förslag och ev. testa det så återkommer jag.

Trädvy Permalänk
Medlem
Plats
Câmara de Lobos, Madeira, Portugal
Registrerad
Nov 2005

Problemet kan bero på att Windows 7 inte stöder än så gammal version av NTFS. En linux-dist kanske gör det. Annars återstår kriminaltekniska program som t.ex. foremost, som är oberoende av filsystem. Foremost finns på live-CD:n SystemRescue CD.

Fagerja

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Mar 2010

Nu var det längesen jag gick igenom en ide-disk med adapter, men minns jag inte fel så ska jumprarna stå på "cable select" när den kopplas på detta vis.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2010

Som WolfeOfVengeance säger så stämmer det nog med "cable select", tack o lov så ersatte sata ide med dess jumprar.

Trädvy Permalänk
Medlem
Registrerad
Jan 2014

En polare till mig har en dator med ett lite halvgammalt moderkort som har en IDE port, tänkte att jag skulle pröva där då det blir tillfälle, då arbetskamraten jag lånade adaptern av behövde ha tillbaka den en vecka.

Jag har inte testat cable select med adaptern, men det ska jag pröva då jag lånar adaptern igen. Gäller samma jumper-inställning om jag kopplar in disken i polarens moderkort (CS)?

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Mar 2010
Skrivet av brushdentist:

En polare till mig har en dator med ett lite halvgammalt moderkort som har en IDE port, tänkte att jag skulle pröva där då det blir tillfälle, då arbetskamraten jag lånade adaptern av behövde ha tillbaka den en vecka.

Jag har inte testat cable select med adaptern, men det ska jag pröva då jag lånar adaptern igen. Gäller samma jumper-inställning om jag kopplar in disken i polarens moderkort (CS)?

För att göra en så enkel beskrivning som möjligt så gäller "master/slave" när du kopplar till ett moderkorts ide-uttag, och "cable select" för övriga "extra-kopplingar" tex. usb, raid-kort osv. Hur jumprarna ska stå när den kopplas till ett moderkort utan att disken ska agera system har jag faktiskt inte en aning om, den enda gången jag provat att kombinera sata och ide var på ett gammalt moder-kort som vägrade köra ide och sata samtidigt.

Dock är "cable-select" oftast ett säkert kort om man bara ska komma åt filer, så ska du koppla disken till en annan dator så var inte rädd för att prova dig fram mellan dessa tre lägen (tänk dock på att inte göra det medan datorn är igång).

Trädvy Permalänk
Medlem
Registrerad
Nov 2014

Jag sitter nu med en likadan disk och har denna adapter:
http://www.kjell.com/sortiment/dator-kringutrustning/datorkom...

I manualen till adaptern står att disken ska strappas som master.
Testade igenom ett antal IDE-diskar...ingen funka. Kollade manualen och såg att ingen disk var strappad som master. Efter omstrappning fungerar alla.
Nu med denna Maxtor finns ingen klisterlapp men jag hittade texten MS på kretskortet och strappade där men den funkar inte. Är det bara en strapp?
Den har för övrigt likadan historia som TS disk. Det är dessutom också mitt första inlägg på SC. Har TS möjligen någon länk till diskens datablad?

Det sitter en lapp med streckkode där det står: Replace with Compaq Spare 8 4 GBHD [334719-001-001]

Edit: Det står visst på skylten att master on = J50 och där satte jag den ju. Konstigt att den inte går igång. Den snurrar på och den låter inte illa. Adapterns IDE-lampa tänds inte som på de andra diskarna.
Adaptern borde väl klara FAT32?
Hmm, adaptern passar bara XP och senare men filformat står det inget om.

Edit2:
I mitt fall hittas inte disken ens till skillnad mot TS. På en annan disk hittas en boot-partition med filformat ext3 (Linux) och en andra partition anges som Other.

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av PeterNoster:

Jag sitter nu med en likadan disk och har denna adapter:
http://www.kjell.com/sortiment/dator-kringutrustning/datorkom...

I manualen till adaptern står att disken ska strappas som master.
Testade igenom ett antal IDE-diskar...ingen funka. Kollade manualen och såg att ingen disk var strappad som master. Efter omstrappning fungerar alla.
Nu med denna Maxtor finns ingen klisterlapp men jag hittade texten MS på kretskortet och strappade där men den funkar inte. Är det bara en strapp?
Den har för övrigt likadan historia som TS disk. Det är dessutom också mitt första inlägg på SC. Har TS möjligen någon länk till diskens datablad?

Det sitter en lapp med streckkode där det står: Replace with Compaq Spare 8 4 GBHD [334719-001-001]

Edit: Det står visst på skylten att master on = J50 och där satte jag den ju. Konstigt att den inte går igång. Den snurrar på och den låter inte illa. Adapterns IDE-lampa tänds inte som på de andra diskarna.
Adaptern borde väl klara FAT32?
Hmm, adaptern passar bara XP och senare men filformat står det inget om.

Edit2:
I mitt fall hittas inte disken ens till skillnad mot TS. På en annan disk hittas en boot-partition med filformat ext3 (Linux) och en andra partition anges som Other.

Adaptern bryr sig nog inte om filsystemet på disken, det är bara en dum anslutning som förmedlar signalerna och det är upp till datorn att tolka den, däremot så måste den stödjas av drivrutinerna så det är nog därför det står xp, men prova från linux, det brukar vara bättre på sånt här.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av PeterNoster:

Jag sitter nu med en likadan disk och har denna adapter:
http://www.kjell.com/sortiment/dator-kringutrustning/datorkom...

I manualen till adaptern står att disken ska strappas som master.
Testade igenom ett antal IDE-diskar...ingen funka. Kollade manualen och såg att ingen disk var strappad som master. Efter omstrappning fungerar alla.
Nu med denna Maxtor finns ingen klisterlapp men jag hittade texten MS på kretskortet och strappade där men den funkar inte. Är det bara en strapp?
Den har för övrigt likadan historia som TS disk. Det är dessutom också mitt första inlägg på SC. Har TS möjligen någon länk till diskens datablad?

Det sitter en lapp med streckkode där det står: Replace with Compaq Spare 8 4 GBHD [334719-001-001]

Edit: Det står visst på skylten att master on = J50 och där satte jag den ju. Konstigt att den inte går igång. Den snurrar på och den låter inte illa. Adapterns IDE-lampa tänds inte som på de andra diskarna.
Adaptern borde väl klara FAT32?
Hmm, adaptern passar bara XP och senare men filformat står det inget om.

Edit2:
I mitt fall hittas inte disken ens till skillnad mot TS. På en annan disk hittas en boot-partition med filformat ext3 (Linux) och en andra partition anges som Other.

Inte säkert att adaptern fungerar med en så gammal disk. IDE diskar var uselt standardiserade tills UDMA 33/66 tiden och alla hade Master/Slave och Cable Select. Alla adaptrar jag vet kör min UDMA 33 eller 66, vilket jag inte tror den disken stöder fullt ut. Din disk är på gränsen i så fall.
Cable select beror på "kabeln" som du kopplar in, på en USB adapter så har jag märkt på gamla diskar att man ibland inte kan sätta master, utan måste sätta Cable Select ändå.
http://www.4drives.com/DRIVESPECS/MAXTOR/4878.txt (öppna den i webbläsaren)

Testa alla kombinationer en efter en, har du tur så fungerar den. Annars får du skaffa ett gammalt moderkort med äkta IDE och föra över sakerna på det sättet.

Trädvy Permalänk
Avstängd
Plats
Falköping
Registrerad
Jun 2008

Fyfan på den tiden man hade 4-5 IDE sladdar i datorn, och speciellt när man byggde datorn och skulle få alla jumprar rätt, så blev de inte rätt iallafall. Sen när de va så fel de kunde bli enligt teorin så va de enda sättet de funka på till slut, haha.

Corsair Obsidian 900D, Intel Core i7 6800k@4.2ghz/1.290v, Asus Rampage V Edition 10, Asus Strix GTX 1080, Corsair Vengeance LPX 3000mhz 4x4gb, Corsair RM650i

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av eparaggare:

Fyfan på den tiden man hade 4-5 IDE sladdar i datorn, och speciellt när man byggde datorn och skulle få alla jumprar rätt, så blev de inte rätt iallafall. Sen när de va så fel de kunde bli enligt teorin så va de enda sättet de funka på till slut, haha.

Skratta du, själv har jag fortfarande en IDE SSD i servern med IDE kabel och en IDE 80GB skräp/temp disk med SATA-IDE omvandlare i Windows 10 datorn (för att testa värsta fall scenario) och det funkar fint.
Dessutom har en del av de gamla fortfarande IDE kabel till DVDn.'

Jag har även nån 25kr USB2 -> 2,5" IDE adapter med lika olika gamla IDE laptop diskar för test OS. Har Windows 7 som körs från USB på dem, för att felsöka eller testa saker vid behov.