R9 280x ingen bild (lösning för Win/Linux)

Trädvy Permalänk
Medlem
Plats
Plats:
Registrerad
Mar 2011

R9 280x ingen bild (lösning för Win/Linux)

Har haft lite huvudvärk med ett nyinköpt 280x, men löste problemet och tänkte dela med mig lite info om det kan vara till hjälp för någon annan.

GPU: Asus DirectCU II R9 280x
Moderkort: MSI P67A-GD55 (B3)
CPU: 2500K (Sandy Bridge)

Vid uppstart efter montering gick datorn inte ens till POST. Fläktarna och hårddiskarna varvade upp, men det var allt. Ingen monitorsignal, ingen BIOS.

Lösningen var att uppdatera BIOS till en version som kan hantera Intel Management Engine 8 (Intel ME8). Se https://forum-en.msi.com/index.php?topic=176575.0
Den senaste stabila versionen av BIOS som har stöd för detta är 4.3, och finns på MSI's hemsida. Dock kommer den med Windows installer enbart (en stor .exe fil), och då jag kör Linux fick jag hitta en annan utväg. Om man blir medlem på MSI's forum får man tillgång till de experimentella beta-versionerna. https://forum-en.msi.com/index.php?topic=164135.msg1267825
Där laddade jag ner en BIOS image för version 4.43 (E7681IMS.443), vilken jag kunde installera med kommandot flashrom.

sudo flashrom -p internal -w E7681IMS.443 -o logfile.txt

Det ska sägas att det finns rapporter om att folk som har installerat 4.3 med Sandy Bridge processor som har fått problem. MSI själva rekommenderar bara att installera BIOS med Intel ME8 om man har Ivy Bridge, så jag var lite skeptisk. Beta-versionen fungarar iaf fint för mig hittills, men har inte provat att överklocka än.

Bör väl lägga till en disclaimer att detta görs givetvis på egen risk. Flasha BIOS kan förstöra ditt moderkort!

Trädvy Permalänk
Festpilot, Antiallo
David Kvist
Plats
Göteborg
Registrerad
Jun 2012
Skrivet av Mikael07:

Har haft lite huvudvärk med ett nyinköpt 280x, men löste problemet och tänkte dela med mig lite info om det kan vara till hjälp för någon annan.

GPU: Asus DirectCU II R9 280x
Moderkort: MSI P67A-GD55 (B3)
CPU: 2500K (Sandy Bridge)

Vid uppstart efter montering gick datorn inte ens till POST. Fläktarna och hårddiskarna varvade upp, men det var allt. Ingen monitorsignal, ingen BIOS.

Lösningen var att uppdatera BIOS till en version som kan hantera Intel Management Engine 8 (Intel ME8). Se https://forum-en.msi.com/index.php?topic=176575.0
Den senaste stabila versionen av BIOS som har stöd för detta är 4.3, och finns på MSI's hemsida. Dock kommer den med Windows installer enbart (en stor .exe fil), och då jag kör Linux fick jag hitta en annan utväg. Om man blir medlem på MSI's forum får man tillgång till de experimentella beta-versionerna. https://forum-en.msi.com/index.php?topic=164135.msg1267825
Där laddade jag ner en BIOS image för version 4.43 (E7681IMS.443), vilken jag kunde installera med kommandot flashrom.

sudo flashrom -p internal -w E7681IMS.443 -o logfile.txt

Det ska sägas att det finns rapporter om att folk som har installerat 4.3 med Sandy Bridge processor som har fått problem. MSI själva rekommenderar bara att installera BIOS med Intel ME8 om man har Ivy Bridge, så jag var lite skeptisk. Beta-versionen fungarar iaf fint för mig hittills, men har inte provat att överklocka än.

Bör väl lägga till en disclaimer att detta görs givetvis på egen risk. Flasha BIOS kan förstöra ditt moderkort!

Eller så är flashar från dos-liknande miljö och slipper alla risker som sker genom operativsystemets miljö.
Så vitt jag vet så är samtliga Assemble filer ROM eller Bin och fungerar ypperligt genom flashrom och således behövs varken medlemskap eller beta bios.

Synpunkter på min moderering? Kontakt:
| PM:a mig | Maila mig | PM:a Moderatorerna | Kontaktformuläret |
Testpilot, Skribent, Moderator & Geeks Gaming Huvudadmin
| Geeks Officiella Discord-server |
Forumregler

Trädvy Permalänk
Medlem
Plats
Plats:
Registrerad
Mar 2011
Skrivet av DavidtheDoom:

Eller så är flashar från dos-liknande miljö och slipper alla risker som sker genom operativsystemets miljö.
Så vitt jag vet så är samtliga Assemble filer ROM eller Bin och fungerar ypperligt genom flashrom och således behövs varken medlemskap eller beta bios.

Ja, med Linux kan det vara en bra ide att stänga ner X servern innan man kör flashrom.

Nu är det så att jag faktiskt har hämtat och kollat BIOS för alla Intel ME8 BIOS (v4.1, 4.2 och 4.3) för mitt moderkort, och inte bara plockar påståenden ur tomma luften. De är samtliga endast en windows .exe fil med ROM'et "inbakat". Annars skulle jag inte påstå att de är just .exe filer. Tidigare versioner utan Intel ME8 innehåller dock separat BIOS image. Möjligen kan man få tag på enbart ROM'et på annat håll än deras officiella site, men det har jag inte kollat.

http://www.msi.com/product/mb/P67AGD55.html#/?div=BIOS

Trädvy Permalänk
Festpilot, Antiallo
David Kvist
Plats
Göteborg
Registrerad
Jun 2012
Skrivet av Mikael07:

Ja, med Linux kan det vara en bra ide att stänga ner X servern innan man kör flashrom.

Nu är det så att jag faktiskt har hämtat och kollat BIOS för alla Intel ME8 BIOS (v4.1, 4.2 och 4.3) för mitt moderkort, och inte bara plockar påståenden ur tomma luften. De är samtliga endast en windows .exe fil med ROM'et "inbakat". Annars skulle jag inte påstå att de är just .exe filer. Tidigare versioner utan Intel ME8 innehåller dock separat BIOS image. Möjligen kan man få tag på enbart ROM'et på annat håll än deras officiella site, men det har jag inte kollat.

http://www.msi.com/product/mb/P67AGD55.html#/?div=BIOS

Det är så pass illa?
Till mina två brädor så har det funnits endast bios filerna + fristående nedladdning med windows installer. Riktigt dåligt av dem faktiskt.

Synpunkter på min moderering? Kontakt:
| PM:a mig | Maila mig | PM:a Moderatorerna | Kontaktformuläret |
Testpilot, Skribent, Moderator & Geeks Gaming Huvudadmin
| Geeks Officiella Discord-server |
Forumregler

Trädvy Permalänk
Medlem
Plats
Plats:
Registrerad
Mar 2011
Skrivet av DavidtheDoom:

Det är så pass illa?
Till mina två brädor så har det funnits endast bios filerna + fristående nedladdning med windows installer. Riktigt dåligt av dem faktiskt.

Det verkar faktiskt inte så illa ändå. Blev nyfiken och laddade ner BIOS för tre slumpvis valda moderkort ur den senaste uppsättningen. Alla hade separat BIOS image. Så antingen hade jag otur, eller så gör dom bara så för de äldre moderkorten av någon anledning.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2006

Lite förvånade att bios filen var en exe fil faktiskt, flesta moderkortsfabrikat har aldrig haft detta, samt också haft uppgraderingsverktyget inbyggt i bios själv, MSI har så numera också.

Dock att orsaken till problemet du hade med grafikkortet var ej uppdaterat bios var dock uppenbart.

Acer Predator Helios 300

Trädvy Permalänk
Medlem
Plats
Plats:
Registrerad
Mar 2011
Skrivet av ggustavsson:

Dock att orsaken till problemet du hade med grafikkortet var ej uppdaterat bios var dock uppenbart.

Inte för mig ! Jag blev först orolig att jag hade blivit blåst och köpt ett brick till begagnat grafikkort..