Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004

Gammal google

Av nån anledning ser google ut för mig som det gjorde för typ två år sen eller nåt, minst!
Varför är det så och vad kan man göra för att få bort det? -.-

Speciellt bildsöken är hemsk!
http://i.imgur.com/IvZ70Pf.png
Webläsaren är Opera 20.0.1387.91

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Feb 2012

Testat med annan webbläsare?

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004

I Chrome ser det rätt ut. Men jag vill använda Opera.

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Medlem
Plats
Eskilstuna
Registrerad
Jun 2013

Gamalt os eller webbläsare? Inte för att det borde bli nån skillnad

Dator: Fractal design arc xl---asus sabertooth r2.0---amd fx 8320 4.5ghz---16gb corsair vengeance---gtx770---corsair ax860i---dvd-brännare---2tb hdd.
Runt datorn har jag: cooler master inferno/razer deathadder respawn---cooler master 400 ceres---mad catz cyborg v5.
Släpbar: compaq presario cq56.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004

Nej, uppdaterad webläsare och OS:et är Windows 8.1

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Medlem
Plats
uddevalla
Registrerad
Sep 2007

Fan vad skönt säger jag, det där utseendet är ju snyggare och inte alls lika kluttigt
Hur gjorde du?

Spelburk: Fractal Design R4 * AMD Ryzen 1600X kyld av H80i V1 * ASUS GTX770 DCII * Corsair Vengeance LPX 16GB DDR4 2666MHz * ASUS PRIME B350-PLUS * EVGA Supernova G2 750W * 1TB HDD * Samsung EVO 250GB SSD
Tillbehör: Steelseries Rival 300 * SweC Qpad Musmatta * BenQ XL2411T 144hz * BenQ 24" * Qpad MK-50 * Hyper X Cloud *

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002

Har du inaktiverat Javascript, måhända? Så ser Google ut för mig i Opera, men det är för att jag medvetet inaktiverar Javascript .

Högerklicka på sidan, i Opera och kolla på "Edit Site Preferences" → "Scripting" → "Enable JavaScript". Ifall den är urbockad så är det svaret — aktivera och ladda om sidan. Om den redan är förbockad så kanske du har någon plugin som trilskas.

Jag kör Opera 12.16, så de kanske flyttat på sidinställningar och annat i sina fräsiga nya Operaversioner, men att det åtminstone har med att Javascript är inaktiverat att göra låter troligt.

Skrivet av lucifer579:

Fan vad skönt säger jag, det där utseendet är ju snyggare och inte alls lika kluttigt
Hur gjorde du?

När Google började sno tangentbordsfokus på söksidan så att tangentbordsnavigering i Opera inte längre fungerade, kombinerat med autosökning när textfältet ändrades, blev jag rätt irriterad. Då stängdes Javascript av på Googles sidor, och allt blev rent och användbart igen .

Just bildsökning kan vinna en del på deras Javascripttillägg, men vanliga sökningar är en annan femma.

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004

Aha...kan ha med detta att göra alltså?

EDIT: Nope, hände inget när jag lade google i exceptions...

Skrivet av lucifer579:

Fan vad skönt säger jag, det där utseendet är ju snyggare och inte alls lika kluttigt
Hur gjorde du?

Ingen aning, tyvärr, för jag vill inte ha det så här :/

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002
Skrivet av Loxus:

Aha...kan ha med detta att göra alltså?
http://i.imgur.com/8rAkwYC.png

EDIT: Nope, hände inget när jag lade google i exceptions...

Jag vågar närpå definitivt säga att det har att göra med att Javascript inte laddas på Googles domän. Exakt varför är nästa steg att lista ut.

Du har inte någon AdBlock, eller NoScript-liknande sak, eller reklamomdirigering i hosts-filen, eller … ? Fungerar det i andra webbläsare? I så fall har du lokaliserat problemet till just Opera, i alla fall.

Testa att högerklicka på sidan och välja "Inspect element" (om det nu finns kvar i din nya Operaversion). Du kan titta på fliken "Console" för att se om det dyker upp något felmeddelande, och på fliken "Scripts" för att se vilka som laddas. Om det står "This window has no runtime." så är Javascript inaktiverat i Opera. Står det något annat så laddar den åtminstone en delmängd av de Javascript som används.

En ytterligare möjlighet att testa att starta en ren browserprofil och se om det kvarstår. Om inte så ligger felet i din profil. Testa att rensa kakor och cache.

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004
Skrivet av phz:

Jag vågar närpå definitivt säga att det har att göra med att Javascript inte laddas på Googles domän. Exakt varför är nästa steg att lista ut.

Du har inte någon AdBlock, eller NoScript-liknande sak, eller reklamomdirigering i hosts-filen, eller … ? Fungerar det i andra webbläsare? I så fall har du lokaliserat problemet till just Opera, i alla fall.

Testa att högerklicka på sidan och välja "Inspect element" (om det nu finns kvar i din nya Operaversion). Du kan titta på fliken "Console" för att se om det dyker upp något felmeddelande, och på fliken "Scripts" för att se vilka som laddas. Om det står "This window has no runtime." så är Javascript inaktiverat i Opera. Står det något annat så laddar den åtminstone en delmängd av de Javascript som används.

En ytterligare möjlighet att testa att starta en ren browserprofil och se om det kvarstår. Om inte så ligger felet i din profil. Testa att rensa kakor och cache.

Inaktivering av adblock gör ingen skillnad.
Inget noscript mer än det jag visade ovan, men ställa in att den inte ska användas gjorde ingen skillnad.
Och ja, det är bara Opera problemet finns i.

Console säger:

Citat:

Opera has modified script or content on www.google.se (PATCH-1176, Navigation keys are not working on Google - hide Opera tag from userAgent for all sites). See browser.js for details VM37:64
Consider using 'dppx' units instead of 'dpi', as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: (min-resolution: 144dpi), (-webkit-min-device-pixel-ratio: 1.5)

Nån script-flik hittar jag inte? :S

Radera cookies gjorde ingen skillnad...
Får väl göra en helrensning..jobbigt...

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002
Skrivet av Loxus:

Console säger:

Det låter inte helt omöjligt att det skulle kunna vara relaterat, men allt detta verkar göra är att skriva om user-agent för att Google ska servera en annan variant av sin sida. Man kan faktiskt se den exakta filen som gör detta på Github: operasoftware / browserjs / OPRdesktop / browserjs-15.0.js (rad ~210).

Skrivet av Loxus:

Nån script-flik hittar jag inte? :S

Jag kör Opera 12.16, så jag vet inte hur det ser ut för dig, så det är inget konstigt om den saknas. Kanske det finns någon liknande motsvarighet, kanske inte.

Skrivet av Loxus:

Radera cookies gjorde ingen skillnad...
Får väl göra en helrensning..jobbigt...

Testa att starta Opera i en ny och ren profil (du måste inte ta bort din nuvarande). Ett sätt är att helt enkelt döpa om sin inställningsmapp till något annat temporärt, starta webbläsaren, testa om Google fungerar som du vill, stänga webbläsaren och ersätta den nygenererade inställningsmappen med den du sparat. Alternativt kan du leta efter hur man startar en ny profil i de nya Operaversionerna — tidigare gick det att göra med en kommandoradsswitch, men det kan ha ändrats nu.

Ett ytterligare alternativ är att det helt enkelt är en bugg i Opera (avvakta tills du testat med en ren profil, dock), varpå man kan rapportera det och hoppas på att de fixar det till en framtida release.

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004
Skrivet av phz:

Testa att starta Opera i en ny och ren profil (du måste inte ta bort din nuvarande). Ett sätt är att helt enkelt döpa om sin inställningsmapp till något annat temporärt, starta webbläsaren, testa om Google fungerar som du vill, stänga webbläsaren och ersätta den nygenererade inställningsmappen med den du sparat. Alternativt kan du leta efter hur man startar en ny profil i de nya Operaversionerna — tidigare gick det att göra med en kommandoradsswitch, men det kan ha ändrats nu.

Var hittar man den mappen?

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002
Skrivet av Loxus:

Var hittar man den mappen?

`~/.opera` i Linuxmiljö; vet inte i Windowsmiljö, men det låter googlingsbart. Troligen i mappstrukturen för din Windowsanvändarprofil, `userdata`, `Opera`, något sådant.

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Solna
Registrerad
Sep 2004
Skrivet av Loxus:

Inaktivering av adblock gör ingen skillnad.
Inget noscript mer än det jag visade ovan, men ställa in att den inte ska användas gjorde ingen skillnad.
Och ja, det är bara Opera problemet finns i.

Console säger:

Nån script-flik hittar jag inte? :S

Radera cookies gjorde ingen skillnad...
Får väl göra en helrensning..jobbigt...

Ta en titt längst ner på sidan, ska finnas en länk som heter "Switch to standard version". Den fixar ditt problem.
Har man redan standard versionen finns det en "Switch to basic" istället om man vill ha det äldre utseendet.

Asus Z170-A | i7 6700k | 16GB HyperX Fury | MSI r9 390x

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Okt 2008

Oj vad jag saknar att kunna ändra tidsspannet med en knapptryckning!

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Aug 2009

Saxat från google Groups

Opera is not a supported browser for Image search. This isn't a technical issue. It sounds like this is frustrating and I'm sorry for that, but it is indeed the status of Image search on Opera for the time being.

https://productforums.google.com/forum/#!topic/websearch/5RBC...

ASUS P9X79 | RX 580 | Corsair DDR3 XMS3 8x8Gb | Intel I7 3820 | 2x Samsung 840 Pro 256Gb + 1 Intel 520 256 + 1 Crucial M500 256Gb
DELL XPS 15 | I7 | 512GB | 16GB ram | 4K EYEFINITY

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002
Skrivet av orig_rejser:

Saxat från google Groups

Opera is not a supported browser for Image search. This isn't a technical issue. It sounds like this is frustrating and I'm sorry for that, but it is indeed the status of Image search on Opera for the time being.

https://productforums.google.com/forum/#!topic/websearch/5RBC...

Diskussionen är lite daterad (2012), och det fungerar i 12.16 för mig (om jag aktiverar Javascript, vill säga). Det skulle kunna vara så att Operas nyare versioner inte hanterar detta väl, men det känns som att det borde vara löst vid det här laget.

Länken jag skickade till Operas Githubkonto där de visade sina sitespecifika Javascriptändringar verkade tyder på att Opera automatiskt döljer sin user agent på alla Googles domäner (åtminstone i den versionen av läsare; kan ha ändrats sedan dess), så de borde serveras samma funktioner som andra läsare. Eftersom de använder Blink-motorn så borde stödet ej heller vara något problem rent tekniskt.

Opera är sällan explicit supportade, men då de är kompatibla med standarder så brukar saker fungera ändå. Problemet är att vissa sidor serverar andra versioner av sina filer för Opera om de ser deras "user agent"-sträng, så därför döljs den ofta. En ytterligare sak för trådskaparen att testa skulle kunna vara att maskera browsern som en annan läsare och se om något ändras.

Historiskt sett så exempelvis blockade exempelvis Microsoft Opera helt och hållet från MSN ett kort tag. Sedermera gavs de access igen, och de lovade att inte göra om något sådant. Något år senare så gavs Opera felaktiga CSS-regler för msn.com så att sidan såg icke-fungerande ut (trots att Opera rent tekniskt kunde rendera samma CSS som IE). Det fixades och lovades att inte göras om. Sedan förstördes Hotmail för Operaanvändare, etc. . Google har mig veterligen ingen historik av att explicit vilja stänga ute någon läsare, och det fungerar som sagt på min äldre Operainstallation, så i detta fall tror jag än så länge att det beror på något tekniskt problem på trådskaparens sida. Kanske "Switch to basic version" längst ner på sidan kan ha råkat tryckas som någon nämner, men det låter märkligt att göra detta av misstag.

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Aug 2009
Skrivet av phz:

Diskussionen är lite daterad (2012), och det fungerar i 12.16 för mig (om jag aktiverar Javascript, vill säga). Det skulle kunna vara så att Operas nyare versioner inte hanterar detta väl, men det känns som att det borde vara löst vid det här laget.

Brukar kolla datum, man ska inte trött-posta på internet, snart kommer robert.
Men vad har opera för problem med sådant egentligen när det inte är första gången, googlar man lite till så kommer flera gånger liknande problem vid olika tillfällen. Nu verkar den ju bara slå till Classic mode, men ändå.

ASUS P9X79 | RX 580 | Corsair DDR3 XMS3 8x8Gb | Intel I7 3820 | 2x Samsung 840 Pro 256Gb + 1 Intel 520 256 + 1 Crucial M500 256Gb
DELL XPS 15 | I7 | 512GB | 16GB ram | 4K EYEFINITY

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004
Skrivet av phz:

`~/.opera` i Linuxmiljö; vet inte i Windowsmiljö, men det låter googlingsbart. Troligen i mappstrukturen för din Windowsanvändarprofil, `userdata`, `Opera`, något sådant.

Hittade inte via google, men på opera://about fanns det
EDIT: Trodde jag...står att det ska vara den här mappen, men var?

EDIT2: Gjorde så att jag helt enkelt bytte namn på hela mappen. Ny profil, ingen skillnad. -.-

Skrivet av AcidStorm:

Ta en titt längst ner på sidan, ska finnas en länk som heter "Switch to standard version". Den fixar ditt problem.
Har man redan standard versionen finns det en "Switch to basic" istället om man vill ha det äldre utseendet.

Finns ingen sådan länk

Skrivet av orig_rejser:

Saxat från google Groups

Opera is not a supported browser for Image search. This isn't a technical issue. It sounds like this is frustrating and I'm sorry for that, but it is indeed the status of Image search on Opera for the time being.

https://productforums.google.com/forum/#!topic/websearch/5RBC...

Det funkade förut (tills några dagar före jag skapade tråden).

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004

Har också funderat på, mest tack vare tråden, om det har med en java-uppdatering att göra...det KAN vara så att jag uppdaterade java i samband med att google fulade sig.

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002
Skrivet av orig_rejser:

Brukar kolla datum, man ska inte trött-posta på internet, snart kommer robert.
Men vad har opera för problem med sådant egentligen när det inte är första gången, googlar man lite till så kommer flera gånger liknande problem vid olika tillfällen. Nu verkar den ju bara slå till Classic mode, men ändå.

Problemet är ofta att olika webbläsare tolkar saker lite olika. Det var ett massivt mycket större problem förr, av olika anledningar, men fortfarande skrivs sidor för att fungera med dessa äldre versioner av webbläsare, och även idag finns det små egenheter hos olika läsare.

När en läsare ber om en sida som skickar de med en identifikationstagg, en user agent string. Programmerare låter sina skript titta genom denna, och om de typ hittar "Internet Explorer" så tänker de "aha! Internet Explorer ska få denna fil", osv. Problemet med läsare med små marknadsandelar så som Opera är att de ofta inte är med i dessa kontroller, och får då ibland i stället någon "fallbackversion" av skripten, som kanske inte fungerar riktigt som de ska.

Egentligen så borde programmerare (åtminstone idag) generellt i stället fråga webbläsaren om den stöder en viss funktion och agera därefter, så slipper alla bry sig speciellt mycket om identifikationstaggar. Problemet förvärras av att läsare känner sig tvungna att medvetet ljuga om sina taggar för att få rätt version för att webbprogrammerare använder dåliga identifikationstekniker. I kort så är det en massiv soppa.

Den fil från Operas Github jag länkade tidigare var egentligen bara en mängd regler som Opera kodat in i själva läsaren för att användaren inte ska märka så mycket och behöva lista ut vilka sidor som man behöver "ljuga" för. På Googles sidor så plockar Opera automatiskt helt enkelt bort den del av sin tagg som säger att de är Opera, i förhoppningen att de i stället ska få samma skript som exempelvis Firefox eller Chrome får, för som regel har de inga problem att tolka dessa. Samtidigt så försöker andra browsers helgardera och kalla sig för alla browsers samtidigt, mer eller mindre. Detta är en faktisk sådan sträng från en standardinstallation av en viss webbläsare; gissa vilken:

"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1933.0 Safari/537.36"

OK, så den säger att den är "Mozilla", vilket är företaget bakom Firefox, men sedan att den använder "AppleWebKit", vilket är motorn bakom Safari, och specificerar detta till "KHTML" vilket är grunden till WebKit, och säger att den är som "Gecko", vilket återigen är Firefoxmotorn, och sedan kallar den sig "Chrome", och sedan "Safari". Vad — i — glödheta …? Strängen har utvecklats till att bli något annat än en identifikationssträng och är nu snarare en sträng som annonserar vilka saker läsaren är kompatibel med, men, tja. Kaos.

Opera var länge en av de få browsers som inte började med att kalla sig "Mozilla/5.0" utan faktiskt sa "Opera" som standard, men sedan något år har de helt skrotat detta och kallar även sig själva för "Mozilla" till en början. De har bytt ut "Opera" mot "OPR", men som sågs innan så tog de även bort denna del av sin agentsträng från många sidor.

Situationen är alltså inte helt lysande, och när sedan webbsidor ändrar sitt innehåll samtidigt som läsare implementerar egna fixar så ser man snabbt att dessa lösningar mest genererar ett kaos för alla parter, men så är helt enkelt läget på vår kära webb .

———

Just om det är användaragentproblem här eller lokala inställningar vet jag inte. Jag har använt Opera i väldigt många år och gör det fortfarande, men Opera har inte bjudit in mig till deras omskrivning av webbläsaren som de började för något år sedan, så jag är kvar på 12.16 .

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2013

Har samma sak xD Fick idag, använder Maxathon

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004

Intressant...både Opera och Maxthon (heter den va? ) använder Blink.

Senast redigerad av Loxus, 2004-08-02 klockan 13:13

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2004

En annan intressant sak, google translate har det rätta utseendet...
http://i.imgur.com/dECHybl.png

EDIT: Console säger:
Opera has modified script or content on translate.google.se (PATCH-1148, Google Translate: use flash instead of mp3-audio). See browser.js for details VM169:64
Opera has modified script or content on translate.google.se (PATCH-1176, Navigation keys are not working on Google - hide Opera tag from userAgent for all sites). See browser.js for details VM169:64
Uncaught TypeError: Cannot convert undefined or null to object desktop_module_main.js:48
Consider using 'dppx' units instead of 'dpi', as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: (min-resolution: 144dpi), (-webkit-min-device-pixel-ratio: 1.5)

Senast redigerad av Loxus, 2004-08-02 klockan 13:13