Hittar inte sda vid Linux installation

Permalänk
Medlem

Hittar inte sda vid Linux installation

Hej alla Linux Lovers.

Jag har försökt att installera Linux paralellt med min W8.1 installation, men det har inte gått så bra. Jag har bränt ut disten på en DVD och bootar ifrån den. När jag sedan vill installera den så hittar inte Gparted min primärdisk (sda) i listan, enbart min sekundära hårddisk. Den finns med i listan över var den skall placera startmedia, men inte i partitionstabellen. Jag har provat med några olika distar, Mint, Ubuntu och Debian med samma problem.

Provade att skapa en tom partition på min primärdisk, fungerar inte. Formatterade den som FAT och NTFS, fungerade inte heller. Har inte kunnat hitta någon inställning i BIOS som fungerar. Den hittar alla diskar och hårdvara i Linux Live, men inte själva partitionen jag skapat för att lägga det på.

Hårdvara:

Asus P6T Deluxe v2
Intel i7 950
6Gb Corsair Dominator
Sapphire Radeon 7850
500Gb primär HDD
1.5Tb sekundär HDD

Om någon har något tips så vore det extremt uppskattat, har inte lyckats hitta någon lösning via Google heller...

Permalänk

Vilken distribution?

Kör kommandot lsblk -f i terminalen och posta output.

Permalänk
Medlem
Skrivet av Baba Tong:

Vilken distribution?

Kör kommandot lsblk -f i terminalen och posta output.

HAr som sagt provat olikka, senast Ubuntu 14.04. Kunde inte hitta terminalen i live sessionen. Dock så kom det upp ett felmeddelande när jag skulle mounta min HDD, det stod något om snabbstart i windows. Ska försöka stänga av det och se om det fungerar.

Permalänk
Medlem

Om du har en GPT-partitionstabell har det nog med det att göra?

Permalänk
Medlem

Detta får jag fram:

ubuntu@ubuntu:~$ lsblk -f
NAME FSTYPE LABEL MOUNTPOINT
sda
├─sda1
└─sda2
sdb
└─sdb1
sr0 iso9660 Ubuntu 14.04 LTS amd64 /cdrom
sr1
loop0 /rofs
ubuntu@ubuntu:~$

Vet inte vad GPT betyder? Funkar inte att installera nu heller, efter att ha tagit bort fastboot...

edit: Kollade upp vad GPT betyder, enligt Diskpart har jag inte det aktiverat.

Permalänk
Skrivet av netbuddy:

Detta får jag fram:

ubuntu@ubuntu:~$ lsblk -f
NAME FSTYPE LABEL MOUNTPOINT
sda
├─sda1
└─sda2
sdb
└─sdb1
sr0 iso9660 Ubuntu 14.04 LTS amd64 /cdrom
sr1
loop0 /rofs
ubuntu@ubuntu:~$

Vet inte vad GPT betyder? Funkar inte att installera nu heller, efter att ha tagit bort fastboot...

edit: Kollade upp vad GPT betyder, enligt Diskpart har jag inte det aktiverat.

Det ser ut som att systemet inte känner av partitionerna på hårddiskarna. Har du testat att i Windows 8 krympa Windows-partitionen till den storlek du vill att den ska ha och sen radera alla andra partitioner. Du borde då kunna skapa dem med verktyg som Gparted istället.

Permalänk
Medlem
Skrivet av Baba Tong:

Det ser ut som att systemet inte känner av partitionerna på hårddiskarna. Har du testat att i Windows 8 krympa Windows-partitionen till den storlek du vill att den ska ha och sen radera alla andra partitioner. Du borde då kunna skapa dem med verktyg som Gparted istället.

Nja, den ser ju sda1 och sda2, vilket är de 2 partitioner jag har vid det tillfället. Krympte min C disk så att jag hade en tom partition med oallokerat utrymme. Jag har inte tagit bort några andra partitioner, det kan jag inte göra. Det jag möjligen kan göra är att fysiskt koppla ur min sekundära hårddisk. Ser inte hur det skulle hjälpa dock, den borde kunna hitta sda hursom...

Jag vill verkligen få detta att fungera, har mycket tid att slösa på detta nu och jag tycker sånt här är skoj. I allra värsta fall så får jag helt enkelt skapa en tom partition på sdb, men nog fan ska den kunna hitta sda i vilket fall som helst...?

edit: Förresten, hur kan jag använda Gparted när jag bootar från skivan? Finns det inlagt i Live disten? Dessutom är jag osäker på hur den kan hitta disken när inte installationsprogrammet gör det.

Permalänk
Skrivet av netbuddy:

Nja, den ser ju sda1 och sda2, vilket är de 2 partitioner jag har vid det tillfället.

Du har naturligtvis rätt. Vad jag menade och borde ha skrivit är att den inte känner av filsystemen på partitionen. Även om det är ett Windows-filsystem så borde det kännas av.

Citat:

Krympte min C disk så att jag hade en tom partition med oallokerat utrymme. Jag har inte tagit bort några andra partitioner, det kan jag inte göra.

Precis, allt som inte Windows använder ska vara oallokerat.

Citat:

Det jag möjligen kan göra är att fysiskt koppla ur min sekundära hårddisk. Ser inte hur det skulle hjälpa dock, den borde kunna hitta sda hursom...

Tror inte heller det skulle göra någon skillnad.

Citat:

Jag vill verkligen få detta att fungera, har mycket tid att slösa på detta nu och jag tycker sånt här är skoj. I allra värsta fall så får jag helt enkelt skapa en tom partition på sdb, men nog fan ska den kunna hitta sda i vilket fall som helst...?

edit: Förresten, hur kan jag använda Gparted när jag bootar från skivan? Finns det inlagt i Live disten? Dessutom är jag osäker på hur den kan hitta disken när inte installationsprogrammet gör det.

När du laddar in tex en Ubuntu Live-dist så borde Gparted ingå, annars kan man installera det genom pakethanteraren.

Egentligen så borde du kolla upp partitioneringsverktyg för terminal istället, det är mycket möjligt att det är ett problem med gparted/installeraren . Du kan öppna upp ett terminalemulatorfönster i livedisten också. Om disken använder MBR så är det kommandot fdisk som gäller, för GPT gdisk. Googla dessa för lite mer info kanske.

Permalänk
Medlem
Skrivet av Baba Tong:

Du har naturligtvis rätt. Vad jag menade och borde ha skrivit är att den inte känner av filsystemen på partitionen. Även om det är ett Windows-filsystem så borde det kännas av.

Nej, det verkar inte som att den gör det. Bara så skumt, har ju haft Linux parallelt med Windows tidigare, fast då W7 istället. Vet inte om det är någon skillnad i diskhantering eller liknande på W8... Har ju även som sagt provat att ta bort fastboot, vilket gör att jag nu kan komma åt alla diskarna i filhanteraren, men inte i installationen... skitirriterande...

Citat:

Precis, allt som inte Windows använder ska vara oallokerat.

Tror inte heller det skulle göra någon skillnad.

När du laddar in tex en Ubuntu Live-dist så borde Gparted ingå, annars kan man installera det genom pakethanteraren.

Egentligen så borde du kolla upp partitioneringsverktyg för terminal istället, det är mycket möjligt att det är ett problem med gparted/installeraren . Du kan öppna upp ett terminalemulatorfönster i livedisten också. Om disken använder MBR så är det kommandot fdisk som gäller, för GPT gdisk. Googla dessa för lite mer info kanske.

Ska kolla lite mer på partitioneringsverktygen. Har enligt Windows inte GPT, så jag antar att det är MBR då. Funderade på om det kan ha något att göra med hur den är konfad i BIOS? Har diskarna som IDE just nu, inte AHCI. Borde förvisso inte spela någon roll? Vet förresten inte ens om GPT fungerar på denna datorn, den är ju inte direkt ny

Ska försöka mecka lite senare som sagt, i absolut värsta fall får jag försöka allokera utrymme på sekundär disken, fast helst inte.

Permalänk
Skrivet av netbuddy:

Du stängde av fastboot men har du stängt av secureboot? Har för mig att vissa ubuntu versioner hade stöd för secureboot men vet inte om det gäller alla eller bara vissa.

Sedan så kanske den ville du skulle köra checkdisk för att fixa en sak i NTFS innan installationen. Sedan bör du ta bort den tomma partitionen och låta Ubuntu skapa nya. Helst en för root och en för home.

Permalänk

Testa avsluta w8 ordentligt innan installation... Orkar inte kolla nu på mobilen men googla så hittar du nog

Skickades från m.sweclockers.com

Permalänk
Medlem
Skrivet av Commander:

Du stängde av fastboot men har du stängt av secureboot? Har för mig att vissa ubuntu versioner hade stöd för secureboot men vet inte om det gäller alla eller bara vissa.

Sedan så kanske den ville du skulle köra checkdisk för att fixa en sak i NTFS innan installationen. Sedan bör du ta bort den tomma partitionen och låta Ubuntu skapa nya. Helst en för root och en för home.

Är inte säker på att jag har stängt av secureboot, har googlat mig galen så jag kommer inte ihåg om jag lyckats med det. Ska testa igen imorrn. Ska jag köra chkdisk innan jat bootar Linux? Vill helst ha en tom partition så jag inte råkar sopa hela C:, det har hänt förr...

edit: Är secure boot bara för UEFI? I så fall har jag inte den möjligheten, X58 moderkort är för gammalt för det.

Skrivet av freddan83:

Testa avsluta w8 ordentligt innan installation... Orkar inte kolla nu på mobilen men googla så hittar du nog

Skickades från m.sweclockers.com

Jo, det är ju fastboot som ordnar det, det är avstängt.

Permalänk
Medlem

Update, lyckades hita en lösning här:
http://ubuntuforums.org/showthread.php?t=2003675

Installerar nu och hoppas på att Windows fortfarande fungerar efteråt