Surfa över VPN går inte - vad är det för fel?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2007

Surfa över VPN går inte - vad är det för fel?

Jag försöker koppla upp mig via en VPN-anslutning till mitt hemnätverk, för att komma åt utdelade nätverksdiskar. Det fungerar, men när VPN-anslutningen är uppe så går det inte att surfa. Vad kan det vara för fel?

Klient: Windows 8, ansluten till Internet via ett annat företags nätverk.
- VPN-klient: Windows inbyggda.
Router hemma hos mig: Asus RT-AC66U
- Enable PPTP-server: Yes
- Network place (Samba) support: Yes
- Broadcast support: both
- Authentication: Auto
- Connect to DBS server automatically: Yes
- Connect to WINS server automatically
- Client IP adress (VPN adress scope): 192.168.10.2-11 [Överlappar inte vanliga DHCP-scopet]
- Under WAN Settings har jag NAT Passthrough On för PPTP, L2TP, Ipsec, RTSP, H.323, och SIP. PPoE Relay är Off.

* När jag ansluter till VPN:et så fungerar inloggningen.
* Sedan kan jag browse:a mitt interna nät ("\\servernamn\" i Win Explorer) och t.ex. kopiera filer därifrån.
* Men jag kan inte surfa på nätet, jag får "den här websidan är inte tillgänglig"

På klienten har jag fått IP 192.168.0.19 i den trådlösa adaptern med default gateway 192-168-0.1.
Och 192.168.10.2 från PPP-"adaptern".
Men den har default gateway="0.0.0.0", vilket väl är det som orsakar problemet antar jag.

Jag kan tänka mig två lösningar:
1. På nåt sätt routa internet-trafiken över den trådlösa adaptern i stället för över VPN:et.
2. Ordna så routningen genom hemmaroutern fungerar, och då är det väl först och främst default gateway som behöver fixas.

Men jag vet inte hur jag gör någon av dem - jag är helt rudis på VPN.

Trädvy Permalänk
Moderator
Registrerad
Aug 2007
Skrivet av peterhjalmarsson:

Jag försöker koppla upp mig via en VPN-anslutning till mitt hemnätverk, för att komma åt utdelade nätverksdiskar. Det fungerar, men när VPN-anslutningen är uppe så går det inte att surfa. Vad kan det vara för fel?

Klient: Windows 8, ansluten till Internet via ett annat företags nätverk.
- VPN-klient: Windows inbyggda.
Router hemma hos mig: Asus RT-AC66U
- Enable PPTP-server: Yes
- Network place (Samba) support: Yes
- Broadcast support: both
- Authentication: Auto
- Connect to DBS server automatically: Yes
- Connect to WINS server automatically
- Client IP adress (VPN adress scope): 192.168.10.2-11 [Överlappar inte vanliga DHCP-scopet]
- Under WAN Settings har jag NAT Passthrough On för PPTP, L2TP, Ipsec, RTSP, H.323, och SIP. PPoE Relay är Off.

* När jag ansluter till VPN:et så fungerar inloggningen.
* Sedan kan jag browse:a mitt interna nät ("\\servernamn\" i Win Explorer) och t.ex. kopiera filer därifrån.
* Men jag kan inte surfa på nätet, jag får "den här websidan är inte tillgänglig"

På klienten har jag fått IP 192.168.0.19 i den trådlösa adaptern med default gateway 192-168-0.1.
Och 192.168.10.2 från PPP-"adaptern".
Men den har default gateway="0.0.0.0", vilket väl är det som orsakar problemet antar jag.

Jag kan tänka mig två lösningar:
1. På nåt sätt routa internet-trafiken över den trådlösa adaptern i stället för över VPN:et.
2. Ordna så routningen genom hemmaroutern fungerar, och då är det väl först och främst default gateway som behöver fixas.

Men jag vet inte hur jag gör någon av dem - jag är helt rudis på VPN.

Jag kör enligt punkt 2.

Jag tror att du behöver ange gateway och dns i din VPN-server för att få det att funka. Så har jag behövt göra i min VPN-server.

Använd gilla för att markera nyttiga inlägg!

Trädvy Permalänk
Medlem
Plats
A.ROOT-SERVERS.NET
Registrerad
Jul 2001

Hur fungerar det om du tar bort bocken till "Use default gateway on remote network" under inställningarna advanced TCP/IP Settings på VPN-klienten?

Medlem #14

CISSP, MCT,MCITP, MCSE+Security, MCSE+Messaging, Inet+, Network+,MCT, MCP,CNA, CCA, CCNA, A+

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Aug 2007

@JenzA: då går det att surfa, men inte browse:a nätet. Men tack för att du visade att det fanns en virtuella adapter att pilla på:
jag provade att manuellt knappa in Googles DNS 8.8.8.8 i VPN-adaptern, och nu verkar det fungera. Eftersom jag använder WINS för datornamnen intern i hemmanätverket så lär det fortsätta att fungera bra, även om det säkert inte är den mest eleganta metoden.

Jag tar gärna emot förslag på bättre lösningar!

Edit: @giplet: det finns inga sådana inställningar i routerns DNS-server tyvärr. De inställningar jag listade är alla som finns.

Trädvy Permalänk
Geeks Gaming
Registrerad
Aug 2006

Routern bör ju tilldela dom sakerna automatiskt, kontrollera att GW, DNS etc står på WAN. Men om dom inte gör det redan så borde det vara problem för dom lokalt kopplade datorerna också.