ASUS RT-AC66U Remote Desktop problem

Trädvy Permalänk
Medlem
Plats
Lkpg
Registrerad
Jan 2003

ASUS RT-AC66U Remote Desktop problem

Hej, jag känner att jag har provat det mesta själv nu och vänder mig därför mot eliten för att se om någon har några fler tips innan router antingen 1: åker I väggen eller 2: tillbaka till återförsäljare.

Jag har en uppsättning hemma med en Netgear WNR2000, 1 stycken laptop ( windows 8 ) , 1 stycken stationär (server) windows 7 samt en LG Tv55"

Med denna uppsättning har jag inte haft några som helst problem under 4 års tid. TVn ansluter till Plex server I Win 7 maskinen, laptopen accessar win 7 maskinen via RDP och för filer etc. Windows 7 maskinen star utan skärm och aggerar således bara som en "server" . Jag kör även en FTP server + RDP externt via port forwarding ( på WIN7 maskinen utan problem)

Jag bestämde mig sedan I förra veckan att byta ut med WNR mot en ASUS RT-AC66U eftersom den såg rätt så spännande ut ( och jag bevöer giga på WAN).
Sagt och gjort så slog jag till.

Här börjar problemen:

Uppsättningen går utan problem och allt verkar fungera. Routern kör DHCP och alla datorer får adresser, plex spelar på TVn mot win 7 maskinen osv. dvs. allt fungerar som det ska. UTOM 1 sak.
RDP. Vad jag än vrider och vänder på får jag inte RDP mot win 7 maskinen att fungera ( vare sig lokalt eller externt)

Jag har testat följande:
Flashat om router till Merlin firmware
Öppnat för port forward (3389)
stängt av brandvägg I windows 7 samt I Asusen
Kollat alla policys på win 7 maskinen och sett till att alla typer av äldre RDP är ok
bytt IP på hela nätet till den gamla adress rangen
provat från mobil enhet + padda ( om det skulle vara ngt med win 8 klienten)
kollat I loggarna på routern ( ser att extern trafik kommer till router men sen inte kan gå in I 3389 på server)
Letat I loggarna på win 7 maskinen utan att egentligen hitta något.
testat att koppla in den gamla routern och pang så fungerar allt précis som vanligt...

Om någon har ett tips på vad mer jag bör testa innan jag gör något drastiskt så är ni mer än välkomna!

Mvh

Kevin

Mycket mumbo-jumbo nu känner jag.

Trädvy Permalänk
Medlem
Registrerad
Maj 2014

Vad är det du vill göra? Öppna för RDP från internet genom routern? Jag misstänker att det är vad du vill åstadkomma även om det inte står uttryckligen.
Hade inte ASUS någon form av VPN? Det kan vara lätt att sätta upp och dessutom får du det extremt mycket säkrare än det helt okrypterade remote desktop-protokollet?

Trädvy Permalänk
Medlem
Plats
Kristianstad
Registrerad
Maj 2011

Om du kollar portforward-inställningarna i den gamla routern, vilken port är då öppen mot Win7-maskinen?

Trädvy Permalänk
Medlem
Plats
Hässleholm
Registrerad
Feb 2005

Är det enbart internt så ska inga portöppningar behövas.
Är det nya nätverket satt på samma typ som det gamla?

"Hem/Privat, Företag" och vad de nu heter.

[ Corsair 460X ] [ Corsair HX750i ] [ AMD Ryzen 2700X ] [ Asus 1080 ROG Strix ] [ Asus Crosshair VI Hero]
[ 16GB G.Skill FlareX CL14 3400Mhz DDR4 ] [ Samsung 960 EVO 500GB + Samsung 850 Pro 256GB ] [ Logitech G933 ] [ Corsair H115i ] [ Win10 x64 Pro ] 3dMark 19.263p CPU-Z

Trädvy Permalänk
Medlem
Registrerad
Apr 2003

Hej!
Eftersom du provar (utan lyckat resultat) även internt så har jag ett par frågor som vi kan börja med.

FTP fungerar från din Win8 klient mot Win7 precis som tidigare?
Om det är så, så ligger problemet ej i lager 2 och vi kan börja felsöka L3.

Om du sniffar paket på Windows 7 maskinen när du försöker ansluta mot den från din Win8. Får du fram någon trafik då som är relevant? Dvs, kommer paketen fram?

Jag förutsätter att alla sitter på samma nät(?) så att ingen Routing behövs?
Andra tjänster (förutom ftp) fungerar bra?

mmm

Trädvy Permalänk
Medlem
Plats
Lkpg
Registrerad
Jan 2003

Tack för alla svar. lite förtydliganden nedan.

Steg 1 är ju att få RDP att fungera Internt. ( externt kan vänta eftersom det inte är någon mening att titta på det nu)
filbrowsing/Plex media GW mellan win8 och win7 fungerar bra, FTP har jag inte testat tyvärr.

Allt sitter på samma nät dvs. Win7 in I routern (asus) med kabel och win 8 kör wifi TV kör kabel.

VPN körde jag tidigare via WIN7 men tänkte nu att köra direct I Asus router och det fungerar bra ( dock går det itne att ansluta till RDP efter lyckad VPN länkning, men det är steg )

Vad jag kan se kommer Inga paket fram till win 7 maskinen, men jag kollade bara med netstat kanske måste sniffa med ngt annat?

Tack för alla svar hoppas att vi kan knäcka denna nöt!

Mycket mumbo-jumbo nu känner jag.

Trädvy Permalänk
Medlem
Registrerad
Apr 2003

Testa med t.ex wireshark. Då kan vi se om några paket kommer fram eller om dessa stannar i din Router/AP.

HIttade ett longshot från någon som, liksom du bytte Router där det tidigare fungerade.

Citat:

"In Windows Firewall (on the WIN8 desktop), first make sure that Remote Desktop is enabled. to do this, open Windows Firewall from the Control Panel, select (on the left hand side of links) "Allow an app or feature through the Window firewall", then check the box next to "Remote Desktop". (I needed to do this even with the DD-WRT router). Then click the back arrow to go back to the main Windows Firewall page and select (again, on the left side links) "Advanced setings". Select "Inbound Rules" on the left and scroll down to "Remote Desktop - User Mode" You should see four entries (TCP Domain Private, TCP Public, UDP Domain Private, and UDP Public). On mine, only TCP Domain Private and UPD Domain Private were enabled. Enabling TCP Public and UDP Public fixed my problem. RDP now works through the Asus RT-AC66U router."

mmm

Trädvy Permalänk
Medlem
Plats
Lkpg
Registrerad
Jan 2003
Skrivet av yoggan:

Testa med t.ex wireshark. Då kan vi se om några paket kommer fram eller om dessa stannar i din Router/AP.

HIttade ett longshot från någon som, liksom du bytte Router där det tidigare fungerade.

Testat att stänga av hela Win FW. samt att jag nu har godkänt för alla typer av RDP utan lycka.

Tack iaf.

Då får jag testa med WireShark. är lite bökigt iom att jag inte har ngn. skärm till win 7 datorn

Mycket mumbo-jumbo nu känner jag.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2002

Det enda du skall behöva göra är att öppna upp port 3389 (rdp-default) för din maskins IPv4-adress (ex: 192.168.1.5). I en Asus-router med grafiskt gränssnitt görs detta under WAN-->Portvidarebefordran.

Vilken port RDP ska lyssna på kan ändras i regedit (Registret): Leta upp och klicka på följande registerundernyckel:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber.

Behöver du kolla att porten är öppen kan du göra det med: http://canyouseeme.org/ eller kommandot netstat i cmd.

: Asus Prime Z270, i7 7700K@4,9, Corsair H115, 16GB RAM, Samsung 960, 980 Ti
: Asus Sabertooth Z77, i5 3570K@4,9GHz, Corsair H70, 16GB RAM, 660 Ti x2
: Debian Linux@AMD X2 2,6GHz, 4GB RAM, Asus G210, 10TB WD Green(RAID1)
: Xp-m 2400@4100+, Duron 600@1GHz, K6-2 300@375MHz, P75MHz, sHg 8000, Acer 5930G (all R.I.P).

Trädvy Permalänk
Medlem
Plats
Lkpg
Registrerad
Jan 2003
Skrivet av Xorcist:

Det enda du skall behöva göra är att öppna upp port 3389 (rdp-default) för din maskins IPv4-adress (ex: 192.168.1.5). I en Asus-router med grafiskt gränssnitt görs detta under WAN-->Portvidarebefordran.

Vilken port RDP ska lyssna på kan ändras i regedit (Registret): Leta upp och klicka på följande registerundernyckel:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber.

Behöver du kolla att porten är öppen kan du göra det med: http://canyouseeme.org/ eller kommandot netstat i cmd.

Problemet är ju att det inte ens funkar I det lokala nätet och RDP lyssnar på 3389 eftersom det funkar utmärkt när jag ansluter via min gamla router (bade internt och externt) mot 3389.

Mycket mumbo-jumbo nu känner jag.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2002

Kan du pinga mottagaren, så ska du även kunna ansluta till den. Om du använder Win 8 så kan du börja med att sluta använda det.

: Asus Prime Z270, i7 7700K@4,9, Corsair H115, 16GB RAM, Samsung 960, 980 Ti
: Asus Sabertooth Z77, i5 3570K@4,9GHz, Corsair H70, 16GB RAM, 660 Ti x2
: Debian Linux@AMD X2 2,6GHz, 4GB RAM, Asus G210, 10TB WD Green(RAID1)
: Xp-m 2400@4100+, Duron 600@1GHz, K6-2 300@375MHz, P75MHz, sHg 8000, Acer 5930G (all R.I.P).

Trädvy Permalänk
Medlem
Plats
Lkpg
Registrerad
Jan 2003
Skrivet av Xorcist:

Kan du pinga mottagaren, så ska du även kunna ansluta till den. Om du använder Win 8 så kan du börja med att sluta använda det.

Som sagt ping, Fileshare, Plex etc. fungerar bra. Endast RDP som inte fungerar. Nu kör jag windows 8 och det har fungerat bra tidigare så det var inte riktigt vägen jag tänkte ta bara för att jag köpt en ny router.

FYI har jag även testat från MacOS och Ubuntu med samma resultat så jag tror inte det är Win8 det är fel på I detta samanhang.

Mycket mumbo-jumbo nu känner jag.

Trädvy Permalänk
Medlem
Registrerad
Nov 2005

Jag hade samma problem tidigare som du (fast i lite annan skepnad, jag kunde inte köra RDP till min Win7)

Jag löste problemet lite som Alexander den store och den Gordiska knuten...

Jag installerade TeamViewer på burkarna istället!

Eftersom "Microsoftteknikerna" som ringer från Indien och vill "hjälpa" dig ibland använder TeamView borde det ju även fungera för hemmabruk

Du slipper för övrigt göra någon port forwarding i routern.

Trädvy Permalänk
Medlem
Plats
Lkpg
Registrerad
Jan 2003

Jag kan meddela att jag har lyckats att lösa problemet. Eller rättare sagt så löste problemet sig själv.

Efter att ha skapat en helt ny ren profil på windows 7 datorn och tagit bort alla VPN tunnel inställningar så ville det fungera... Funkar kanon bade externt och internt nu, WOL , FTP osv osv.

tack för all hjälp

Mycket mumbo-jumbo nu känner jag.