Problem installera grafikkort

Permalänk
Medlem

Problem installera grafikkort

Hej alla Linuxkunniga!

Fram tills nu har jag kört med integrerad grafik på min Mint-burk (Cinnamon) men nu har jag lagt vantarna på ett GTX750Ti som jag vill använda istället. När jag helt sonika stoppade in kortet och kopplade DVI-kabeln till skärmen fick jag korrekt bild under bootandets första par sekunder, sen blir bilden korrupt och oläsbar. Moderkortets DVI-port tycks förbikopplad när GPU-kortet sitter i.

Jag plockade därför ut GPU:n, laddade ner drivrutiner från NVIDIAS hemsida och installerade dem. Stoppade tillbaka GPU:n men problemet med korrupt bild kvarstår. Ut med GPU:n igen, prövade även att köra "sudo apt-get install nvidia-current", in med kortet igen men samma problem. Nu tycks dessutom skrivbordet vara låst till "recovery mode" när GPU:n är urkopplad.

Vad tror ni? Går det att reda ur?

patient67

Skickades från m.sweclockers.com

Permalänk
Medlem

Liten check bara...du byter till grafikkortets DVI port?

Permalänk
Avstängd

Gå in i bios och stäng av att den ska köra på Auto och ändra till PCI-E

Permalänk
Medlem
Skrivet av Surgubben:

Liten check bara...du byter till grafikkortets DVI port?

Precis. Närhelst grafikkortet sitter i ansluter jag via grafikkortets DVI-port. När grafikkortet är inkopplat kommer ingen bild från moderkortets DVI-port.

Skickades från m.sweclockers.com

Permalänk
Medlem

Du måste ha senast 340.24 till 750ti modellen den går att instalera från xorg edgers

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-340

om det är ubuntu du använder

Permalänk
Medlem

Nu lyckades jag få igång datorn med grafikkortet inkopplat, command line endast. Hittade ett felmeddelande om att NVIDIA Kernel module är 334.21 (den jag tankade hem från NVIDIAS hemsida), men att NVIDIA Driver component är 304.88.

Skickades från m.sweclockers.com

Permalänk
Medlem

Du måste förståss ha samma verision av drivern och kernell modulen men 750 är så nytt att du även måste ha senaste 337 eller 340 drivrutinerna

Permalänk
Medlem
Skrivet av patient67:

Hej alla Linuxkunniga!

Fram tills nu har jag kört med integrerad grafik på min Mint-burk (Cinnamon) men nu har jag lagt vantarna på ett GTX750Ti som jag vill använda istället. När jag helt sonika stoppade in kortet och kopplade DVI-kabeln till skärmen fick jag korrekt bild under bootandets första par sekunder, sen blir bilden korrupt och oläsbar. Moderkortets DVI-port tycks förbikopplad när GPU-kortet sitter i.

Jag plockade därför ut GPU:n, laddade ner drivrutiner från NVIDIAS hemsida och installerade dem. Stoppade tillbaka GPU:n men problemet med korrupt bild kvarstår. Ut med GPU:n igen, prövade även att köra "sudo apt-get install nvidia-current", in med kortet igen men samma problem. Nu tycks dessutom skrivbordet vara låst till "recovery mode" när GPU:n är urkopplad.

Vad tror ni? Går det att reda ur?

patient67

Skickades från m.sweclockers.com

körde du med proproetära drivrutiner till den integrerade grafiken? Om du gjorde det skall dessa avinstalleras innan grafikkortet sätts i. Mint föreslår nya drivrutiner när du startar upp med grafikkortet så varför hålla på att installera manuellt, det är Windowstänk.

Permalänk
Medlem
Skrivet av dewpo:

Du måste förståss ha samma verision av drivern och kernell modulen men 750 är så nytt att du även måste ha senaste 337 eller 340 drivrutinerna

334.21 skall fungera med 750Ti enligt hemsidan: http://www.nvidia.com/Download/driverResults.aspx/73666/en-us

Nu startar datorn i Recovery mode med grafikkortet inkopplat. Vet inte vad som fungerade till slut. Känns som om jag har gått loss med en kniv i stackars datorn, bla så kan jag inte göra sudo apt-get update längre utan att den klagar på "Failed to fetch...". Finns det något jag kan göra för att reda ut detta och ta mig sista biten?

Skickades från m.sweclockers.com

Permalänk
Medlem

Jag har ingen aning om hur det löste sig till slut, men nu verkar allt ändå ha löst sig. Linux är underbart.

Stort tack till Surgubben, Swefox, dewpo och NoWin!

Permalänk
Medlem
Skrivet av patient67:

Nu lyckades jag få igång datorn med grafikkortet inkopplat, command line endast. Hittade ett felmeddelande om att NVIDIA Kernel module är 334.21 (den jag tankade hem från NVIDIAS hemsida), men att NVIDIA Driver component är 304.88.

Skickades från m.sweclockers.com

det är normalt sett en dålig ide att installera NVIDIAS kernel modul från nvidas source packet istället för från en paket distrubutör systemet slutar att Auto updatera drivrutiner och då och då när kernelen som forsätter att updatera sig blir för ny slutar det att fungera och Drivrutinerna måste kompileras om...

Permalänk
Medlem

Men vad gör man om man vill ha absolut senaste drivar pga att det kanske fixar till nått man har problem med?
Sen ska väl egentligen Nvidias installer fixa kernel biten med?

Skickades från m.sweclockers.com