Installation av Windows 7 hittar inte SSD:n

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010

Installation av Windows 7 hittar inte SSD:n

Hej

Har stött på detta problem nu för andra gången på 3 år:P Ska installera Windows 7 på en Samsung 840 Evo 120 GB SSD men när jag valt systemspråk och tangentspråk och går vidare till nästa steg där man väljer hårddisk att installera på så hittas inte SSD:n, SSD:n är ensamt inkopplad. Jag har provat både SATA 6gb/s Turbo uttaget, ett vanligt grått Sata 6gb/s uttag och ett blått Sata 3gb/s uttag, inget hjälper.

SSD:n finns i Bios men hittas inte när jag ska installera operativet. Sist jag hade detta problem så löste det sig men jag minns inte hur:(

Moderkortet Asus P9P67 m ATX
SSD 840 EVO 120 gb
ACHI påslaget

Jag läste att problemet löst sig när någon installerat via USB men då jag bara har windows på skiva och inte har ett USB så måste jag lösa det ändå.

Några förslag?

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Mar 2010

Formaterat den ?

Om inte så är det kanske lösningen...

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010
Skrivet av Dread56:

Formaterat den ?

Om inte så är det kanske lösningen...

Ja, jag antar att ja kan prova det också, men finns det något effektivare sätt än Killdisk som tar 12 timmar?:/

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009

Den optiska enheten ska kopplas till en sataport i ideläge, ssdn ska ha ahci, detta ska du ställa in i bios, det kan ju även vara så att du behöver drivrutiner till satakontrollern.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010
Skrivet av mrqaffe:

Den optiska enheten ska kopplas till en sataport i ideläge, ssdn ska ha ahci, detta ska du ställa in i bios, det kan ju även vara så att du behöver drivrutiner till satakontrollern.

Inte riktigt säker vad du menar med IDEläge? SSDn har AHCI och har alldelles nyss uppdaterat drivrutinerna för sata kontrollerna.

Disken i hanteraren:

http://i58.tinypic.com/23to7ie.png

Disk 0/D är SSD:n

Disk 1 är den gamla jag kör på nu

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av P!ngv!N:

Inte riktigt säker vad du menar med IDEläge? SSDn har AHCI och har alldelles nyss uppdaterat drivrutinerna för sata kontrollerna.

Kolla avsnitt 3.5.4 i manualen, sid 3-17 där står det om var du justerar de olika lägena på sataportarna.

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010
Skrivet av mrqaffe:

Kolla avsnitt 3.5.4 i manualen, sid 3-17 där står det om var du justerar de olika lägena på sataportarna.

http://www.asus.com/Motherboards/P8P67M/HelpDesk_Manual/

Den manualen gick jag till och kollade men där slutar allt vid 2.9

Vart hittade du den du kollade på?

Trädvy Permalänk
Rekordmedlem
Plats
Salstad
Registrerad
Feb 2009
Skrivet av P!ngv!N:

http://www.asus.com/Motherboards/P8P67M/HelpDesk_Manual/

Den manualen gick jag till och kollade men där slutar allt vid 2.9

Vart hittade du den du kollade på?

http://dlcdnet.asus.com/pub/ASUS/mb/LGA1155/P8P67_REV_3-1/E65...

Ryzen 5 2400G, Asus ROG STRIX B350-F Gaming, 500GB Samsung 970EVO NVMe M.2 och en väldig massa masslagring. Seasonic Focus+ Gold 650W, Antec P 180 med Schyte o Sharkoon fläktar via en t-balancer, Tittar på en Acer ET430Kbmiippx 43" 4K
Främre ljudkanalerna återges via Behringer DCX2496, högtalare Truth B3031A, Truth B2092A Har också Oscilloskop, mätmikrofon och en Colorimeter.

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010

Allt är inställt som det ska vara men nu har jag börjat fundera på att försöka installera Windows via ett USB istället då skivan är något skadad. Har följt guiden här på Swec angående hur man ordnar så att USB blir en bootable device, har även rensat den via CMD och följt alla steg som slutligen lyckades. När jag sedan försöker kopiera över Windows 7 ISO filen så laddar den till 99% för att sedan ge felmeddelandet : We were unable to copy your files. Please check your USB device and the selected ISO file and try again.

Har googlat på problemet och lösningen som ges är att rensa disken via CMD som jag redan gjort. Finns det något annat som kan orsaka detta=?

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010

Påbörjade en installation av Windows 7 via USB stickan, alla HDD hittas numera men kan dessvärre inte installera W7 på SSD:n då följande meddelande dyker upp:

Windows was unable to locate an existing partition or create a new one.

Trädvy Permalänk
Medlem
Plats
Mölndal
Registrerad
Okt 2013
Skrivet av P!ngv!N:

Påbörjade en installation av Windows 7 via USB stickan, alla HDD hittas numera men kan dessvärre inte installera W7 på SSD:n då följande meddelande dyker upp:

Windows was unable to locate an existing partition or create a new one.

Det funkar inte pga att du har en partition på ssdn redan, I ntfs. För att det ska funka så måste du gå in i diskhanteraren och välja ta bort volym sen kan du installera windows. Jag hade samma problem som du men detta löste det.
Mvh

Stationär Dator Intel Core i7 4790k 4.85 Ghz @1.3V, Kelvin S24, Gigabyte Windforce GTX 970, Kingston Hyper X 4x4 GB 1600 MHz, Samsung 840x3, Msi Z97 Gaming 7, Windows 10 Pro / Fedora 28, Beyerdynamic DT 990 PRO, Asus PG279Q. Bärbar Dator Lenovo Yoga 720 Nas FreeNas 4 Tb

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Aug 2004

Vilken version av windows 7 använder du Home eller Pro ?
Jag har med Samsung SSD och win7 och den funkar bra inga problem. Bara det går inte köra Secure Erease via Samsung_Magician som skapar bootbar CD/USB.

Ditt problem kan vara några av följande:
- Din moderkort är gammalt kan behöva senaste bios
- Partition problem på disken
- Din Win7 install CD är skadad

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2003
Skrivet av P!ngv!N:

Ja, jag antar att ja kan prova det också, men finns det något effektivare sätt än Killdisk som tar 12 timmar?:/

Eftersom MBR ligger i början på disken räcker det med 1 min med Killdisk för att "killa" partitionstabellen

Skrivet av P!ngv!N:

Påbörjade en installation av Windows 7 via USB stickan, alla HDD hittas numera men kan dessvärre inte installera W7 på SSD:n då följande meddelande dyker upp:

Windows was unable to locate an existing partition or create a new one.

Den läskunnige konstaterar att det inte finns någon ledig partition för OS. Gå in i "Avancerat" och formatera valfri partition och peka ut den åt Win.

Trädvy Permalänk
Medlem
Registrerad
Okt 2010

Har för mig jag hade nåt sånt krångel en gång.Prova lägg satadrivers på ett Usb.
Starta sen windowsinstall.välj sen något typ options avancerad install drivers.välj då sata driven på usb.

Chassi.Corsair Obsidian 750 D.Moderkort Asus Maximus VII Hero. Processor Intel I7 4790K. Med kylare Noctua NH-D15.Grafikkort Asus Strix 970.SLI.SSD.1 Samsung 850 Pro 256 GB.SSD.2 Samsung 840 Evo 500 GB till spel.Nätagg Evga 850 G2.Minne 16 gb corsair vengeance pro 2133 mhtz.Skärm. Asus PG278QR.
Asus frontbase.Asus sli brygga med belysning.2×596 gb.Mekaniska hårddiskar.

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010
Skrivet av Android98Geek:

Det funkar inte pga att du har en partition på ssdn redan, I ntfs. För att det ska funka så måste du gå in i diskhanteraren och välja ta bort volym sen kan du installera windows. Jag hade samma problem som du men detta löste det.
Mvh

Testade just men fungerade fortfarande inte:/

Skrivet av intel2000:

Vilken version av windows 7 använder du Home eller Pro ?
Jag har med Samsung SSD och win7 och den funkar bra inga problem. Bara det går inte köra Secure Erease via Samsung_Magician som skapar bootbar CD/USB.

Ditt problem kan vara några av följande:
- Din moderkort är gammalt kan behöva senaste bios
- Partition problem på disken
- Din Win7 install CD är skadad

Jag använder Windows 7 Ultimate x64 och har alldelles nyligen installerat nya sata drivers, flashat bios + usb 3.0 portarna. Installerar via ett USB minne alltså ingen skiva längre då den såg risig ut.

Ingen bättring tyvärr

Skrivet av jookeer:

Eftersom MBR ligger i början på disken räcker det med 1 min med Killdisk för att "killa" partitionstabellen

Den läskunnige konstaterar att det inte finns någon ledig partition för OS. Gå in i "Avancerat" och formatera valfri partition och peka ut den åt Win.

Förstår inte riktigt hur jag skal göra det:s hur "pekar" jag ut den åt Windows?

Trädvy Permalänk
Medlem
Plats
Märsta
Registrerad
Jun 2008

Tryck in usb:n i en 2.0, har läst att det krånglar om man kör in den i en 3.0..

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010
Skrivet av Carlsberg 4.2:

Tryck in usb:n i en 2.0, har läst att det krånglar om man kör in den i en 3.0..

USB sitter redan i en 2.0 port:/

Funkar ju att använda som lagringsdisk väll inne i windows men med 111gb utrymme utav 120gb även efter jag formaterat disken så är det bara 111GB som är tillgängliga. Jag förstår bara inte varför windows inte skapar en sabla partition om det behövs nudå? det har den alltid kunnat göra tidigare på min gamla hårddisk...

http://i59.tinypic.com/rlvzoj.png

I enhentshanteraren står det primary partition

http://i59.tinypic.com/o90fba.png

Disk 0 är SSD

Disk 1 är den gamla 1 TB från samsung

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Aug 2004

WIndows 7 är första OS med att stödja SSD så det bör funka. Asså du kan prova Windows 8 kanske är din sista lösning.

Om win7 ssd källa wiki:

Microsoft Windows 7 is the first Windows operating system to include native support for solid state drives (SSDs). SSD-specific features that ship in Windows 7 include :

SSD Identification - SSDs are identified as non-rotating media, which allows Windows 7 to turn drive defragmentation off. This improves drive lifespan by reducing the number of writes.

TRIM Support - Windows 7 will inform the SSDs which data blocks are no longer in use and can be deleted internally. This reduces the amount of internal fragmentation which can greatly slow down write operations.

Enhanced Wear-Leveling - By eliminating merge operations for all deleted data blocks, and preserving the unused storage area as much as possible.

Early Garbage Collection - Improves write speeds, especially when the SSD storage capacity is fully utilized.

These SSD-specific optimizations make Windows 7 the best operating system for solid state drives.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2006
Skrivet av P!ngv!N:

USB sitter redan i en 2.0 port:/

Funkar ju att använda som lagringsdisk väll inne i windows men med 111gb utrymme utav 120gb även efter jag formaterat disken så är det bara 111GB som är tillgängliga. Jag förstår bara inte varför windows inte skapar en sabla partition om det behövs nudå? det har den alltid kunnat göra tidigare på min gamla hårddisk...

http://i59.tinypic.com/rlvzoj.png

I enhentshanteraren står det primary partition

http://i59.tinypic.com/o90fba.png

Disk 0 är SSD

Disk 1 är den gamla 1 TB från samsung

Du bootar datorn med skiva eller USB, väljer språk osv, sen installera nu.
Sen på nästa skärm går du in på avancerade enhetsalternativ (tror det heter så, men minns inte exakt på rak arm) där väljer du att ta bort den befintliga partitionen som finns, sen klickar du på uppdatera, sen klickar du bara på nästa, OBS att du varken ska skapa eller formatera någon partition själv, den delen fixar Windows installationsprogram själv, då ska det fungera.

Tror du försöker välja att lägga windows på en redan befintlig partition, och det är inte alls säkert att det fungerar.

För tillfället en sketen Acer gaming laptop

Trädvy Permalänk
Medlem
Registrerad
Jun 2012

Koppla ur alla diskar förutom den du tänker installera systemet på. Hade liknande problem med min laptop med två SSDer i

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2004
Skrivet av P!ngv!N:

USB sitter redan i en 2.0 port:/

Funkar ju att använda som lagringsdisk väll inne i windows men med 111gb utrymme utav 120gb även efter jag formaterat disken så är det bara 111GB som är tillgängliga. Jag förstår bara inte varför windows inte skapar en sabla partition om det behövs nudå? det har den alltid kunnat göra tidigare på min gamla hårddisk...

http://i59.tinypic.com/rlvzoj.png

I enhentshanteraren står det primary partition

http://i59.tinypic.com/o90fba.png

Disk 0 är SSD

Disk 1 är den gamla 1 TB från samsung

Har du provat rensa bort *alla* partitioner ifrån SSDn med diskpart innan du installerar?
Jag har själv haft problem vid installation om det ligger någon liten skräp partition kvar (resultat av avbryten installation).
Under installationen ska endast SSDn vara inkopplad.

Kör en CMD prompt i administratör läge och skriv sedan diskpart.

list disk select disk N list partition select partition N delete partition list partition select partition N delete partition osv....

Om det inte går att ta bort en partition med "delete partition" får du komplettera med ett "override".
Dvs

delete partition override

Det är väldigt viktigt att du väljer rätt disk nummer i början så du inte börjar ta bort partitioner ifrån din nuvarande OS disk.

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010
Skrivet av ggustavsson:

Du bootar datorn med skiva eller USB, väljer språk osv, sen installera nu.
Sen på nästa skärm går du in på avancerade enhetsalternativ (tror det heter så, men minns inte exakt på rak arm) där väljer du att ta bort den befintliga partitionen som finns, sen klickar du på uppdatera, sen klickar du bara på nästa, OBS att du varken ska skapa eller formatera någon partition själv, den delen fixar Windows installationsprogram själv, då ska det fungera.

Tror du försöker välja att lägga windows på en redan befintlig partition, och det är inte alls säkert att det fungerar.

Första installationsförsöket så var SSD:n helt ren och det fanns inga partitioner på den i efterhand provade jag skapa en egen partition att installera på men som inte heller gick tyvärr.

Skrivet av usermane:

Koppla ur alla diskar förutom den du tänker installera systemet på. Hade liknande problem med min laptop med två SSDer i

Skickades från m.sweclockers.com

Har kopplat ur alla andra Hårddiskar inklusive CD/DVD brännaren under varje installationsförsök

Skrivet av henkiii:

Har du provat rensa bort *alla* partitioner ifrån SSDn med diskpart innan du installerar?
Jag har själv haft problem vid installation om det ligger någon liten skräp partition kvar (resultat av avbryten installation).
Under installationen ska endast SSDn vara inkopplad.

Kör en CMD prompt i administratör läge och skriv sedan diskpart.
http://i.imgur.com/V7GoAxC.png

list disk select disk N list partition select partition N delete partition list partition select partition N delete partition osv....

Om det inte går att ta bort en partition med "delete partition" får du komplettera med ett "override".
Dvs

delete partition override

Det är väldigt viktigt att du väljer rätt disk nummer i början så du inte börjar ta bort partitioner ifrån din nuvarande OS disk.

Har även testat det här men utan resultat:/

Trädvy Permalänk
Medlem
Plats
SweClockers forum
Registrerad
Aug 2012
Skrivet av henkiii:

Har du provat rensa bort *alla* partitioner ifrån SSDn med diskpart innan du installerar?
Jag har själv haft problem vid installation om det ligger någon liten skräp partition kvar (resultat av avbryten installation).
Under installationen ska endast SSDn vara inkopplad.

Kör en CMD prompt i administratör läge och skriv sedan diskpart.
http://i.imgur.com/V7GoAxC.png

list disk select disk N list partition select partition N delete partition list partition select partition N delete partition osv....

Om det inte går att ta bort en partition med "delete partition" får du komplettera med ett "override".
Dvs

delete partition override

Det är väldigt viktigt att du väljer rätt disk nummer i början så du inte börjar ta bort partitioner ifrån din nuvarande OS disk.

Eller så använder man bara "clean" som tar bort partitionstabellen. Det går mycket snabbare och är mycket mindre att skriva.

Skrivet av P!ngv!N:

Påbörjade en installation av Windows 7 via USB stickan, alla HDD hittas numera men kan dessvärre inte installera W7 på SSD:n då följande meddelande dyker upp:

Windows was unable to locate an existing partition or create a new one.

Försöker du göra en uppgradering? Det går bara om du redan har en befintlig Windows-installation på disken.

Guide: Roota din HTC - BB-Kod-knappar på Prisjakt

              Min burk - Kvävekyld till 80%
8700K@stock
1070 Ti@stock

Ibland har jag fel, men då är det någon annans fel.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jun 2002

Många BIOS'ar har kass implementering av USB-bootande enheter, vilket gör att USB-minne ej kan användas för installation.
Bränna skiva och installera från DVD är enda alternativet. Har flertalet Dell och HP, samt någon äldre ASUS som är precis så, med exakt det felmeddelandet.

Trädvy Permalänk
Medlem
Plats
Sverige
Registrerad
Aug 2004

@oxygenial har rätt använd inte usb-minne installera via DVD. Asså om det fortfarande inte funkade prova Windows 7 Professional istället för Ultimate.

Jag har Windows 7 Home och det krånglar under installation min tangentbord slutar funka men detta händer inte med Windows 7 Professional.

Trädvy Permalänk
Medlem
Plats
Södermanland
Registrerad
Sep 2010
Skrivet av intel2000:

@oxygenial har rätt använd inte usb-minne installera via DVD. Asså om det fortfarande inte funkade prova Windows 7 Professional istället för Ultimate.

Jag har Windows 7 Home och det krånglar under installation min tangentbord slutar funka men detta händer inte med Windows 7 Professional.

Anledningen till att jag köpte ett USB att installera med var just eftersom skivan med Windows 7 hade otaliga repor och smuts på sig osv.

Hursomhelst så tvättade jag skivan men tandkräm och sköljde av med vatten (har provat detta 2 gånger på 10 år och otroligt nog har det fungerat båda gångerna) Efter tvättningen så formaterade jag SSD:n ytterligare 1 gång och provade göra installationen igen, då gick det utan problem.

Tack så väldigt mycket för all hjälp och olika sätt att försöka lösa detta på:)

Till slut gick det!

Trädvy Permalänk
Hedersmedlem
Plats
Omnipresent
Registrerad
Okt 2004
Skrivet av P!ngv!N:

Anledningen till att jag köpte ett USB att installera med var just eftersom skivan med Windows 7 hade otaliga repor och smuts på sig osv.

Hursomhelst så tvättade jag skivan men tandkräm och sköljde av med vatten (har provat detta 2 gånger på 10 år och otroligt nog har det fungerat båda gångerna) Efter tvättningen så formaterade jag SSD:n ytterligare 1 gång och provade göra installationen igen, då gick det utan problem.

Tack så väldigt mycket för all hjälp och olika sätt att försöka lösa detta på:)

Till slut gick det!

Passa på att göra en kopia på din W7 skiva då.

Gud är Död! - Nietzsche
Nietzsche är Död! - Gud