Tveksam till benchmark-resultat på min Samsung SSD

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2010

Tveksam till benchmark-resultat på min Samsung SSD

Hej Alla,

Jag har skrivit tidigare om att min Samsung SSD inte uppfattas helt korrekt av varken Samsung Magician 4.4, eller moderkortets BIOS.
http://www.sweclockers.com/forum/6-lagring/1270048-mitt-nya-moderkort-gigabyte-tror-ssd-ar-en-hdd/

Jag har nu kört AS SSD och får följande värden:
AS SSD Benchmark 1.7.4739.38088
------------------------------
Name: Samsung SSD 840 EVO 500G SCSI Disk Device
Firmware: EXT0
Controller: iaStorA
Offset: 103424 K - OK
Size: 465,76 GB
Date: 2014-08-13 22:45:40
------------------------------
Sequential:
------------------------------
Read: 497,76 MB/s
Write: 421,63 MB/s
------------------------------
4K:
------------------------------
Read: 31,45 MB/s
Write: 56,76 MB/s
------------------------------
4K-64Threads:
------------------------------
Read: 350,07 MB/s
Write: 146,30 MB/s
------------------------------
Access Times:
------------------------------
Read: -.--- ms
Write: 0,068 ms
------------------------------
Score:
------------------------------
Read: 431
Write: 245
Total: 904
------------------------------

..det ser inte så bra ut va?

FD Define S | Gigabyte Z97X-Gaming G1 | Intel Core i7-4790K @ 4,6 GHz | Nocctua NH-D15S | Corsair 32GB DDR3 VENGEANCE PRO @ 2400MHZ | Asus Strix GTX1080 (A8G) | Samsung SSD 850 EVO 500GB (system) | Samsung SSD 840 EVO 500GB (spel) | Seagate Barracuda 2TB (data) | Evga SuperNOVA G3 850W | Windows10 Pro x64 | Asus PG278Q

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

Fick 1130 i poäng med min "500" gb 840 EVO.
Alla mina "writes" vad betydligt snabbare än vad du får, 469 poäng i writes och 426 i reads.

Sitter din disk i rätt SATA port ? så du inte kör den i någon marvell kontroller eller liknande...

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av DaddyCoolSwe:

Name: Samsung SSD 840 EVO 500G SCSI Disk Device
Firmware: EXT0
Controller: iaStorA

Säger mig att disken inte kör i AHCI läge, därför är troligen resultaten lägre.
Om jag minns rätt så är iaStorA RAID läge, som behövs bytas i BIOS till ACHI.

Problemet är att om du bara "byter rakt av" kommer inte Windows att starta.
Du måste ändra lite i registret för att få det att fungera.
http://www.overclock.net/t/1227636/how-to-change-sata-modes-a...

När den har startat upp igen kan man återställa dessa värden så att bara AHCI läget startar istället.
Testa om det är felet först dock.

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av Paddanx:

Säger mig att disken inte kör i AHCI läge, därför är troligen resultaten lägre.
Om jag minns rätt så är iaStorA RAID läge, som behövs bytas i BIOS till ACHI.

Problemet är att om du bara "byter rakt av" kommer inte Windows att starta.
Du måste ändra lite i registret för att få det att fungera.
http://www.overclock.net/t/1227636/how-to-change-sata-modes-a...

När den har startat upp igen kan man återställa dessa värden så att bara AHCI läget startar istället.
Testa om det är felet först dock.

iastor är Intels AHCI drivrutin.
Det betyder att han har installerat Intel rapid storage blabla.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av Svensktiger:

iastor är Intels AHCI drivrutin.
Det betyder att han har installerat Intel rapid storage blabla.

naje. AHCI drivare heter msahci. Men som du säger kan det vara något rapid storage läge. Dock är just det läget ett RAID läge, varpå den drivaren ska laddas.

Trädvy Permalänk
Entusiast
Plats
Göteborg
Registrerad
Dec 2005
Skrivet av Paddanx:

Säger mig att disken inte kör i AHCI läge, därför är troligen resultaten lägre.
Om jag minns rätt så är iaStorA RAID läge, som behövs bytas i BIOS till ACHI.

Problemet är att om du bara "byter rakt av" kommer inte Windows att starta.
Du måste ändra lite i registret för att få det att fungera.
http://www.overclock.net/t/1227636/how-to-change-sata-modes-a...

När den har startat upp igen kan man återställa dessa värden så att bara AHCI läget startar istället.
Testa om det är felet först dock.

RAID och AHCI har samma funktioner. Finns ingen anledning att byta från RAID till AHCI om man inte vill slippa de där extra sekunderna i när man bootar.

Q9450, HD4850, 8 GB DDR2 800 MHz, 3x750 GB, Antec 300, Dell 2408WFP, U2410, Qnap TS-419p+ 4x2 TB Samsung F4, Asus UL30A-QX056V, Logitech Z-680, Sennheiser HD380pro, M-Audio FastTrack Pro, Ibanez sa160qm, Ibanez TB 15R, Zoom 505II, Ibanez GSR 200, Ibanez SW 35, Cort AC-15, Squier SD-3 BBL, Yamaha PSR 270, Røde NT1-A, Nikon D200, Nikkor 18-70/3,5-4,5, 70-300VR, 50/1,8, 28/2,8, Tamron 17-50/2,8, 90/2,8, Sigma 30/1,4, SB-800, SB-25, SB-24

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av Zotamedu:

RAID och AHCI har samma funktioner. Finns ingen anledning att byta från RAID till AHCI om man inte vill slippa de där extra sekunderna i när man bootar.

Är du säker på det? För bla TRIM ska inte fungera om man kör RAID läge, om man inte har tex Intels speciella drivare och de få SSD de har som stöder det. Dessutom kan du inte få direkta DMA läge (om inte RAID kortet) stöder det, vilket ger CPU overhead och sänker IOPs. Endast dyra hårdvaru-raid kort kommer runt det problemet.

Är så jag har förstått och upplevt det som de senaste 10åren iaf, men om något har ändrats så rätta mig gärna med lite hänvisningar.

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Aug 2006
Skrivet av Paddanx:

naje. AHCI drivare heter msahci. Men som du säger kan det vara något rapid storage läge. Dock är just det läget ett RAID läge, varpå den drivaren ska laddas.

msahci är Microsoft egna AHCI drivrutiner men sedan har Intel, AMD och många andra egna AHCI drivrutiner http://www.win-raid.com/t29f25-Recommended-AHCI-and-RAID-Driv...

janee

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av janee:

msahci är Microsoft egna AHCI drivrutiner men sedan har Intel, AMD och många andra egna AHCI drivrutiner http://www.win-raid.com/t29f25-Recommended-AHCI-and-RAID-Driv...

"These are the latest and probably last "classical" Intel RST AHCI/RAID drivers, which are managing the Intel SATA AHCI/RAID Controller with just 1 single driver named iaStor.sys."
Se där... okej.

Men det förklarar fortfarande inte hans problem, eller varför den väljer att ha SCSI namn på enheten.
Dessutom enligt den sidan du länkade så använder de samma drivare i både ACHI och RAID läge, så det kan fortfarande vara så att enheten kör i just RAID läge.

Trädvy Permalänk
Entusiast
Plats
Göteborg
Registrerad
Dec 2005
Skrivet av Paddanx:

Är du säker på det? För bla TRIM ska inte fungera om man kör RAID läge, om man inte har tex Intels speciella drivare och de få SSD de har som stöder det. Dessutom kan du inte få direkta DMA läge (om inte RAID kortet) stöder det, vilket ger CPU overhead och sänker IOPs. Endast dyra hårdvaru-raid kort kommer runt det problemet.

Är så jag har förstått och upplevt det som de senaste 10åren iaf, men om något har ändrats så rätta mig gärna med lite hänvisningar.

Ja det är jag. TRIM fungerar fortfarande. Problemet var att TRIM inte fungerade på just RAIDade enheter, inte att det är avstängt helt. RAID är bara lite extra saker ovanpå AHCI för att göra så att man kan köra just RAID. Hade det inte varit för att det tar ett par sekunder extra varje gång man bootar för att RAIDen ska initieras hade det inte funnits någon anledning att inte köra RAID alltid.

Edit: Jag har RAID aktiverat på moderkortet istället för AHCI eftersom jag rätt länge körde en RAID1 med två hårddiskar. Eftersom de började bli ledsna har jag nu ersatt den med nya grejer men la samtidigt ner RAIDen för jag inte orkade med den längre. Moderkortet kör dock fortfarande RAID för jag är för lat för att gå igenom hela manövern med att byta till AHCI och jag orkar inte installera om hela datorn för det. Här är ett litet test på min SSD.

Alltså inga som helst problem med TRIM när chipsetet står i RAID. Hade jag däremot haft två SSD i RAID0 hade det varit en annan femma. Senaste chipsertet från Intel med senaste Intel Rapid Storage ska klara TRIM i specifikt RAID0 men inte i andra lösningar.

Q9450, HD4850, 8 GB DDR2 800 MHz, 3x750 GB, Antec 300, Dell 2408WFP, U2410, Qnap TS-419p+ 4x2 TB Samsung F4, Asus UL30A-QX056V, Logitech Z-680, Sennheiser HD380pro, M-Audio FastTrack Pro, Ibanez sa160qm, Ibanez TB 15R, Zoom 505II, Ibanez GSR 200, Ibanez SW 35, Cort AC-15, Squier SD-3 BBL, Yamaha PSR 270, Røde NT1-A, Nikon D200, Nikkor 18-70/3,5-4,5, 70-300VR, 50/1,8, 28/2,8, Tamron 17-50/2,8, 90/2,8, Sigma 30/1,4, SB-800, SB-25, SB-24

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2010
Skrivet av Svensktiger:

Fick 1130 i poäng med min "500" gb 840 EVO.
Alla mina "writes" vad betydligt snabbare än vad du får, 469 poäng i writes och 426 i reads.

Sitter din disk i rätt SATA port ? så du inte kör den i någon marvell kontroller eller liknande...

Japp, alla tre diskarna på Intel-kontrollern.
SATA0: Samsung SSD 840 EVO 500GB
SATA1: Seagate Barracuda 2TB 7200rpm SATA/600 64MB
SATA2: Seagate Barracuda 2TB 7200rpm SATA/600 64MB
SATA3: Optiarc DVD RW AD-7240S SATA 150

FD Define S | Gigabyte Z97X-Gaming G1 | Intel Core i7-4790K @ 4,6 GHz | Nocctua NH-D15S | Corsair 32GB DDR3 VENGEANCE PRO @ 2400MHZ | Asus Strix GTX1080 (A8G) | Samsung SSD 850 EVO 500GB (system) | Samsung SSD 840 EVO 500GB (spel) | Seagate Barracuda 2TB (data) | Evga SuperNOVA G3 850W | Windows10 Pro x64 | Asus PG278Q

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2010
Skrivet av Paddanx:

Säger mig att disken inte kör i AHCI läge, därför är troligen resultaten lägre.
Om jag minns rätt så är iaStorA RAID läge, som behövs bytas i BIOS till ACHI.

Problemet är att om du bara "byter rakt av" kommer inte Windows att starta.
Du måste ändra lite i registret för att få det att fungera.
http://www.overclock.net/t/1227636/how-to-change-sata-modes-a...

När den har startat upp igen kan man återställa dessa värden så att bara AHCI läget startar istället.
Testa om det är felet först dock.

Grejen är att jag inte kan köra AHCI eftersom jag har en RAID1-array för data. Jag har mailat Gigabyte och fick nåt automat-godag-yxskaft-svar. Nu har jag lagt in en post i Samsungs support-forum.. får se om det ger nåt?

FD Define S | Gigabyte Z97X-Gaming G1 | Intel Core i7-4790K @ 4,6 GHz | Nocctua NH-D15S | Corsair 32GB DDR3 VENGEANCE PRO @ 2400MHZ | Asus Strix GTX1080 (A8G) | Samsung SSD 850 EVO 500GB (system) | Samsung SSD 840 EVO 500GB (spel) | Seagate Barracuda 2TB (data) | Evga SuperNOVA G3 850W | Windows10 Pro x64 | Asus PG278Q

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jan 2003

Asså, om man på intels SATAchipset ställer in RAID så gäller det ALLA portar. Det betyder inte att man MÅSTE köra RAID på ALLIHOPA. Tex. kör du RAID på 3 och resterande 3 som singlediskar. Alla 6 kör AHCI.

Avseende drirutiner så säger erfarenheten att Intels egna är att föredra före M$.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Maj 2010

Intel- eller MS-drivare?

Skrivet av jookeer:

Asså, om man på intels SATAchipset ställer in RAID så gäller det ALLA portar. Det betyder inte att man MÅSTE köra RAID på ALLIHOPA. Tex. kör du RAID på 3 och resterande 3 som singlediskar. Alla 6 kör AHCI.

Avseende drirutiner så säger erfarenheten att Intels egna är att föredra före M$.

Det låter ju jättebra! *tumme upp*

Enligt min enhetshanterare, när jag tittar på Lagringsstyrenheter:
Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller
Leverantör: Intel Corporation
Datum: 2014-05-02
Version: 13.1.0.1058

..det är väl okej? :/

FD Define S | Gigabyte Z97X-Gaming G1 | Intel Core i7-4790K @ 4,6 GHz | Nocctua NH-D15S | Corsair 32GB DDR3 VENGEANCE PRO @ 2400MHZ | Asus Strix GTX1080 (A8G) | Samsung SSD 850 EVO 500GB (system) | Samsung SSD 840 EVO 500GB (spel) | Seagate Barracuda 2TB (data) | Evga SuperNOVA G3 850W | Windows10 Pro x64 | Asus PG278Q