Försökte installera Ubuntu och det står att det redan finns installerat...

Permalänk
Medlem

Försökte installera Ubuntu och det står att det redan finns installerat...

Hej!
Jag försökte installera Ubuntu via USB jämsides Windows 7 men då står det att det redan är installerat jämsides windows. Vilket inte stämmer.
Detta är mitt andra försök denna månaden då förra gången så blev det något fel och jag kom varken in i windows eller Ubuntu så det blev det en fabriksåterställning.

Är det bara att installera om Ubuntu eller är det något som är på tok ?
Tacksam för hjälp!

Permalänk
Medlem

Är det ubuntu installern som gnäller? Det kan vara så bara att installern reagerar på att det redan finns en ex4 partition med ubuntu men som egentligen inte kanske funderar efter som det blev fel. Du borde bara kunna formatera partitionen med den tidigare intallationen och installera ubuntu, detta kan du dock göra i installations programmet.

Eftersom du har windows 7 vid sidan av så antar jag att du inte har uefi moderkort?

Att dömma av ditt tidigare försökt så låter det som att det blev något fel med bootloadern för windows, och att grub inte var installerat eftersom det blev fel tidigare i försöket innan att intallera.

Permalänk
Medlem
Skrivet av bud986:

Är det ubuntu installern som gnäller? Det kan vara så bara att installern reagerar på att det redan finns en ex4 partition med ubuntu men som egentligen inte kanske funderar efter som det blev fel. Du borde bara kunna formatera partitionen med den tidigare intallationen och installera ubuntu, detta kan du dock göra i installations programmet.

Eftersom du har windows 7 vid sidan av så antar jag att du inte har uefi moderkort?

Att dömma av ditt tidigare försökt så låter det som att det blev något fel med bootloadern för windows, och att grub inte var installerat eftersom det blev fel tidigare i försöket innan att intallera.

Jag har UEFI moderkort jo, är detta ett problem ?

Permalänk
Rekordmedlem
Skrivet av critaL:

Jag har UEFI moderkort jo, är detta ett problem ?

Ja det kan det vara, du måste stänga av "secure boot" eller ställa om det till "legacy mode" eller liknande, moderkortet är annars låst så att det bara kan köra win8.

Permalänk
Medlem
Skrivet av mrqaffe:

Ja det kan det vara, du måste stänga av "secure boot" eller ställa om det till "legacy mode" eller liknande, moderkortet är annars låst så att det bara kan köra win8.

Okej nu har det hänt samma sak igen som förra gången.. Jag försökte installera Ubuntu igen och allt verkade gå bra tills installationen var klar och jag skulle starta om datorn. Då får jag grub rescue mode: no such device och så står den och tuggar där bara. Och hittar inte längre Windows 7 loader i partitionen..

Skickades från m.sweclockers.com

Permalänk
Rekordmedlem
Permalänk
Medlem
Skrivet av critaL:

Jag har UEFI moderkort jo, är detta ett problem ?

ändra INTE till "legacy mode" i BIOS om du inte vill installera om windows också, börja med att ta bort "Secure boot"

Permalänk
Medlem
Skrivet av Oneone:

ändra INTE till "legacy mode" i BIOS om du inte vill installera om windows också, börja med att ta bort "Secure boot"

Hittar inget legacy mode i UEFI. Inget fastboot/secure boot eller något sånt heller.
Har nu fått igång windows igen, hur ska jag gå tillväga för att installera Ubuntu jämsides windows 7 UTAN att jag behöver gå igenom detta igen ?

Permalänk
Rekordmedlem

Du får nog läsa moderkortsmanualen om hur du stänger av secure boot.
Ska du bara testa linux skulle du även kunna köra det virtuellt.

Permalänk
Medlem

Vad har du för moderkort? model etc

Permalänk
Inaktiv

Låter som att du meckat och failat fram och tillbaka.. Gör om och gör rätt!

Gör backup på dina grejer, Ändra till Legacy och ta bort Secure boot/fast boot, formatera om hela disken, installera om Windows 7, installera sedan Ubuntu på nytt.

Trodde inte man kunde faila på en Ubunut installation, men kul att du kör Linux, Ubuntu är bättre än inget Linux.

Permalänk
Medlem

GRUB har jag också gått bet på när jag installerade Gentoo. GRUB tar lite utrymme i början av en hårddisk ifall du inte ser till att ge den utrymme. Gissar att Ubuntus automatiska hantering av detta är allt annat än optimal.

Du kan försöka Googla på Restore Windows bootloader och liknande, man kan försöka fixa det med hjälp av en Windows install DVD. Ifall din data inte är uppbackat så föreslår jag att du letar rätt på en extern hårddisk, bootar upp Kubuntu Live DVD och kopierar alla dina filer från hårddisk till hårddisk. Kubuntu har automatisk mounting av hårddiskar, USB-minnen etc så det är ganska lätt att göra.

Personligen så skulle jag aldrig försöka installera Linux på en fysisk disk som redan han en Windows installation, alldeles för mycket risker. Kolla om ditt moderkort har stöd för att boota i UEFI eller Legacy "samtidigt" (stöda båda samtidigt så att du kan boota dem från Boot override utan problem).

Permalänk
Medlem

Har för mig att om det finns för många partitioner så kan inte installations programmet för Ubuntu hantera dem automatiskt. Skapa en partition för Ubuntu från Windows och installera Ubuntu manuellt på denna partition. Kan vara likadant med boot-partitionen.