Ubuntu 14.04 hög cpu användning

Permalänk
Medlem

Ubuntu 14.04 hög cpu användning

Har som titeln säger ett problem med väldigt hög cpu användning i Ubuntu 14.04
(pendlar mellan 50% och 100% på alla kärnor)
Har precis installerat det på en gammal Dell dator med följande specs:
*Intel q6600
*2gb ddr2 667mhz
*1tb WD blue
*Nvidia gtx 260
Jag tycker dem specs:en borde klara Ubuntu fint eftersom Windows flyter helt ok på det

Inga program har installerats hittills utan det är helt nyinstallerat
Datorn ska användas till Folding@home, men lyckades inte installera programvaran eftersom nästan allt jag försöker köra slutar svara
Vore ytterst tacksam för hjälp

Permalänk
Medlem

Men kolla vad det som drar cpu för det är omöjligt att veta för oss som inte ser systemet.

top från skalet eller om du vill ha grafiskt så kolla på länken nedan
http://www.thegeekstuff.com/2009/11/ubuntu-tips-graphical-mon...

Permalänk
Medlem
Skrivet av aluser:

Men kolla vad det som drar cpu för det är omöjligt att veta för oss som inte ser systemet.

top från skalet eller om du vill ha grafiskt så kolla på länken nedan
http://www.thegeekstuff.com/2009/11/ubuntu-tips-graphical-mon...

Kanske ska säga att jag inte är någon höjdare på Ubuntu och är för tillfället ganska förvirrad (första gången jag kör Ubuntu)

Men jag kollade i Ubuntus "system monitor" och där ser jag inget som drar såpass mycket cpu kraft
Endast några få (ca 5) program på 1-2%

Permalänk
Hedersmedlem
Skrivet av Scitus:

Kanske ska säga att jag inte är någon höjdare på Ubuntu och är för tillfället ganska förvirrad (första gången jag kör Ubuntu)

Men jag kollade i Ubuntus "system monitor" och där ser jag inget som drar såpass mycket cpu kraft
Endast några få (ca 5) program på 1-2%

Hur vet du att du har hög CPU-användning från första början om det inte syns i dessa rapporteringsverktyg?

Permalänk
Medlem
Skrivet av phz:

Hur vet du att du har hög CPU-användning från första början om det inte syns i dessa rapporteringsverktyg?

Jo alltså jag ser att cpu användningen är hög (en graf samt %)
men listan med processer som körs visar inte att något drar så mycket cpu kraft som används

Jag antar att "system monitor" är som aktivitetshanteraren (eller?)

Permalänk
Medlem

Jag har hittat svaret till problemet
Det finns tydligen en bugg i 14.04 som orsakar väldigt hög cpu load
Någonting med "compiz"

Iaf, tack till dem svarade, ska installera 13.10 istället

Permalänk
Medlem
Skrivet av Scitus:

Jag har hittat svaret till problemet
Det finns tydligen en bugg i 14.04 som orsakar väldigt hög cpu load
Någonting med "compiz"

Iaf, tack till dem svarade, ska installera 13.10 istället

Alternativt, dessutom lättare, köra detta kommando: sudo apt-get remove compiz

Permalänk
Skrivet av oTiuZ:

Alternativt, dessutom lättare, köra detta kommando: sudo apt-get remove compiz

Unity behöver väl compiz?

Permalänk
Medlem

Som TS säger så visas inte alltid enstaka processers CPU-användning i systemövervakaren. Däremot går det att se totalanvändningen i grafdelen.

Det finns många orsaker till varför användningen är hög. En av dem kan vara att RAMbussen flaskar (Den har FSB), IO-bussen är upptagen eller att det finns något systemprogram som ligger i bakgrunden och kör. Ett ex. på detta kan vara specialmonteringar i fstab.

Har TS SSD? Installerat något speciellt efter installationen? Monterar TS fjärrenheter, RAIDenheter, krypterade enheter eller "ovanligare" filsystem?

Finns det perioder då användningen är låg/hög eller ligger den konstant på 50%?

Permalänk
Medlem
Skrivet av Commander:

Unity behöver väl compiz?

Ah, kanske det gör. Men det går väl med andra alternativ också? Till exempel xcompmgr eller liknande, eller?

Permalänk
Medlem
Skrivet av Erwya:

Som TS säger så visas inte alltid enstaka processers CPU-användning i systemövervakaren. Däremot går det att se totalanvändningen i grafdelen.

Det finns många orsaker till varför användningen är hög. En av dem kan vara att RAMbussen flaskar (Den har FSB), IO-bussen är upptagen eller att det finns något systemprogram som ligger i bakgrunden och kör. Ett ex. på detta kan vara specialmonteringar i fstab.

Har TS SSD? Installerat något speciellt efter installationen? Monterar TS fjärrenheter, RAIDenheter, krypterade enheter eller "ovanligare" filsystem?

Finns det perioder då användningen är låg/hög eller ligger den konstant på 50%?

Kör på en vanlig 1tb WD blue hårddisk
CPU:n pendlar mellan 50-100% på alla kärnor, stannar ofta en längre tid på 100%

Men jag tror inte det är något fel på datorn utan det är en bugg som orsakar den höga cpu användningen
Tror dem nyss släppte beta till 14.10, de kanske har fixat buggen i den versionen
Det kvittar ändå, 13.10 fungerar bra, datorn ska ändå bara användas till folding

Tack för hjälpen iaf

Skrivet av oTiuZ:

Ah, kanske det gör. Men det går väl med andra alternativ också? Till exempel xcompmgr eller liknande, eller?

Är som sagt erfaren i Ubuntu eftersom det är första gången jag använder det
Så förstår inte riktigt vad du menar :/
Men som Commando sa så tror jag att "compiz" behövs för att det ska fungera korrekt

Permalänk
Skrivet av oTiuZ:

Ah, kanske det gör. Men det går väl med andra alternativ också? Till exempel xcompmgr eller liknande, eller?

Unity är ett plugin till Compiz så tror inte att man har något val.

Permalänk
Medlem

Prova att installera gnome-fallbak och kör gnome för att se omdet blir mindre processoranvändning då.

Permalänk
Medlem

Ubuntu borde installera nvidias open source drivrutiner som standard. Dom är, om jag får vara krass, riktigt risiga. Om du inte installerat nvidias stängda drivrutiner så tycker jag du ska börja med att göra det. Nu var det rätt många år sedan jag körde ubuntu men om inget ändrats så kommer det med ett verktyg som kan installera dom automatiskt. Let efter "install additional driver/hardware" eller liknande i menyerna.

alternaivt kan du följa den här guiden för att installera dom senaste via ett programbibliotek från tredjepart (ubuntu tillhandahåller inte dom nyaste själva)

http://www.binarytides.com/install-nvidia-drivers-ubuntu-14-0...