Bahnhof IP-telefoni konfigurationsproblem

Permalänk

Bahnhof IP-telefoni konfigurationsproblem

Jag har löst problemet! Scrolla ner för att se lösningen!

Jag köpte nyligen en Gigaset C530 IP, men jag har problem med att försöka koppla den till min leverantör, Bahnhof. Eftersom att Bahnhof inte är en av de registrerade leverantörerna hos Gigaset så kan jag inte bara ladda ner den automatiska konfigurationen via "Start Configuration Assistant", utan jag måste göra det manuellt. Jag har försökt hitta information på deras hemsida, men det var tyvärr inte mycket till hjälp. Informationen jag har fått ifrån Bahnhof är följande:

SIP-användarnamn: 55XXXXXXXXX (11 siffror)
SIP-lösenord: n7XXXXXX (8 bokstäver/siffror)
SIP-server: bahnhof-lda.soho1.voip.bahnhof.net

Och min IP-telefons inställningsfönster ser ut såhär (jag har inte ändrat på någonting):

Vad ska jag skriva i de olika tomma rutorna?

Permalänk
Medlem

Testa med detta:
Authentication Name: SIP-användarnamn: 55XXXXXXXXX (11 siffror)
Authentication password: n7XXXXXX (6 bokstäver/siffror)
Username: SIP-användarnamn: 55XXXXXXXXX (11 siffror)
Display name: SIP-användarnamn: 55XXXXXXXXX (11 siffror)
Proxy server address: bahnhof-lda.soho1.voip.bahnhof.net
Domain: bahnhof-lda.soho1.voip.bahnhof.net
Registrar server: bahnhof-lda.soho1.voip.bahnhof.net
Outbound proxy: bahnhof-lda.soho1.voip.bahnhof.net

Möjligen öppna port 5060 inne i routern också. Tror det inte skall behövas.

Permalänk
Skrivet av XPerion:

Testa med detta:
Authentication Name: SIP-användarnamn: 55XXXXXXXXX (11 siffror)
Authentication password: n7XXXXXX (6 bokstäver/siffror)
Username: SIP-användarnamn: 55XXXXXXXXX (11 siffror)
Display name: SIP-användarnamn: 55XXXXXXXXX (11 siffror)
Proxy server address: bahnhof-lda.soho1.voip.bahnhof.net
Domain: bahnhof-lda.soho1.voip.bahnhof.net
Registrar server: bahnhof-lda.soho1.voip.bahnhof.net
Outbound proxy: bahnhof-lda.soho1.voip.bahnhof.net

Möjligen öppna port 5060 inne i routern också. Tror det inte skall behövas.

Jag testade det här. När jag försöker registrera handenheten står det "Söker basstation som är i registreringsläge" ett tag, sedan står det bara "Registrering misslyckades".

Det här är inställningarna jag testade:

Jag har både testat att ha 'STUN enabled' på 'Yes' och 'No', jag fick samma resultat på båda alternativen.

Permalänk
Medlem

Märkligt, det fungerar på Siemens A580 och skall fungera på C530 med. STUN ska du inte aktivera.
Vad har du för router? Möjligen måste ändra nånting därinne för IP tele skall fungera. Det fick jag göra på min AC66 och deaktivera WAN - NAT Genompassering (SIP Passthrough = inaktivera)
Kolla upp din router om nån inställning skall ändras för VOIP.

Dum fråga, men du har väl inte fyllt i asteriska tecken efter 55 som visas på screenshoten va? Ska vara 11 siffriga användarnamn, utan asteriska tecken.

Permalänk
Skrivet av XPerion:

Märkligt, det fungerar på Siemens A580 och skall fungera på C530 med. STUN ska du inte aktivera.
Vad har du för router? Möjligen måste ändra nånting därinne för IP tele skall fungera. Det fick jag göra på min AC66 och deaktivera WAN - NAT Genompassering (SIP Passthrough = inaktivera)
Kolla upp din router om nån inställning skall ändras för VOIP.

Dum fråga, men du har väl inte fyllt i asteriska tecken efter 55 som visas på screenshoten va? Ska vara 11 siffriga användarnamn, utan asteriska tecken.

Jag har en Netgear WNDR4500, jag kollade igenom WAN-inställningarna men jag hittar ingen SIP passthrough inställning.

Nej, där jag har skrivit asterisker har jag de riktiga siffrorna.

Permalänk
Medlem

Fyll bara i det här: http://i.imgur.com/836EgNL.png
Vet inte om du måste tala om vilket telefonnummer du har någonstans.

Permalänk
Medlem

Testa bocka i SIP ALG och disabla det. Öppna port i routern samma port som vald i C510.
Sen kan testa växla mellan NAT Filtering Secured - Open (Open ger mindre säkerhet, ej rek.)

Från Bahnhof:
De portar som ska vidarebefordras är:
69 – UDP
5060 – 5080 TCP och UDP
9000 – 14000 UDP
50000 – 60000 UDP

Testat ställa in med Start Config Assist? Behöver ingen kod för köra med det. https://www.gigaset.com/fileadmin/legacy-assets/CustomerCare/Docs_Pics/Voip_einrichten_eng_Merkur.pdf

Annars vet jag inte, maila Siemens support och se om dom kan hjälpa dig med inställningarna ihop med din router.
Kan testa koppla C510 direkt i vägguttaget, utan router och se om det fungerar först?

Permalänk
Skrivet av jocke92:

Fyll bara i det här: http://i.imgur.com/836EgNL.png
Vet inte om du måste tala om vilket telefonnummer du har någonstans.

Jag testade det här, svaret jag fick var "No line configured."

Permalänk
Medlem

Har du en Asus router så kan det vara där problemet ligger. Det går inte att vidarebefordra ovanstående portar på den.

Själv löste jag problemet med Merlins FW.

Hoppas det löser sig.

Permalänk
Skrivet av XPerion:

Testa bocka i SIP ALG och disabla det. Öppna port i routern samma port som vald i C510.
Sen kan testa växla mellan NAT Filtering Secured - Open (Open ger mindre säkerhet, ej rek.)
http://screenshots.portforward.com/routers/Netgear/WNDR4500/W...

Från Bahnhof:
De portar som ska vidarebefordras är:
69 – UDP
5060 – 5080 TCP och UDP
9000 – 14000 UDP
50000 – 60000 UDP

Testat ställa in med Start Config Assist? Behöver ingen kod för köra med det. https://www.gigaset.com/fileadmin/legacy-assets/CustomerCare/Docs_Pics/Voip_einrichten_eng_Merkur.pdf

Annars vet jag inte, maila Siemens support och se om dom kan hjälpa dig med inställningarna ihop med din router.
Kan testa koppla C510 direkt i vägguttaget, utan router och se om det fungerar först?

Alla portar som ska vara vidarebefodrade är det. Jag har testat avaktivera SIP ALG, och jag har även testat att ha NAT-filtrering öppnad. Jag har testat använda 'Start Configuration Assistant', men Bahnhof finns tyvärr inte i listan på leverantörer man kan välja. Jag har även testat att koppla basstationen direkt till WAN-uttaget, men problemet kvarstod ändå.

Permalänk
Medlem
Skrivet av theuserman:

Jag testade det här. När jag försöker registrera handenheten står det "Söker basstation som är i registreringsläge" ett tag, sedan står det bara "Registrering misslyckades".

Den klagar på att kopplingen mellan din egna basstation och din handenhet misslyckas, inte att registreringen mellan dig och Bahnhof misslyckades.
Oftast finns det en knapp du ska trycka på på basstationen, och sedan trycker du på registrera i din handenhet. Vänta några sekunder, pang, klart.

Permalänk
Skrivet av Kamouflage:

Den klagar på att kopplingen mellan din egna basstation och din handenhet misslyckas, inte att registreringen mellan dig och Bahnhof misslyckades.
Oftast finns det en knapp du ska trycka på på basstationen, och sedan trycker du på registrera i din handenhet. Vänta några sekunder, pang, klart.

Jag kom på det efter ett tag, men tusen tack ändå!

Permalänk

Först och främst vill jag tacka alla som har svarat i den här tråden. Sedan vill jag säga:

Jag kom på lösningen till problemet!

Först och främst så ska man trycka och hålla i knappen på basstationen när det står "Söker basstation som är i registreringsläge" på handenheten, fram till handenheten hittar basstationen. Sedan visade sig att problemet inte var min router eller inställningarna under 'Connections'. Utan det fanns en inställning under 'Number Assignment' som automatiskt var på 'Fixed line' på 'for outgoing calls' men den skulle egentligen vara på 'IP1', vilket är den profilen som jag har skrivit in Bahnhofs konfigurationer i.

Så såhär ska det göras, för alla som har samma problem som jag hade i framtiden:

1. Koppla SIP-basstationen till routern och telenätet och gå in på http://www.gigaset-config.com/ -> Din telefon (System PIN brukar vara '0000' när den är fabriksinställd) -> 'Settings' -> 'Management' -> 'Firmware Update' och tryck på 'Update firmware'.

2. Gå tillbaka in på din telefon (System PIN brukar vara '0000' när den är fabriksinställd) -> 'Settings' -> 'Management' -> 'Reboot & Reset' och fabriksåterställ basstationen genom att trycka på 'OK' under 'Factory settings'.

3. När telefonen är uppdaterad och fabriksåterställd går du in på 'Settings' -> 'Telephony' -> 'Connections' och tryck på 'Edit' på 'IP1' (eller en annan profil, om du vill göra det), sedan skriver du in följande:

Där asteriskerna (*) motsvarar de siffrorna som Bahnhof har gett dig som SIP-användarnamn.

Det som ska fyllas i är alltså:

Authentication name: SIP-användarnamn (11 siffror i mitt fall)
Authentication password: SIP-lösenord (8 siffror/bokstäver i mitt fall)
Username: SIP-användarnamn (11 siffror i mitt fall)
Display name: SIP-användarnamn (11 siffror i mitt fall)

Domain: SIP-server (bahnhof-lda.soho1.voip.bahnhof.net i mitt fall)
Proxy server address: SIP-server (bahnhof-lda.soho1.voip.bahnhof.net i mitt fall)
Registration server: SIP-server (bahnhof-lda.soho1.voip.bahnhof.net i mitt fall)
Outbound server address: SIP-server (bahnhof-lda.soho1.voip.bahnhof.net i mitt fall)

Och klickar sedan på 'Set'. Sedan bockar du in den så att den är 'Active' och klickar på 'Update profile' till det står "Profile update successful." och 'Status' står på "Registered"

4. Gå in på inställningen 'Number Assignment' och välj 'IP1' (eller en annan profil, om du har valt en annan profil i tredje steget) på 'for outgoing calls'. Det ska se ut såhär:

5. Ett till tips är att du går in på inställningen 'Audio' och väljer 'Optimized for high bandwith', så du får högre ljudkvalité när du pratar, om du vill ha det. Det ska se ut såhär:

Permalänk
Medlem

Några portar ska inte behöva forwardas i routern. Gör man det innebär det att man bara kan ha en sip-enhet bakom routern.

När du säger det så är C530 en bas som kan hantera flera telefoner, så då måste man tala om vilken handenhet som har vilket nummer/tjänst.

Permalänk
Skrivet av jocke92:

Några portar ska inte behöva forwardas i routern. Gör man det innebär det att man bara kan ha en sip-enhet bakom routern.

När du säger det så är C530 en bas som kan hantera flera telefoner, så då måste man tala om vilken handenhet som har vilket nummer/tjänst.

Ja precis, tack!

Permalänk
Medlem
Skrivet av theuserman:

Jag kom på lösningen till problemet!

Klockren guide. OP delivers

Jag tror dock att display name inte ska vara ditt användarnamn. Display name sätts i from headern och visas på de telefoner som har stöd för det. Nu när du ringer vissa kommer det stå typ
"From: 55xxxxxxxx
08-12345678"

Så där kan du med fördel skriva ditt namn, ditt telefonnummer eller lämna blankt. Ser lite snyggare ut om du ringer någon som har en telefon med stöd för det.

Permalänk
Medlem

SIP och RTP port kan behöva ändras

Hej,

Mycket bra guide men tyvärr funkade det dock inte 100% för mig.
Jag kunde ringa ut men de inkommande samtalen fungerade inte.
Det ringde i telefonen men jag hörde inte de som ringde och de hörde inte mig.

Jag hittade denna hjälp från GigaSet och den hjälpte mig.
http://www.gigaset.com/fileadmin/legacy-assets/NAT_troublesho...

Jag behövde inte göra någon som helst port forward in min ASUS router utan jag bara startade om min GigaSet C530IP och sedan funkar även inkommande samtal.

/Z

Permalänk
Medlem

Jag får inte till det, det går att ringa ut. När jag ringer till telefonen går signaler fram och ringsignal börjar spela. Trycker på svara och ringsignalen tystnar i handenheten men samtalet kopplas ej upp, i mobilen fortsätter signalerna gå fram. Tycker jag har följt instruktionerna här ovan och kan inte begripa vad felet är.

Permalänk
Medlem

Löste problemet genom att koppla den direkt i mediakonverteraren. Så routern bråkar med det på något sätt.

Permalänk
Medlem

Jag har en C610 och hade samma problem. Jag löste det genom att aktivera "Use random ports for SIP" i "Advanced VoIP Settings". Dessutom passade jag på att forwarda dessa portar till VOIP-enheten: 5004:5076. Det sista kanske inte var nödvändigt men nu funkar det och då vill jag ju inte störa apparaterna...

Permalänk
Medlem

Hej!
Jag skaffade en C530IP och följde @theuserman 's guide, jättebra!
Inkommande samtal fungerade dock inte så då läste jag gigasets felsökning som @ZathrasB länkade till och nu fungerar det!

Tack för all hjälp, sparade lite pengar på att köpa en sån här istället för bahnhofs sip-box plus en telefon. Och nu kan man ha den bakom routern vilket jag ville.

Mvh, Jakob

Permalänk
Medlem

Hej och tack till 'theuserman' och 'ZathrasB'!

Jag följde guiden men var också tvungen att ändra SIP och RTP port för att få inkommande samtal att fungera.
Behövde inte heller forwarda några portar i routern (ASUS).

/P

Permalänk
Medlem

Precis fått fiber och medieomvandlaren för Öppen Fiber verkar ha en dedikerad port för telefoni.

Är det någon för- eller nackdel med att koppla telefonin till routern istället för Port 3 på medieomvandlaren?

Tanken var att använda samma telefon som TS (Gigaset 530) och routern är en Asus N66U.

Permalänk
Medlem

SIP och RTP port kan behöva ändras

Hej,

Ja, jag kan bara instämma och tacka för denna guide.

Jag hade också problem med att ringa ut. Men in gick bra.
Jag har en ASUS RT-AC66U, en Gigaset 530 IP och nytt konto hos Bahnhof.

Med följande "Advanced VoIP Settings" slapp jag göra port forward i routern.

N

Permalänk
Medlem

Ska registreringen mot operatören fungera oavsett om man öppnat portar i routern eller ej? Fastnar nämligen på "Registration at provider failed".

Har den just nu kopplad bakom routern.
Om jag istället provar Port3 på mediekonverteraren, går det då ens att logga in på telefonens webbaserade gränssnitt eller är jag då hänvisad till handenheten för att utföra ändringar?

Permalänk
Medlem
Skrivet av Reckie:

Ska registreringen mot operatören fungera oavsett om man öppnat portar i routern eller ej? Fastnar nämligen på "Registration at provider failed".

Har den just nu kopplad bakom routern.
Om jag istället provar Port3 på mediekonverteraren, går det då ens att logga in på telefonens webbaserade gränssnitt eller är jag då hänvisad till handenheten för att utföra ändringar?

Har du olika färgade portar på mediakonverteraren? Då borde du fått instruktioner på hur det ska kopplas. Ofta kommer ip-telefonin på en egen port då. Men bahnhof kanske kör allt på samma ändå.

Börja med att koppla innan routern med IP-telefonin och se att det kommer igång där så att du vet att den är rätt konfad och om det är i routern felet ligger

Permalänk
Medlem

Har stött på problem gällande C530, Bahnhof och Asus RT68U...
Följde tidigare (för kanske ett år sedan) theuserma's finfina genomgång en bit upp och fick allt att lira fint.
Sedan dess har jag vid uppdatering av firmware i routern gjort factory reset, och jag kunde inte längre svara på inkommande samtal.
När jag nu idag skulle ta tag i det, så var det ju det där tipset om att Inaktivera "SIP Genompasseing".
Kruxet är att om jag gör det så kan jag inte ringa varken ut eller in, och i uren står det "Kan ej registr. hos IP1"
Aktiverar jag "SIP Genompassering" igen försvinner det problemet, men jag kan fortfarande inte svara på inkommande samtal.
Någon som känner igen sig? Har ni löst problemet?

/GC

Permalänk
Medlem
Skrivet av GeorgeCostanza:

Har stött på problem gällande C530, Bahnhof och Asus RT68U...
Följde tidigare (för kanske ett år sedan) theuserma's finfina genomgång en bit upp och fick allt att lira fint.
Sedan dess har jag vid uppdatering av firmware i routern gjort factory reset, och jag kunde inte längre svara på inkommande samtal.
När jag nu idag skulle ta tag i det, så var det ju det där tipset om att Inaktivera "SIP Genompasseing".
Kruxet är att om jag gör det så kan jag inte ringa varken ut eller in, och i uren står det "Kan ej registr. hos IP1"
Aktiverar jag "SIP Genompassering" igen försvinner det problemet, men jag kan fortfarande inte svara på inkommande samtal.
Någon som känner igen sig? Har ni löst problemet?

/GC

Sitter precis med detta problem. Skulle hjälpa far min, åskan tagit gamla Ciscoboxen och konfa den den som vanligt, gjorde sedan en update på 68an och allt slutade funka. Har exakt samma erfarenhet som du, så om någon har en lösning på hur man åtminstående kan ta tillbaka en gammal firmware?

Permalänk
Medlem

Har nu lite mer information och det verkar som om det är dax att varna högt och tydligt vad Asus håller på med.
Asus har fått Amerikanska myndigheterna på sig att ha mer kontroll över vilka Firmware som installeras på deras hårdvara. Därför har de släppt en ny firmware till (alla?) deras routrar där ;
1, du kan inte gå tillbaka äldre versioner
2, du kan inte lägga in någon annan firmware från någon open source, i alla fall inte ännu.

Det verkar är att uppdateringen är inte klar, dvs fruktansvärt buggig, routrar som även blivit brickade och funktioner som bara försvann, inklusive vårat SIP-Stöd.

LÄGG INTE IN DENNA UPPDATERING!

MER INFO
http://www.snbforums.com/threads/asus-firmware-will-change-th...
och hur du kan hacka ner versionen,
http://www.snbforums.com/threads/68u-3-0-0-4-380_3264-downgra...

Har inte provat själv då jag inte har fysisk tillgång till routern i fråga. suck..

Permalänk
Medlem

@GeorgeCostanza:

Har nu löst det efter lite klurande. Detta om man har oturen att ha uppgraderat, ni som inte gjort det, gör det inte utan lägg in Merlin istället.

Problemet ligger i att routern verkar ha problem att vidarebefodra UDP-paket, i alla fall SIP telefonens RTP UDP paket.
Så de inställningar som du nu har lagt in för att skicka vidare RTP paketen funkar ej och blir blockade, dvs inget ljud på inkommande samtal då ljudet går i RTP-paketen.
Lösningen är då:
Gå till WAN -> port forward
Välj här famous gamers list-> Counterstrike TCP och sedan deras UDP. Ändra portvalen som de stämmer med de portar du haft innan, gör inget annat, bara lägg till och spara. Nu ska ljudet komma tillbaka.

/C