Raspbian: öäå blir ?? ?? ??

Permalänk
Medlem

Raspbian: öäå blir ?? ?? ??

Ok nu är det så här att åäö har blivit till ??? på alla mina filer som hade namn med dessa bokstäver i sig, vilket jag skulle vilja ha tillbaka. Det har fungerat förut men eftersom min raspi med os raspbian är en server så tog jag bort allt onödigt grafiskt trams och lite till. Efter det har det inte fungerat med åäö. Jag ssh:ar till mitt system och om man trycker på ö så försvinner mitt manm@mittsystem på skärmen och det viss i stället: (arg: 6) trycker jag på å eller ä hör jag bara Windows bing dong melodi.

Jag provade att köra kommandot locale som gav följande:

LANG= LANGUAGE= LC_CTYPE="POSIX" LC_NUMERIC="POSIX" LC_TIME="POSIX" LC_COLLATE="POSIX" LC_MONETARY="POSIX" LC_MESSAGES="POSIX" LC_PAPER="POSIX" LC_NAME="POSIX" LC_ADDRESS="POSIX" LC_TELEPHONE="POSIX" LC_MEASUREMENT="POSIX" LC_IDENTIFICATION="POSIX" LC_ALL=

Så jag misstänker att jag av misstag råkat ta bort något men det kan vara vad som helst.

Permalänk
Medlem

Borde du inte ha typ svenska efter Language=?

Permalänk
Medlem

Jo det tycker jag också, har kört sudo raspi-config o tryckte i svenska men det verkar inte som om det hamnar i locale

Permalänk
Medlem

Testa att köra raspi-config och välj Internationalisation Options - Locale. Bläddra fram till sv_SE-UTF-8 (tror jag att det ska vara). Välj bort ev. annat.

Permalänk
Permalänk
Medlem
Skrivet av saturday_sun:

Testa att köra raspi-config och välj Internationalisation Options - Locale. Bläddra fram till sv_SE-UTF-8 (tror jag att det ska vara). Välj bort ev. annat.

Det verkar inte ha fungerat
Körde:

sudo raspi-config -> 4 Internationalisation Options -> I1 Change Locale -> sv_SE.UTF-8 UTF -8 -> None

Men det står ändå:

Generating locales (this might take a while)... en_GB.UTF-8... done Generation complete.

Permalänk
Medlem

Testa att göra det från menyn (gui:t). Svårt att bedöma om något är fel i kommandot du kört.

$ sudo raspi-config

Permalänk
Medlem

Hur pass mycket av "debian" finns kvar i raspbian? Om det är sig väldigt likt så är det så här det ser ut på min debian-maskin.

Nu skjuter jag lite ifrån höften då detta är något jag sällan pillat med, men pröva detta, en liten mer manuell väg att gå.
Öppna upp /etc/locale.gen och avkommentera allt bortsett ifrån det du vill använda.
Jag använder exempelvis en_US.UTF-8 UTF-8.

Generera valda locales:

root@server:~# locale-gen Generating locales (this might take a while)... en_US.UTF-8... done Generation complete.

Verifiera tillgängliga locales

root@server:~# locale -a C C.UTF-8 en_US.utf8 POSIX

Kika så /etc/default/locale matchar:

root@bottenskrap:~# cat /etc/default/locale # File generated by update-locale LANG="en_US.UTF-8" LANGUAGE="en_US:en"

Se till så att detta finns i /etc/profile, lägg till det i slutet annars. Osäker om detta behövs, kan vara så att debian sätter LANG på annat sätt.
export LANG="en_US.UTF-8"

Se till att logga ut/in ordentligt innan det prövas på nytt.

Verifiera:

root@server:~# echo $LANG en_US.UTF-8 root@server:~# locale LANG=en_US.UTF-8 LANGUAGE=en_US:en LC_CTYPE="en_US.UTF-8" LC_NUMERIC="en_US.UTF-8" LC_TIME="en_US.UTF-8" LC_COLLATE="en_US.UTF-8" LC_MONETARY="en_US.UTF-8" LC_MESSAGES="en_US.UTF-8" LC_PAPER="en_US.UTF-8" LC_NAME="en_US.UTF-8" LC_ADDRESS="en_US.UTF-8" LC_TELEPHONE="en_US.UTF-8" LC_MEASUREMENT="en_US.UTF-8" LC_IDENTIFICATION="en_US.UTF-8" LC_ALL=

Konfigurerar du via dpkg-reconfigure locales så uppdateras /etc/default/locale och /etc/locale.gen automatiskt.

Angående tangentbordslayout så kan du ta och kika i denna fil (/etc/default/keyboard) som används av systemet för konfigurera tangentbordet både i console och i grafisk miljö. XKBLAYOUT-raden är nog den som är intressant, och bör vara satt till se för svensk layout.

root@server:~# cat /etc/default/keyboard # KEYBOARD CONFIGURATION FILE # Consult the keyboard(5) manual page. XKBMODEL="pc105" XKBLAYOUT="se" XKBVARIANT="" XKBOPTIONS="" BACKSPACE="guess"

Kanske behöver starta om keyboard-setup tjänsten också? (service keyboard-setup restart)

Vad använder du för SSH-klient? Använder du Putty, se till att Window > Translation > Remote character set är satt till UTF-8.

Permalänk
Medlem

Tack för alla svar!
@Hieronymus: Det har jag redan provat tyvär
@saturday_sun: Jag har tagit bort allt som heter gui
@jagardaniel: Har kollat alla filer och ändrat det som behövts ändras så att alla matchar varandra. Dock fick jag denna felkod när jag körde dpkg-reconfigure locales;

virre@virre131 ~ $ sudo dpkg-reconfigure locales perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LANG = "se_SV.UTF-8" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory /usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory /usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory /usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory

För att eliminera en möjlig orsak kan det va ett program jag råkat ta bort? i så fall vilket

Permalänk
Medlem
Skrivet av Virre131:

Tack för alla svar!
@Hieronymus: Det har jag redan provat tyvär
@saturday_sun: Jag har tagit bort allt som heter gui
@jagardaniel: Har kollat alla filer och ändrat det som behövts ändras så att alla matchar varandra. Dock fick jag denna felkod när jag körde dpkg-reconfigure locales;

virre@virre131 ~ $ sudo dpkg-reconfigure locales perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LANG = "se_SV.UTF-8" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory /usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory /usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory /usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory

För att eliminera en möjlig orsak kan det va ett program jag råkat ta bort? i så fall vilket

Ett potentiellt fel jag ser är "se_SV.UTF-8" vilket borde vara "sv_SE.UTF-8" ...

Permalänk
Medlem

Efter att ha korrigerat språk namnet till det rätta så fick jag till det, så nu fungerar det perfekt!