GRUB vill inte installeras på Ubuntu Server 14.04

Permalänk
Moderator

GRUB vill inte installeras på Ubuntu Server 14.04

Edit; Se min andra post för nuvarande problem!

Jag har haft planer på att bygga en liten mediaserver hemma, och efter att ha experimenterat en del i Virtualbox så köpte jag tillslut hårdvara. Problem uppdagades dock direkt.

Under installationen så går det inte att konfigurera nätverket, det står bara "Automatisk nätverkskonfigurering misslyckades" och att mitt nätverk kanske inte använder DHCP-protokollet eller att någon nätverksmaskinvara inte fungerar korrekt. DHCP är dock aktiverat i min router. Skippar jag att konfigurera nätverket under installationen så går det inte att göra några uppdateringar heller (såklart). Min initiala reaktion var att det kanske saknas drivrutiner till nätverkskorten, men eftersom mina linuxkunskaper endast sträcker sig till spetsen på min näsa, och mina nätverkskunskaper ungefär lika långt så har jag ingen aning om hur jag ska göra för att felsöka på bästa sätt, eller om uppdatering av drivrutiner m.m. fungerar på liknande sätt som i Windows. Eller är det bara så enkelt att moderkortet inte stödjer Linux (står endast "Support for Windows 8.1/8/7" på hemsidan upptäckte jag nu)?

Hjälp på hur jag kan lösa problemet uppskattas, om det går att lösa över huvud taget.

Hårdvara
Moderkort: Gigabyte GA-H97N-WIFI (2st nätverkskort, Intel/Atheros Gbit)
Processor: Intel i5 4570S
Router: Asus RT-N16

Permalänk
Medlem

Ställ in en statisk IP på den och uppdatera sedan vilken DNS server du ska använda dig av. Det är dock konstigt att det inte går med DHCP servern.

http://superuser.com/questions/751995/setup-static-ip-under-u...
http://unix.stackexchange.com/questions/128220/how-do-i-set-m...

Permalänk
Moderator
Skrivet av trexake:

Ställ in en statisk IP på den och uppdatera sedan vilken DNS server du ska använda dig av. Det är dock konstigt att det inte går med DHCP servern.

http://superuser.com/questions/751995/setup-static-ip-under-u...
http://unix.stackexchange.com/questions/128220/how-do-i-set-m...

Dags för dagens dum: jag bytte nätverkskabel och då verkade det fungera. -.-

Men till nästa problem, GRUB vill inte installeras. Står bara att det är ett allvarligt problem.

Det är sent så har inte testat eller googlat något än, får bli morgondagens (dagens?) bekymmer. Men är det någon som har några tips tills jag sätter mig vid datorn igen så vore det kanon.

Ändrar rubriken också.

Permalänk
Moderator

Lätta, men dumma lösningar på problemet.

http://superuser.com/questions/845630/ubuntu-server-14-04-lts...

Permalänk
Medlem
Skrivet av Casgar:

Dags för dagens dum: jag bytte nätverkskabel och då verkade det fungera. -.-

Men till nästa problem, GRUB vill inte installeras. Står bara att det är ett allvarligt problem.

Det är sent så har inte testat eller googlat något än, får bli morgondagens (dagens?) bekymmer. Men är det någon som har några tips tills jag sätter mig vid datorn igen så vore det kanon.

Ändrar rubriken också.

Vanligt fel tydligen, var med om detta med. Starta datorn me usb stickan i som du installera med, grub har isntallerats på stickan så då kommer servern starta.
sedan loggar du in och kör:

sudo grub-install /dev/sda (byt sda mot de din disk heter, sda sdb sdc etc...)