Trädvy Permalänk
Medlem
Registrerad
Mar 2012

xsplit visar bara svart

Hej!

Jag försöker få igång en stream med 2 stycken canon videokameror, dessa är kopplade med hdmi-kablar (ca. 30 meter med hjälp av förstärkare) till 2 stycken capturekort (black magic intensity pro). Jag får perfekt signal genom kabeln, jag har testar direkt till en tv och även in i datorn med black magics egna programvara (media express). Capturekorten är inställda på 1080i 50fps vilket är precis vad kamerorna ger genom hdmi-porten.

Nu till problemen, jag får ingen annan programvara än BM Media Express att visa bild från kamerorna. Jag har testat med Xsplit och OBS, precis samma fel med båda; det visas bara en svart ruta. Jag har givetvis ställt in upplösningen i programmen till samma som capturekorten (1080i 50fps).

Edit: jag har testat med Wirecast nu också, där fungerade kamerorna men jag vill inte riktigt använda det programmet.

Är det någon som har haft liknande problem? någon som vet hur man löser det?

tack på förhand!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

Får du någon bild om kopplar något annat till ditt black magic?
t.ex. spelkonsol eller annan PC.

Edit:
prova amarec också http://www.amarectv.com/english/amarectv_e.htm
amarec har stöd för det mesta

Edit 2:
har du möjlighet att prova 720p istället?
vet att Black Magic intensity Pro är gjord specifikt för 720p.

Dator 1: i7 5820k | Asus X99-S | 16GB DDR4 | GTX 1080ti SLI | NZXT H440
Dator 2: i7 5820k | Asrock X99M | 32GB DDR4 | GTX 970 | SC-512N1-L Capture Card | Fractal Design Node 804
Skärm:Philips BDM4065UC
Mixer: Behringer X2222USB
Mina bästa tider inom speedruns

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av MaxieTheHatter:

Får du någon bild om kopplar något annat till ditt black magic?
t.ex. spelkonsol eller annan PC.

Edit:
prova amarec också http://www.amarectv.com/english/amarectv_e.htm
amarec har stöd för det mesta

Edit 2:
har du möjlighet att prova 720p istället?
vet att Black Magic intensity Pro är gjord specifikt för 720p.

Just nu har jag inte fysisk tillgång till datorn utan jag styr den med teamviewer, jag kan testa koppla in något annat imorgon.

Amarec skall provas!

Problemet är att jag inte kan styra vilken upplösning som skickas genom hdmi-porten på kamerorna, den verkar vara precis samma oberoende av inspelningsupplösningen. Kamerorna är av modellen Canon HF R56.

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av MaxieTheHatter:

prova amarec också http://www.amarectv.com/english/amarectv_e.htm
amarec har stöd för det mesta

Har testat det lite nu, får inte fram någon bild där heller. Vet inte om jag gör rätt däremot, förstår inte programmet riktigt.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008

Efter att ha googlat lite har jag kommit fram till att det eventuellt kan vara så att din kamera skickar ut en 1080p50 signal, något som dina capture cards inte klarar av.
Ska kolla vidare om jag inte kan hitta någon konkret förklaring!
Här har du lite läsning med en person som har samma problem http://forum.blackmagicdesign.com/viewtopic.php?f=18&t=21429
Verkar dock konstigt att det isåfall fungerar med andra program.

Dator 1: i7 5820k | Asus X99-S | 16GB DDR4 | GTX 1080ti SLI | NZXT H440
Dator 2: i7 5820k | Asrock X99M | 32GB DDR4 | GTX 970 | SC-512N1-L Capture Card | Fractal Design Node 804
Skärm:Philips BDM4065UC
Mixer: Behringer X2222USB
Mina bästa tider inom speedruns

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av MaxieTheHatter:

Efter att ha googlat lite har jag kommit fram till att det eventuellt kan vara så att din kamera skickar ut en 1080p50 signal, något som dina capture cards inte klarar av.
Ska kolla vidare om jag inte kan hitta någon konkret förklaring!
Här har du lite läsning med en person som har samma problem http://forum.blackmagicdesign.com/viewtopic.php?f=18&t=21429
Verkar dock konstigt att det isåfall fungerar med andra program.

Jag kan nästan garantera att det är 1080i den skickar ut. Jag installerade tidigare korten och kamerorna i min egen dator (sitter i en annan dator nu) och då fick jag allt att fungera, även med xsplit. Då använde jag 1080i i inställningarna. Jag funderar på om det kan ha att göra med att datorn de sitter i nu inte har något grafikkort, då det är den största skillnaden mellan datorerna.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008
Skrivet av rfyt:

Jag kan nästan garantera att det är 1080i den skickar ut. Jag installerade tidigare korten och kamerorna i min egen dator (sitter i en annan dator nu) och då fick jag allt att fungera, även med xsplit. Då använde jag 1080i i inställningarna. Jag funderar på om det kan ha att göra med att datorn de sitter i nu inte har något grafikkort, då det är den största skillnaden mellan datorerna.

Ja då är det garanterat inget fel på dina kort
Om du har möjlighet prova med ett grafikkort i.
Vad är det för CPU?

Edit:
hittade det här efter en del sökande på deras värdelösa supportavdelning

Citat:

Desktop Video Products
An accelerated graphics card is required for use with Desktop Video products. A motherboard integrated graphics card is not adequate and will not work properly.

Dator 1: i7 5820k | Asus X99-S | 16GB DDR4 | GTX 1080ti SLI | NZXT H440
Dator 2: i7 5820k | Asrock X99M | 32GB DDR4 | GTX 970 | SC-512N1-L Capture Card | Fractal Design Node 804
Skärm:Philips BDM4065UC
Mixer: Behringer X2222USB
Mina bästa tider inom speedruns

Trädvy Permalänk
Medlem
Registrerad
Mar 2012

Jag har testat fler program nu och lyckats få igång det med programmet Livestream Studio. Båda programmen som jag får igång kamerorna med (Livestream Studio och Wirecast) verkar ha en sak gemensamt, de visar capturekorten som en enhet med namnet "Intensity Pro". De andra programmen visar två enheter med namnen "Blackmagic WDM Capture" och "Decklink Video Capture".

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av MaxieTheHatter:

Ja då är det garanterat inget fel på dina kort
Om du har möjlighet prova med ett grafikkort i.
Vad är det för CPU?

Tänkte åka dit och sätta i ett grafikkort imorgon!
Det är en Intel Xeon E31235, den har 8gb minne och körs på ett intel moderkort (kommer inte ihåg modell).

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av MaxieTheHatter:

Edit:
hittade det här efter en del sökande på deras värdelösa supportavdelning

Kan du länka till den sidan du hittade det på? får hoppas att det är lösningen!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008
Skrivet av rfyt:

Jag har testat fler program nu och lyckats få igång det med programmet Livestream Studio. Båda programmen som jag får igång kamerorna med (Livestream Studio och Wirecast) verkar ha en sak gemensamt, de visar capturekorten som en enhet med namnet "Intensity Pro". De andra programmen visar två enheter med namnen "Blackmagic WDM Capture" och "Decklink Video Capture".

Blackmagic WDM Capture är normalt, så ska det se ut när det fungerar.
CPUn ska inte ha några som helst problem med korten (har själv kört 4 kort samtidigt på en 2500K, ett Black magic intensity pro, ett SC-512n1 och två PEXHDCAP).
Återkom när du provat med ett grafikkort!
Behöver inte vara något avancerat, ett dedikerat kort borde räcka.

här har du en länk till supportdelen https://www.blackmagicdesign.com/support/note/9685

Dator 1: i7 5820k | Asus X99-S | 16GB DDR4 | GTX 1080ti SLI | NZXT H440
Dator 2: i7 5820k | Asrock X99M | 32GB DDR4 | GTX 970 | SC-512N1-L Capture Card | Fractal Design Node 804
Skärm:Philips BDM4065UC
Mixer: Behringer X2222USB
Mina bästa tider inom speedruns

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av MaxieTheHatter:

Blackmagic WDM Capture är normalt, så ska det se ut när det fungerar.
CPUn ska inte ha några som helst problem med korten (har själv kört 4 kort samtidigt på en 2500K, ett Black magic intensity pro, ett SC-512n1 och två PEXHDCAP).
Återkom när du provat med ett grafikkort!
Behöver inte vara något avancerat, ett dedikerat kort borde räcka.

här har du en länk till supportdelen https://www.blackmagicdesign.com/support/note/9685

Det kortet som jag tänkte sätta in är ett gt330 eller liknande om jag minns rätt. Tror du att det räcker eller ska jag försöka leta fram något annat?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008
Skrivet av rfyt:

Det kortet som jag tänkte sätta in är ett gt330 eller liknande om jag minns rätt. Tror du att det räcker eller ska jag försöka leta fram något annat?

Borde inte vara några problem.
PEXHDCAP kräver ett grafikkort med DirectX 9.0, kan inte tänka mig att Intensity pro är speciellt mer krävande.

Dator 1: i7 5820k | Asus X99-S | 16GB DDR4 | GTX 1080ti SLI | NZXT H440
Dator 2: i7 5820k | Asrock X99M | 32GB DDR4 | GTX 970 | SC-512N1-L Capture Card | Fractal Design Node 804
Skärm:Philips BDM4065UC
Mixer: Behringer X2222USB
Mina bästa tider inom speedruns

Trädvy Permalänk
Medlem
Registrerad
Mar 2012
Skrivet av MaxieTheHatter:

Borde inte vara några problem.
PEXHDCAP kräver ett grafikkort med DirectX 9.0, kan inte tänka mig att Intensity pro är speciellt mer krävande.

Det funkar perfekt nu! Stoppade in ett 8800gt och det var tydligen tillräckligt. Tack så mycket för hjälpen!

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Okt 2008
Skrivet av rfyt:

Det funkar perfekt nu! Stoppade in ett 8800gt och det var tydligen tillräckligt. Tack så mycket för hjälpen!

Perfekt!
Gott nytt år på dig

Dator 1: i7 5820k | Asus X99-S | 16GB DDR4 | GTX 1080ti SLI | NZXT H440
Dator 2: i7 5820k | Asrock X99M | 32GB DDR4 | GTX 970 | SC-512N1-L Capture Card | Fractal Design Node 804
Skärm:Philips BDM4065UC
Mixer: Behringer X2222USB
Mina bästa tider inom speedruns