Inget ljud från nyinstallerad debian

Permalänk
Medlem

Inget ljud från nyinstallerad debian

Hej,
installerade debian för några dagar sedan på en dator som stog stående och tänkte ha den som htpc och server (typ minecraft). Men jag får inget ljud, alsamixer väljer pulseaudio som default. Mina ljudkort (från hdmi):
Här är min en lista över ljudkort, men dock såg den annorlunda ut innan jag reboota

snuken@Gengar:~$ cat /proc/asound/cards 1 [Intel]: HDA-Intel - HDA Intel HDA Intel at 0xf77f4000 irq 41

Och nej den är inte mutad i alsamixer.
Så här ser min /etc/modprobe.d/alsa-base.conf ut

# autoloader aliases install sound-slot-0 /sbin/modprobe snd-card-0 install sound-slot-1 /sbin/modprobe snd-card-1 install sound-slot-2 /sbin/modprobe snd-card-2 install sound-slot-3 /sbin/modprobe snd-card-3 install sound-slot-4 /sbin/modprobe snd-card-4 install sound-slot-5 /sbin/modprobe snd-card-5 install sound-slot-6 /sbin/modprobe snd-card-6 install sound-slot-7 /sbin/modprobe snd-card-7 # Cause optional modules to be loaded above generic modules install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; : ; } install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; } install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; } # Keep snd-pcsp from beeing loaded as first soundcard options snd-pcsp index=-2 # Keep snd-usb-audio from beeing loaded as first soundcard options snd-usb-audio index=-2 # Prevent abnormal drivers from grabbing index 0 options bt87x index=-2 options cx88_alsa index=-2 options snd-atiixp-modem index=-2 options snd-intel8x0m index=-2 options snd-via82xx-modem index=-2 options snd_hda_intel index=1 options snd_mia index=0

Vill påpeka att innan rebooten så stod det under soundcards snd_hda_intel och inte HDA-Intel - HDA Intel
HDA Intel at 0xf77f4000 irq 41

EDIT: Ps. Allt ljud går från hdmi från moderkortet, så jag använder inget pci ljudkort.

Permalänk
Medlem

För att utesluta var felet ligger så är det intressant om det kommer något ljud ur 3.5"-porten samt om du kan spela brus över HDMI med cat /dev/urandom | aplay -D hw:0,3 (ändra ev. till annan hw adress).

Permalänk
Hedersmedlem

Installera paketet `pavucontrol` om det inte redan är installerat och starta programmet med samma namn. Det är ett generellt gränssnitt för att välja ljudkällor och annat, som bör kunna ge mer information. Ut- och ingångar kan vara mutade även där — `alsamixer` är rätt irrelevant i sammanhanget sedan övergången till PulseAudio.

Permalänk
Medlem
Skrivet av phz:

Installera paketet `pavucontrol` om det inte redan är installerat och starta programmet med samma namn. Det är ett generellt gränssnitt för att välja ljudkällor och annat, som bör kunna ge mer information. Ut- och ingångar kan vara mutade även där — `alsamixer` är rätt irrelevant i sammanhanget sedan övergången till PulseAudio.

Det har jag gjort, men jag ser inte mitt ljudkort där heller.
EDIT: Hitta felet i pavucontrol! Det var fel under configuration, nu fungerar det! Tusen tack!
En snabb fråga också, annars startar jag en ny tråd. Det är hur jag mountar min NAS och mina delade windows mappar på servern. Vill gärna att de ska mountas vid start
EDIT2: Det är debian jag använder

EDIT3: Nu har jag lyckas mounta nasen, men undrar hur jag ändrar behörighet så jag även kan skriva osv. Nu kan jag enbart läsa. Provat olika chmod saker som jag googlat men inget har hjälpt.