PI tangentbordslayouts problem

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Okt 2011

PI tangentbordslayouts problem

Har problem med tangentbordets tecken/layout inte stämmer i terminalen. Tangentbordet är k400 och pi:n är en pi 2:a. Kör berryboot om det spelar någon roll.

Har följande inställningar:
XKBMODEL="pc105"
XKBLAYOUT="se"
XKBVARIANT=""
XKBOPTIONS=""

(I terminalen) Mitt största problem är att div. tangenter ligger på fel plats ex. / (aka shift+7) ligger på --knappen (höger om .) eller att &-knappen ligger på shift+7 istället för 6. Hur löser man dessa problemen? (verkar alltså vara layout-relaterat?). Har som ni ser ändrat XKBLAYOUT till "se" men det verkar vara XKBMODEL som är fel?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2013

om du har raspbian så kan du skriva "sudo raspi-config" och komma in i en jätte fin meny, där väljer du nummer 4 och följer guiden, välj det förvalda om du inte fattar vad du gör.

AMD FX-8350|Sapphire R9 280|Obsidian 800D|Argon AR01

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Okt 2011
Skrivet av utsatt_unge496:

om du har raspbian så kan du skriva "sudo raspi-config" och komma in i en jätte fin meny, där väljer du nummer 4 och följer guiden, välj det förvalda om du inte fattar vad du gör.

Tack för svaret, löste sig dock genom att skriva:
sudo dpkg-reconfigure keyboard-configuration
och sedan välja "logitech internet 350 keyboard", vilket har liknande layout som k400 vilket "generic pc 105" inte hade (amerikansk standard?)

Länk för framtida intressenter:
https://importgeek.wordpress.com/2013/04/04/raspberry-pi-chan...