Kan inte installera Spotify [ubuntu]

Permalänk

Kan inte installera Spotify [ubuntu]

Hej, jag har försökt installera Spotify hela natten nu men fastnar i samma problem hela tiden. När jag skriver sudo apt-get install spotify-client så står det E: unable to locate package spotify-client. Vad ska jag göra? Har följt dessa guider:

https://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/S...
https://www.spotify.com/se/download/previews/
http://howtoubuntu.org/how-to-install-spotify-in-ubuntu

Tack på förhand!

Permalänk
Medlem
Skrivet av Samuel_Karlsson:

Hej, jag har försökt installera Spotify hela natten nu men fastnar i samma problem hela tiden. När jag skriver sudo apt-get install spotify-client så står det E: unable to locate package spotify-client. Vad ska jag göra? Har följt dessa guider:

https://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/S...
https://www.spotify.com/se/download/previews/
http://howtoubuntu.org/how-to-install-spotify-in-ubuntu

Tack på förhand!

Om Du har laggt till repon och nyckeln kör

sudo apt-get update

för det verkar som den inte har updaterar repon åt dig. Sen testa igen med

sudo apt-get install spotify-client

Permalänk
Skrivet av Sandia:

Om Du har laggt till repon och nyckeln kör

sudo apt-get update

för det verkar som den inte har updaterar repon åt dig. Sen testa igen med

sudo apt-get install spotify-client

Jag har gjort det. Jag har gjort alla steg som står i guiderna.

Skickades från m.sweclockers.com

Permalänk

Om du har följt den översta länken och skrivit in kommandot

sudo sh -c 'echo "deb http://repository.spotify.com/stable non-free" > /etc/apt/sources.list.d/spotify.list'

Måste du in i filen /etc/apt/sources.list.d/spotify.list och ändra raden

till

deb http://repository.spotify.com/ stable non-free

Detta kan du göra från ett terminalfönster med kommandot

sudo nano /etc/apt/sources.list.d/spotify.list

och sen uppdatera paketlistorna igen med

sudo apt-get update

Installera med

sudo apt-get install spotify-client

Permalänk
Skrivet av CryingFreeman:

Om du har följt den översta länken och skrivit in kommandot

sudo sh -c 'echo "deb http://repository.spotify.com/stable non-free" > /etc/apt/sources.list.d/spotify.list'

Måste du in i filen /etc/apt/sources.list.d/spotify.list och ändra raden

till

deb http://repository.spotify.com/ stable non-free

Detta kan du göra från ett terminalfönster med kommandot

sudo nano /etc/apt/sources.list.d/spotify.list

och sen uppdatera paketlistorna igen med

sudo apt-get update

Installera med

sudo apt-get install spotify-client

Tack för svar. Gjorde det du sa men problemet kvarstår. Här är en screen shot:

Permalänk
Medlem

Hur ser raden i /etc/apt/sources.list ut?

EDIT: Det är definitivt där problemet är, det syns på din senaste bild. Det ska bara stå "deb http://repository.spotify.com stable non-free" och inget annat, annars kommer det inte fungera.

Permalänk

En annan sak som förmodligen kommer att paja din installation av Spotify är att du har en distribution som har gått End Of Life (EOL). Ubuntu 11.10 Oneiric Ocelot som du verkar köra stöddes med säkerhetsuppdateringar fram till 9 maj 2013 och du bör därför uppgradera din distribution till 12.04 som är en Long Term Support (LTS-version) och som stöds fram till åtminstone 2017.

Som du ser i din egen skärmbild här ovan så står det oneiric på några ställen och ett meddelande om att sökvägen inte hittas (Not found).

Du bör uppdatera din /etc/apt/sources.list fil som bestämmer varifrån dina paket ska hämtas ifrån. Detta kan du göra genom att i det grafiska skalet trycka <Alt>+<F2> och skriva

gksudo gedit /etc/apt/sources.list

Sen måste du ersätta alla förekomster (tryck <Ctrl>+<H>) av

se.archive

med

old-releases

så att det istället för exempelvis

står

Gör likadant med

security

och ändra det till

old-releases

Därefter, för att påbörja installationen, kör du i tur och ordning

sudo apt-get update sudo apt-get install update-manager-core update-manager sudo apt-get dist-upgrade sudo do-release upgrade

Den här uppgraderingen kan ta upp till några timmar så du är medveten om det, men för att kunna installera Spotify-klienten måste du göra så eftersom den i sin tur har beroende av andra paket som måste installeras.

Lycka till!

Permalänk
Medlem
Skrivet av CryingFreeman:

En annan sak som förmodligen kommer att paja din installation av Spotify är att du har en distribution som har gått End Of Life (EOL). Ubuntu 11.10 Oneiric Ocelot som du verkar köra stöddes med säkerhetsuppdateringar fram till 9 maj 2013 och du bör därför uppgradera din distribution till 12.04 som är en Long Term Support (LTS-version) och som stöds fram till åtminstone 2017.

Är det inte bättre att köra 14.04? Det är ju också en LTS-version, som kommer stödas betydligt längre än 12.04.

Permalänk
Skrivet av Kerias:

Är det inte bättre att köra 14.04? Det är ju också en LTS-version, som kommer stödas betydligt längre än 12.04.

Givetvis, men det går inte på ett enkelt sätt att uppgradera till 14.04 från 11.10. Däremot är det betydligt enklare från 12.04 -> 14.04

Detta då under förutsättning att man alls vill uppgradera och inte bara ger upp och kör en nyinstallation.

Permalänk
Skrivet av LemonIllusion:

Hur ser raden i /etc/apt/sources.list ut?

EDIT: Det är definitivt där problemet är, det syns på din senaste bild. Det ska bara stå "deb http://repository.spotify.com stable non-free" och inget annat, annars kommer det inte fungera.

Jag gick in och kollade, här är en screenshot med raderna längst ned:

Ska jag ta bort alla utom "deb http://repository.spotify.com stable non-free"? Vill bara dubbelkolla vad du menar.

Permalänk
Medlem
Skrivet av Samuel_Karlsson:

Jag gick in och kollade, här är en screenshot med raderna längst ned:
http://i.imgur.com/nABf5mO.png
Ska jag ta bort alla utom "deb http://repository.spotify.com stable non-free"? Vill bara dubbelkolla vad du menar.

Du ska inte ta bort något ubuntu-repo. Som det ser ut där behöver du ta bort en av dina spotify-rader och avkommentera den andra.

Sedan kanske du även måste göra det som @CryingFreeman skriver.

Permalänk
Skrivet av LemonIllusion:

Du ska inte ta bort något ubuntu-repo. Som det ser ut där behöver du ta bort en av dina spotify-rader och avkommentera den andra.

Sedan kanske du även måste göra det som @CryingFreeman skriver.

Vad innebär avkommentera?

Permalänk
Medlem
Skrivet av Samuel_Karlsson:

Vad innebär avkommentera?

Brädgård # innebär att raden är en kommentar och ignoreras. Ta bort brädgården för att avkommentera.

Permalänk
Skrivet av LemonIllusion:

Brädgård # innebär att raden är en kommentar och ignoreras. Ta bort brädgården för att avkommentera.

Ok, tack. Jag tog bort dubletterna och har bara kvar en spotifyrad i sources.list + src-raden. Det ser ur såhär:

Den hittar fortfarande inte spotify-client. Står fortfarande att jag har dubletter.

Permalänk

@Samuel_Karlsson:
Du har säkert nån fil i katalogen /etc/apt/sources.list.d där det står en liknande rad för spotify.

EDIT: Sen har du fortfarande en End Of Life-version av Ubuntu som inte kommer att gå att uppdatera när sources.list ser ut som den gör. Du måste göra som jag skrivit i ett inlägg ovan. För spotify-klienten kräver säkerligen beroendepaket som inte kommer att hittas.

EDIT2: Ser också att du har två rader med en annan version av Ubuntu (de som slutar med "trusty main" ... Dessa bör du sätta # framför och köra sudo apt-get update