Streaming problem

Trädvy Permalänk
Medlem
Registrerad
Maj 2015

Streaming problem

Hej, jag försöker få igång en Cs Go stream på twitch med OBS men får screen tearing och fps'en går helt crazy, någon som kan förklara för mig varför och hjälpa en förvirrad tomte?

Provade med Nvidia Experience 720p 60 fps 5mbps, då har jag inga problem 500-600 fps. men får så mkt mindre inställningar så skulle vilja ha igång OBS.

OBS Settings
Encoding
Video
Advanced
FMS URL är Stockholm

Min setup
▶ Gaming Monitor: Benq XL2410T (120hz)
▶ Work Monitor:: Benq G2420 HD (60hz)
▶ Internet: 100/50 fiber (comhem)
▶ CPU: i7-5820k
▶ CPU Cooler: Cooler Master V8 GTS
▶ Ram: Crucial 2133MHz 12gb
▶ GPU: EVGA GeForce GTX 780 3GB
▶ Motherboard: MSI X99S SLI Pluss
▶ SSD #1: Samsung SSD 840 ProSeries 128gb (os)
▶ SSD #2: Samsung SSD 840 ProSeries 256gb (spel)
▶ HDD #3: Western Digital 2 TB (övrigt)

Mvh Dennis aka ZuroX

Trädvy Permalänk
Medlem
Plats
192.168.0.1
Registrerad
Jul 2007

Ta bort custom buffer. Sätt CPU preset på veryfast. Sätt fps:en på 60.

Audio bitraten känns fel. Ska inte den vara på 128?
Om det inte blir bättre: streama kanske en halvtimme och langa upp en logg efteråt.

Den kam hittas i %appdata% roaming OBS
Eller något sånt.

Nu vet jag inte heller om du är partner eller inte, men försök att hålla bitraten under 3k eftersom många andra länder inte har så bra uppladdning, vilket resulteras i buffer på streamen.

Edit: juste! Jag brukar försöka undvika använda t.ex Stockholm som server point eftersom i princip alla andra svenskar använder den också. Detta resulteras i att trafiken på servern blir omdirigerad till en annan EU-server som i följd skapar lagg/buffer, eftersom alla andra också sitter på den servern.

Låter silly, men jag brukar skifta mellan US och Paris.

Skickades från m.sweclockers.com

6700k @ 4.8GHz . 16GB @ 2666MHz . x2 1070 @ 2150/4600
360+240 rad custom loop
Flickr 500px

Trädvy Permalänk
Medlem
Registrerad
Maj 2015

när videon blir klar så kan du se hur min fps och annat beter sig här https://youtu.be/GgI-6gmEBQM

tog bort Custom buffer och satte CPU på veryfast, ändra även ljudet till 128, la in ett plugin som visa pingen jag skulle få till alla servrar och böt till näst bäst från Stockholm vilket var London.

streama i 10 min och fick denna log,

16:43:13: Server Ping plugin strings not found, dynamically loading 24 strings
Warning -- Bad call to String::Mid. iStart or iEnd is bigger than the current length (string: //web-api.azubu.tv/stream/broadcaster-key/).
16:43:32: Problem accessing the DNS. (addr: 瑨灴s, error: 11004)
16:44:10: Open Broadcaster Software v0.651b - 64bit ( ^ω^)
16:44:10: -------------------------------
16:44:10: CPU Name: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz
16:44:10: CPU Speed: 3300MHz
16:44:10: Physical Memory: 12183MB Total, 1153MB Free
16:44:10: stepping id: 2, model 63, family 6, type 0, extmodel 1, extfamily 0, HTT 1, logical cores 12, total cores 6
16:44:10: monitor 1: pos={0, 0}, size={1920, 1080}
16:44:10: monitor 2: pos={-1920, 0}, size={1920, 1080}
16:44:10: Windows Version: 6.1 Build 7601 S
16:44:10: Aero is Enabled
16:44:10: -------------------------------
16:44:10: OBS Modules:
16:44:10: Base Address Module
16:44:10: 000000003FED0000 OBS.exe
16:44:10: 00000000F1C50000 OBSApi.dll
16:44:10: 00000000F2A50000 DShowPlugin.dll
16:44:10: 00000000F2960000 GraphicsCapture.dll
16:44:10: 00000000F2A20000 NoiseGate.dll
16:44:10: 00000000F2930000 PSVPlugin.dll
16:44:10: 00000000F2900000 scenesw.dll
16:44:10: 00000000F24B0000 ServerPingPlugin.dll
16:44:10: ------------------------------------------
16:44:10: Adapter 1
16:44:10: Video Adapter: NVIDIA GeForce GTX 780
16:44:10: Video Adapter Dedicated Video Memory: 3161128960
16:44:10: Video Adapter Shared System Memory: 1824114688
16:44:10: Video Adapter Output 1: pos={0, 0}, size={1920, 1080}, attached=true
16:44:10: Video Adapter Output 2: pos={-1920, 0}, size={1920, 1080}, attached=true
16:44:10: =====Stream Start: 2015-05-24, 16:44:10===============================================
16:44:10: Multithreaded optimizations: On
16:44:10: Base resolution: 1920x1080
16:44:10: Output resolution: 1280x720
16:44:10: ------------------------------------------
16:44:10: Loading up D3D10 on NVIDIA GeForce GTX 780 (Adapter 1)...
16:44:10: ------------------------------------------
16:44:10: Audio Format: 48000 Hz
16:44:10: ------------------------------------------
16:44:10: Audio Channels: 2 Ch
16:44:10: Playback device {0.0.0.00000000}.{173633c6-c398-478c-bb38-e609dffe71e4}
16:44:10: ------------------------------------------
16:44:10: Using desktop audio input: Speakers (Turtle Beach Z60 Game Audio)
16:44:10: Global Audio time adjust: 0
16:44:11: ------------------------------------------
16:44:11: Using auxilary audio input: Microphone (Turtle Beach Z60 Chat Audio)
16:44:11: Mic time offset: 0
16:44:11: ------------------------------------------
16:44:11: Audio Encoding: AAC
16:44:11: bitrate: 128
16:44:11: Using graphics capture
16:44:11: Scene buffering time set to 700
16:44:11: ------------------------------------------
16:44:11: Video Encoding: x264
16:44:11: fps: 60
16:44:11: width: 1280, height: 720
16:44:11: preset: veryfast
16:44:11: profile: main
16:44:11: keyint: 120
16:44:11: CBR: yes
16:44:11: CFR: yes
16:44:11: max bitrate: 2800
16:44:11: buffer size: 2800
16:44:11: ------------------------------------------
16:44:12: Using RTMP service: Twitch
16:44:12: Server selection: rtmp://live-lhr.twitch.tv/app
16:44:12: Interface: Intel(R) Ethernet Connection (2) I218-V (ethernet, 1000 mbps)
16:44:13: Completed handshake with rtmp://live-lhr.twitch.tv/app in 700 ms.
16:44:14: SO_SNDBUF was at 8192
16:44:14: SO_SNDBUF is now 65536
16:44:14: RTMPPublisher::SocketLoop: Increasing send buffer to ISB 131072 (buffer: 0 / 374784)
16:44:20: Trying to hook process: csgo.exe
16:44:23: SharedTexCapture hooked
16:44:25: RTMPPublisher::SocketLoop: Increasing send buffer to ISB 262144 (buffer: 0 / 374784)
16:44:30: RTMPPublisher::SocketLoop: Increasing send buffer to ISB 524288 (buffer: 0 / 374784)
16:48:08: GraphicsCaptureSource::NewCapture: eliminating old capture
16:48:08: SharedTexCapture hooked
16:50:25: GraphicsCaptureSource::NewCapture: eliminating old capture
16:50:25: SharedTexCapture hooked
16:53:34: FlushBufferedVideo: Flushing 74 packets over 1216 ms
16:53:35: Total frames encoded: 33836, total frames duplicated: 11764 (34.77%)
16:53:35: Total frames rendered: 33000, number of late frames: 548 (1.66%) (it's okay for some frames to be late)
16:53:35:
16:53:35: Profiler time results:
16:53:35:
16:53:35: ==============================================================
16:53:35: video thread frame - [100%] [avg time: 5.239 ms] [children: 10%] [unaccounted: 90%]
16:53:35: | scene->Preprocess - [0.0191%] [avg time: 0.001 ms]
16:53:35: | GPU download and conversion - [9.98%] [avg time: 0.523 ms] [children: 5.1%] [unaccounted: 4.89%]
16:53:35: | | flush - [4.58%] [avg time: 0.24 ms]
16:53:35: | | CopyResource - [0.42%] [avg time: 0.022 ms]
16:53:35: | | conversion to 4:2:0 - [0.0954%] [avg time: 0.005 ms]
16:53:35: Convert444Threads - [100%] [avg time: 0.22 ms] [children: 98.6%] [unaccounted: 1.36%]
16:53:35: | Convert444toNV12 - [98.6%] [avg time: 0.217 ms]
16:53:35: encoder thread frame - [100%] [avg time: 0.67 ms] [children: 2.99%] [unaccounted: 97%]
16:53:35: | sending stuff out - [2.99%] [avg time: 0.02 ms]
16:53:35: ==============================================================
16:53:35:
16:53:35:
16:53:35: Profiler CPU results:
16:53:35:
16:53:35: ==============================================================
16:53:35: video thread frame - [cpu time: avg 0.152 ms, total 5038.83 ms] [avg calls per frame: 1]
16:53:35: | scene->Preprocess - [cpu time: avg 0 ms, total 15.6 ms] [avg calls per frame: 1]
16:53:35: | GPU download and conversion - [cpu time: avg 0.043 ms, total 1450.81 ms] [avg calls per frame: 1]
16:53:35: | | flush - [cpu time: avg 0.031 ms, total 1029.61 ms] [avg calls per frame: 1]
16:53:35: | | CopyResource - [cpu time: avg 0.006 ms, total 202.8 ms] [avg calls per frame: 1]
16:53:35: | | conversion to 4:2:0 - [cpu time: avg 0 ms, total 15.6 ms] [avg calls per frame: 1]
16:53:35: Convert444Threads - [cpu time: avg 0.123 ms, total 16317.7 ms] [avg calls per frame: 4]
16:53:35: | Convert444toNV12 - [cpu time: avg 0.123 ms, total 16224.1 ms] [avg calls per frame: 4]
16:53:35: encoder thread frame - [cpu time: avg 0.021 ms, total 717.604 ms] [avg calls per frame: 1]
16:53:35: | sending stuff out - [cpu time: avg 0.001 ms, total 46.8 ms] [avg calls per frame: 1]
16:53:35: ==============================================================
16:53:35:
16:53:35: =====Stream End: 2015-05-24, 16:53:35=================================================
16:53:35: ~RTMPPublisher: Packet flush completed in 85 ms
16:53:35: ~RTMPPublisher: Send thread terminated in 0 ms
16:53:35: RTMPPublisher::SocketLoop: Graceful loop exit
16:53:35: ~RTMPPublisher: Socket thread terminated in 0 ms
16:53:37: =====Stream End: 2015-05-24, 16:53:37=================================================
16:53:46: ~RTMPPublisher: Final socket shutdown completed in 10296 ms
16:53:46: Average send payload: 5347 bytes, average send interval: 14 ms
16:53:46: Number of times waited to send: 0, Waited for a total of 0 bytes
16:53:46: Number of b-frames dropped: 0 (0%), Number of p-frames dropped: 0 (0%), Total 0 (0%)
16:53:46: Number of bytes sent: 205749909
16:53:48: Server Ping plugin instance deleted; removing dynamically loaded localization strings
16:53:48: Terminating 0x25d4
16:53:48: Terminating 0xbb0

Last game capture log:
2015-05-24, 16:44:20: we're booting up:
16:44:20: CaptureThread: attached to process csgo.exe
16:44:20: D3D9 Present
16:44:20: (half life scientist) everything.. seems to be in order
16:44:23: D3D9EndScene called
16:44:23: D3DPRESENT_PARAMETERS {
16:44:23: BackBufferWidth: 1280
16:44:23: BackBufferHeight: 960
16:44:23: BackBufferFormat: D3DFMT_A8R8G8B8
16:44:23: BackBufferCount: 1
16:44:23: MultiSampleType: D3DMULTISAMPLE_NONE
16:44:23: MultiSampleQuality: 0
16:44:23: SwapEffect: D3DSWAPEFFECT_DISCARD
16:44:23: hDeviceWindow: 529156
16:44:23: Windowed: false
16:44:23: EnableAutoDepthStencil: true
16:44:23: AutoDepthStencilFormat: D3DFMT_D24S8
16:44:23: Flags: None
16:44:23: FullScreen_RefreshRateInHz: 120
16:44:23: PresentationInterval: 2147483648
16:44:23: };
16:44:23: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:44:23: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:44:23: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:44:23: successfully set up d3d9 hooks
16:44:23: D3D9Present called
16:44:23: DoD3D9GPUHook: success
16:44:24: D3DSURFACE_DESC {
16:44:24: Format: D3DFMT_A8R8G8B8
16:44:24: Type: D3DRTYPE_SURFACE
16:44:24: Usage: D3DUSAGE_RENDERTARGET
16:44:24: Pool: D3DPOOL_DEFAULT
16:44:24: MultiSampleType: D3DMULTISAMPLE_NONE
16:44:24: MultiSampleQuality: 0
16:44:24: Width: 1280
16:44:24: Height: 960
16:44:24: };
16:44:24: successfully capturing d3d9 frames via GPU
16:48:05: D3D9Reset called
16:48:05: ---------------------- Cleared D3D9 Capture ----------------------
16:48:07: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:48:07: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:48:07: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:48:07: successfully set up d3d9 hooks
16:48:08: D3D9EndScene called
16:48:08: D3D9Present called
16:48:08: DoD3D9GPUHook: success
16:48:08: D3DSURFACE_DESC {
16:48:08: Format: D3DFMT_A8R8G8B8
16:48:08: Type: D3DRTYPE_SURFACE
16:48:08: Usage: D3DUSAGE_RENDERTARGET
16:48:08: Pool: D3DPOOL_DEFAULT
16:48:08: MultiSampleType: D3DMULTISAMPLE_NONE
16:48:08: MultiSampleQuality: 0
16:48:08: Width: 1280
16:48:08: Height: 960
16:48:08: };
16:48:08: successfully capturing d3d9 frames via GPU
16:50:23: D3D9Reset called
16:50:23: ---------------------- Cleared D3D9 Capture ----------------------
16:50:23: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:50:23: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:50:23: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application
16:50:23: successfully set up d3d9 hooks
16:50:25: D3D9EndScene called
16:50:25: D3D9Present called
16:50:25: DoD3D9GPUHook: success
16:50:25: D3DSURFACE_DESC {
16:50:25: Format: D3DFMT_A8R8G8B8
16:50:25: Type: D3DRTYPE_SURFACE
16:50:25: Usage: D3DUSAGE_RENDERTARGET
16:50:25: Pool: D3DPOOL_DEFAULT
16:50:25: MultiSampleType: D3DMULTISAMPLE_NONE
16:50:25: MultiSampleQuality: 0
16:50:25: Width: 1280
16:50:25: Height: 960
16:50:25: };
16:50:25: successfully capturing d3d9 frames via GPU

Trädvy Permalänk
Medlem
Plats
192.168.0.1
Registrerad
Jul 2007

Hmph.. Det enda jag kan se rakt från loggen är att du har ett annat program i bakgrunden som hookar directx9

"16:44:23: WARNING: Another hook is already present while trying to hook d3d9.dll, hook target is unknown. If you experience crashes, try disabling the other hooking application"

Du dippar väldigt i FPS:en, men hårdvaran är det inte fel på. Möjligtvis gamla drivrutiner och virus?
Tror du skulle kunna felsöka bättre på OBS hemsida.

6700k @ 4.8GHz . 16GB @ 2666MHz . x2 1070 @ 2150/4600
360+240 rad custom loop
Flickr 500px

Trädvy Permalänk
Medlem
Registrerad
Maj 2015

det som är konstigt är ju att jag har inga problem när jag streamar via shadowplay då kan jag ha 400-500 fps utan problem, drivrutiner till allt är up to date virus är det enda isf

Trädvy Permalänk
Medlem
Registrerad
Jul 2011
Skrivet av zurox:

det som är konstigt är ju att jag har inga problem när jag streamar via shadowplay då kan jag ha 400-500 fps utan problem, drivrutiner till allt är up to date virus är det enda isf

Hög fps är väl väldigt beroende på din processor och i Shadowplay är det ditt grafikkort som jobbar och med OBS din processor. Sen kan det kanske vara så att OBS ger högre kvalité också.