Lärare vill komma åt min linux maskin via SSH, hur ?

Permalänk
Medlem

Lärare vill komma åt min linux maskin via SSH, hur ?

Hej!
Min lärare vill komma åt min linux maskin via ssh och då undrar jag hur det ska gå till ? Lite info först:

Maskinen är en Raspberry Pi
Jag ansluter mig till den via SSH (men detta är ju då lokalt).

Det står såhär i uppgiften "Ni skall
sätta upp en webbserver så att jag kan titta på den när ni redovisat."

Hur går detta till ?

Permalänk
Rekordmedlem

Det låter som om du ska se till att servern kan använda ssh mot internet, du ska nog peka om portar i routern så att servern kan svara på anropen och så måtte ju din lärare veta vilket publikt ip nummer du använder, jag tycker att du kan läsa på lite själv om hur du ska lösa det och detaljerna kommer att skilja beroende på vad du har för hårdvara och du kan ju även diskutera det med läraren för det är kanske det han egentligen vill.

Permalänk
Medlem

@mrqaffe:
Hej!
Jag har öppnat port 22 via min router och brandvägg. Den publika IP-adressen för min Raspberry Pi fick jag reda på via www.whatsmyip.org
Men när jag försöker ansluta till min Raspberry Pi via min publika IP-adress så händer det absolut ingenting. Några funderingar på vad det kan vara ?
Jag får connection timed out när jag ansluter till min Raspberry Pi via min publika adress.

Permalänk
Medlem

DU behöver även göra en sk Port Forward i din router, så att all trafik till port 22 pekas om till Raspberryn's interna IP-adress

Permalänk
Rekordmedlem
Skrivet av critaL:

@mrqaffe:
Hej!
Jag har öppnat port 22 via min router och brandvägg. Den publika IP-adressen för min Raspberry Pi fick jag reda på via www.whatsmyip.org
Men när jag försöker ansluta till min Raspberry Pi via min publika IP-adress så händer det absolut ingenting. Några funderingar på vad det kan vara ?
Jag får connection timed out när jag ansluter till min Raspberry Pi via min publika adress.

Du kan inte ansluta från ditt lan via din publika ip utan det måste du testa från "utsidan"

Permalänk
Medlem
Skrivet av critaL:

@mrqaffe:
Hej!
Jag har öppnat port 22 via min router och brandvägg. Den publika IP-adressen för min Raspberry Pi fick jag reda på via www.whatsmyip.org
Men när jag försöker ansluta till min Raspberry Pi via min publika IP-adress så händer det absolut ingenting. Några funderingar på vad det kan vara ?
Jag får connection timed out när jag ansluter till min Raspberry Pi via min publika adress.

Kolla också så du inte sitter på en NAT444 adress, då kommer det inte vara möjligt att koppla upp sig mot dig.
http://en.wikipedia.org/wiki/Carrier-grade_NAT

Permalänk
Medlem

Är väl enkelt och ta med den lilla datorn till skolan ?

Permalänk
Medlem

Okej jag lyckas verkligen inte få detta att funka. Det jag har gjort:
Jag har öppnat portar (22,80) till min raspberry pi (192.168.1.51) på både TCP/UDP via min router.
Jag har stängt av brandväggen på raspberry pi.

Jag har sen tidigare en apache2 server körandes på Raspberry Pi, så om jag surfar in på 192.168.1.51 får jag upp den hemsidan.
Surfar jag in på min raspberry pi's publika ip-adress så kommer den inte upp, jag kan inte ansluta mig till den.

Jag har inte lyckats ansluta till min raspberry pi via SSH med raspberry pi's publika IP-adress.

Permalänk
Medlem
Skrivet av Meto:

Är väl enkelt och ta med den lilla datorn till skolan ?

Det skulle ju vara bra! Men det är en distanskurs så det är inte det som är tanken

Permalänk

@critaL:

Vad har du för router?

Permalänk
Medlem
Skrivet av zxhosting:

@critaL:

Vad har du för router?

ASUS rt-ac66u

Permalänk
Medlem

Testa att surfa till det Extera IP- Numret via din Iphone/ Smartphone så det inte går via ditt WiFi. Om det inte fungerar så är det inte öppnat på rätt sätt i Routern.

Permalänk

Har du gjort en port forward? Alltså ställt in i routern att all trafik på port 22/80 ska gå till 192.168.1.51? Du gör det under Advanced Settings -> WAN -> Virtual Server / Port Forwarding i routern

Permalänk
Medlem

Om det inte är en del i uppgiften så är ju ett alternativ att sätta upp en VPN och gå den vägen istället. Sitter själv med en RT-AC66U och det är väldigt enkelt.

Permalänk
Skrivet av critaL:

ASUS rt-ac66u

Har du gjort som dom här har gjort det?

http://portforward.com/english/routers/port_forwarding/Asus/R...

Så här ska den se ut dock så kan du köra med TCP om du vill det.

Permalänk
Medlem
Skrivet av critaL:

Okej jag lyckas verkligen inte få detta att funka. Det jag har gjort:
Jag har öppnat portar (22,80) till min raspberry pi (192.168.1.51) på både TCP/UDP via min router.
Jag har stängt av brandväggen på raspberry pi.

Jag har sen tidigare en apache2 server körandes på Raspberry Pi, så om jag surfar in på 192.168.1.51 får jag upp den hemsidan.
Surfar jag in på min raspberry pi's publika ip-adress så kommer den inte upp, jag kan inte ansluta mig till den.

Jag har inte lyckats ansluta till min raspberry pi via SSH med raspberry pi's publika IP-adress.

så du har allt så inte gjort vad mrqaffe påpekade eller inte redigt förstått vad han menat med

Skrivet av mrqaffe:

Du kan inte ansluta från ditt lan via din publika ip utan det måste du testa från "utsidan"

Precis som mrqaffe säger så kan du inte ansluta till din raspberry pi från ditt lokala nät via ditt publika ip nummer. För att kunna ansluta till din server via ditt publika ip innifrån ditt lan så behöver din router stödja NAT reflection/NAT loopback

Då de flesta nuförtiden har någon form av mobil surf så tycker jag att det är lättare att testa utifall anslutningar av den här typen fungerar genom att använda telefonen, för att sedan fortsätta använda de lokala adresserna.

Testa att surfa in på sidan och ssh via antingen mobil/surfplatta som är uppkopplad med 3g eller 4g finns appar för att ansluta via ssh för både android och ios eller be en kompis gör detta åt dig från sin dator. Borde även gå genom en proxy

Permalänk
Medlem
Skrivet av zxhosting:

Har du gjort som dom här har gjort det?

http://portforward.com/english/routers/port_forwarding/Asus/R...

Så här ska den se ut dock så kan du köra med TCP om du vill det.

http://i.imgur.com/cP4RBMT.png

Exakt så har jag, likadant för port 80

Permalänk
Rekordmedlem
Skrivet av critaL:

Exakt så har jag, likadant för port 80

Men varifrån försöker du nå ditt publika ip, från lanet eller utifrån ?

Permalänk
Medlem

@mrqaffe:
bara en fråga, varför måste han vara utanför sitt lan för att komma åt den, jag kan sitta på mitt lan och ändå komma åt min pi från min globala ip?

Permalänk
Medlem

@mrqaffe: Från min telefon via 4G, men även via det lokala nätverket.

Kör jag in 192.168.1.51 i min webbläsare på datorn så funkar det. Kör jag in min publika IP-adress i webbläsaren på datorn så funkar det inte. Kör jag in 192.168.1.51 på min telefon med wifi funkar det. Kör jag in min publika ip-adress via telefon med 4g funkar det inte.

Permalänk
Rekordmedlem
Skrivet av perlennartsson:

@mrqaffe:
bara en fråga, varför måste han vara utanför sitt lan för att komma åt den, jag kan sitta på mitt lan och ändå komma åt min pi från min globala ip?

Då har du tur (och routern ? eller nån server hanterar det) man använder olika adresser för att nå servern beroende på om man är i samma lan eller inte om man inte har installerat nått som översätter adresserna.
Det kan också vara så att du inte har nat utan kör datorn via ett publikt ip.
Normalt sett så får man inte svar om man använder det publika ip till servern inom lanet.

Permalänk
Rekordmedlem
Skrivet av critaL:

@mrqaffe: Från min telefon via 4G, men även via det lokala nätverket.

Kör jag in 192.168.1.51 i min webbläsare på datorn så funkar det. Kör jag in min publika IP-adress i webbläsaren på datorn så funkar det inte. Kör jag in 192.168.1.51 på min telefon med wifi funkar det. Kör jag in min publika ip-adress via telefon med 4g funkar det inte.

Du skriver att du öppnat portar men har du även pekat dem mot rätt interna ipnummer ? Kan du pinga servern ?

Permalänk
Medlem
Skrivet av mrqaffe:

Du skriver att du öppnat portar men har du även pekat dem mot rätt interna ipnummer ? Kan du pinga servern ?

Japp kan pinga både 192.168.1.51 samt min publika ipv6 adress.

Här kommer lite skärmdumpar:
http://imgur.com/a/erPfJ

Permalänk
Medlem

@critaL:
kan du printa inställningarna i routern där du öppnar portarna?

Permalänk
Medlem
Skrivet av perlennartsson:

@critaL:
kan du printa inställningarna i routern där du öppnar portarna?

http://imgur.com/zEPKxfQ

Permalänk
Medlem

Testa här kanske.
http://www.yougetsignal.com/tools/open-ports/

Använd din externa adress och port 22.

Permalänk
Medlem
Skrivet av L'ombra:

Testa här kanske.
http://www.yougetsignal.com/tools/open-ports/

Använd din externa adress och port 22.

Testade med både ipv4 adress samt ipv6 adress båda stängda. Börjar tro att det är något med ipv6 konfigurationen jag har som ställer till det. Vi hade nämligen i uppgift att ställa in en maskin som ipv6 tunnel så att de andra datorer i LAN:et kunde få sin egen ipv6 adress.

Permalänk
Medlem

Börja med att testa ett steg i taget, så att du kan se var det felar. Annars kommer du lägga en massa tid i onödan på att titta på inställningar som inte orsakar felet.

1: Testa att lokalt från din Pi ssh:a till sig själv via localhost (ssh username@localhost). Fungerar inte det så kör din sshd inte korrekt. Kontrollera att du har en installerad och att den är startad, och kontrollera sedan inställningarna för den.
2: Testa sedan att från din Pi ssh:a till sig själv via dess lokala IP. Fungerar inte det så har du inte öppnat porten korrekt i brandväggen. Du säger att du stängt av den, men det går så vitt jag vet inte att stänga av netfilter. Har du öppnat upp så att allt vidarebefordras?
3: Testa sedan att ssh:a från en annan dator i samma subnät till din Pi via dess lokala IP. Fungerar inte det så har du någon form av extra brandvägg i ditt nätverk som blockerar det.
4: Testa att ssh:a från internet via din externa IP-adress. Fungerar inte det så har du inte vidarebefordrat porten korrekt i din router, eller så har du ingen egen IPv4-adress, utan din ISP kör NAT där flera kunder delar på en IPv4-adress.
5: Testa att från en dator i samma subnät som din Pi ssh:a via din externa IP. Fungerar inte det så stödjer inte din router NAT-loopback.

Permalänk
Medlem

Kan man inte se i routern vilket IP-nummer den har?
Tänkte att han kanske inte har ett riktigt publikt IP-nummer hela vägen.
Ibland så får man privat IP-nummer från internetleverantören.
Går man via t.ex whatismyip.com så syns bara det publik IP-numret och inte IP-numret som routern verkligen har.
Vilken leverantör har du?

Permalänk
Medlem

Med risk för att vara allt för IT Crowd men har du testat att starta om routern så den inte buggat sig och inte gjort att regeln slagit.
Har likadan router som dig, testade att sätta upp en portforward och satte igång min rasp vilket fungerade utan problem. Testa och dra över raspberryn till en kompis som du vet att det fungerar för så kan ni utesluta raspberryn som problemet. Då är det bara router settings eller ISP som failar. Om du har fiber och inte har modem, testa att koppla förbi routern och kör direkt emot nätet och se om du kommer åt den då. Gör du inte det så skulle det kunna vara ISP som blockar trafik för att man inte skall köra webservrar på deras nät.
Du får helt enkelt köra klassiska uteslutningsmetoden.