[LÖST] Arch Linux fast i boot (Start job is running...)

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2011

[LÖST] Arch Linux fast i boot (Start job is running...)

Hej,

Jag lade nyligen till en ny hårddisk i min fstab och sedan dess har jag inte kunnat boota systemet. Den fastnar på ett en process i bootfasen där det står:

[*****] (1 of 2) A start job is running for...th0.device (1min 15s / 1min 30s)

Den byter mellan följande "start jobs":
th0.device
573c.device
eth0.device

Efter 1 min och 30 sek går den vidare och jag får detta:

Welcome to emergency mode! After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to try again to boot into default mode. Give root password for maintenance (or press Control-D to continue):

När jag trycker Control-D så står det "Error getting authority: Error initializinga authority: Could not connect: No such file or directory (g-io-error-quark, 1).

Hur ska jag göra för att komma in i systemet och ta bort hårddisken från fstab så att problemet försvinner? Eller finns det någon annan lösning?

Tack på förhand!

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2011
Skrivet av Kioskvältaren:

Hej,

Jag lade nyligen till en ny hårddisk i min fstab och sedan dess har jag inte kunnat boota systemet. Den fastnar på ett en process i bootfasen där det står:

[*****] (1 of 2) A start job is running for...th0.device (1min 15s / 1min 30s)

Den byter mellan följande "start jobs":
th0.device
573c.device
eth0.device

Efter 1 min och 30 sek går den vidare och jag får detta:

Welcome to emergency mode! After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to try again to boot into default mode. Give root password for maintenance (or press Control-D to continue):

När jag trycker Control-D så står det [vänta, jag ska kolla vad det står, uppdaterar snart].

Hur ska jag göra för att komma in i systemet och ta bort hårddisken från fstab så att problemet försvinner? Eller finns det någon annan lösning?

Tack på förhand!

För att boota datorn i Single User Mode (detta borde ta dig förbi boot screen) trycker du på e när du når grub (för dit antar jag att du kommer?) och sen lägger du till ett s i slutet på raden som inleds med kernel.

Edit: Eller vänta här nu, du får ju möjligheten att äntra maintanence mode, varför inte bara göra det?

Linux: the operating system with a CLUE; Command Line User Environment.

GNU/Linux

Trädvy Permalänk
Medlem
Registrerad
Feb 2009

Boota med arch från usb och montera din systemdisk , kör sedan en arch chroot och redigera din fstab därifrån

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2011
Skrivet av GLaDER:

För att boota datorn i Single User Mode (detta borde ta dig förbi boot screen) trycker du på e när du når grub (för dit antar jag att du kommer?) och sen lägger du till ett s i slutet på raden som inleds med kernel.

Edit: Eller vänta här nu, du får ju möjligheten att äntra maintanence mode, varför inte bara göra det?

I mina grubinställningar (e) finns ingen rad som börjar med kernel eller något som jag kan uppfatta som likvärdigt. Jag kan inte göra något från maintenance mode, jag får bara upp authorityerrormeddelandet (se huvudpost).

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Feb 2009

@Kioskvältaren:

- Starta arch från usb
- Montera din systemdisk under /mnt
- kör arch-chroot /mnt /bin/bash
- kör nano /etc/fstab

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2011
Skrivet av Kioskvältaren:

I mina grubinställningar (e) finns ingen rad som börjar med kernel eller något som jag kan uppfatta som likvärdigt. Jag kan inte göra något från maintenance mode, jag får bara upp authorityerrormeddelandet (se huvudpost).

Va? Det måste finnas en rad för kernel paramters!

Linux: the operating system with a CLUE; Command Line User Environment.

GNU/Linux

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2011
Skrivet av llxt:

@Kioskvältaren:

- Starta arch från usb
- Montera din systemdisk under /mnt
- kör arch-chroot /mnt /bin/bash
- kör nano /etc/fstab

Tackar så mycket, nu är allt normalt igen!

Skrivet av GLaDER:

Va? Det måste finnas en rad för kernel paramters!

Det fanns ingen rad som började med ordet kernel men jag är inte så bra på att tolka mer utav dem en så. Tack för din tid.

Trädvy Permalänk
Medlem
Plats
#Archlinux
Registrerad
Jun 2007

@Kioskvältaren:
I framtiden kör mount -a då brukar man hitta om det finns fel i fstaben innan du bootar om. Fick du igång disken i fstab btw?

Arch - Makepkg, not war -||- Asus Crosshair Hero VI -||- GSkill 16GiB DDR4 15-15-15-35-1T 3600Mhz -||- AMD 1600x @ 4.1GHz -||- nVidia MSI 970 Gaming -||- Samsung 850 Pro -||- EVEGA G2 750W -||- Corsair 570x -||- Asus Xonar Essence STX -||- Sennheiser HD-650 -||
Arch Linux, one hell of a distribution.

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2011
Skrivet av Commander:

@Kioskvältaren:
I framtiden kör mount -a då brukar man hitta om det finns fel i fstaben innan du bootar om. Fick du igång disken i fstab btw?

Visst gjorde jag det. Använde detta som entry:

# /dev/sdb4 LABEL=Games UUID=********-****-****-****-************ /mnt/Games ext4 defaults,noatime,data=writeback 0 2