Refresh rate i ElementaryOS Freya

Trädvy Permalänk
Medlem
Registrerad
Aug 2007

Refresh rate i ElementaryOS Freya

Hej

Jag brukar ge mig på att byta ut windows på min burk vartannat år och testar lite nya distar.
Jag är ingen van linux användare dock har jag någon serverburk hemma som fungerar fint med diverse saker.
FTP, Web, MySQL osv... så länge inget desktop är inblandat.

Har dock alltid stött på problem som fått mig att ge upp.
Denna gång var det refresh rate.
Jag har en 144Hz kapabel skärm. Körde med nvidias drivisar direkt från hemsidan.
Allt gick fint dock när jag startade om var min refresh rate tillbaka på 60Hz EFTER inloggning.
Alltså vid loginskärmen så är den 144Hz men när jag loggar in så hoppar den ner till 60Hz.
Nu tror man ju direkt att det är min user som ställer till det men icke.
Hela dagen spenderade jag med olika lösningar jag hittat med hjälp av google men har inte lyckat lösa detta.
Jag har inte gjort några ändringar manuellt i xxorg.conf utan där står det att mode ska vara 1920x1080_144
Inte heller i min usermapp finns något som talar om annat.
Loggar jag in med Gästusern som skapas vid installationen av OS så händer samma sak och där har jag inte heller varit och pillat.

Testat drivisar från nvidias hemsida och från repos nvidia-331
Är det någon som vet hur man ska gå till väga?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2011
Skrivet av cabraja:

Hej

Jag brukar ge mig på att byta ut windows på min burk vartannat år och testar lite nya distar.
Jag är ingen van linux användare dock har jag någon serverburk hemma som fungerar fint med diverse saker.
FTP, Web, MySQL osv... så länge inget desktop är inblandat.

Har dock alltid stött på problem som fått mig att ge upp.
Denna gång var det refresh rate.
Jag har en 144Hz kapabel skärm. Körde med nvidias drivisar direkt från hemsidan.
Allt gick fint dock när jag startade om var min refresh rate tillbaka på 60Hz EFTER inloggning.
Alltså vid loginskärmen så är den 144Hz men när jag loggar in så hoppar den ner till 60Hz.
Nu tror man ju direkt att det är min user som ställer till det men icke.
Hela dagen spenderade jag med olika lösningar jag hittat med hjälp av google men har inte lyckat lösa detta.
Jag har inte gjort några ändringar manuellt i xxorg.conf utan där står det att mode ska vara 1920x1080_144
Inte heller i min usermapp finns något som talar om annat.
Loggar jag in med Gästusern som skapas vid installationen av OS så händer samma sak och där har jag inte heller varit och pillat.

Testat drivisar från nvidias hemsida och från repos nvidia-331
Är det någon som vet hur man ska gå till väga?

Min första tanke är att lägga till

--rate 144

i ~/.xprofile. Har du kollat på det?

Linux: the operating system with a CLUE; Command Line User Environment.

GNU/Linux

Trädvy Permalänk
Medlem
Registrerad
Aug 2007
Skrivet av GLaDER:

Min första tanke är att lägga till

--rate 144

i ~/.xprofile. Har du kollat på det?

Har ingen sån fil i hemmappen. Har en .nvidia-settings-rc dock så hittar jag inget
på nätet om man kan lägga in refresh mode där kanske.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2011

@cabraja: Skapa den dåe Kör något i stil med

touch $HOME/.xprofile && echo "xrandr --rate 144" > $HOME/.xprofile

Linux: the operating system with a CLUE; Command Line User Environment.

GNU/Linux

Trädvy Permalänk
Medlem
Registrerad
Aug 2007
Skrivet av GLaDER:

@cabraja: Skapa den dåe Kör något i stil med

touch $HOME/.xprofile && echo "xrandr --rate 144" > $HOME/.xprofile

Det positiva var att lightdm läste den vid start weee.
Dock så fick jag en liten ruta vid inloggning.
"Error found when loading .xprofile: Rate 144.0 Hz not available for this size."
Sen loggar den in som vanligt i 60Hz. Jag går till nvidia settings och ställer in 144 manuellt.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2011
Skrivet av cabraja:

Det positiva var att lightdm läste den vid start weee.
Dock så fick jag en liten ruta vid inloggning.
"Error found when loading .xprofile: Rate 144.0 Hz not available for this size."
Sen loggar den in som vanligt i 60Hz. Jag går till nvidia settings och ställer in 144 manuellt.

Hm, "for this size" låter skumt. Kör du flera skärmar eller något liknande? I sådana fall borde du kunna specificera ytterligare vilken skärm som ska köra vilken rate.

Linux: the operating system with a CLUE; Command Line User Environment.

GNU/Linux

Trädvy Permalänk
Medlem
Registrerad
Aug 2007

I nvidia-settings brukar det vid upplösning alltid stå "auto" och då kan jag inte välja refresh rate.
Jag måste välja 1920x1080 sen så dyker listan för refreh rate upp och där kan jag välja rätt.
Kan det vara så att han sätter upplösning på auto och då är den inte tillgänglig 144Hz?
Isåfall skulle man behöva sätta 1920x1080 också som upplösning.
Hur gör man det isåfall?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2011
Skrivet av cabraja:

I nvidia-settings brukar det vid upplösning alltid stå "auto" och då kan jag inte välja refresh rate.
Jag måste välja 1920x1080 sen så dyker listan för refreh rate upp och där kan jag välja rätt.
Kan det vara så att han sätter upplösning på auto och då är den inte tillgänglig 144Hz?
Isåfall skulle man behöva sätta 1920x1080 också som upplösning.
Hur gör man det isåfall?

Kör du bara en skärm?

Kör följande kommando

> xrandr

Du borde få en output som talar om för dig vilka utgångar du har på ditt grafikkort. De utgångar som har en skärm ansluten kommer även lista möjliga upplösningar och rates. För mig ser det ut såhär:

glader@arch-powerhouse ~ >xrandr Screen 0: minimum 8 x 8, current 4000 x 2560, maximum 16384 x 16384 DVI-I-0 disconnected primary (normal left inverted right x axis y axis) DVI-I-1 connected 2560x1440+0+615 (normal left inverted right x axis y axis) 597mm x 336mm 2560x1440 59.95*+ 1920x1200 59.88 1680x1050 59.95 1600x1200 60.00 1280x1024 75.02 60.02 1280x800 59.81 1152x864 75.00 1024x768 75.03 60.00 800x600 75.00 60.32 640x480 75.00 59.94 HDMI-0 disconnected (normal left inverted right x axis y axis) DVI-D-0 connected 1440x2560+2560+0 left (normal left inverted right x axis y axis) 597mm x 336mm 2560x1440 59.95*+ 1920x1080 60.00 1680x1050 59.95 1440x900 59.89 1280x1024 75.02 60.02 1280x960 60.00 1280x800 59.81 1280x720 60.00 1152x864 75.00 1024x768 75.03 70.07 60.00 800x600 75.00 72.19 60.32 56.25 640x480 75.00 59.94

Som du ser har jag 4 utångar och 2 skärmar. Det du vill göra är att lista ut vilken utgång du använder dig av och sedan skriva följande i din $HOME/.xprofile.

xrandr --output DVI-D-0 --fb 1920x1080 xrandr --rate 144

Fast du byter ut DVI-D-0 mot det din skärm heter

Linux: the operating system with a CLUE; Command Line User Environment.

GNU/Linux

Trädvy Permalänk
Medlem
Registrerad
Aug 2007
Skrivet av cabraja:

I nvidia-settings brukar det vid upplösning alltid stå "auto" och då kan jag inte välja refresh rate.
Jag måste välja 1920x1080 sen så dyker listan för refreh rate upp och där kan jag välja rätt.
Kan det vara så att han sätter upplösning på auto och då är den inte tillgänglig 144Hz?
Isåfall skulle man behöva sätta 1920x1080 också som upplösning.
Hur gör man det isåfall?

Kör jag följande:
xrandr --output DVI-D-0 --mode 1920x1080 --rate 144

manuellt så fixar den biffen. Men lägger jag in det i .xprofile så fungerar det inte. Kör fortfarande i 60Hz vid inloggning.
Inget felmeddelande heller. Loggar in och så kör jag manuellt vips så är det 144Hz.
Skumt

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2011
Skrivet av cabraja:

Kör jag följande:
xrandr --output DVI-D-0 --mode 1920x1080 --rate 144

manuellt så fixar den biffen. Men lägger jag in det i .xprofile så fungerar det inte. Kör fortfarande i 60Hz vid inloggning.
Inget felmeddelande heller. Loggar in och så kör jag manuellt vips så är det 144Hz.
Skumt

Prova att lägga dem på olika rader?

Linux: the operating system with a CLUE; Command Line User Environment.

GNU/Linux

Trädvy Permalänk
Medlem
Registrerad
Dec 2004

Lägg in det i autostart
http://i.stack.imgur.com/dLtUl.png

Trädvy Permalänk
Medlem
Registrerad
Aug 2007
Skrivet av GLaDER:

Prova att lägga dem på olika rader?

Provade olika rader.
Rate som första och även som sista vid olika tillfällen. Gick inget vidare.
Har endast en skärm som heter DVI-D-0

Trädvy Permalänk
Medlem
Registrerad
Aug 2007
Skrivet av cabraja:

Provade olika rader.
Rate som första och även som sista vid olika tillfällen. Gick inget vidare.
Har endast en skärm som heter DVI-D-0

Ska till Borås djurpark nu med dottern. Återkommer senare under kvällen

Trädvy Permalänk
Medlem
Registrerad
Aug 2007
Skrivet av Yaroze:

Fungerade självklart med detta. Tack för hjälpen Yaroze nu kämpar vi vidare