Trädvy Permalänk
Medlem
Registrerad
Jun 2013

CUPS-bekymmer...

Som titeln antyder har jag lite bekymmer med att få en nätverksskrivare att fungera. Har följt wikin på archwiki samt googlat som f*n...
Jag hittar och lyckas lägga till skrivaren via localhost:631. Har även laddat ner officiella drivare från epsons hemsida. Laddar ner en *.rpm vilken jag packar upp med rpmextract och kopierar över innehållet till /opt/epson.........
I mappstrukturen finns en PPD-fil som jag använder under CUPS när man lägger till en skrivare så känns som att jag är med i matchen fram tills denna punkt.
Det som händer när jag provar att skriva ut en testsida är att under "Printers"-tabben får jag status: Idle: "Rendering complete".
Tittar jag under "Jobs" står det Stopped : "Filter failed".

Skrivaren i fråga är en Epson XP-425.
Kör Arch Linux på datorn.
Kan tillägga att skrivaren fungerar på min win10 under virtualbox så inget fel på nätverket.

Tacksam för hjälp då jag börjar bli gråhårig här

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2002

Enligt drivar-sidan du länkar så krävs LSB 3.2+.

Citat:

[Notice]
In order to install these drivers, you need to install LSB package (version 3.2 or later) beforehand.

Arch verkar väl ha följande i AUR:
https://aur.archlinux.org/packages/ld-lsb/

Sen så behöver du ju inte bara PPD, utan även filter-programmet. Kanske det fungerar med den du packade upp från rpm:en, isf gäller det ju bara att den ska ligga på rätt ställe.
Du får säkert en del felutskrifter i /var/log/cups/ som beskriver ditt problem tydligare (ex. om filtret ligger på fel plats, har fel exekveringsflaggor, osv..), så kolla där först.

Ev. kanske du måste kompilera detta själv från källkod (.tar.gz versionen på sidan du länkade), läs isf README och INSTALL filen för instruktioner.

The difference between stupidity and genius - the latter has limits

Trädvy Permalänk
Medlem
Registrerad
Jun 2013

Fan vad dum jag känner mig xD
Som du nämnde:
"[Notice]
In order to install these drivers, you need to install LSB package (version 3.2 or later) beforehand.
"
Jag missade den detaljen och sagt och gjort, nu fungerar det :).
Behövde inte kompilera något själv, allt som behövdes fanns i rpm:en.

Sort tack!!!! <3