[LÖST] Hur få hörlurar och högtalare att fungera separat?

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2011

[LÖST] Hur få hörlurar och högtalare att fungera separat?

Hej!

Jag har ALSA med PulseAudio på Arch Linux med Xfce4. När jag har Auto-mute på "Disabled" I alsamixer, så låter både högtalaren och hörlurarna samtidigt när båda är inkopplade. Om jag sätter på auto-mute så försvinner problemet men då måste jag manuellt un-muta ljudet varje gång jag byter mellan hörlurar och högtalare (jag kopplar in och ut hörlurarna här jag använder/inte använder dem).

Hur kan jag få det så att högtalarna blir tysta när jag kopplar in hörlurarna utan att det mutas?

Tack på förhand!

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Nov 2011
Skrivet av Kioskvältaren:

Hej!

Jag har ALSA med PulseAudio på Arch Linux med Xfce4. När jag har Auto-mute på "Disabled" I alsamixer, så låter både högtalaren och hörlurarna samtidigt när båda är inkopplade. Om jag sätter på auto-mute så försvinner problemet men då måste jag manuellt un-muta ljudet varje gång jag byter mellan hörlurar och högtalare (jag kopplar in och ut hörlurarna här jag använder/inte använder dem).

Hur kan jag få det så att högtalarna blir tysta när jag kopplar in hörlurarna utan att det mutas?

Tack på förhand!

Jag har inte heller funnit en lösning på detta. Jag använder pavucontrol för att justera allt ljud manuellt.

Linux: the operating system with a CLUE; Command Line User Environment.

GNU/Linux

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Mar 2002

Testat detta?:

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooti...

Citat:

ALSA channels mute when headphones are plugged/unplugged improperly

If when you unplug your headphones or plug them in the audio remains muted in alsamixer on the wrong channel due to it being set to 0%, you may be able to fix it by opening /etc/pulse/default.pa and commenting out the line:

load-module module-switch-on-port-available

The difference between stupidity and genius - the latter has limits

Trädvy Permalänk
Medlem
Plats
Lund
Registrerad
Maj 2011

Det verkar ha fixat det, tack ska du ha!